Subject: [lamps] ACME integrations with BRSKI and cmcRA bit

From: Michael Richardson <[email-masked]>
Date: Thu, 09 Apr 2020 20:39:52 -0400

Esko Dijk <[email-masked]> wrote:
    > Currently BRSKI Section 5.5.4 has this text:

    doc> The MASA MUST verify that the registrar voucher-request is signed by a registrar

    > If the Registrar would use a non-RA certificate e.g. ACME (LE) standard
    > EE certificate, then it seems that it cannot get anything from MASA...?
    > And BRSKI would not work?

I agree that there are potential issues here.

1) I think that the MASA may skip that check for recognized registrars, so
   that the ACME integration work can work.  This would be a local
   configuration.

2) It may be that draft-ietf-acme-integrations and/or
   draft-friel-acme-subdomains may need to specify a way to ask for cmcRA to
   be set within ACME, when using ACME when doing the pre-authorization for "domain.com"
        cf: NOTE: Pre-Authorization of "domain.com" is complete
   The ACME spec does support authorizations for domains, and maybe that
   would be the best way to do this.
   This also supports the concept that the cmcRA bit ought to apply to all RA
   operations (CMP and well as EST), as proposed in LAMPS.

I think that we should perhaps plan a design team meeting/BOF around this discussion.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Esko Dijk <[email-masked]>
Date: Mon, 20 Apr 2020 09:06:55 +0000

>    that the ACME integration work can work.  This would be a local

This option sounds acceptable to me - if the MASA is pre-configured to trust a particular certificate supplied by the customer, then it can be set as trusted as an authorized RA for that customer.  Although doing the "RA check" on the Registrar cert would be an even more secure solution, thinking about some possible attacks where an employee could misuse this process to get his/her own EE certificate approved to 'act as RA'. But it's up to the manufacturer & customer here to choose the solution that works and provides sufficient security in their view.

>    be set within ACME, when using ACME when doing the pre-authorization for "domain.com"

It would be great if such functionality is supported.  I do not currently follow ACME in any way so I hope others have opportunity to bring this idea in.

Esko

IoTconsultancy.nl  |  Email/Skype: [email-masked]