Subject: [lamps] draft-ietf-anima-bootstrapping-keyinfra will be updating RFC7030

From: Warren Kumari <[email-masked]>
Date: Tue, 28 Apr 2020 11:34:06 -0400

Hi there all,

draft-ietf-anima-bootstrapping-keyinfra
(https://datatracker.ietf.org/doc/draft-ietf-anima-bootstrapping-keyinfra/)
was recently approved for publication.

Back in October the designated expert for the well-known URIs (Mark
Nottingham) had sent
"I think this document needs to update RFC7030, if it's changing how
the well-known URI is handled." - unfortunately this comment was lost
during the transition of the draft between ADs (and was caught by the
IANA).

There has been some back and forth with the authors and Mark, and it
seems like the correct outcome is for this document to be listed as
Updates RFC7030. Benjamin Kaduk suggested that inform LAMPS...

So, unless anyone *strongly* objects, this document will be listed as
"Updates: RFC7030" (and, we hope, in the future, to have more clarity
/ granularity around Updates, so that we can have things like
"Extends", "See Also",  etc.)

Thank you,
W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Russ Housley <[email-masked]>
Date: Tue, 28 Apr 2020 12:04:51 -0400

Warren:

Would it be better to put that part in draft-ietf-lamps-rfc7030est-clarify?  That I-D is in WG Last Call now, so the dependency should not cause a big delay.

Russ

> On Apr 28, 2020, at 11:34 AM, Warren Kumari <[email-masked]> wrote:
> 
> Hi there all,
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Michael Richardson <[email-masked]>
Date: Tue, 28 Apr 2020 12:51:25 -0400

Russ Housley <[email-masked]> wrote:
    > Would it be better to put that part in
    > draft-ietf-lamps-rfc7030est-clarify?  That I-D is in WG Last Call now,
    > so the dependency should not cause a big delay.

I don't think that this helps.
The point is that RFC7030 would acquire, via meta-data, a forward reference
to https://datatracker.ietf.org/doc/draft-ietf-anima-bootstrapping-keyinfra/

Warren,

    > "Extends", "See Also",  etc.)

I think that it is worth saying somewhere (to avoid the IESG timesink)
https://datatracker.ietf.org/doc/draft-ietf-anima-bootstrapping-keyinfra/
"Updates" is of the form Extends.

While the draft-ietf-lamps-rfc7030est-clarify Updates is of the form Amends.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-