Subject: [lamps] on certification authorities.

From: Michael Richardson <[email-masked]>
Date: Fri, 26 Jun 2020 17:56:42 -0400

Russ Housley <[email-masked]> wrote:
    > Thank you.  Many people get it wrong, but X.509 and RFC 5280 (as well
    > as the earlier versions in RFC 2459 and RFC 3280) all use
    > {CA=} "certification authority".

I guess it might be worth spreading this point more widely :-)
I'll all for stamping out the wrong expansions, even if it sometimes seems pendantic.

I'm told that Google is about to start their Cloud *Certificate* Authority.
If that happens, I believe that any chance to assert the term will be
completely lost :-)

On the other hand, if they go with "certification authority", then perhaps
the tide of the terminology will be reversed.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Nico Williams <[email-masked]>
Date: Fri, 26 Jun 2020 17:04:42 -0500

On Fri, Jun 26, 2020 at 05:56:42PM -0400, Michael Richardson wrote:
> I'm told that Google is about to start their Cloud *Certificate*
> Authority.  If that happens, I believe that any chance to assert the
> term will be completely lost :-)

Then clearly they have not read the specs and have no idea what they're
doing!!1!  :^)  Just like with IpSec.

Nico
--

---

From: "Erik Andersen" <[email-masked]>
Date: Sat, 27 Jun 2020 09:57:16 +0200

There certainly is a big difference between the term certification (an act)
and the term certificate (a data value). Certification implies that the CA
does some validation before issuing a certificate. When a read an article
and hit the term certificate authority, I stop reading thinking the guy
cannot even get the term right. He/She does not know what a CA is.

Erik 

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of Michael Richardson
Sent: 26 June 2020 23:57
To: [email-masked]; Russ Housley <[email-masked]>; [email-masked]; Ben
Kaduk <[email-masked]>
Cc: Ryan Sleevi <[email-masked]>; Nico Williams
<[email-masked]>
Subject: [lamps] on certification authorities.

    > {CA=} "certification authority".

I guess it might be worth spreading this point more widely :-) I'll all for
stamping out the wrong expansions, even if it sometimes seems pendantic.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -=
IPv6 IoT consulting =-

---

From: "Erik Andersen" <[email-masked]>
Date: Sun, 28 Jun 2020 09:41:01 +0200

32 years ago X.509 (1988) defined certification authority. There has been plenty of time to get acquainted with the term.

Erik

-----Original Message-----
From: Carsten Bormann <[email-masked]> 
Sent: 27 June 2020 22:19
To: Erik Andersen <[email-masked]>
Cc: [email-masked]
Subject: Re: [Anima] [lamps] on certification authorities.

On 2020-06-27, at 09:57, Erik Andersen <[email-masked]> wrote:
> certificate authority

4 matches in 1id-abstracts.txt.
7292 files on my laptop happen to match.

Enjoy how RFC 4523 dances right into the fire here:

      ( 2.5.6.16 NAME 'certificationAuthority'
           DESC 'X.509 certificate authority'
           SUP top AUXILIARY
           MUST ( authorityRevocationList $
                certificateRevocationList $ cACertificate )
           MAY crossCertificatePair )

RFCs with “certificate authority” released before RFC 5280:

rfc1305.txt rfc2246.txt rfc2408.txt rfc2633.txt rfc2634.txt rfc2752.txt rfc2828.txt rfc2847.txt rfc2904.txt rfc3108.txt rfc3182.txt rfc3193.txt rfc3520.txt rfc3552.txt rfc3588.txt rfc3720.txt rfc3723.txt rfc3760.txt rfc3851.txt rfc3854.txt rfc3911.txt rfc3920.txt rfc3923.txt rfc4171.txt rfc4230.txt rfc4255.txt rfc4261.txt rfc4346.txt rfc4474.txt rfc4523.txt rfc4534.txt rfc4582.txt rfc4795.txt rfc4870.txt rfc4949.txt rfc4953.txt rfc5040.txt rfc5197.txt rfc5246.txt

RFCs with “certificate authority” released after RFC 5280:

rfc5479.txt rfc5763.txt rfc5765.txt rfc5981.txt rfc6101.txt rfc6187.txt rfc6189.txt rfc6376.txt rfc6406.txt rfc6810.txt rfc6818.txt rfc6837.txt rfc6940.txt rfc6950.txt rfc6962.txt rfc7143.txt rfc7146.txt rfc7211.txt rfc7340.txt rfc7378.txt rfc7427.txt rfc7533.txt rfc7576.txt rfc7671.txt rfc7826.txt rfc7858.txt rfc7859.txt rfc7958.txt rfc8023.txt rfc8071.txt rfc8446.txt rfc8572.txt rfc8705.txt

(Not all of these are about X.509 certificates, of course.
And I’m probably missing a few because line breaking obscures the combination.)

Yes, you saw TLS 1.0, 1.1, 1.2, and 1.3 there.

Now starting to write the errata reports :-)

Grüße, Carsten