Subject: [lamps] CMPv2/LightWeiight-CMP profile over CoAP transport

From: Mohit Sahni <[email-masked]>
Date: Thu, 4 Jun 2020 11:03:56 -0700

Hi Jim,
There were some discussions about using CoAP as transport for the
Lightweight CMP profile in the last LAMPS WG meeting. After having some
discussions with Hendrik, David, and Andreas I have written an
internet-draft for using CoAP as transport for CMPv2 / Light Weight CMP
Profile. If I am not mistaken, the recommendation was to present this draft
to ACE WG for the review instead of Lamps group, can you please advice on
that?

Here is the link to the internet-draft that I wrote
https://www.ietf.org/id/draft-msahni-tbd-cmpv2-coap-transport-00.txt

Thanks
Mohit

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Thu, 4 Jun 2020 19:32:27 +0000

Great. We can now once again have more than one protocols that do the same 
thing over the same transport protocol.

This should go in the ACE WG. ACE worked on EST-coaps 
(draft-ietf-ace-coap-est) as well.

Panos

From: Spasm <[email-masked]> On Behalf Of Mohit Sahni
Sent: Thursday, June 04, 2020 2:04 PM
To: Jim Schaad <[email-masked]>; Brockhaus, Hendrik 
<[email-masked]>; LAMPS WG <[email-masked]>
Subject: [lamps] CMPv2/LightWeiight-CMP profile over CoAP transport

Hi Jim,

There were some discussions about using CoAP as transport for the Lightweight 
CMP profile in the last LAMPS WG meeting. After having some discussions with 
Hendrik, David, and Andreas I have written an internet-draft for using CoAP as 
transport for CMPv2 / Light Weight CMP Profile. If I am not mistaken, the 
recommendation was to present this draft to ACE WG for the review instead of 
Lamps group, can you please advice on that?

Thanks

Mohit

---

From: Mohit Sahni <[email-masked]>
Date: Thu, 4 Jun 2020 17:06:30 -0700

Panos,
I am sorry, I did not understand the first part of your comment. Can you
please elaborate on which two same protocols you are referring to here
that will work on CoAP?

-Mohit

On Thu, Jun 4, 2020 at 12:32 PM Panos Kampanakis (pkampana) <
[email-masked]> wrote:

> *From:* Spasm <[email-masked]> *On Behalf Of *Mohit Sahni
> *Sent:* Thursday, June 04, 2020 2:04 PM
> *To:* Jim Schaad <[email-masked]>; Brockhaus, Hendrik <
> [email-masked]>; LAMPS WG <[email-masked]>
> *Subject:* [lamps] CMPv2/LightWeiight-CMP profile over CoAP transport
>
>
>
> Hi Jim,
>

---

From: Tomas Gustavsson <[email-masked]>
Date: Fri, 5 Jun 2020 07:40:24 +0200

Hi,

I noticed that section 4, Proxy Support (good section btw), mentions
Announcement messages. These are excluded from the Lightweight
specification. Since the LIghtweight specification is mentioned in the
beginning, I'm not sure if that's worth mentioning here?

Cheers,
Tomas

On 2020-06-04 20:03, Mohit Sahni wrote:
> Profile. If I am not mistaken, the recommendation was to present this
> draft to ACE WG for the review instead of Lamps group, can you please
> advice on that?
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
>

---

From: Mohit Sahni <[email-masked]>
Date: Thu, 4 Jun 2020 22:48:34 -0700

Hi Tomas
Thanks for the feedback, I was trying to write it in a way so that it can
work for both CMPv2 and LightWeight CMP, I have noted it your feedback and
I will try to make it more clear.

-Mohit

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Fri, 5 Jun 2020 06:50:40 +0000

Hi Mohit

> Von: Mohit Sahni <[email-masked]> 
> Gesendet: Donnerstag, 4. Juni 2020 20:04
>
> Here is the link to the internet-draft that I wrote https://www.ietf.org/id/draft-msahni-tbd-cmpv2-coap-transport-00.txt
>
Thanks for submitting this draft. 
I will reference it in the Lightweight CMP Profile draft.

- Hendrik

---

From: Jim Schaad <[email-masked]>
Date: Fri, 5 Jun 2020 19:19:02 -0700

I suppose that this could go into the ACE working group, but it will require a charter change to do so.  

I would suggest that you review the EST document with special attention to the sections on DTLS and proxying.  It would also help to have some idea of guidance for when coap or coaps is going to be used.  I am not sure that this strongly exists in CMP as my very vague memory was that it was assumed that all transactions where going to be done over TLS with server validation as a minimum.

Jim

From: Spasm <[email-masked]> On Behalf Of Mohit Sahni
Sent: Thursday, June 4, 2020 10:49 PM
To: Tomas Gustavsson <[email-masked]>
Cc: LAMPS WG <[email-masked]>
Subject: Re: [lamps] CMPv2/LightWeiight-CMP profile over CoAP transport

Hi Tomas

Thanks for the feedback, I was trying to write it in a way so that it can work for both CMPv2 and LightWeight CMP, I have noted it your feedback and I will try to make it more clear.

-Mohit 

On Thu, Jun 4, 2020 at 10:40 PM Tomas Gustavsson <tomas@primekey..se <mailto:[email-masked]> > wrote:

Hi,

Cheers,
Tomas

On 2020-06-04 20:03, Mohit Sahni wrote:
> [email-masked] <mailto:[email-masked]> 

_______________________________________________
Spasm mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/spasm

---

From: Mohit Sahni <[email-masked]>
Date: Sat, 6 Jun 2020 10:01:02 -0700

Hi Jim,
Thanks for the feedback. I will go over the EST document and update
sections around DTLS and proxying and address your other comments. Once
ready, I will post the draft in ACE WG.

Regards,
Mohit

On Fri, Jun 5, 2020 at 7:19 PM Jim Schaad <[email-masked]> wrote:

> I would suggest that you review the EST document with special attention to
> the sections on DTLS and proxying.  It would also help to have some idea of
> guidance for when coap or coaps is going to be used.  I am not sure that
> this strongly exists in CMP as my very vague memory was that it was assumed
> that all transactions where going to be done over TLS with server
> validation as a minimum.
>
>
>
> Jim
>
>
>
>
>
> *Sent:* Thursday, June 4, 2020 10:49 PM
> *To:* Tomas Gustavsson <[email-masked]>
> *Cc:* LAMPS WG <[email-masked]>
> *Subject:* Re: [lamps] CMPv2/LightWeiight-CMP profile over CoAP transport
>
>
>
> Hi Tomas
>
> On Thu, Jun 4, 2020 at 10:40 PM Tomas Gustavsson <tomas@primekey..se
> <[email-masked]>> wrote:
>
> Hi,
>