Subject: RE: [Speechsc] FW: EMMA and Speechsc

From: "BRANDT,MARC (HP-France,ex2)" <[email-masked]>
Date: Wed, 3 Sep 2003 22:52:59 +0200

would there be a way for MRCP v2 to tolerate different
types of payload and making sure that implementers of 
media resources can decide what the best is in some situations
(extensions, future features ...) ?
I can envision this shall not prevent a protocol from working.
Additionally speechsc may want to standardize some default profiles
to make sure some level of interop is guaranteed.

I feel important to split what shall be in the core protocol
definitions from what is the responsibility of a media resource
feature set.

(if not already included in current draft)

> -----Original Message-----
> From: Jeff Kusnitz [mailto:[email-masked]]
> Sent: Tuesday, September 02, 2003 10:50 PM
> To: Eric Burger
> Cc: IETF SPEECHSC (E-mail); [email-masked]
> Subject: [Speechsc] FW: EMMA and Speechsc
> 
> 
> Another option would be the XML format specified in the W3C 
> VBWG Semantic 
> Interpretation spec, located here
> (http://www.w3.org/TR/semantic-interpretation/#SI7.).  It 
> might fall into 
> the same "not quite complete" bucket that EMMA does, but it's 
> probably 
> worth a quick look, and feedback for the SISR spec would be 
> helpful as 
> well.
> 
> Thanks,
> Jeff
> 
> > "Eric Burger" <[email-masked]>
> > Sent by: [email-masked]
> > 
> > 08/29/2003 11:10 AM
> > 
> > 
> >  To: "IETF SPEECHSC (E-mail)" <[email-masked]>
> >  cc: 
> >  Subject: RE: [Speechsc] FW: EMMA and Speechsc
> > 
> > Anyone object?  Alternate approaches?
> > 
> > > -----Original Message-----
> > > From: Daniel Burnett [mailto:[email-masked]]
> > > Sent: Mon, August 25, 2003 1:11 PM
> > > To: IETF SPEECHSC (E-mail)
> > > Subject: RE: [Speechsc] FW: EMMA and Speechsc
> > > 
> > > 
> > > Eric,
> > > 
> > > I'd discourage our group from adopting EMMA yet.  This 
> > > document that was just published is a first working draft, 
> > > and the W3C process can be quite slow.  My preference would 
> > > be to stay with our existing interchange format for MRCP2, 
> > > both because EMMA is on a different maturity schedule and 
> > > because it provides an easier transition to MRCP2.  If and 
> > > when we discuss MRCP3, it would be appropriate to re-evaluate 
> > > the status of EMMA.
> > > 
> > > However, it is reasonable for members of our group to review 
> > > the EMMA draft and provide feedback at this early stage so 
> > > that it can move towards what we eventually want it to be.
> > > 
> > > -- dan
> > 
> > 
> > _______________________________________________
> > Speechsc mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speechsc
> 
> 
> 
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Deborah Dahl" <[email-masked]>
Date: Mon, 25 Aug 2003 09:45:47 -0400

Thanks, Eric. I forgot to mention that feedback should
be sent to [email-masked], the Multimodal Interaction
Working Group's public mailing list. 

Looking forward to any comments or suggestions you may have.

regards,

Debbie

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Eric Burger
> Sent: Monday, August 25, 2003 9:09 AM
> Cc: [email-masked]
> Debbie is the Chair of the W3C MMI Work Group.  She is 
> soliciting feedback on EMMA, which is the leading candidate 
> as an interchange format for ASR results for MRCPv2.
> 
> From: Deborah Dahl [mailto:[email-masked]]
> Sent: Tue, August 12, 2003 10:24 AM
> To: Eric Burger
> Subject: EMMA and Speechsc
> 
> 
> Hi Eric,
> As you may be aware, the Multimodal Interaction Working 
> Group has just published a Working Draft of EMMA, 
> (Extensible MultiModal Annotation) the follow-on to NLSML, 
> for representing user input. We're looking for feedback from
> other interested parties and we'd like specifically to get some 
> feedback from the Speechsc group. Either feedback from the group 
> as a whole or feedback from individual participants would be useful. 
> What do you think would be a good way to go about this?
> 
> Best regards,
> 
> Debbie 
> 
> Brief description of EMMA:
> 
> EMMA is designed as a data exchange format for use in representing
> application specific interpretations of user input together with
> annotations such as confidence scores, time stamps and input medium
> etc. Speech and handwriting recognizers, natural language engines,
> media interpreters, and multimodal integration components generate
> EMMA markup. 
> 
> EMMA spec:
> 
     http://www.w3.org/TR/2003/WD-emma-20030811/

Multimodal Interaction home page:

     http://www.w3.org/TR/2002/mmi/

More information about the role EMMA plays in the W3C Multimodal
Interaction Framework can be found in:

     http://www.w3.org/TR/mmi-framework/

---

From: "Daniel Burnett" <[email-masked]>
Date: Mon, 25 Aug 2003 10:10:59 -0700

Eric,

I'd discourage our group from adopting EMMA yet.  This document that was just published is a first working draft, and the W3C process can be quite slow.  My preference would be to stay with our existing interchange format for MRCP2, both because EMMA is on a different maturity schedule and because it provides an easier transition to MRCP2.  If and when we discuss MRCP3, it would be appropriate to re-evaluate the status of EMMA.

However, it is reasonable for members of our group to review the EMMA draft and provide feedback at this early stage so that it can move towards what we eventually want it to be.

-- dan

-----Original Message-----
From: Eric Burger [mailto:[email-masked]]
Sent: Monday, August 25, 2003 6:09 AM
To: IETF SPEECHSC (E-mail)
Cc: [email-masked]
Subject: [Speechsc] FW: EMMA and Speechsc

Debbie is the Chair of the W3C MMI Work Group.  She is soliciting feedback on EMMA, which is the leading candidate as an interchange format for ASR results for MRCPv2.

-----Original Message-----
From: Deborah Dahl [mailto:[email-masked]]
Sent: Tue, August 12, 2003 10:24 AM
To: Eric Burger
Subject: EMMA and Speechsc

Hi Eric,

Best regards,

Debbie 

EMMA spec: