Subject: RE: [Speechsc] IANA considerations for group feedback

From: "Reifenrath, Klaus" <[email-masked]>
Date: Thu, 27 Jan 2005 02:59:54 -0500

Quoting from
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdp-new-23.txt:
   Note: The media types "control" and "data" were listed as valid in
   the previous version of this specification [6], however their
   semantics were never fully specified and they are not widely used.
   These media types have been removed in this specification, although
   they still remain valid media type capabilities for a SIP user agent
   as defined in RFC 3840 [23].  If these media types are considered
   useful in future, a Standards Track RFC MUST be produced to document
   their use.  Until that is done, applications SHOULD NOT use these
   types and SHOULD NOT declare support for them in SIP capabilities
   declarations (even though they exist in the registry created by RFC
   3840).

-----Original Message-----
From: Thomas Gal [mailto:[email-masked]]
Sent: Mittwoch, 26. Januar 2005 20:48
To: 'Dan Burnett'; 'Reifenrath, Klaus'
Cc: [email-masked]
Subject: RE: [Speechsc] IANA considerations for group feedback

[email-masked]

-Tom

[email-masked]  

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Dan Burnett
> Sent: Wednesday, January 26, 2005 10:15 AM
> To: Reifenrath, Klaus
> Cc: [email-masked]
> Subject: RE: [Speechsc] IANA considerations for group feedback
> 
> I agree that there needs to be an registration of 
> application/x-nlsml (or, as an email from Tom pointed out, 
> application/nlsml).  Technically it should be in a separate 
> RFC from MRCP, but I can include it in the draft if there are 
> no objections.
> 

I would certainly agree with not using "application/nlsml" but something
similar to obviate confusion, even mrcp-nlsml or something.

> If "control" is already registered, do we need to do it?  In 
> short, it's not clear to me in which
> namespace(s) the SDP items you mention should be registered.  
> Are they new namespaces for MRCP or are there existing 
> namespaces to which the items should be added?
> 

Isn't MRCPv2 "control"? I would guess control is too ambiguous and probably
why it's being deprecated.

-Tom

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Sarvi Shanmugham <[email-masked]>
Date: Thu, 27 Jan 2005 09:57:10 -0800

Which is exactly what is being done here.

So we are fine.

Sarvi

---

From: David R Oran <[email-masked]>
Date: Thu, 27 Jan 2005 13:37:58 -0500

>  Which is exactly what is being done here.
Yes, I agree this is fine.

> From: Thomas Gal [ mailto:[email-masked] ]
> [ mailto:[email-masked] ] On Behalf Of Dan Burnett
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]

---

From: "Thomas Gal" <[email-masked]>
Date: Thu, 27 Jan 2005 13:08:30 -0800

Klaus,

	MRCPv2 is the "control" for a media server. It can be
application/mrcpv2 or control/mrcpv2 but not both correct? Currently we are
specifying it in the draft as application/mrcpv2, which would obviate the
need for control no? Or are you proposing something different? I certainly
think control/mrcpv2 makes more sense despite the seeming tradition toward
using application/xxxx for everything.

-Tom

[email-masked]  

> From: Sarvi Shanmugham [mailto:[email-masked]] 
> Sent: Thursday, January 27, 2005 9:57 AM
> To: Reifenrath, Klaus
> Cc: Thomas Gal; 'Dan Burnett'; [email-masked]
> Subject: Re: [Speechsc] IANA considerations for group feedback
>