Subject: Re: [Speechsc] IANA considerations for group feedback

From: Dan Burnett <[email-masked]>
Date: Wed, 9 Feb 2005 07:01:51 -0800 (PST)

Just to be clear, there are no IANA considerations
here, right?  The "control" type exists and we do not
need to request any sort of registration because of
our documented use, right?

--- David R Oran <[email-masked]> wrote:

> 
> On Jan 27, 2005, at 12:57 PM, Sarvi Shanmugham
> wrote:
> 
> >  Which is exactly what is being done here.
> >
> >  So we are fine.
> >
> Yes, I agree this is fine.
> 
> >  Sarvi
> >  Reifenrath, Klaus wrote:
> > Quoting from
> > 
>
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdp-new-23.txt:
> >    Note: The media types "control" and "data" were
> listed as valid in
> >    the previous version of this specification [6],
> however their
> >    semantics were never fully specified and they
> are not widely used.
> >    These media types have been removed in this
> specification, although
> >    they still remain valid media type capabilities
> for a SIP user agent
> >    as defined in RFC 3840 [23].  If these media
> types are considered
> >    useful in future, a Standards Track RFC MUST be
> produced to document
> >    their use.  Until that is done, applications
> SHOULD NOT use these
> >    types and SHOULD NOT declare support for them
> in SIP capabilities
> >    declarations (even though they exist in the
> registry created by RFC
> >    3840).
> >
> > -----Original Message-----
> > From: Thomas Gal [ mailto:[email-masked] ]
> > Sent: Mittwoch, 26. Januar 2005 20:48
> > To: 'Dan Burnett'; 'Reifenrath, Klaus'
> > Cc: [email-masked]
> > Subject: RE: [Speechsc] IANA considerations for
> group feedback
> >
> >
> >  [email-masked]
> >
> > -Tom
> >
> >  [email-masked]
> >
> >
> > -----Original Message-----
> > From: [email-masked]
> > [ mailto:[email-masked] ] On Behalf Of
> Dan Burnett
> > Sent: Wednesday, January 26, 2005 10:15 AM
> > To: Reifenrath, Klaus
> > Cc: [email-masked]
> > Subject: RE: [Speechsc] IANA considerations for
> group feedback
> >
> > I agree that there needs to be an registration of
> > application/x-nlsml (or, as an email from Tom
> pointed out,
> > application/nlsml).  Technically it should be in a
> separate
> > RFC from MRCP, but I can include it in the draft
> if there are
> > no objections.
> >
> >
> > I would certainly agree with not using
> "application/nlsml" but 
> > something
> > similar to obviate confusion, even mrcp-nlsml or
> something.
> >
> >
> > If "control" is already registered, do we need to
> do it?  In
> > short, it's not clear to me in which
> > namespace(s) the SDP items you mention should be
> registered.
> > Are they new namespaces for MRCP or are there
> existing
> > namespaces to which the items should be added?
> >
> >
> > Isn't MRCPv2 "control"? I would guess control is
> too ambiguous and 
> > probably
> > why it's being deprecated.
> >
> > -Tom
> >
> > _______________________________________________
> > Speechsc mailing list
> >  [email-masked]
> >  https://www1.ietf.org/mailman/listinfo/speechsc
> >
> >
> >
> >  _______________________________________________
> > Speechsc mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speechsc
> >
> David R. Oran
> Cisco Fellow
> Cisco Systems
> 7 Ladyslipper Lane
> Acton, MA 01720 USA
> Tel: +1 978 264 2048
> Email: [email-masked]
> 
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 

__________________________________ 
Do you Yahoo!? 
Meet the all-new My Yahoo! - Try it today! 
http://my.yahoo.com 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: David R Oran <[email-masked]>
Date: Wed, 9 Feb 2005 10:17:07 -0500

> our documented use, right?
Yes, unless MMUSIC nukes it. Queries launched by Eric to see what's 
up...

David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 09 Feb 2005 16:30:33 +0100

David R Oran wrote:
> Yes, unless MMUSIC nukes it. Queries launched by Eric to see what's up...
> 

Consider yourself nuked. The following is present in the latest SDP-new 
(version 23), section 10:

It is noted that "text" and
    "message" are valid media types for use with SDP, but that "control"
    and "data" are under-specified and deprecated.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

---

From: Sarvi Shanmugham <[email-masked]>
Date: Wed, 09 Feb 2005 09:25:07 -0800

What does the following in draft-23 mean

Note: The media types "control" and "data" were listed as valid in
   the previous version of this specification [6], however their
   semantics were never fully specified and they are not widely used.
   These media types have been removed in this specification, although
   they still remain valid media type capabilities for a SIP user agent
   as defined in RFC 3840 [23].  If these media types are considered
   useful in future, a Standards Track RFC MUST be produced to document
   their use.  Until that is done, applications SHOULD NOT use these
   types and SHOULD NOT declare support for them in SIP capabilities
   declarations (even though they exist in the registry created by RFC
   3840).

Does it not allow the use of control a media type if its use is defined 
by a standards track RFC such as this.

Do you have any suggestion as to how we go about addressing this issue.

Thanks,
Sarvi

Magnus Westerlund wrote:

> Consider yourself nuked. The following is present in the latest 
> SDP-new (version 23), section 10:
>

---

From: Sarvi Shanmugham <[email-masked]>
Date: Wed, 09 Feb 2005 10:54:27 -0800

Should we be using either "message" or "application" perhaps for this 
use instead of "control"

Sarvi

---

From: Sarvi Shanmugham <[email-masked]>
Date: Wed, 09 Feb 2005 15:10:48 -0800

I did a little bit of searching. It looks like the following draft.

http://bgp.potaroo.net/ietf/all-ids/draft-camarillo-mmusic-sdp-bfcp-00.txt

uses SDP media type "application" to do something similar in model what 
MRCPv2 is doing.

So, if there is no objecttion, I would propose that we move from 
"control" to "application"

Any thoughts,
Sarvi