Subject: RE: [Speechsc] Lexicon search order

From: "Reifenrath, Klaus" <[email-masked]>
Date: Fri, 3 Jun 2005 06:45:55 -0400

Hi Dave!

I think the text of the latest spec is OK!

Even if the SSML document contains lexicon references, the lexicons
specified via the MRCP header should *not* be ignored, but the SSML lexicons
take precedence.
Example:
SSML lexicon contains pronunciations for A and C
MRCP lexicon contains pronunciations for A and D
Case 1:
The text to speak does contain C. The TTS engine uses the SSML lexicon. 
Case 2:
The text to speak does contain A. The TTS engine uses the SSML lexicon,
although A is in the MRCP lexicon.
Case 3:
The text to speak does contain D. The TTS engine uses the MRCP lexicon,
because D is not found in the SSML lexicon.
Case 4:
The text to speak does contain B. The TTS engine uses is language dependent
internal "lexicon", because B is neither found in the SSML lexicon nor in
the MRCP lexicon. 

Klaus

-----Original Message-----
From: David R. Oran [mailto:[email-masked]] 
Sent: Donnerstag, 2. Juni 2005 20:39
To: IETF SPEECHSC ((E-mail))
Subject: [Speechsc] Lexicon search order

Your intrepid co-chair has been doing his assigned due-diligence on the
mrcpv2 spec in preparation for last call. This is one of a few issues that
have come up for which I would like guidance form the WG.

The text says the folowing about the lexicon search oder header:

      "This header is used to specify the list of active Lexicon
      URIs and the search order among the active lexicons. Note,
      the lexicons specified within the SSML document still take
      precedence over the lexicons specified in this header."

This implies, at least to me, if the SSML says *anything* about lexicons,
then the entire header is ignored. There is no concatenation or other form
of merging of the two lists, right?

If you think the text is perfectly clear and I'm worrying about nothing,
I'll consider leaving it as is.

If you agree with my interpretation and can see the ambiguity, I'll change
the last sentence to:

      "If the SSML document for the corresponding SPEAK
      operation contains any lexicon references, those lexicons
      are used and the lexicons specified in this header are ignored."

If you think something else was intended, speak now or make your case during
last call!

Dave.

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "David R. Oran" <[email-masked]>
Date: Fri, 3 Jun 2005 07:41:31 -0400

OK, I wasn't aware that it was trivial to construct a total order  
among overlapping lexicons at the time a request is received.
Is it?