Subject: RE: [Speechsc] RECORD method

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Tue, 7 Jun 2005 11:32:16 -0700

I think we want to allow for HTTP as well. So, "MUST HTTPS and SHOULD
HTTP" would be fine with me.

Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of David R. Oran
     Sent: Tuesday, June 07, 2005 8:29 AM
     To: [email-masked] ((((E-mail))))
     Subject: [Speechsc] RECORD method
     
     the text says:
     
     "The RECORD request places the recorder resource in the 
     Recording state. Depending on the headers specified in the 
     RECORD method the resource may start recording the audio 
     immediately or wait for the end pointing functionality to 
     detect speech in the audio. It then saves the audio to the 
     URI supplied in the recording-uri header. If the 
     recording-uri is not specified, the server MUST capture 
     the media onto a local disk and return a URI pointing to 
     the recorded audio in the RECORD-COMPLETE event. The 
     server MUST support HTTP and file URI schemes."
     
     Sorry, but a file: URI won't work - it's not generally 
     usable between systems. Because of this and the secuirty 
     issues, the last sentence probably ought to be:
     
     "The server MUST support the HTTPS URI scheme and MAY 
     support other schemes. Note that due to the sensitive 
     nature of voice recordings, any other URI schemes 
     supported by the server SHOULD employ integrity and 
     confidentiality on the data transfer (e.g. FTPS)."
     
     I changed the text, so let me know if this is going to 
     cause heartburn.
     
     dave.

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 7 Jun 2005 14:42:52 -0400

> HTTP" would be fine with me.
But then the recordings are transferred in an insecure manner, so  
encouraging HTTP is not what we want to do. I don't think this is a  
practical issue though, because it's very difficult to imagine an  
implementation that can do HTTPS and not HTTP.

---

From: Brett Gavagni <[email-masked]>
Date: Tue, 7 Jun 2005 14:48:50 -0400

The only comment I have is to keep the wording consistent throughput the 
specification. I would be careful in the deviation of terminology across 
sections. 

For example in section: 8.5. Synthesizer Message Body 
 
Synthesizer Speech Data 
Lexicon Data
..
..
...
All media servers MUST support the 
   HTTP uri access mechanism. 

Thanks,

Brett Gavagni 
WebSphere Voice Server Development 
http://www-306.ibm.com/software/pervasive/voice_server/ 
[email-masked]

"Shanmugham, Saravanan" <[email-masked]> 
Sent by: [email-masked]
06/07/2005 02:32 PM

To
"David R. Oran" <[email-masked]>, <[email-masked]>
cc

Subject
RE: [Speechsc] RECORD method

Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of David R. Oran
     Sent: Tuesday, June 07, 2005 8:29 AM
     To: [email-masked] ((((E-mail))))
     Subject: [Speechsc] RECORD method
 
     the text says:

 

     dave.