Subject: [Speechsc] Question about how to give an error message

From: Jesús Bernat Vercher <[email-masked]>
Date: Wed, 01 Jun 2005 17:40:24 +0200

In the current draft, it says in page 29, section 6.2 (SET-PARAMS):

   "If some of the headers being set are unsupported for the resource or
   have illegal values, the server MUST reject the request with a 403,
   Bad Parameter, and MUST include in the response the header fields
   that could not be set."

    Where in the response message should the wrong headers be? I mean, 
in the message-body, adding in the message-headers only the wrong headers...
    If the parameter has a wrong value, should not be better to return 
404 (Ilegal value for header) instead of  403 (Unsuported Header)?

    Thanks,
       Jesus.

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 1 Jun 2005 09:18:35 -0700

Should be returned in the same way it was sent, i.e. not in the body.

Sarvi 

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Jesús 
     Bernat Vercher
     Sent: Wednesday, June 01, 2005 8:40 AM
     To: [email-masked]
     Subject: [Speechsc] Question about how to give an error message

        "If some of the headers being set are unsupported for 
     the resource or
        have illegal values, the server MUST reject the request 
     with a 403,
        Bad Parameter, and MUST include in the response the 
     header fields
        that could not be set."
     
         Where in the response message should the wrong headers 
     be? I mean, in the message-body, adding in the 
     message-headers only the wrong headers...
         If the parameter has a wrong value, should not be 
     better to return
     404 (Ilegal value for header) instead of  403 (Unsuported Header)?
     
         Thanks,
            Jesus.

---

From: Jesús Bernat Vercher <[email-masked]>
Date: Wed, 01 Jun 2005 18:30:22 +0200

Just imagine the next example:

MRCP/2.0 462 SPEAK 1
Channel-Identifier:3332AECB23433802@speechsynth
Voice-gender:neutral
Prosody-contour:(0%,+20Hz) (10%,+30% (40%,+10Hz)
Speech-Language:en-US

Hello World.

There is a missing parenthesis in the Prosody-contour field.
I think the right answer should be to return the 404 code (Invalid 
header value, instead of 403) and returning the Channel-Identifier 
header and the Prosody-contour, not adding to the response the correct 
header values:

        MRCP/2.0 162 543257 404 COMPLETE
        Channel-Identifier: 32AECB23433802@speechsynth
        Prosody-contour:(0%,+20Hz) (10%,+30% (40%,+10Hz) 

Is that correct?

Thanks:

    Jesús.

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 1 Jun 2005 11:27:22 -0700

Correct.

Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Jesús 
     Bernat Vercher
     Sent: Wednesday, June 01, 2005 9:30 AM
     To: Shanmugham, Saravanan
     Cc: [email-masked]
     Subject: Re: [Speechsc] Question about how to give an error message

     MRCP/2.0 462 SPEAK 1
     
     Hello World.
     
     There is a missing parenthesis in the Prosody-contour field.
     I think the right answer should be to return the 404 code 
     (Invalid header value, instead of 403) and returning the 
     Channel-Identifier header and the Prosody-contour, not 
     adding to the response the correct header values:

     Is that correct?
     
     Thanks:
     
         Jesús.