Subject: RE: [Speechsc] MRCPv2 clarification

From: "Reifenrath, Klaus" <[email-masked]>
Date: Tue, 7 Jun 2005 08:29:17 -0400

Hi Pierre,
 
"both" does not mean in parallel. But you can use the same resource to do a
"normal" recognition and later use the same resource to perform a
recognition in hotword mode.
 
Regards,
Klaus

  _____  

From: Pierre Forgues [mailto:[email-masked]] 
Sent: Dienstag, 7. Juni 2005 14:12
To: IETF SPEECHSC (E-mail)
Subject: [Speechsc] MRCPv2 clarification

Section 9 of the MRCPv2 specification includes the following sentence:  "The
recognition resource may support recognition in the normal or hotword modes
or both."  I'm not sure the same recognition resource can support "both"
because the state machinery does not allow two concurrent recognition
requests to be active, as also stated in section 9.9 "If the resource is in
the recognizing state, the RECOGNIZE request MUST respond with a failure
status"

It is probably safer/simpler to assume hotword recognition will be done by a
separate recognition resource.  The mention of "both" should then be removed
from the spec.

Pierre

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Tue, 7 Jun 2005 13:41:27 +0100

... which is what my response was going to be until I read:
  
   "or implementations where a 
   single recognition resource does not support both modes, they can be 
   implemented as separate resources and allocated to the same SIP 
   session with different MRCP session identifiers and share the RTP 
   audio feed. "

This loosely implies to me that the intent is for parallel hotword and normal recognition. 

While MRCP should of course allow you to do this (forking media to perform simultaneous recognitions), we should probably clarify , to avoid confusion, that a single speechrecog is not intended to support both modes concurrently.

- Dave
  ----- Original Message ----- 
  From: Reifenrath, Klaus 
  To: 'Pierre Forgues' ; IETF SPEECHSC (E-mail) 
  Sent: Tuesday, June 07, 2005 1:29 PM
  Subject: RE: [Speechsc] MRCPv2 clarification

  Hi Pierre,

  "both" does not mean in parallel. But you can use the same resource to do a "normal" recognition and later use the same resource to perform a recognition in hotword mode.

  Regards,
  Klaus

------------------------------------------------------------------------------

Section 9 of the MRCPv2 specification includes the following sentence:  "The recognition resource may support recognition in the normal or hotword modes or both."  I'm not sure the same recognition resource can support "both" because the state machinery does not allow two concurrent recognition requests to be active, as also stated in section 9.9 "If the resource is in the recognizing state, the RECOGNIZE request MUST respond with a failure status" 

  It is probably safer/simpler to assume hotword recognition will be done by a separate recognition resource.  The mention of "both" should then be removed from the spec.

  Pierre

------------------------------------------------------------------------------