Subject: [Speechsc] Widening a private discussion on hotword mode

From: "David R. Oran" <[email-masked]>
Date: Wed, 15 Jun 2005 08:07:35 -0400

This started with a query to Sarvi, but based on the exchange it  
appears worthwhile to entertain a technical change to the specification.

Comments pro and con please.

Dave.

Begin forwarded message:

> From: "Shanmugham, Saravanan" <[email-masked]>
> Date: June 14, 2005 10:06:50 PM EDT
> To: "David R. Oran" <[email-masked]>, "Eric Burger"  
> <[email-masked]>, "Dan Burnett" <[email-masked]>
> Subject: RE: Query on hotword mode
>
>
> This is what was intended.  But I agree that your suggestion is easier
> on the client and more appropriate on the for hotwords.
> I remember proposing this during the MRCPv1 extensions for this, but
> dropped out of the discussion.
>
> I think you should propose it to the wider audience.
>
> If you forward this thread to the alias, I can send a proposal for
> change in text in the response and seee if anyone has an issue with
> this.
>
>
> Sarvi
>
>      -----Original Message-----
>      From: David R. Oran [mailto:[email-masked]]
>      Sent: Tuesday, June 14, 2005 1:43 PM
>      To: Shanmugham, Saravanan; Eric Burger; Dan Burnett
>      Subject: Query on hotword mode
>
>      The definition of hotword mode says:
>
>      "Hotword mode is where the recognizer looks for a match
>      against specific speech grammar or DTMF sequence and
>      ignores speech or DTMF that does not match. It neither
>      times out nor generates a no-match.
>      The recognition completes only for a successful match of
>      grammar or if the client cancels the request."
>
>      It seems weird that you have to "re-prime" a hotword
>      recognizer each time it detects a match, rather than let
>      it continue recognizing and just generating
>      Recognition-complete events until you tell it to stop by
>      canceling the operation or issuing a new RECOGNIZE.
>
>      Is this what was intended?
>
>

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Brett Gavagni <[email-masked]>
Date: Wed, 15 Jun 2005 11:20:42 -0400

The suggestion sounds like adding convolution to the Recognizer resource 
state machine, by altering it to require multiple RECOGNITION-COMPLETE 
events.

I would like to ensure that the thread we had a month ago on hotword is 
addressed, as I never got a final response/consensus.

[Speechsc] MRCPv2 Hotword Mode Recognition clarification
http://www.ietf.org/mail-archive/web/speechsc/current/msg01239.html

I would vote to keep the current Recognizer state machine consistent for 
both recognition modes, and to modify the wording w.r.t timers as proposed 
in the thread identified above.

I would think that for most scenarios, a hotword recognition match would 
typically require application execution changes such that a new grammar 
set is loaded and re-recognition is required. For this reason I don't 
believe that the specification should be modified to workaround an 
exception case.

Thanks,

Brett Gavagni 
WebSphere Voice Server Development 
http://www-306.ibm.com/software/pervasive/voice_server/ 
[email-masked]

"David R. Oran" <[email-masked]> 
Sent by: [email-masked]
06/15/2005 08:07 AM

To
"[email-masked] ((((E-mail))))" <[email-masked]>
cc

Subject
[Speechsc] Widening a private discussion on hotword mode

Dave.

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 15 Jun 2005 11:29:49 -0400

Thanks, I'll make sure we get the timer issue dealt with on this  
editing pass.
Sarvi's on the hook to resolve it.

Dave.