Subject: RE: [Speechsc] EMMA: Extensible MultiModal Annotation markup lang uage support?

From: "Reifenrath, Klaus" <[email-masked]>
Date: Wed, 1 Jun 2005 09:50:44 -0400

Hi Brett,

right, NLSML did not become a W3C Recommendation. Therefore the MRCPv2 spec
includes a definition of NLSML (see sections 9.6 and A.2.1 in the 06 version
of MRCPv2).

Klaus 

-----Original Message-----
From: Brett Gavagni [mailto:[email-masked]] 
Sent: Mittwoch, 1. Juni 2005 15:34
To: Jerry Carter
Cc: [email-masked]
Subject: Re: [Speechsc] EMMA: Extensible MultiModal Annotation markup
language support?

The current W3 NLSML specification is also a "W3 Working Draft" and not a
"W3 Recommendation". 

http://www.w3.org/TR/nl-spec/
Natural Language Semantics Markup Language for the Speech Interface
Framework

W3C Working Draft 20 November 2000

The current NLSML specification is actually more outdated in terms of the
function required to support the current SGRS specification (ie. Semantic
Interpretation). 

My suggestion would be to amend the current MRCPv2 specification to include
EMMA support as at least optional.

Thanks,

Brett Gavagni
WebSphere Voice Server Development
http://www-306.ibm.com/software/pervasive/voice_server/
(561) 862-2097 T/L (975)
[email-masked]

Jerry Carter <[email-masked]>
06/01/2005 09:16 AM

To
Brett Gavagni/West Palm Beach/IBM@IBMUS
cc
[email-masked]
Subject
Re: [Speechsc] EMMA: Extensible MultiModal Annotation markup language
support?

Give that EMMA is at working draft level within the W3C, it would be 
premature to require any form of EMMA support.  Making a provision in 
MRCP to support EMMA at a later date would be appropriate, though.

On Jun 1, 2005, at 8:59 AM, Brett Gavagni wrote:

> Are there currently any plans to include the support for W3C EMMA 
> Working
> Draft to the MRCPv2 specification for the returning of recognition
> results?
>
> Thanks,
>
> Brett Gavagni
> WebSphere Voice Server Development
> http://www-306.ibm.com/software/pervasive/voice_server/
> (561) 862-2097 T/L (975)
> [email-masked]
>
>
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
>

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 1 Jun 2005 10:07:48 -0400

**Chair hat on**

The WG consensus, established over a number of IETF meetings and  
mailing list discussion, was to publish MRCPv2 with the embedded  
NLSML so that implementations would have a stable base for  
development and initial deployment.

The intent has always been to incorporate EMMA once it was deemed  
fully cooked.

If the WG wants to revisit this consensus in light of the fact we  
will be going to last call on MRCPv2 imminently, I'll certainly  
entertain that possibility.

Dave.

---

From: "Dave Burke" <[email-masked]>
Date: Wed, 1 Jun 2005 16:30:26 +0100

Having experienced the pain of several MRCPv1 ASR integrations (almost 
exclusively because of the previously insufficiently defined reco results), 
we agree with the comment for "stable base for development and deployment".

Worried that even a "MAY support EMMA" is damaging but think it a reasonable 
compromise to add an informative note pointing out that the intent is to 
incorporate EMMA when it is a stable standard. This way the direction is 
clear and we don't have to revisit this question bimonthly!

-- Dave

----- Original Message ----- 
From: "David R. Oran" <[email-masked]>
To: "Reifenrath, Klaus" <[email-masked]>
Cc: <[email-masked]>; "Jerry Carter" <[email-masked]>
Sent: Wednesday, June 01, 2005 3:07 PM
Subject: Re: [Speechsc] EMMA: Extensible MultiModal Annotation markup 
language support?

> **Chair hat on**
>
> The WG consensus, established over a number of IETF meetings and  mailing 
> list discussion, was to publish MRCPv2 with the embedded  NLSML so that 
> implementations would have a stable base for  development and initial 
> deployment.
>
> The intent has always been to incorporate EMMA once it was deemed  fully 
> cooked.
>
> If the WG wants to revisit this consensus in light of the fact we  will be 
> going to last call on MRCPv2 imminently, I'll certainly  entertain that 
> possibility.
>
> Dave.
>
>