Subject: RE: [Speechsc] Problem with draft-6 RECOGNIZEcommandandtest/uri-listcontent type

From: "Wyss, Felix" <[email-masked]>
Date: Wed, 15 Jun 2005 14:43:42 -0500

I'll give it a try.  By when do you need it?

Felix

> -----Original Message-----
> From: Shanmugham, Saravanan [mailto:[email-masked]]
> Sent: Wednesday, June 15, 2005 13:53
> To: Wyss, Felix; Dave Burke; David R. Oran
> Cc: [email-masked]; Bennett, Patrick
> Subject: RE: [Speechsc] Problem with draft-6
RECOGNIZEcommandandtest/uri-
> listcontent type
> 
> I am fine with the idea.
> Would you be able to propose a content-type registration section for
> this content-type.
> We could add it to the current list of registrations and retire the
> one-of header.
> 
> Sarvi
> 
>      -----Original Message-----
>      From: Wyss, Felix [mailto:[email-masked]]
>      Sent: Wednesday, June 15, 2005 11:37 AM
>      To: Dave Burke; Shanmugham, Saravanan; David R. Oran
>      Cc: [email-masked]; Bennett, Patrick
>      Subject: RE: [Speechsc] Problem with draft-6
>      RECOGNIZEcommandandtest/uri-listcontent type
> 
>      I think that's a terrible abuse of the MIME types!  The
>      weight parameter controls the weight with which the
>      grammar is considered in a particular recognition
>      operation.  That has *absolutely nothing* to do with the
>      type of the grammar.  Using a MIME-type parameter for this
>      would be akin to controlling the text size of an HTML page
>      through its MIME type.
> 
>      I personally don't really have a problem with using an
>      inline "one-of"
>      grammar.  However, if that's considered too much hassle
>      for the clients, what about introducing a content type
>      text/grammar-refs for the RECOGNIZE command?  Each line of
>      the body would be a URI enclosed in angle brackets,
>      followed by a colon and a list of parameters.  For
>      example:
> 
>      Channel-Identifier: 123456789012345@speechrecog
>      N-Best-List-Length: 3
>      Content-Type: text/grammar-refs
>      Content-Length: xxx
> 
>      <http://myserver/grammars/form1.gram>
>      <http://myserver/grammars/form2.gram>:weight=0.85
>      <http://myserver/grammars/universals.gram>:weight=0.75
> 
> 
>      Felix
> 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 15 Jun 2005 12:51:01 -0700

We are trying to get the spec into last call quickly. So in the next
week or 2 would be nice.

Sarvi 

     -----Original Message-----
     From: Wyss, Felix [mailto:[email-masked]] 
     Sent: Wednesday, June 15, 2005 12:44 PM
     To: Shanmugham, Saravanan; Dave Burke; David R. Oran
     Cc: [email-masked]; Bennett, Patrick
     Subject: RE: [Speechsc] Problem with draft-6 
     RECOGNIZEcommandandtest/uri-listcontent type

     Felix