Subject: [Speechsc] Re: I-D ACTION:draft-melanchuk-speechsc-serverloc-00.txt

From: Tim Melanchuk <[email-masked]>
Date: Tue, 3 Jan 2006 16:16:34 -0800

the draft below is now available in the archives. we'd appreciate
a little feedback on whether the work group feels that this
approach is worthwhile. the draft discusses the currently defined
mrcpv2 resources and a few other capabilities that may differ
between servers but for which a client may choose to express a
preference. these were chosen based on previous mail list
discussion but we may have missed some.

a couple of questions we have are:

- what is the right set of capabilities?
- is the proposed mrcpv2 tree appropriate or is
  a more generic approach possible? we chose "mrcpv2" since
  the goal is to route to a server that supports specific mrcpv2
  protocol capabilities.
- is hierarchical capabilities expressed as sub-features of each
  resource the right approach, where indication of the sub-feature
  (such as jump-size) implies that the server supports that
  time of resource (such as a speech synthesizer)?

cheers,
timm

On 1/3/06, [email-masked] <[email-masked]> wrote:
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
>         Title           : Locating Media Resource Control Protocol
>                           Version 2 (MRCPv2) Servers
>         Author(s)       : T. Melanchuk, C. Boulton
>         Filename        : draft-melanchuk-speechsc-serverloc-00.txt
>         Pages           : 17
>         Date            : 2006-1-3
>
>    This specification defines and registers a set of Media Feature Tags
>    for the Media Resource Control Protocol Version 2 (MRCPv2).  Clients
>    and servers can use these tags in conjunction with the Session
>    Initiation Protocol (SIP) capabilities framework so that client
>    requests can be routed to the server best able to satisfy the clients
>    requirements.
>
> A URL for this Internet-Draft is:
>
> http://www.ietf.org/internet-drafts/draft-melanchuk-speechsc-serverloc-00.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of the
> message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
>         "get draft-melanchuk-speechsc-serverloc-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
>         [email-masked].
> In the body type:
>         "FILE /internet-drafts/draft-melanchuk-speechsc-serverloc-00.txt".
>
> NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
>
>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce
>
>
>
_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Wed, 4 Jan 2006 11:02:59 -0000

Nice to see the capabilities/prefs suggestion turn into a concrete proposal!

Some of the feature tags I was thinking about when suggesting this are based on bad interoperability experiences seen in practice. I would offer the following feature tags are very important - second only to identifying the media resource types:
    - mrcpv2.speechrecog.grammartypes - specifies the grammar types supported
    - mrcpv2.speechrecog.sitagformat - specifies the semantic interpretation tag format *
    - mrcpv2.speechrecog.recoresults - specifies format used for recognition results (i.e. NLSML or EMMA)
    - mrcpv2.speechrecog.languages - specifies the languages supported (actually this applies to multiple resource types)

Other comments:
 1. mrcpv2.speechrecog.grammars is not practical (a server is going to have a very large cache!)
 2. I think putting the version number in the feature tag may not turn out prudent (will MRCPv2.2 / v3 use mrcpv2 feature tags?)
 3. I like the hierarchical structure suggested in feature tags

(*) For historical reasons, the application/srgs and application/srgs+xml MIME types do not imply the tag-format. Today, there is one SI standard in development (W3C SISR - Candidate Rec available soon) and at least two well known proprietary SI formats. Real speech grammars need SI and, IMO, it's easily the biggest problem affecting true VoiceXML application portability today. 

Dave
  ----- Original Message ----- 
  From: Tim Melanchuk 
  To: [email-masked] 
  Sent: Wednesday, January 04, 2006 12:16 AM
  Subject: [Speechsc] Re: I-D ACTION:draft-melanchuk-speechsc-serverloc-00.txt

  cheers,
  timm

  On 1/3/06, [email-masked] <[email-masked] > wrote:
    A New Internet-Draft is available from the on-line Internet-Drafts directories. 

    To remove yourself from the I-D Announcement list, send a message to
    [email-masked] with the word unsubscribe in the body of the message.
    You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
    to change your subscription settings. 

    Internet-Drafts are also available by anonymous FTP. Login with the username
    "anonymous" and a password of your e-mail address. After logging in,
    type "cd internet-drafts" and then
            "get draft-melanchuk-speechsc-serverloc-00.txt".

    Send a message to:
            [email-masked].
    In the body type:

            a MIME-compliant mail reader.  Different MIME-compliant mail readers 

------------------------------------------------------------------------------

---

From: Tim Melanchuk <[email-masked]>
Date: Mon, 9 Jan 2006 11:51:52 -0800

hi dave,

thanks for your comments and suggestions.

dave oran has suggested that "speechsc" may also be an
appropriate prefix instead of a protocol specific prefix.
it is starting to look like many of the tags are not protocol
specific so i am considering switch to something like
"speechsc" instead of "mrcpv2".

comments on this proposal form the list would be apreciated.
i'm not sure what to do with respect to grammars. there
was considerable discussion  on the list about pre-loaded
grammars and how a client could either request, or know before
hand that there would be no significant delay for a grammar.
is this still an issue and is there an alternative solution?

cheers,
timm

On 1/4/06, Dave Burke <[email-masked]> wrote:
> Some of the feature tags I was thinking about when suggesting this are
> based on bad interoperability experiences seen in practice. I would offer
> the following feature tags are very important - second only to identifying
> the media resource types:
>     - mrcpv2.speechrecog.languages - specifies the languages supported
> (actually this applies to multiple resource types)
>
> Other comments:
>  2. I think putting the version number in the feature tag may not turn out
> prudent (will MRCPv2.2 / v3 use mrcpv2 feature tags?)
> (*) For historical reasons, the application/srgs and application/srgs+xml
> MIME types do not imply the tag-format. Today, there is one SI standard in
> development (W3C SISR - Candidate Rec available soon) and at least two well
> known proprietary SI formats. Real speech grammars need SI and, IMO, it's
> easily the biggest problem affecting true VoiceXML application portability
> today.
>
> Dave
>
>