Subject: [Speechsc] Speaker Verification (Section 11) review comments

From: "Dave Burke" <[email-masked]>
Date: Sat, 14 Jan 2006 14:26:51 -0000

Hello,

Had cause to review Section 11 of MRCPv2-09. Needs editorial attention - please see below:

Dave

1. Typos

Respository-URI -> Repository-URI
Voiceprint-Identity -> Voiceprint-Identifier

2. Error in examples

According to the spec:

The value of the Verification-Mode header MUST be one of either "train" or "verify".

... yet none of the examples include said header (and one erroneously places it in the VERIFY-FROM-BUFFER message - it is only meant to be present in the START-SESSION message).

3. Not well defined how to specifiy shared resources:

The current text for sharing sessions between a co-resident recogniser or recorder and a speaker verification engine is restrictive and not accurately specified. The key point is that the related resources are related because they were allocated within the same SIP dialog and not that they were allocated within the same (INVITE) message transaction.

Suggest changing:

   It is possible for a speaker verification resource to share the same
   session with a recognizer resource or to operate in independently.
   In order to share the same session, the SDP/SIP INVITE message for
   the verification resource MUST also include the recognizer resource
   request

to:

   It is possible for a speaker verification resource to share the same
   session with a recognizer resource or to operate independently.
   In order to share the same session, the verification and recognizer
   resources must be allocated from within the same SIP dialog.

4. <result-type> not defined anywhere in the spec. Doesn't appear in schema. Probably not necessary.

5. <num-frames> not defined anywhere in the spec.

6. Not clear for some elements if they're required or optional (section 11.5.x)

7. Define values in section 11.5.6. Presumably "et-phoned-home" is in context only if we publish on 04/01/xx?

8. Examples missing the xmlns in NLSML in VERIFICATION-COMPLETE message bodies. Actually, shouldn't the  http://www.ietf.org/xml/ns/mrcpv2 namespace apply to all NLSML documents throughout the specification not just those associated with verification?

9. What does the grammar attribute on <result> mean in the context of verification?

10. Many examples include <extensions> in their NLSML. Presumably this needs to be deleted (since the element is neither defined nor specified)?

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Sun, 15 Jan 2006 18:11:25 -0000

Six more comments on Section 11:

11. Missing state machine diagram

12. In section 11.4.3, it says "...voiceprint identifier headers of the VERIFY method". However, Voiceprint-Identifier is placed in START-SESSION not VERIFY

13. The BNF is restricting the Voiceprint-Identifer to have only 3 characters after the period. None of the examples follow this. Why the restriction in length? Suggest:

 voiceprint-identifier  =  "Voiceprint-Identifier" ":"
                                   1*VCHAR "." 1*VCHAR
                                   *[";" 1*VCHAR "." 1*VCHAR] CRLF

14. What kind of values does <decision> take when (a) training has been performed or (b) for multi-verification (can more than one voice-print be "accepted"?)

15. Minor inconsistency: Why does <verification-score> range from -1.0 to 1.0 whereas confidence (for ASR) ranges from 0 to 1.0. Why not align <verification-score> range with confidence range?

16. Editorial: Use voice-print or voiceprint but be consistent.
  ----- Original Message ----- 
  From: Dave Burke 
  To: [email-masked] 
  Sent: Saturday, January 14, 2006 2:26 PM
  Subject: [Speechsc] Speaker Verification (Section 11) review comments

  Hello,

  Dave

  1. Typos

  2. Error in examples

  According to the spec:

  Suggest changing:

  to:

------------------------------------------------------------------------------