Subject: [Speechsc] Specifying errors from GET-PARAMS mis-use

From: "Dave Burke" <[email-masked]>
Date: Sat, 11 Feb 2006 18:07:27 -0000

We don't seem to be specifying errors for GET-PARAMS. Suggest adding (i.e. this is presumably the intent):

 If some of the headers being retrieved are unsupported for the resource,
 the server MUST reject the request with a 403 Unsupported Header. 
 Such a response MUST include the (empty) unsupported headers
 exactly as they were sent from the client.

Dave
_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 22 Feb 2006 16:32:43 -0800

Makes sense. 
The same error codes and handling as defined for SET-PARAMS will be
added to the GET-PARAMS section as well.
Hope that addresses your concern.
 
Thanks,
Sarvi

________________________________

	From: [email-masked]
[mailto:[email-masked]] On Behalf Of Dave Burke
	Sent: Saturday, February 11, 2006 10:07 AM
	To: [email-masked]
	Subject: [Speechsc] Specifying errors from GET-PARAMS mis-use

	We don't seem to be specifying errors for GET-PARAMS. Suggest
adding (i.e. this is presumably the intent):
	 
	 If some of the headers being retrieved are unsupported for the
resource,
	 the server MUST reject the request with a 403 Unsupported
Header. 
	 Such a response MUST include the (empty) unsupported headers
	 exactly as they were sent from the client.
	 
	Dave

---

From: "Dave Burke" <[email-masked]>
Date: Thu, 23 Feb 2006 10:49:43 -0000

With this approach you can't differentiate between an unsupported header and a header that is not set of holds a blank value. 

Dave
  ----- Original Message ----- 
  From: Reifenrath, Klaus 
  To: 'Shanmugham, Saravanan' ; Dave Burke ; [email-masked] 
  Cc: Forgues, Pierre 
  Sent: Thursday, February 23, 2006 9:36 AM
  Subject: RE: [Speechsc] Specifying errors from GET-PARAMS mis-use

  I would think with GET-PARAM unsupported headers can be safely ignored. So what about returning 201 and all supported headers (and empty unsupported headers?)?

  Regards,
  Klaus

------------------------------------------------------------------------------
  From: Shanmugham, Saravanan [mailto:[email-masked]] 
  Sent: Donnerstag, 23. Februar 2006 01:33
  To: Dave Burke; [email-masked]
  Subject: RE: [Speechsc] Specifying errors from GET-PARAMS mis-use

  Makes sense. 
  The same error codes and handling as defined for SET-PARAMS will be added to the GET-PARAMS section as well.
  Hope that addresses your concern.

  Thanks,
  Sarvi

----------------------------------------------------------------------------
    From: [email-masked] [mailto:[email-masked]] On Behalf Of Dave Burke
    Sent: Saturday, February 11, 2006 10:07 AM
    To: [email-masked]
    Subject: [Speechsc] Specifying errors from GET-PARAMS mis-use

    Dave