Subject: RE: [speechsc] Voice-xml:lang header

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Sun, 30 Apr 2006 08:19:39 -0700

I don't believe Voice-xml:lang  was intended to be used as a header.
There is a separate langauge header to specify language.
 
But this brings out a good point. We should clarify that xml lang is not
one of the Voice-* parameters. 
 
Wondering if we should clarify by enumerating the individual Voice-*
parameters that we want to support and their possibel values and add it
to the ABNF as well, instead of just refering to the W3C doc, which
leaves it open for such interpretation.
 
Thx,
Sarvi

________________________________

	From: Dave Burke [mailto:[email-masked]] 
	Sent: Sunday, April 30, 2006 6:33 AM
	To: [email-masked]
	Subject: [speechsc] Voice-xml:lang header

	According to 8.4.6, there are a number of Voice- headers derived
from attributes on the <voice> element in SSML. One of those attributes
is xml:lang, resulting in, for example:
	 
	Voice-xml:lang: en-US
	 
	i.e. the colon in xml:lang will cause a parser to return a
header name of Voice-xml with a value of lang: en-US. Probably just need
to clarify that the preceding xml: (which is really a namespace
designation) be dropped, i.e.
	 
	Voice-lang: en-US
	 
	Dave

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Sun, 30 Apr 2006 16:28:04 +0100

Works for me.

Dave
  ----- Original Message ----- 
  From: Shanmugham, Saravanan 
  To: Dave Burke ; [email-masked] 
  Sent: Sunday, April 30, 2006 4:19 PM
  Subject: RE: [speechsc] Voice-xml:lang header

  But this brings out a good point. We should clarify that xml lang is not one of the Voice-* parameters. 

  Wondering if we should clarify by enumerating the individual Voice-* parameters that we want to support and their possibel values and add it to the ABNF as well, instead of just refering to the W3C doc, which leaves it open for such interpretation.

  Thx,
  Sarvi

----------------------------------------------------------------------------
    From: Dave Burke [mailto:[email-masked]] 
    Sent: Sunday, April 30, 2006 6:33 AM
    To: [email-masked]
    Subject: [speechsc] Voice-xml:lang header

    According to 8.4.6, there are a number of Voice- headers derived from attributes on the <voice> element in SSML. One of those attributes is xml:lang, resulting in, for example:

    Voice-xml:lang: en-US

    i.e. the colon in xml:lang will cause a parser to return a header name of Voice-xml with a value of lang: en-US. Probably just need to clarify that the preceding xml: (which is really a namespace designation) be dropped, i.e.

    Voice-lang: en-US

    Dave

---

From: Jerry Carter <[email-masked]>
Date: Sun, 30 Apr 2006 12:52:46 -0400

Yes.  An explicit list is much better.

On Apr 30, 2006, at 11:19 AM, Shanmugham, Saravanan wrote:
> parameters that we want to support and their possibel values and add 
> it to the ABNF as well, instead of just refering to the W3C doc, which 
>> According to 8.4.6, there are a number of Voice- headers derived from 
>> attributes on the <voice> element in SSML. One of those attributes is 
>> xml:lang, resulting in, for example:
>>  
>> Voice-xml:lang: en-US
>>  
>> i.e. the colon in xml:lang will cause a parser to return a header 
>> name of Voice-xml with a value of lang: en-US. Probably just need to 
>> clarify that the preceding xml: (which is really a namespace 
>> Dave_______________________________________________
> Speechsc mailing list
> [email-masked]