Subject: RE: [Speechsc] message-length clarification

From: "Carter, Jerry" <[email-masked]>
Date: Thu, 13 Apr 2006 11:45:51 -0400

Brett:

I don't understand your comment.  I don't believe that either HTTP 1.1 or
SIP (RFC 3261) requires a length on the initial line.  Can you clarify?

-=- Jerry

> -----Original Message-----
> From: Brett Gavagni [mailto:[email-masked]]
> Sent: Thursday, April 13, 2006 11:21 AM
> To: [email-masked]
> Subject: [Speechsc] message-length clarification
> 
> What is the reasoning for including the length of the start-line in the
> message-length value?
> 
> Seems a bit inconsistent with other textual based protocols including: SIP
> 2.0, HTTP 1.1, or even MRCPv1.
> 
> 5.1.  Common Protocol Elements
> 
>    The message-length field specifies the length of the message,
>    including the start-line, and MUST be the 2nd token from the
>    beginning of the message.  This is to make the framing and parsing of
>    the message simpler to do.  This field specifies the length of the
>    message including data that may be encoded into the body of the
>    message.
> 
> 
> 5.2.  Request
>    The message-length field specifies the length of the message,
>    including the start-line.
> 
> 
> 5.3.  Response
>    The message-length field specifies the length of the message,
>    including the start-line.
> 
> I hope that this is just a wording problem as even some of the examples
> don't have an accurate message-length value w.r.t draft-9 wording.
> 
> Shanmugham & Burnett      Expires June 10, 2006                [Page 99]
> 
> 
> Internet-Draft                   MRCPv2                    December 2005
> 
> 
>    S->C:MRCP/2.0 69 543259 200 COMPLETE
>    Channel-Identifier:32AECB23433801@speechrecog
>            Completion-Cause:000 success
> 
> Propose to modify the wording that message-length does NOT include the
> start-line as an issue to track for the next draft.
> 
> Thanks,
> 
> Brett Gavagni
> WebSphere Voice Server Development
> http://www-306.ibm.com/software/pervasive/voice_server/
> [email-masked]
> 
> 
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Brett Gavagni <[email-masked]>
Date: Thu, 13 Apr 2006 12:09:03 -0400

I'll try to clarify, MRCPv2 defines a start-line message-length token for 
the equivalent function that is facilitated by the "Content-Length" header 
used in SIP, HTTP 1.1, and even MRCPv1. 

I don't have a problem with the deviation from the other referenced 
protocols, but the inclusion of the length of the start-line in the 
message-length seems a bit redundant. 

Thanks,

Brett Gavagni 

"Carter, Jerry" <[email-masked]> 
04/13/2006 11:45 AM

To
Brett Gavagni/West Palm Beach/IBM@IBMUS
cc
[email-masked]
Subject
RE: [Speechsc] message-length clarification

Brett:

-=- Jerry