Subject: RE: [Speechsc] Confusable-Phrases-URI clarification request

From: "Saravanan Shanmugham \(sarvi\)" <[email-masked]>
Date: Fri, 16 Jun 2006 10:46:48 -0700

This makes sense. Anyone opposed to allowing this in START-ENROLLMENT as
well?

Do note though, that this is technically an enhancement request. And
current support in RECOGNIZE does meet the needs though not as efficient
as specifying it during START-ENROLMENT.

So, we will track it as a good suggestion. But it may not get into the
spec based on draft scheduling timelines and issues.

Thanks,
Sarvi

     -----Original Message-----
     From: Brett Gavagni [mailto:[email-masked]] 
     Sent: Wednesday, May 31, 2006 6:21 AM
     To: [email-masked]
     Subject: [Speechsc] Confusable-Phrases-URI clarification request
     
     Is there a specific testcase or rationale which required 
     the limitation for the "Confusable-Phrases-URI" header to 
     occur only in a RECOGNIZE request. 
     
     It would seem that the "Confusable-Phrases-URI" should be 
     valid to occur in a START-PHRASE-ENROLLMENT request.
     
     9.4.45.  Confusable-Phrases-URI
     
        This header specifies a grammar that defines invalid phrases for
        enrollment.  For example, typical applications do not allow an
        enrolled phrase that is also a command word.  This 
     header MAY occur
        in RECOGNIZE requests that are part of an enrollement session.
     
        confusable-phrases-uri   =  "Confusable-Phrases-URI" 
     ":" Uri CRLF
     
     Thanks,
     
     Brett Gavagni
     WebSphere Voice Server Development
     http://www-306.ibm.com/software/pervasive/voice_server/
     [email-masked]

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Sat, 17 Jun 2006 13:00:50 +0100

I agree this makes sense. Going further, once Confusable-Phrases-URI is 
allowed  in START-PHRASE-ENROLLMENT, I see no need for it in RECOGNIZE (why 
would the confusable phrases change *during* enrollment?).

Dave

----- Original Message ----- 
From: "Saravanan Shanmugham (sarvi)" <[email-masked]>
To: "Brett Gavagni" <[email-masked]>; <[email-masked]>
Sent: Friday, June 16, 2006 6:46 PM
Subject: RE: [Speechsc] Confusable-Phrases-URI clarification request

Thanks,
Sarvi

     -----Original Message-----
     From: Brett Gavagni [mailto:[email-masked]]
     Sent: Wednesday, May 31, 2006 6:21 AM
     To: [email-masked]
     Subject: [Speechsc] Confusable-Phrases-URI clarification request

     Thanks,

     Brett Gavagni