Subject: [speechsc] SPEAK error and effect on queue

From: "Dave Burke" <[email-masked]>
Date: Sun, 18 Jun 2006 13:38:17 +0100

The spec doesn't appear to specify what happens if an IN-PROGRESS SPEAK request terminates with an error and there are N requests behind it in the queue. With the speech recogniser resource, and assuming Cancel-If-Queue: false,  the remaining N requests terminate with status "011 cancelled". I'm pretty sure the intent is for the speech synthesiser resource to do the same.  If so, this suggests a clarification in para 5 in section 8.6 and a new Completion-Cause of "007 cancelled". 

Dave

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Saravanan Shanmugham \(sarvi\)" <[email-masked]>
Date: Sun, 18 Jun 2006 20:55:02 -0700

makes sense. I agree this should be done.
 
Sarvi

________________________________

	From: Dave Burke [mailto:[email-masked]] 
	Sent: Sunday, June 18, 2006 5:38 AM
	To: [email-masked]
	Subject: [speechsc] SPEAK error and effect on queue

	The spec doesn't appear to specify what happens if an
IN-PROGRESS SPEAK request terminates with an error and there are N
requests behind it in the queue. With the speech recogniser resource,
and assuming Cancel-If-Queue: false,  the remaining N requests terminate
with status "011 cancelled". I'm pretty sure the intent is for the
speech synthesiser resource to do the same.  If so, this suggests a
clarification in para 5 in section 8.6 and a new Completion-Cause of
"007 cancelled". 
	 
	Dave