Subject: Re: [Speechsc] Interpret-Text description in error

From: Dan Burnett <[email-masked]>
Date: Fri, 9 Jun 2006 04:40:43 -0700 (PDT)

After reading the entire thread to which you refer, I
would conclude that
1) the original motivation for requesting any changes
at all was satisfied by Dave Burke's note that UTF-8
is the default encoding for any text, and
2) there were mixed opinions on whether the simple
UTF-8 string or the reference to MIME text was better.

I therefore don't consider this an "error".  However,
I would like to get opinions on what implementers use
today and would prefer to use today.  If there is an
overwhelming consensus that the simple UTF-8 text is
sufficient (including explicit stated support by Eric
and Sarvi, the proponents of the reference), then we
can consider reverting to the earlier version.
Otherwise, this is not a clarification but a feature
change.

-- dan

--- "Carter, Jerry" <[email-masked]> wrote:

> 
> The language in section 9.4.31 for Interpret-Text
> does not match the
> examples in sections 9.20 and 9.21.  The error was
> introduced between draft
> 4 and 5.  The text in section 9.4.31 should read:
> 
>    This header field is used to provide the text
> string for which a 
>    natural language interpretation is desired.  This
> header field MUST 
>    be used when invoking the INTERPRET method.  
>               
>    interpret-text           =  "Interpret-Text" ":"
> 1*OCTET CRLF
> 
> to bring this section in line with the examples and
> the discussion on the
> mailing list.
> 
> 
> Background:
> 
> On 16 August 2005 [1], a questioner asked whether
> this should be changed to
> a reference because the character encoding was not
> specified.  Four days
> later, Dave Burke [2] pointed out that all MRCP
> headers are encoded as UTF-8
> strings.  Two subsequent posts [3][4] confirmed that
> having a reference was
> unnecessary.
> 
> [1]
>
http://www1.ietf.org/mail-archive/web/speechsc/current/msg00850.html
> [2]
http://www1.ietf.org/mail-archive/web/speechsc/current/msg00878.html
> [3]
http://www1.ietf.org/mail-archive/web/speechsc/current/msg00882.html
> [4]
http://www1.ietf.org/mail-archive/web/speechsc/current/msg00890.html
> 
> 
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Dan Burnett <[email-masked]>
Date: Fri, 9 Jun 2006 04:44:14 -0700 (PDT)

Now tracked as issue 92 in
http://www.softarmor.com/roundup/speechsc.

-- dan