Subject: Re: [speechsc] CONTROL/STOP requests in idle state

From: Dan Burnett <[email-masked]>
Date: Tue, 13 Jun 2006 03:43:53 -0700 (PDT)

The thread on this was fairly clear, but I have a
question about the Active-Request-Id-List.  Do you
really want it to be left out?

In the more general case, where one STOP request is
applied to a list of requests via the
Active-Request-Id-List, what should be returned in the
response's Active-Request-Id-List if, say, some of the
requests were stopped and one or more were already
idle?

-- dan

--- Dave Burke <[email-masked]> wrote:

> Would be nice to clarify that a CONTROL or STOP
> request which doesn't "catch" an IN-PROGRESS SPEAK
> request still returns a response with status code
> 200 albeit without a Active-Request-Id-List. I could
> easily imagine an implementor mistakenly assume a
> 402 Method not valid in this state should be
> returned.
> 
> Dave>
_______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Dan Burnett <[email-masked]>
Date: Tue, 13 Jun 2006 03:47:12 -0700 (PDT)

This is now tracked as issue 93 at
http://www.softarmor.com/roundup/speechsc.

-- dan

---

From: "Dave Burke" <[email-masked]>
Date: Wed, 14 Jun 2006 11:15:31 +0100

Here's my take / understanding:

In a response, the Active-Request-Id-List indicates the requests affected by 
the request. If a STOP request is applied to several requests and some of 
those were idle (hence not affected), then those idle requests do not appear 
in the Active-Request-Id-List header field value in the response. In the 
special case that no requests were affected, we're saying that an empty list 
manifests as an omitted Active-Request-Id-List header field in the response.

Dave

---

From: Dan Burnett <[email-masked]>
Date: Wed, 14 Jun 2006 03:48:26 -0700 (PDT)

I tend to agree with you.  What do you think of this
text in RESUME (sec. 8.10)?

'If a RESUME request is issued on a session with an
active SPEAK request that is speaking (i.e., not
paused) the server SHOULD respond with a status of 200
"Success". If a SPEAK request was active the server
MUST return an active-request-id-list header with the
request-id of the SPEAK request that was resumed.'

This can be interpreted in a way that matches your
understanding, below, but it can also be interpreted
as the opposite, i.e. that because the target state
was achieved the request-id must be included.
How do you interpret this method's behavior?

-- dan

---

From: "Dave Burke" <[email-masked]>
Date: Thu, 15 Jun 2006 13:34:10 +0100

Works for me.

Dave