Subject: Re: [speechsc] Fallback <audio> and 003 uri-failure

From: Dan Burnett <[email-masked]>
Date: Fri, 16 Jun 2006 16:55:16 -0700 (PDT)

Tracked as issues 98 and 99 on
http://www.softarmor.com/roundup/speechsc.

Please check the resolution on this issue.  The email
trail was somewhat convoluted, so I may have missed an
agreement (for example, with respect to combination of
Failed-URI and Failed-URI-Cause and the number of
times they are permitted).

-- dan

--- Dave Burke <[email-masked]> wrote:

> If I have some SSML along the lines of
> 
> <speak>
>      <audio src="baduri.wav"> <!-- invalid URI -->
>          <audio src="gooduri.wav"/> <!-- valid URI
> -->
>      </audio>
> </speak>
> 
> will  I get a SPEAK-COMPLETE with 000 normal or 003
> uri-failure? 
> 
> SSML requires that processing continues but that the
> hosting environment be notified. It would be useful
> to clarify that this is indeed the case with the
> basicsynth / speechsynth and that 003 uri-failure
> will be returned. Without this, the most trivial of
> media server applications (i.e. playing
> announcements) is not possible to be implemented
> robustly. 
> 
> Dave
> > _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Sat, 17 Jun 2006 12:56:04 +0100

This is consistent with my understanding of the resolution (nice 
distillation job).

Since a failed SSML document URI will cause an error and stop processing of 
the request, the question of multiple Failed-URI headers goes away (and 
maybe forever if, in the future version of addendum, an event is generated 
per failed URI).

One tiny issue that remains is that 8.4.12 says "... provide the failed URI 
in the method response". If the SPEAK requests are queued then the 
speechsynth only finds the URI failure when the offending request 
transitions from PENDING to IN-PROGRESS. Therefore, we simply need to allow 
the Failed-URI and Failed-URI-Cause header fields in SPEAK-COMPLETE also

Dave