Subject: Re: [speechsc] State machine diagram for speaker verification resource -> additional suggestions

From: "Dave Burke" <[email-masked]>
Date: Fri, 30 Jun 2006 15:16:27 +0100

Two additional suggestions: Change "Verifying State" to "Verifying/Training 
State" and add the START-SESSION / END-SESSION methods for completeness. See 
below.

   Idle                 Verifying/Training
   State                     State
     |                         |
     |----------|              |
     |     START-SESSION       |
     |<---------|              |
     |                         |
     |----------|              |
     |     END-SESSION         |
     |<---------|              |
     |                         |
     |---------VERIFY--------->|
     |                         |
     |---VERIFY-FROM-BUFFER--->|
     |                         |
     |----------|              |
     |  VERIFY-ROLLBACK        |
     |<---------|              |
     |                         |
     |                |--------|
     | GET-INTERMEDIATE-RESULTS|
     |                |------->|
     |                         |
     |                |--------|
     |     START-INPUT-TIMERS  |
     |                |------->|
     |                         |
     |                |--------|
     |         START-OF-INPUT  |
     |                |------->|
     |                         |
     |<-VERIFICATION-COMPLETE--|
     |                         |
     |<--------STOP------------|
     |                         |
     |----------|              |
     |         STOP            |
     |<---------|              |
     |                         |
     |----------|              |
     |    CLEAR-BUFFER         |
     |<---------|              |
     |                         |
     |----------|              |
     |   QUERY-VOICEPRINT      |
     |<---------|              |
     |                         |
     |----------|              |
     |  DELETE-VOICEPRINT      |
     |<---------|              |
     |                         |
----- Original Message ----- 
From: "Dave Burke" <[email-masked]>
To: <[email-masked]>
Sent: Friday, June 30, 2006 2:51 PM
Subject: [speechsc] State machine diagram for speaker verification resource

> Below is a state machine figure for the speaker verification resource (the 
> existing one is just a copy of the speech synthesiser's - probably a 
> placeholder for the real thing). Comments welcome on its accuracy to the 
> intent.
>
> Dave
>
>
>   Idle                      Verifying
>   State                     State
>     |                         |
>     |---------VERIFY--------->|
>     |                         |
>     |---VERIFY-FROM-BUFFER--->|
>     |                         |
>     |----------|              |
>     |  VERIFY-ROLLBACK        |
>     |<---------|              |
>     |                         |
>     |                |--------|
>     | GET-INTERMEDIATE-RESULTS|
>     |                |------->|
>     |                         |
>     |                |--------|
>     |     START-INPUT-TIMERS  |
>     |                |------->|
>     |                         |
>     |                |--------|
>     |         START-OF-INPUT  |
>     |                |------->|
>     |                         |
>     |<-VERIFICATION-COMPLETE--|
>     |                         |
>     |<--------STOP------------|
>     |                         |
>     |----------|              |
>     |         STOP            |
>     |<---------|              |
>     |                         |
>     |----------|              |
>     |    CLEAR-BUFFER         |
>     |<---------|              |
>     |                         |
>     |----------|              |
>     |   QUERY-VOICEPRINT      |
>     |<---------|              |
>     |                         |
>     |----------|              |
>     |  DELETE-VOICEPRINT      |
>     |<---------|              |
>     |                         |
>     |                         | 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Bergallo Patrizio" <[email-masked]>
Date: Fri, 30 Jun 2006 17:04:26 +0200

Hi,
What about adding a "session opened" (or a more appropriate name) state
to represent the verification/identification session?
No other resources have a session, with the exception of enrollment in
the recognition resource, but the related state machine diagram is
missing. 
See below.

Regards,
Patrizio Bergallo & Vittorio Manzone, Loquendo.

  Idle              Session Opened       Verifying/Training
  State             State                State
   |                   |                         |
   |--START-SESSION--->|                         |
   |                   |                         |
   |                   |----------|              |
   |                   |     START-SESSION       |
   |                   |<---------|              |
   |                   |                         |
   |<--END-SESSION-----|                         |
   |                   |                         |
   |                   |---------VERIFY--------->|
   |                   |                         |
   |                   |---VERIFY-FROM-BUFFER--->|
   |                   |                         |
   |                   |----------|              |
   |                   |  VERIFY-ROLLBACK        |
   |                   |<---------|              |
   |                   |                         |
   |                   |                |--------|
   |                   | GET-INTERMEDIATE-RESULTS|
   |                   |                |------->|
   |                   |                         |
   |                   |                |--------|
   |                   |     START-INPUT-TIMERS  |
   |                   |                |------->|
   |                   |                         |
   |                   |                |--------|
   |                   |         START-OF-INPUT  |
   |                   |                |------->|
   |                   |                         |
   |                   |<-VERIFICATION-COMPLETE--|
   |                   |                         |
   |                   |<--------STOP------------|
   |                   |                         |
   |                   |----------|              |
   |                   |         STOP            |
   |                   |<---------|              |
   |                   |                         |
   |----------|        |                         |
   |         STOP      |                         |    
   |<---------|        |                         |
   |                   |----------|              |
   |                   |    CLEAR-BUFFER         |
   |                   |<---------|              |
   |                   |                         |
   |----------|        |                         |
   |   CLEAR-BUFFER    |                         |    
   |<---------|        |                         |
   |                   |                         |
   |                   |----------|              |
   |                   |   QUERY-VOICEPRINT      |
   |                   |<---------|              |
   |                   |                         |
   |----------|        |                         |
   | QUERY-VOICEPRINT  |                         |
   |<---------|        |                         |
   |                   |                         |
   |                   |----------|              |
   |                   |  DELETE-VOICEPRINT      |
   |                   |<---------|              |
   |                   |                         |
   |----------|        |                         |
   | DELETE-VOICEPRINT |                         |
   |<---------|        |                         |

> -----Original Message-----
> From: Dave Burke [mailto:[email-masked]] 
> Sent: Friday, June 30, 2006 4:16 PM
> To: [email-masked]
> Subject: Re: [speechsc] State machine diagram for speaker 
> verificationresource -> additional suggestions
> 
> 
> > Below is a state machine figure for the speaker 
> verification resource 
> > (the
> [email-masked] https://www1.ietf.org/mailman/listinfo/speechsc
> 

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please send an e_mail to <mailto:[email-masked]>[email-masked]. Thank you<http://www.loquendo.com>www.loquendo.com
================================================
_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Bergallo Patrizio" <[email-masked]>
Date: Fri, 30 Jun 2006 17:11:44 +0200

Attached a human readable version of the diagram...
 
Patrizio.

-----Original Message-----
From: Bergallo Patrizio 
Sent: Friday, June 30, 2006 5:04 PM
To: Dave Burke; [email-masked]
Subject: RE: [speechsc] State machine diagram for speaker
verificationresource-> additional suggestions

Hi,

Regards,

> From: "Dave Burke" 
> To: 

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia
S.p.A.

================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
<mailto:[email-masked]>[email-masked]. Thank you
<http://www.loquendo.com>www.loquendo.com
================================================