Subject: Re: [Speechsc] What is the scope of MRCPv2 session

From: David R Oran <[email-masked]>
Date: Thu, 15 Jun 2006 17:07:27 -0400

On Jun 13, 2006, at 5:01 AM, Burger, Eric wrote:

> Do we need to tighten the language? Maybe introduce a new term?  
> Pick two from the set {MRCPv2, SIP, control, media control,  
> resource control, or something else descriptive of your choice}.

>
>
> Please follow-up to the list with your thoughts.
>
>
Well, this all seems clear to me, but I can certainly see how a  
newcomer would have his head spinning unless they were already very  
conversant in SIP, SDP, and in the architectural structure of MRCP.

The relationships are (unless I'm REALLY confused).
1. SIP is used to establish and maintain a SIP dialog with a SIP UA  
acting on behalf of an MRCP server.
2. Within that dialog, SDP offer-answer has been used to negotiate  
one *or more* MRCP Sessions. Each of these is described with a  
separate m= line in the SDP. In SDP terminology, each constitutes a  
media session.
3. Within an MRCP session, there may be one or more *channels*  
representing the the way the client refers to a particular resource  
at the server.

Multiple channels within an MRCP session are guaranteed to reach the  
same server state (i.e. are fate-shared) and it is assumed that state  
sharing to optimize processing can be done if the server is smart  
enough to do it.

Multiple MRCP sessions may exist inside a single SIP dialog instance.  
Each session is independent (i.e. not state-shared or fate-shared  
among themselves) and may even be anchored on a different MRCP server  
instance (process, host, etc. of the same logical server). They are  
mutually dependent in that all MRCP sessions within single SIP dialog  
are terminated if the SIP dialog is terminated.

Perhaps we need to say this, or something that more or less conveys  
this, in the architectural framework section.

Dave.

>
>
> From: santhanakrishnan [mailto:[email-masked]]
> Sent: Wednesday, June 07, 2006 1:51 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Speechsc] What is the scope of MRCPv2 session
>
>
>
> Hi,
>
>             The relationship between SIP dialog, MRCP session is  
> not clearly or explicitly stated in the draft.
>
> I have given some of the snippets from the “draft-ietf-speechsc- 
> mrcpv2-09” each of which is leading to different interpretations.  
> Even “2.1 Definitions” section does not capture these items. Any  
> amount of clarity would be appreciated.
>
>
>
> From page 10.
>
>    A separate MRCPv2 session is
>
>    needed to control each of the media processing resources associated
>
>    with the SIP dialog between the client and server.  Within a SIP
>
>    dialog, the individual resource control channels for the different
>
>    resources are added or removed through SDP offer/answer carried  
> in a
>
>    SIP re-INVITE transaction.
>
> For each resource there has to be a separate MRCP session?
>
>
>
> From page 29
>
>    All MRCPv2 requests, responses and events MUST contain the Channel-
>
>    Identifier header.  The value is allocated by the server when a
>
>    control channel is added to the session and communicated to the
>
>    client by the "a=channel" atribute in the SDP answer from the  
> server
>
>    The header value consists of 2 parts separated by the '@' symbol.
>
>    The first part is an unambiguous string identifying the MRCPv2
>
>    session.
>
>
>
>    Please refer to page 163
>
>    S->C:
>
>           SIP/2.0 200 OK
>
>           To:MediaServer <sip:[email-masked]>
>
>           From:sarvi <sip:[email-masked]>;tag=1928301774
>
>           Call-ID:a84b4c76e66710
>
>           CSeq:314163 INVITE
>
>           Contact:<sip:[email-masked]>
>
>           Content-Type:application/sdp
>
>           Content-Length:131
>
>
>
>           v=0
>
>           o=sarvi 2890844526 2890842809 IN IP4 126.16.64.4
>
>           s=SDP Seminar
>
>           i=A session for processing media
>
>           c=IN IP4 224.2.17.12/127
>
>           m=application 32416  TCP/MRCPv2
>
>           a=channel:32AECB23433801@speechsynth
>
>           a=cmid:1
>
>           m=audio 48260 RTP/AVP 0
>
>           a=rtpmap:0 pcmu/8000
>
>           a=sendonly
>
>           a=mid:1
>
>           m=application 32416  TCP/MRCPv2
>
>           a=channel:32AECB23433802@speechrecog
>
>           a=cmid:2
>
>           m=audio 48260 RTP/AVP 0
>
>           a=rtpmap:0 pcmu/8000
>
>           a=rtpmap:96 telephone-event/8000
>
>           a=fmtp:96 0-15
>
>           a=recvonly
>
>           a=mid:2
>
> Each resource control channel describes a separate session?
>
>
>
> From page 54
>
>    If the synthesizer and recognizer resources are part of the same
>
>    MRCPv2 session, they can be optimized for a quicker kill-on- 
> barge-in
>
>    response if the recognizer and synthesizer interact directly.
>
> Multiple resources can there be in a MRCP session?
>
>
>
> From page 63
>
>       For implementations where a single recognition resource does  
> not support
>
>    both modes, or simultaneous normal and hotword recognition is
>
>    desired, the two modes can be invoked through separate resources
>
>    allocated to the same SIP dialog (with different MRCP session
>
>    identifiers) and share the RTP audio feed.
>
> Can multiple MRCP sessions be there in the same SIP dialog?
>
>
>
> From page 8
>
>    MRCPv2 uses SIP and SDP to create the client/server dialog and  
> set up
>
>    the media channels to the server.  It also uses SIP and SDP to
>
>    establish MRCPv2 control sessions between the client and the server
>
>    for each media processing resource required for that dialog.  The
>
>    MRCPv2 protocol exchange between the client and the media  
> resource is
>
>    carried on that control session.
>
> Again does each resource control channel describe a separate session?
>
>
>
> Regards,
>
> Santhanakrishnan;
>
>
>
>

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: santhanakrishnan <[email-masked]>
Date: Fri, 16 Jun 2006 19:05:38 +0530

Hi Oran,

      Thanks for your detailed explanation. It clarifies enough of our
queries.

But I would like to highlight the main source of confusion again to you.

Please refer the following section from the draft

6.2.1 

   client by the "a=channel" attribute in the SDP answer from the

   server.  The header value consists of 2 parts separated by the '@'

   symbol.  The first part is an unambiguous string identifying the

   MRCPv2 session.  The second part is a string token which specifies

   one of the media processing resource types listed in Section 3.1.

   The unambiguous string (first part) MUST BE unique among the resource

   instances managed by the server and is common to all resource

   channels with that server established through a single SIP dialog.

Here it says the prefix (First part) identifies an MRCPv2 session.

But in the following example, the channel Id returned by the Server 

for Synthesizer and Recognizer belonging to the same MRCPv2 Session 

is shown with different prefix(First Part).

S->C:  SIP/2.0 200 OK

          Via:SIP/2.0/TCP client.atlanta.example.com:5060;

          branch=z9hG4bK74bf9

........................................

          v=0

          s=-

          c=IN IP4 224.2.17.12

          a=setup:passive

          a=connection:existing

          a=channel:32AECB234338@speechrecog

          a=cmid:1

          a=setup:passive

          a=connection:existing

          a=channel:32AECB234339@speechsynth

          a=cmid:1

          m=audio 48260 RTP/AVP 0 96

          a=rtpmap:0 pcmu/8000

          a=fmtp:96 0-15

          a=sendrecv

          a=mid:1

Here I wonder either the example or the draft statement seems to be
incorrect. 

Please clarify on this.

Regards,

Santhanakrishnan;

-----Original Message-----
From: David R Oran [mailto:[email-masked]] 
Sent: Friday, June 16, 2006 2:37 AM
To: IETF SPEECHSC (E-mail)
Subject: Re: [Speechsc] What is the scope of MRCPv2 session

media session.

at the server.

enough to do it.

Dave.

> I have given some of the snippets from the "draft-ietf-speechsc- 

> mrcpv2-09" each of which is leading to different interpretations.  

> Even "2.1 Definitions" section does not capture these items. Any  

>           From:sarvi <sip:[email-masked]>;tag28301774

Speechsc mailing list

[email-masked]