Subject: Re: [speechsc] Load-Lexicon / Lexicon-Search-Order

From: Dan Burnett <[email-masked]>
Date: Fri, 9 Jun 2006 04:09:51 -0700 (PDT)

I agree with your opinions on where the headers may be
used.

Interestingly, DEFINE-LEXICON "tells the server to
load, unload, activate or deactivate the lexicon", but
the text doesn't say how.  I'd like to hear some
opinions from others on this list about the "activate
and deactivate" functionality and its relationship, if
any, to Load-Lexicon, for clarification purposes.

-- dan

--- Dave Burke <[email-masked]> wrote:

> Currently, we don't say which messages the
> Load-Lexicon and Lexicon-Search-Order headers can be
> be specified in. 
> 
> My interpretation is that Load-Lexicon can only be
> specified in DEFINE-LEXICON (to indicate load or
> unload of a lexicon) and Lexicon-Search-Order can be
> specified in SPEAK or SET-PARAMS/GET-PARAMS. Is this
> the intent?
> 
> Why do we need a Load-Lexicon header field at all?
> For DEFINE-GRAMMAR we don't bother providing an
> unload grammar mechanism so seems a little
> inconsistent.
> 
> Dave>
_______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Dan Burnett <[email-masked]>
Date: Fri, 9 Jun 2006 04:17:42 -0700 (PDT)

Tracked as issue 91 on
http://www.softarmor.com/roundup/speechsc.

-- dan