Subject: [spfbis] general changes to RFC 4408 (was: #58: Local policy in 4408bis)

From: Arthur Thisell <[email-masked]>
Date: Thu, 13 Sep 2012 22:55:10 -0700 (PDT)

> I agree it could be reworded without great harm, but I don't see why it should 
> be changed.  Every time we change something in 4408bis from what's in RFC 4408 
> we have created an opportunity for an implementer that's reviewing the new RFC 
> to update their implementation to be confused.

strongly agreed.

> I wish we'd quit rewriting stuff to rewrite it and focus on actual issues that 
> need to be resolved.

This too.

There seems to be too many changes from RFC 4408 for the sake of changes.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 13 Sep 2012 23:28:19 -0700

> There seems to be too many changes from RFC 4408 for the sake of changes.

I think this posture is somewhat dismissive of a bigger picture.
We've learned a lot since 2006 about a number of things, from how SPF
is used to the way these kinds of documents ought to be written.
Adapting RFC4408 to better fit either of those concerns doesn't
qualify as "for the sake of changes" as far as I can tell.

Remember, RFC4408 got through as Experimental which is the IETF's
lowest bar.  Altering the presentation of the material to make the
document more likely to pass Standards Track IESG review is also
something we need to undertake, whether or not we find it contrary to
the idea of maximum preservation.

There's also been a number of changes introduced as compromises to try
to satisfy contentious positions.  In my experience, that's not an
uncommon tactic of working groups, nor is it improper.

-MSK

---

From: Dave Crocker <[email-masked]>
Date: Fri, 14 Sep 2012 08:13:29 -0700

>> I wish we'd quit rewriting stuff to rewrite it and focus on actual issues that

This seems to take the position that more clear, more complete, more 
precise writing of a specification is not an actual issue.

I disagree.  Writing matters.

d/

-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Scott Kitterman <[email-masked]>
Date: Fri, 14 Sep 2012 11:22:46 -0400

>I disagree.  Writing matters.
No.  It doesn't.  It takes the position that we're spending a lot of time on text and structural changes that don't make things better.

Scott K