Subject: Re: [spfbis] #57: x-* fields in 4408bis

From: S Moonesamy <[email-masked]>
Date: Thu, 06 Sep 2012 15:53:16 -0700

At 01:11 06-09-2012, spfbis issue tracker wrote:
>#57: x-* fields in 4408bis
>
>  Message posted by Stuart Gathman on 5 Sept 2012:
>
>  My python milter production software on a dozen MTAs consumes Received-
>  SPF. It is very important for a main MTA getting mail forwarded from an MX
>  (the MX has to check SPF, of course). All the fields are used, plus a few
>  x-* fields I added (like x-bestguess).
>
>  http://www.ietf.org/mail-archive/web/spfbis/current/msg02615.html

x-* fields was not raised as an issue.  There is BCP 178 which 
deprecates the "X-" convention for newly defined parameters in 
application protocols, including new parameters for established 
protocols.  Are any other implementations using "x-"?

Regards,
S. Moonesamy

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 06 Sep 2012 19:19:29 -0400

>protocols.  Are any other implementations using "x-"?

I removed the "X dash" before the initial working group draft based on based on that BCP.  Since they are by definition non-standard, I don't think it's got any interoperability implications.

Scott K