Subject: [spfbis] Seeking AD clarification on what should be DISCUSSED in this WG

From: Arthur Thisell <[email-masked]>
Date: Wed, 12 Sep 2012 21:49:59 -0700 (PDT)

Hector, you keep saying things like:

> {...} as if it (SPFBIS) is a new timeline with suggestions the mode of SPF 
> rejections was never part of the SPF fundamental design philosophy and 
> protocol process {...}

> No, instead, they want -ALL to be relaxed {...}

> That is what should be OUT OF SCOPE - reinventing Applied SPF and it is 
> completely unfair to long time SPF supporters that use SPF today in their 
> product lines.

My memory is rusty enough to go back and check things.   I can find no evidence that SPFf has ever had a stronger policy than what 4408bis currently has.  Nothing that says that it is expected that email that fails SPF checks should be not up to the receiver to decide if it should be rejected.

The first post to the spf-discuss list from you that I could find was from 16 feb 2004, but I may have missed some.   But feb 2004 is not much before MARID started and it is long after Meng Weng Wong changed the SPF documents to say "pass/fail" from "accept/deny".  I can find Meng Weng Wong writing things like "SPF, in the best and worst traditions of Unix, aims to provide mechanism, not policy.", but nothing from him that backs up your claims.

The SPF documents back then have contradictory language, some parts saying clearly that it up to the receiver, some parts saying that non-conformant messages SHOULD be rejected, but on balance most of each document say that up to the receiver.

Can you please give some pointers to back up your claim?   Obviously, I can't give pointers to stuff that isn't there.

One public archive of spf-discuss that I could find is: http://www.mhonarc.org/archive/html/spf-discuss/

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 13 Sep 2012 01:45:26 -0400

On Wednesday, September 12, 2012 09:49:59 PM Arthur Thisell wrote:
> My memory is rusty enough to go back and check things.   I can find no
> evidence that SPFf has ever had a stronger policy than what 4408bis
> currently has.  Nothing that says that it is expected that email that fails
> SPF checks should be not up to the receiver to decide if it should be
> rejected.
> 
> The first post to the spf-discuss list from you that I could find was from
> 16 feb 2004, but I may have missed some.   But feb 2004 is not much before
> MARID started and it is long after Meng Weng Wong changed the SPF documents
> to say "pass/fail" from "accept/deny".  I can find Meng Weng Wong writing
> things like "SPF, in the best and worst traditions of Unix, aims to provide
> mechanism, not policy.", but nothing from him that backs up your claims.
> 
> The SPF documents back then have contradictory language, some parts saying
> clearly that it up to the receiver, some parts saying that non-conformant
> messages SHOULD be rejected, but on balance most of each document say that
> up to the receiver.
> 
> Can you please give some pointers to back up your claim?   Obviously, I
> can't give pointers to stuff that isn't there.
> 
> One public archive of spf-discuss that I could find is:
> http://www.mhonarc.org/archive/html/spf-discuss/

The archive at the actual host for the list, listbox, seems to be incomplete, 
since it starts in April 2004, clearly in mid conversation.  The one you found 
is better.

Scott K