Subject: Re: [spfbis] #58: Local policy in 4408bis

From: Arthur Thisell <[email-masked]>
Date: Fri, 14 Sep 2012 10:03:16 -0700 (PDT)

> Can you give a step by step explanation of how you plan to keep people to 
> whom you send mail from forwarding it wherever they want and otherwise 
> implementing arbitrary local policies of which you disapprove?

SPF isn't any sort of DRM, so no, you can't stop people from forwarding email.  That doesn't mean that an ADMD can't choose to make a sender policy that is more (or less) friendly to forwarders.  Several such examples of how to do so can be found in RFC 4408.   (I'm not sure the "how to" part is appropriate for 4408bis, but that's another subject.)

SPF is not strictly path-authorization, although that is the most common way it is used.

---

From: "John Levine" <[email-masked]>
Date: 14 Sep 2012 18:28:02 -0000

In article <[email-masked]> you write:
>SPF isn't any sort of DRM, so no, you can't stop people from forwarding email.  That doesn't mean
>that an ADMD can't choose to make a sender policy that is more (or less) friendly to forwarders. 

I think we agree here -- the sender can publish any policy it wants,
but the receiver isn't bound by that policy.

R's,
John