Subject: Re: [spfbis] Advocacy/how-to in RFC 4408

From: Arthur Thisell <[email-masked]>
Date: Fri, 14 Sep 2012 09:19:25 -0700 (PDT)

>> Which parts of RFC 4408 could be categorized as advocacy/how-to stuff?
>
> The following are some snippets from 4408bis where receiver behavior
> is explicit:

first, "receiver behavior" is not the same as "advocacy/how-to stuff"

second, receiver behavior is fine as long as it helps the protocol.  In particular, the SPF specs are not just about the communication needed for check_hosts() evaluation, they have also always included communication to the  sender of the email (via SMTP reply codes and exp= info) and to the receiver of the email (via Received-SPF).   Whether SPF should have ventured into those areas is debatable, but RFC 4408 did and changing it would be outside the charter of the WG.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 14 Sep 2012 13:00:31 -0700

> second, receiver behavior is fine as long as it helps the protocol.  In particular, the SPF specs are not just about the communication needed for check_hosts() evaluation, they have also always inc…

It is possible to alter the presentation of the material to resolve
the debate; make those things not part of the core specification, but
rather make them available in an adjunct fashion.

-MSK