Subject: RE: [SPIRITS] Minor modifications to Joined PINT-SPIRITS architec ture

From: "Buller, Jeremy" <[email-masked]>
Date: Tue, 4 Jul 2000 15:48:37 -0400

Hi Alec,

> Sorry to interrupt this discussion thread, but SoftSwitch is 
> completely outside of our Charter. It would be an 
> interesting thread, though!
Mmmmm, OK, how about, 'a thing' that can handle calls, has 
a call model, may know about points in call and may also 
have a detection point 'like' mechanism. i.e. those things 
we probably need to have in the PSTN domain in order to 
initiate services in the Internet domain.

One could maybe consider one variant of this 'thing' to be 
clever Switch (maybe even, in name, with very soft 'Soft' 
before it) then I guess it would loosely fall into the 
PSTN part of the term PSTN/IN.

The point I was trying to make was to just raise awareness 
that the interface discussions of the groups - PINT/SPIRITS 
WGs and the ISC Application group; seem IMHO in large part 
to be looking at much the same thing. 

An issue to consider is whether to follow the PINT 
paradigm i.e. there is an Executive System in the PSTN 
and we don't care what it is - a clever switch, IN or a 
person with a cup of coffee sitting at a switchboard - 
they are expected to do what is requested of them by the 
initiating entity in the Internet domain. If we were to 
follow this paradigm in the SPIRITS case there would 
exist an Initiative System in the PSTN, but again we don't 
need to know, or care, what it is. We would only be
interested in 'how' it talks to the Internet domain and 
'what' it may communicate (the protocol), anything else 
is quite probably pants.

Kind regards,

Jim Buller

p.s. Happy Independence day to any Americans out there 
and (humour :) Happy Thanksgiving to any Brits.

_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits

---

From: Jörgen Björkner <[email-masked]>
Date: Wed, 5 Jul 2000 09:26:20 +0200

I agree with Jeremy, from an IETF SPIRITS viewpoint could PSTN be
substituted with ANY other voice handling "thing". This would only affect
interface D, which is an implementation issue of one of the interfaces of
the SPIRITS client.

/Jörgen

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Buller, Jeremy
> Sent: den 4 juli 2000 21:49
> To: 'Alec Brusilovsky'; SPIRITS list
> Subject: RE: [SPIRITS] Minor modifications to Joined PINT-SPIRITS
> architecture
>
>
> Hi Alec,
>

---

From: Alec Brusilovsky <[email-masked]>
Date: Wed, 05 Jul 2000 10:40:20 -0500

Jim, Jörgen,

If you are proposing to treat softswitch as 'ANY other voice handling
"thing"' - I totally agree. In that case we assume that SS has no special
functionality besides being PSTN element. We do not even have to name this
element SS. This is well within our Charter.
However, SPIRITS charter does not support any SS functionality that is
different from "plain" PSTN/IN element.

Regards,
Alec

---

From: [email-masked]
Date: Wed, 05 Jul 2000 13:24:16 -0400

Jörgen Björkner wrote:
> substituted with ANY other voice handling "thing". 

Well, it is a switch that is a voice handling thing, but for the purposes of
PINT and SPIRITS we are dealing with the service control. So, of course one
needs to look at voice, and--for that matter--the soft switch, but those are
subjects of other IETF WGs, ITU-T, and other bodies.

This would only affect
> interface D, which is an implementation issue of one of the interfaces of

Right. But note that this interface is to the service control.