Subject: Re: [SPIRITS] Minor modifications to Joined PINT-SPIRITS architecture

From: Alec Brusilovsky <[email-masked]>
Date: Mon, 03 Jul 2000 11:41:34 -0500

"Buller, Jeremy" wrote:

> ...
> Below is a couple of diagrams from a draft I was going to
> submit.

> ...

> So if your interested? When
> is the deadline by the way?

The deadline is July 14. Plenty of time...

> ....
> Do we really need to know what happens in the PSTN? Your
> diagram has interfaces D and E?

Lev, Jim, I do agree that interfaces D and E might be important for a
comprehensive architectural picture. I would, however, separate all
interfaces into two groups: Essential Interfaces (A, B, C) and NonEssential
(D, E) Sound like a compromise?

> ...
>
> What is of *real* interest is the action requested (class
> of action requested) and responses that should be
> available at your interface A and B/C (although I'm a
> little unsure of the requirement for an 'explicit' proxy
> in the diagram).

Again, in opinion one of the advantages of having SPIRITS Proxy in the
architecture  - it provides a better scalability.

>
>
> For example, if I were interested (which I am) in this
> approach for say, the interface between a Soft Switch and
> an Application Server (see International SoftSwitch
> Consortium) the action requested might be the exactly same
> as for IN but the implementation in the PSTN/IN/SoftSwitch
> might/ would probably be completely different? But the
> implementation is irrelevant because IMO it is out of
> scope (the IETF does protocols). For the service logic
> in the PSTN of such an implementation I could use an
> IN, Application Server or whatever I liked on the other
> end.
>

Sorry to interrupt this discussion thread, but SoftSwitch is completely
outside of our Charter. It would be an interesting thread, though!

Regards,
Alec

---

From: Alec Brusilovsky <[email-masked]>
Date: Mon, 03 Jul 2000 11:47:11 -0500

"Slutsman, Lev A, ALSVC" wrote:

>  ...
>  As for SPIRITS Proxy, this element is needed, because the SPIRITS requests
> ,in general,  must be terminates at the subscriber's PC.

Can we use more general term IP Host, or Internet Appliance. After all,
Subscriber's PC represents only certain SPIRITS scenarios.

Regards,
Alec