Subject: [SPIRITS] Re: SPIRITS digest, Vol 1 #52 - 4 msgs

From: [email-masked]
Date: Fri, 17 Jan 2003 10:42:55 +0530

hi all,
I hope that we can have subscription to multiple DPs in a single SUBSCRIBE
message.
The DPs to be subscribed in a SUBSCRIBE message can be an ARRAY. In this way we
can
subscribe to mulitple DPs..
and Talking of the Notify ....Notify will be sent only for the DP hit.

thanks
Uppen

[email-masked] on 01/16/2003 10:31:05 PM

Please respond to [email-masked]

To:   [email-masked]
cc:    (bcc: Uppen Babu Chava/HSS)

Subject:  SPIRITS digest, Vol 1 #52 - 4 msgs

Send SPIRITS mailing list submissions to
     [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
     http://lists.bell-labs.com/mailman/listinfo/spirits
or, via email, send a message with subject or body 'help' to
     [email-masked]

You can reach the person managing the list at
     [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of SPIRITS digest..."

Today's Topics:

   1. Re: Subscribing to multiple DPs (Alec Brusilovsky)
   2. Re: Subscribing to multiple DPs (Vijay K. Gurbani)
   3. Re: Subscribing to multiple DPs (Alec Brusilovsky)
   4. Re: Subscribing to multiple DPs (Vijay K. Gurbani)

Message: 1
Date: Wed, 15 Jan 2003 11:07:27 -0600
From: Alec Brusilovsky <[email-masked]>
Gecko/20021120 Netscape/7.01
MIME-Version: 1.0
To: "Vijay K. Gurbani" <[email-masked]>
Cc: SPIRITS list <[email-masked]>
Subject: Re: [SPIRITS] Subscribing to multiple DPs
References: <[email-masked]>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
Sender: [email-masked]
Precedence: bulk
List-Help: <mailto:[email-masked]?subject=help>
List-Post: <mailto:[email-masked]>
List-Subscribe: <http://lists.bell-labs.com/mailman/listinfo/spirits>,      <
mailto:[email-masked]?subject=subscribe>
List-Id: <spirits.lists.bell-labs.com>
List-Unsubscribe: <http://lists.bell-labs.com/mailman/listinfo/spirits>,    <
mailto:[email-masked]?subject=unsubscribe>
List-Archive: <http://lists.bell-labs.com/pipermail/spirits/>

I realize that multiple DP/events subscribe would be a handy thing to have.
In my opinion, single DP/event subscription is a much cleaner thing to
do. If you need to implement a service that asks for multiple subscribes
- just do exactly that: issue multiple SUBSCRIBE loops. Much, much
easier to control and lighter on security threats. Drawback: creates
more network traffic.
It is a good discussion, let's continue it.

-Alec

Vijay K. Gurbani wrote:

> Any thoughts on subscribing to multiple DPs in one SUBSCRIBE request?
> For instance, if I am implementing a presence capability on a black
> phone, I would typically be interested in the following events:
> answering calls and attempt to make a call.
>
> So far in our discussion in the protocol I-D, we do not explicitly
> prohibit subscriptions to multiple DPs, nor to we explicitly condone
> it.  However, the examples in the text all have subscriptions to a
> single DP.
>
> Any thoughts and views would be appreciated.
>
> Thanks,
>
> - vijay

--
Alec Brusilovsky
[email-masked]
Naperville, IL USA
+1.630.369.8196

Message: 2
Date: Wed, 15 Jan 2003 11:19:42 -0600
From: "Vijay K. Gurbani" <[email-masked]>
Organization: Lucent Technologies, Inc./Bell Laboratories
Gecko/20020826
MIME-Version: 1.0
To: Alec Brusilovsky <[email-masked]>
Cc: SPIRITS list <[email-masked]>
Subject: Re: [SPIRITS] Subscribing to multiple DPs
References: <[email-masked]> <[email-masked]>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
Sender: [email-masked]
Precedence: bulk
List-Help: <mailto:[email-masked]?subject=help>
List-Post: <mailto:[email-masked]>
List-Subscribe: <http://lists.bell-labs.com/mailman/listinfo/spirits>,      <
mailto:[email-masked]?subject=subscribe>
List-Id: <spirits.lists.bell-labs.com>
List-Unsubscribe: <http://lists.bell-labs.com/mailman/listinfo/spirits>,    <
mailto:[email-masked]?subject=unsubscribe>
List-Archive: <http://lists.bell-labs.com/pipermail/spirits/>

Alec Brusilovsky wrote:
> I realize that multiple DP/events subscribe would be a handy thing to have.
> In my opinion, single DP/event subscription is a much cleaner thing to
> do. If you need to implement a service that asks for multiple subscribes
> - just do exactly that: issue multiple SUBSCRIBE loops.

But all these SUBSCRIBEs logically belong to the same service.  I think
that we should we should physically end up representing the subscription
to each such DP in the same SUBSCRIBE request.  I would expect one, and
only one NOTIFY when any of these events occur.  What are my
expectations if I send multiple SUBSCRIBEs?  Am I getting multiple
NOTIFYs?

> Much, much
> easier to control and lighter on security threats. Drawback: creates
> more network traffic.

Using a different SUBSCRIBE request for each DP which results in the
same service appears (to me, anyway) cumbersome and network and
processing intensive.  Furthermore, after the NOTIFYs arrive and the
subscription expires, it is easy to re-subscribe using the single
SUBSCRIBE request instead of sending a flurry of multiple SUBSCRIBEs.

Cheers,

- vijay
--
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

Message: 3
Date: Wed, 15 Jan 2003 11:41:30 -0600
From: Alec Brusilovsky <[email-masked]>
Gecko/20021120 Netscape/7.01
MIME-Version: 1.0
To: "Vijay K. Gurbani" <[email-masked]>
Cc: SPIRITS list <[email-masked]>
Subject: Re: [SPIRITS] Subscribing to multiple DPs
References: <[email-masked]> <[email-masked]>
<[email-masked]>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
Sender: [email-masked]
Precedence: bulk
List-Help: <mailto:[email-masked]?subject=help>
List-Post: <mailto:[email-masked]>
List-Subscribe: <http://lists.bell-labs.com/mailman/listinfo/spirits>,      <
mailto:[email-masked]?subject=subscribe>
List-Id: <spirits.lists.bell-labs.com>
List-Unsubscribe: <http://lists.bell-labs.com/mailman/listinfo/spirits>,    <
mailto:[email-masked]?subject=unsubscribe>
List-Archive: <http://lists.bell-labs.com/pipermail/spirits/>

So, where is the logical aggregation of the DPs (events) into one
service happening? What is the same DP (event) is utilized in multiple
servises? Than we are up to a real mess. Sometimes creating extra
traffic is the lesser of evils...
-Alec

Vijay K. Gurbani wrote:

> Alec Brusilovsky wrote:
>
>> I realize that multiple DP/events subscribe would be a handy thing to
>> have.
>> In my opinion, single DP/event subscription is a much cleaner thing
>> to do. If you need to implement a service that asks for multiple
>> subscribes - just do exactly that: issue multiple SUBSCRIBE loops.
>
>
> But all these SUBSCRIBEs logically belong to the same service.  I think
> that we should we should physically end up representing the subscription
> to each such DP in the same SUBSCRIBE request.  I would expect one, and
> only one NOTIFY when any of these events occur.  What are my
> expectations if I send multiple SUBSCRIBEs?  Am I getting multiple
> NOTIFYs?
>
>> Much, much easier to control and lighter on security threats.
>> Drawback: creates more network traffic.
>
>
> Using a different SUBSCRIBE request for each DP which results in the
> same service appears (to me, anyway) cumbersome and network and
> processing intensive.  Furthermore, after the NOTIFYs arrive and the
> subscription expires, it is easy to re-subscribe using the single
> SUBSCRIBE request instead of sending a flurry of multiple SUBSCRIBEs.
>
> Cheers,
>
> - vijay

--
Alec Brusilovsky
[email-masked]
Naperville, IL USA
+1.630.369.8196

Message: 4
Date: Wed, 15 Jan 2003 11:46:59 -0600
From: "Vijay K. Gurbani" <[email-masked]>
Organization: Lucent Technologies, Inc./Bell Laboratories
Gecko/20020826
MIME-Version: 1.0
To: Alec Brusilovsky <[email-masked]>
Cc: SPIRITS list <[email-masked]>
Subject: Re: [SPIRITS] Subscribing to multiple DPs
References: <[email-masked]> <[email-masked]>
<[email-masked]> <[email-masked]>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
Sender: [email-masked]
Precedence: bulk
List-Help: <mailto:[email-masked]?subject=help>
List-Post: <mailto:[email-masked]>
List-Subscribe: <http://lists.bell-labs.com/mailman/listinfo/spirits>,      <
mailto:[email-masked]?subject=subscribe>
List-Id: <spirits.lists.bell-labs.com>
List-Unsubscribe: <http://lists.bell-labs.com/mailman/listinfo/spirits>,    <
mailto:[email-masked]?subject=unsubscribe>
List-Archive: <http://lists.bell-labs.com/pipermail/spirits/>

Alec Brusilovsky wrote:
> So, where is the logical aggregation of the DPs (events) into one
> service happening? What is the same DP (event) is utilized in multiple
> servises? Than we are up to a real mess.

Ah, okay.  I see your point...

- vijay
--
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits

_______________________________________________
SPIRITS mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/spirits

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 20 Jan 2003 13:54:17 -0600

[email-masked] wrote:
> The DPs to be subscribed in a SUBSCRIBE message can be an ARRAY. In this 
> way we can subscribe to mulitple DPs..

Great!  We concur on this; please see my last email on this with details
on the representation of the DPs and subsequent handling of the NOTIFY.

Thanks,

- vijay