Subject: Re: [spring] Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace

From: <[email-masked]>
Date: Mon, 9 Sep 2019 12:53:16 +0000

RFC 8287 is a product of the MPLS WG so in the absence of answer on the SPRING mailing list, I'm redirecting the question to the MPLS WG.

--Bruno

From: spring [mailto:[email-masked]] On Behalf Of Aissaoui, Mustapha (Nokia - CA/Ottawa)
Sent: Friday, August 2, 2019 12:29 AM
To: [email-masked]
Subject: [spring] Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace

Dear all,
I am not sure if this was discussed during the development of RFC 8287 - "Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs)                         with MPLS Data Planes", but I could not find anything in the SPRING mail archive.

Prefix SID and adjacency SID which are originated in an OSPFv3 instance (IPv4 or IPv6 instance) do not have a protocol ID assigned to them in the Segment ID Sub-TLV, as well as in the Label Stack Sub-TLV of the Downstream Detailed Mapping TLV.

Should we assign the next available IANA codepoint values or was there a rationale for omitting them?

Regards,
Mustapha.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 11 Sep 2019 04:20:51 +0000

Hi Mustapha,

The RFC8287 refers to OSPF and not OSPFv2. Conventionally, we use the term OSPF when we are referring to both OSPFv2 and OSPFv3. I am not sure if this was the authors' objective.

One might assume that OSPFv2 is purely for IPv4 and OSPFv3 for IPv6, but this is not true (see RFC5838).

I would it is better to have two separate code-points for OSPFv2 and OSPFv3 in this case.

Thanks,
Ketan

From: mpls <[email-masked]> On Behalf Of [email-masked]
Sent: 09 September 2019 18:23
To: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [mpls] Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace

--Bruno

From: spring [mailto:[email-masked]] On Behalf Of Aissaoui, Mustapha (Nokia - CA/Ottawa)
Sent: Friday, August 2, 2019 12:29 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [spring] Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace

Dear all,

Regards,
Mustapha.

Thank you.

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 11 Sep 2019 06:31:27 +0000

Thank you Ketan.

I believe it would be appropriate to have a separate codepoint for each OSPFv2 and OSPFv3 protocols. Within OSPFv3 we can distinguish the family IPv4 and IPv6 based on the prefix of the SID.

Mustapha.

From: Ketan Talaulikar (ketant) <[email-masked]>
Sent: Wednesday, September 11, 2019 12:21 AM
To: [email-masked]; Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace

Hi Mustapha,

Thanks,
Ketan

From: mpls <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: 09 September 2019 18:23
To: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [mpls] Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace

--Bruno

Dear all,

Regards,
Mustapha.

Thank you.

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 11 Sep 2019 12:18:28 +0000

Hi Ketan/Mustapha,

During the time of this RFC development, we used OSPF as codepoint for both v2 and v3.

I think a separate code point for OSPFv3 would be more cleaner.

Thanks,
Nagendra

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wednesday, September 11, 2019 at 2:31 AM
To: "Ketan Talaulikar (ketant)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace
Resent-From: <[email-masked]>
Resent-To: Nagendra Kumar <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Wednesday, September 11, 2019 at 2:31 AM

Thank you Ketan.

Mustapha.

Hi Mustapha,

The RFC8287 refers to OSPF and not OSPFv2. Conventionally, we use the term OSPF when we are referring to both OSPFv2 and OSPFv3. I am not sure if this was the authors’ objective.

Thanks,
Ketan

RFC 8287 is a product of the MPLS WG so in the absence of answer on the SPRING mailing list, I’m redirecting the question to the MPLS WG.

--Bruno

Dear all,
I am not sure if this was discussed during the development of RFC 8287 – “Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs)                         with MPLS Data Planes”, but I could not find anything in the SPRING mail archive.

Regards,
Mustapha.

Thank you.

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 11 Sep 2019 13:31:58 +0000

+1. We should have different codepoints for OSPFv2 and OSPFv3.

I recall we actually planned to do that not too long ago, but I cannot find the draft on which we split the codepoint.

Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>

Thank you Ketan.

Mustapha.

Hi Mustapha,

Thanks,
Ketan

--Bruno

Dear all,

Regards,
Mustapha.

Thank you.

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 12 Sep 2019 18:42:29 +0000

Carlos,
How do we go about it? Is this an addendum to the RFC?

Mustapha.
Sent from my iPhone

On Sep 11, 2019, at 6:32 AM, Carlos Pignataro (cpignata) <[email-masked]<mailto:[email-masked]>> wrote:

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 11, 2019 at 2:31 AM
To: "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Wednesday, September 11, 2019 at 2:31 AM

Thank you Ketan.

Mustapha.

From: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, September 11, 2019 12:21 AM
To: [email-masked]<mailto:[email-masked]>; Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: Codepoint for OSPFv3 protocol in SPRING LSP-Ping and LSP-Trace

Hi Mustapha,

Thanks,
Ketan

--Bruno

Dear all,

Regards,
Mustapha.

Thank you.

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 12 Sep 2019 18:48:02 +0000

Hi, Mustapha,

Yes, that would need a Std Track RFC: https://www.iana.org/assignments/mpls-lsp-ping-parameters/#protocol-segment-id-sub-tlv

Thanks,

Carlos.

On Sep 12, 2019, at 2:42 PM, Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:

 Carlos,

Mustapha.
Sent from my iPhone

Thank you Ketan.

Mustapha.

Hi Mustapha,

Thanks,
Ketan

--Bruno

Dear all,

Regards,
Mustapha.

Thank you.