Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

From: [email-masked]
Date: Tue, 24 Sep 2019 11:22:34 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Source Packet Routing in Networking WG of the IETF.

        Title           : SRv6 Network Programming
        Authors         : Clarence Filsfils
                          Pablo Camarillo Garvia
                          John Leddy
                          Daniel Voyer
                          Satoru Matsushima
                          Zhenbin Li
	Filename        : draft-ietf-spring-srv6-network-programming-03.txt
	Pages           : 42
	Date            : 2019-09-24

Abstract:
   This document describes the SRv6 network programming concept and its
   most basic functions.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-spring-srv6-network-programming/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-03
https://datatracker.ietf.org/doc/html/draft-ietf-spring-srv6-network-programming-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-srv6-network-programming-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Tue, 24 Sep 2019 18:30:59 +0000

Hi all,

We have just posted the split of SRv6 Network Programming.
The SR endpoint and transit behaviors that perform SRH insertion are now under a new individual draft (draft-filsfils-spring-srv6-net-pgm-insertion). This revision does not contain any other update.

As mentioned last week, throughout the rest of the week we will push another update with a few functional updates (e.g. NH=59).

Thank you,
Pablo (on behalf of the authors).

-----Original Message-----
From: spring <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Reply to: "[email-masked]" <[email-masked]>
Date: Tuesday, 24 September 2019 at 20:23
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

    
    Abstract:

    

    
    
    _______________________________________________
    spring mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spring

---

From: li zhenqiang <[email-masked]>
Date: Fri, 27 Sep 2019 08:41:36 +0000

Hi Pablo and all,

Thank the authors for their efforts and quick reponse to the discussion in the list.
Since the SRH insertion parts are now removed from the base srv6 network programming draft, are the PSP and USP flavors appropriate to stay here? They do the SRH POP action.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]

From: Pablo Camarillo (pcamaril)<mailto:[email-masked]>
Date: 2019-09-25 02:30
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>
Subject: [spring] FW: I-D Action: draft-ietf-spring-srv6-network-programming-03.txt
Hi all,

Thank you,

-----Original Message-----
From: spring <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Reply to: "[email-masked]" <[email-masked]>
Date: Tuesday, 24 September 2019 at 20:23
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

    Abstract:

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Fri, 27 Sep 2019 11:13:02 +0000

Hi Zhenqiang,

Can you clarify what is the issue with the PSP and USP flavors and how it is related to SRH insertion?

For example USP flavor removes the SRH at the last segment (the final destination of the IP packet), before proceeding with the upper layer header processing.

Cheers,
Pablo.

From: li zhenqiang <[email-masked]>
Date: Friday, 27 September 2019 at 10:41
To: "Pablo Camarillo (pcamaril)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: draft-ietf-spring-srv6-network-programming <[email-masked]>
Subject: Re: [spring] FW: I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

Hi Pablo and all,

Best Regards,
Zhenqiang Li

Thank you,

-----Original Message-----
From: spring <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Reply to: "[email-masked]" <[email-masked]>
Date: Tuesday, 24 September 2019 at 20:23
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

    Abstract:

---

From: Ron Bonica <[email-masked]>
Date: Fri, 27 Sep 2019 14:36:55 +0000

Pablo,

Now that T.insert and B.Insert have been removed, what are the remaining use cases for USP and PSP?

                                                                              Ron

Juniper Business Use Only
From: spring <[email-masked]> On Behalf Of Pablo Camarillo (pcamaril)
Sent: Friday, September 27, 2019 7:13 AM
To: li zhenqiang <[email-masked]>; [email-masked]; [email-masked]
Cc: draft-ietf-spring-srv6-network-programming <[email-masked]>
Subject: Re: [spring] FW: I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

Hi Zhenqiang,

Cheers,
Pablo.

From: li zhenqiang <[email-masked]<mailto:[email-masked]>>
Date: Friday, 27 September 2019 at 10:41
To: "Pablo Camarillo (pcamaril)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: draft-ietf-spring-srv6-network-programming <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] FW: I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

Hi Pablo and all,

Best Regards,
Zhenqiang Li
________________________________
[email-masked]<mailto:[email-masked]>

Thank you,

-----Original Message-----
From: spring <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Reply to: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 24 September 2019 at 20:23
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

    Abstract:

    _______________________________________________
    spring mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/spring

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: li zhenqiang <[email-masked]>
Date: Sat, 28 Sep 2019 15:15:06 +0000

Hello Pablo,

Without SRH insertion, PSP and USP are not needed. The example you give is decapsulation, not SRH pop.
I can not imagine the scenario that will use PSP or USP without SRH insertion. We need illustration to keep them in the draft.

Best Regards,
Zhenqiang Li

From: Pablo Camarillo (pcamaril)<mailto:[email-masked]>
Date: 2019-09-27 19:13
To: li zhenqiang<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
CC: draft-ietf-spring-srv6-network-programming<mailto:[email-masked]>
Subject: Re: [spring] FW: I-D Action: draft-ietf-spring-srv6-network-programming-03.txt
Hi Zhenqiang,

Cheers,
Pablo.

Hi Pablo and all,

Best Regards,
Zhenqiang Li

Thank you,

-----Original Message-----
From: spring <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Reply to: "[email-masked]" <[email-masked]>
Date: Tuesday, 24 September 2019 at 20:23
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

    Abstract:

---

From: "Wang, Weibin (NSB - CN/Shanghai)" <[email-masked]>
Date: Sun, 29 Sep 2019 00:35:53 +0000

I think, If SRv6 domain ingress Node encapsulated new outer IPv6 header and inserted SRH simultaneously on Packets entering the SRv6 domain, when the packet reach penultimate or egress Node, the PSP and USP may be invoked;  another example, if packet which is originated or destined to Nodes within SRv6 domain, and the SRH inserted at originated at source represent a TE-path within SRv6 domain, the PSP and USP May also be used, such as CLI Ping command.

--------------------------------------
Cheers !

WANG Weibin

From: ipv6 <[email-masked]> On Behalf Of li zhenqiang
Sent: 2019年9月28日 23:15
To: Pablo Camarillo (pcamaril) <[email-masked]>; [email-masked]; [email-masked]
Cc: draft-ietf-spring-srv6-network-programming <[email-masked]>
Subject: Re: Re: [spring] FW: I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

Hello Pablo,

Best Regards,
Zhenqiang Li

Cheers,
Pablo.

Hi Pablo and all,

Best Regards,
Zhenqiang Li

Thank you,

-----Original Message-----
From: spring <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Reply to: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 24 September 2019 at 20:23
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-03.txt

    Abstract: