Subject: [spring] PSP and USP uN Flavors

From: "G. Sri Karthik Goud" <[email-masked]>
Date: Tue, 25 Aug 2020 22:30:01 +0000

Folks,

In draft-filsfils-spring-net-pgm-extension-srv6-usid, a uN represents an instruction (END, END.T) instantiated on a node. Can that instruction have a PSP or USP flavor? If so, wouldn't the PSP/USP cause an SRH that has not yet been processed to be deleted?

- Karthik

Non-Juniper

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Wed, 9 Sep 2020 08:13:22 +0000

Hi Karthik,

Please see inline.

Cheers,
Pablo.

From: spring <[email-masked]> On Behalf Of G. Sri Karthik Goud
Sent: miércoles, 26 de agosto de 2020 0:30
To: [email-masked]
Cc: Swamy SRK <[email-masked]>
Subject: [spring] PSP and USP uN Flavors

Folks,

In draft-filsfils-spring-net-pgm-extension-srv6-usid, a uN represents an instruction (END, END.T) instantiated on a node. Can that instruction have a PSP or USP flavor?
[PC] The uN behavior is a new behavior. This behavior is defined in https://tools.ietf.org/html/draft-filsfils-spring-net-pgm-extension-srv6-usid-07#section-4.1.1
The uN behavior may be combined with the PSP, USP or USD flavors. Same applies to the uA behavior.
You have the full list of behaviors in Section 9 of the draft.

If so, wouldn't the PSP/USP cause an SRH that has not yet been processed to be deleted?
[PC] No. Leveraging the terminology defined in Section 2 of the draft: the PSP/USP/USD is only executed when you get to the Last uSID of the uSID Container.
Please have a look at the uN pseudocode in the latest revision of the draft (rev 7). I believe the pseudocode is clearer than in previous revisions.
Thanks, and let me know if unclear.

- Karthik

Non-Juniper

---

From: Ron Bonica <[email-masked]>
Date: Fri, 11 Sep 2020 15:31:06 +0000

Pablo,

Assume the following packet:

  *   Destination address is a uSID container
  *   Next header is an SRH

In this case, you wouldn't process the SRH until you process every uSID in the uSID container. Do I have this much right?

So, if any uSID in the container specified the PSP or USP flavor, you would delete an SRH that has not yet been processed.

Do I have this right?

                                                   Ron

Non-Juniper
From: spring <[email-masked]> On Behalf Of Pablo Camarillo (pcamaril)
Sent: Wednesday, September 9, 2020 4:13 AM
To: G. Sri Karthik Goud <gkarthik=[email-masked]>; [email-masked]
Cc: Swamy SRK <[email-masked]>
Subject: Re: [spring] PSP and USP uN Flavors

[External Email. Be cautious of content]

Hi Karthik,

Please see inline.

Cheers,
Pablo.

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of G. Sri Karthik Goud
Sent: miércoles, 26 de agosto de 2020 0:30
To: [email-masked]<mailto:[email-masked]>
Cc: Swamy SRK <[email-masked]<mailto:[email-masked]>>
Subject: [spring] PSP and USP uN Flavors

Folks,

In draft-filsfils-spring-net-pgm-extension-srv6-usid, a uN represents an instruction (END, END.T) instantiated on a node. Can that instruction have a PSP or USP flavor?
[PC] The uN behavior is a new behavior. This behavior is defined in https://tools.ietf.org/html/draft-filsfils-spring-net-pgm-extension-srv6-usid-07#section-4.1.1<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-filsfils-spring-net-pgm-extension-srv6-usid-07*section-4.1.1__;Iw!!NEt6yMaO-gk!XvwFr3yI1zJSgxdaBosAVTHRDz18s-XKUbIl5WNI3Vg7dDeNiCt0bMK1PFKEVCPJ$>
The uN behavior may be combined with the PSP, USP or USD flavors. Same applies to the uA behavior.
You have the full list of behaviors in Section 9 of the draft.

- Karthik

Non-Juniper

---

From: Rajesh M <[email-masked]>
Date: Sat, 12 Sep 2020 02:59:28 +0000

Perfect

So, if any uSID in the container specified the PSP or USP flavor, you would delete an SRH that has not yet been processed.
PSP or USP wont come into picture untill DA.Argument is equal to zero.Hope this clarifies.

1. If (DA.Argument != 0) {
2. Copy DA.Argument into the bits [B..(B+A-1)] of the
Destination Address of the IPv6 header.
3. Set the bits [(B+A)..(B+NF+A-1)] of the Destination Address
of the IPv6 header to zero.
4. } Else {
5. Decrement Segments Left by 1.
6. Copy Segment List[Segments Left] from the SRH to the
Destination Address of the IPv6 header.
7. }

Thanks
Rajesh

Non-Juniper
From: spring <[email-masked]> On Behalf Of Ron Bonica
Sent: Friday, September 11, 2020 9:01 PM
To: Pablo Camarillo (pcamaril) <pcamaril=[email-masked]>; G. Sri Karthik Goud <gkarthik=[email-masked]>; [email-masked]
Cc: Swamy SRK <[email-masked]>
Subject: Re: [spring] PSP and USP uN Flavors

Pablo,

Do I have this right?

                                                   Ron

Non-Juniper
From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Pablo Camarillo (pcamaril)
Sent: Wednesday, September 9, 2020 4:13 AM
To: G. Sri Karthik Goud <gkarthik=[email-masked]<mailto:gkarthik=[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Swamy SRK <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] PSP and USP uN Flavors

Hi Karthik,

Please see inline.

Cheers,
Pablo.

Folks,

- Karthik

Non-Juniper