Subject: [spring] draft-filsfils-spring-net-pgm-extension-srv6-usid-07

From: Rajesh M <[email-masked]>
Date: Thu, 10 Sep 2020 01:38:29 +0000

Hi All,

Section 4.1.21:

In control plane uA SID is advertised with value 2001:db8:0:0N00:FNAJ::

in FIB entry it is represent with value 2001:db8:0:FNAJ::/64
Note: From a formal viewpoint, a uA SID of node N is defined by the
local FIB entry B:uA/64 of N (i.e. this definition is independent from any uN SID of node N).

a) why such discrepancy ? between control plane and forwarding plane.
b) for uA SID Forwarding happens based upon 2001:db8:0/48 ? not based upon 2001:db8:0:0N00 (uN SID) ?
   uSID block: 2001:db8:0::/48
   for uA SID if forwarding is based upon 2001:db8:0/48 then Compressed-SID can be 16 bit
   for uA SID if forwarding is based upon 2001:db8:0:0N00 then Compressed-SID must be 32 bit

Thanks
Rajesh

Juniper Business Use Only

---

From: Peter Psenak <[email-masked]>
Date: Thu, 10 Sep 2020 12:06:22 +0200

Hi Rajesh,

On 10/09/2020 03:38, Rajesh M wrote:
> Hi All,
> 
> *Section 4.1.21:*
> 
> **
> 
> In control plane uA SID is advertised with value 2001:db8:0:*0N00:FNAJ::*
> 
> **
> 
> *in FIB entry it is represent with value *2001:db8:0*:FNAJ::/64*
> 

It's explained in the section 4.1.2.1:

"In order to signal in ISIS a container SID with the same routable 
semantics as End.X"

In other words, we wanted to keep the consistency in a way the SID is 
advertised for different SID types (e.g. END.X and uA).

thanks,
Peter

> 
> b) for uA SID Forwarding happens based upon 2001:db8:0/48 ? not based 
> upon 2001:db8:0:*0N00 (uN SID) ?*
> 
> **uSID block: 2001:db8:0::/48**
> 
> **for uA SID if forwarding is based upon**2001:db8:0/48 then 
> Compressed-SID can be 16 bit
> 
>     for uA SID if forwarding is based upon**2001:db8:0:*0N00 then 
> *Compressed-SID must be 32 bit**
> 
> **
> 
> Thanks
> 
> Rajesh
> 
> **
> 
>

---

From: Rajesh M <[email-masked]>
Date: Thu, 10 Sep 2020 10:45:24 +0000

Hi peter,

1)  What is the difference between these 2 SIDs
42 | 0x002A | uN | [This.ID] |
46 | 0x002E | uN (S&L+End PSP/USP) | [This.ID] |

uN SID (End behavior with NEXT-CSID, PSP and USD flavors) ,  uN (S&L+End PSP/USD)

2)  just to continue below discussion, can you confirm
51 | 0x0033 | uA                              - here FIB must have 2001:db8:0:FNAJ::/64 route (16 bit Compressed-SID)
52 | 0x0034 | uA (S&X+End.X)     -  here FIB must have 2001:db8:0:0N00:FNAJ::/80 route (32 bit Compressed-SID)

Thanks
Rajesh

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]>
Sent: Thursday, September 10, 2020 3:36 PM
To: Rajesh M <[email-masked]>; SPRING WG <[email-masked]>
Subject: Re: [spring] draft-filsfils-spring-net-pgm-extension-srv6-usid-07

[External Email. Be cautious of content]

Hi Rajesh,

"In order to signal in ISIS a container SID with the same routable semantics as End.X"

In other words, we wanted to keep the consistency in a way the SID is advertised for different SID types (e.g. END.X and uA).

thanks,
Peter

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Thu, 10 Sep 2020 12:51:08 +0000

Hi Rajesh,

Inline [PC].

Thanks.

From: spring <[email-masked]> On Behalf Of Rajesh M
Sent: jueves, 10 de septiembre de 2020 12:45
To: Peter Psenak <ppsenak=[email-masked]>; SPRING WG <[email-masked]>
Subject: Re: [spring] draft-filsfils-spring-net-pgm-extension-srv6-usid-07

Hi peter,

uN SID (End behavior with NEXT-CSID, PSP and USD flavors) ,  uN (S&L+End PSP/USD)
[PC] This is a typo. The example in 4.1.1 needs to be corrected to use | 48    | 0x0030 |    uN (S&L+End PSP/USD)    | [This.ID] |

[PC] Not the case. The FIB entry must have 2001:db8:0:FNAJ::/64. This is independent on which flavor the node supports 51-59.
Note that it may also be possible for a packet to arrive to the node with uN uSID followed by a uA.
In such case the packet arriving at the node is 2001:db8:0:0N00:FNAJ::, whereas 0N00 is a uN at node N, and FNAJ is a uA at node N toward neighbor J
I can add a note about this in the next revision of the draft.

Thanks
Rajesh

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]<mailto:ppsenak=[email-masked]>>
Sent: Thursday, September 10, 2020 3:36 PM
To: Rajesh M <[email-masked]<mailto:[email-masked]>>; SPRING WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] draft-filsfils-spring-net-pgm-extension-srv6-usid-07

Hi Rajesh,

thanks,
Peter

---

From: Rajesh M <[email-masked]>
Date: Thu, 10 Sep 2020 13:55:24 +0000

Thanks pablo , now clear about uA sid.  Better to add more explanations in the draft, so that draft readers don’t bother you 😊

A generic question:

1) what is the difference between
42 | 0x002A | uN | [This.ID] |
43| 0x002B | uN (S&L+End) | [This.ID] |

2) So these two does not support PSP & USD flavors ?
42 | 0x002A | uN | [This.ID] |
51 | 0x0033 | uA | [This.ID] |

Thanks
Rajesh

Juniper Business Use Only
From: Pablo Camarillo (pcamaril) <pcamaril=[email-masked]>
Sent: Thursday, September 10, 2020 6:21 PM
To: Rajesh M <[email-masked]>; Peter Psenak <[email-masked]>; SPRING WG <[email-masked]>
Subject: RE: [spring] draft-filsfils-spring-net-pgm-extension-srv6-usid-07

Hi Rajesh,

Inline [PC].

Thanks.

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Rajesh M
Sent: jueves, 10 de septiembre de 2020 12:45
To: Peter Psenak <ppsenak=[email-masked]<mailto:ppsenak=[email-masked]>>; SPRING WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] draft-filsfils-spring-net-pgm-extension-srv6-usid-07

Hi peter,

Thanks
Rajesh

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]<mailto:ppsenak=[email-masked]>>
Sent: Thursday, September 10, 2020 3:36 PM
To: Rajesh M <[email-masked]<mailto:[email-masked]>>; SPRING WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] draft-filsfils-spring-net-pgm-extension-srv6-usid-07

Hi Rajesh,

thanks,
Peter