Subject: [spring] I-D Action: draft-ietf-spring-resource-aware-segments-02.txt

From: [email-masked]
Date: Mon, 22 Feb 2021 03:52:34 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Source Packet Routing in Networking WG of the IETF.

        Title           : Introducing Resource Awareness to SR Segments
        Authors         : Jie Dong
                          Stewart Bryant
                          Takuya Miyasaka
                          Yongqing Zhu
                          Fengwei Qin
                          Zhenqiang Li
                          Francois Clad
	Filename        : draft-ietf-spring-resource-aware-segments-02.txt
	Pages           : 13
	Date            : 2021-02-22

Abstract:
   This document describes the mechanism to associate network resource
   attributes to Segment Routing Identifiers (SIDs).  Such SIDs are
   referred to as resource-aware SIDs in this document.  The resource-
   aware SIDs retain their original forwarding semantics, but with the
   additional semantics to identify the set of network resources
   available for the packet processing action.  The resource-aware SIDs
   can therefore be used to build SR paths or virtual networks with a
   set of reserved network resources.  The proposed mechanism is
   applicable to both segment routing with MPLS data plane (SR-MPLS) and
   segment routing with IPv6 data plane (SRv6).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-spring-resource-aware-segments/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-spring-resource-aware-segments-02
https://datatracker.ietf.org/doc/html/draft-ietf-spring-resource-aware-segments-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-resource-aware-segments-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 24 Feb 2021 03:34:30 +0000

Dear WG, 

We've submitted a new version of draft-ietf-spring-resource-aware-segments. 

Based on the comments and suggestions received, further clarifications about the semantics of resource-aware SID are added. More specifically, the semantics of resource-aware prefix-SID and its associated behavior on the involved network nodes are elaborated. The related control plane considerations are also described. 

As always, review comments and suggestions are appreciated. 

Best regards,
Jie (on behalf of coauthors)

> -----Original Message-----
> From: spring [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, February 22, 2021 7:53 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [spring] I-D Action: draft-ietf-spring-resource-aware-segments-02.txt
> 
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring