Subject: [spring] FW: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt

From: Ron Bonica <[email-masked]>
Date: Sun, 7 Feb 2021 16:46:22 +0000

Please review and comment

Juniper Business Use Only

> -----Original Message-----
> From: [email-masked] <[email-masked]>
> Sent: Sunday, February 7, 2021 11:41 AM
> To: Greg Mirsky <[email-masked]>; Peng Shaofu
> <[email-masked]>; Ron Bonica <[email-masked]>; Shaofu Peng
> <[email-masked]>; Shraddha Hegde <[email-masked]>; EXT-
> [email-masked] <[email-masked]>
> Subject: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt
> 
> [External Email. Be cautious of content]
> 
> 
> A new version of I-D, draft-bonica-spring-srv6-end-dtm-01.txt
> has been successfully submitted by Ron Bonica and posted to the IETF
> repository.
> 
> Name:           draft-bonica-spring-srv6-end-dtm
> Revision:       01
> Title:          The SRv6 END.DTM Segment Type
> Document date:  2021-02-07
> Group:          Individual Submission
> Pages:          7
> URL:   https://www.ietf.org/archive/id/draft-bonica-spring-srv6-end-dtm-01.txt
> Status: https://datatracker.ietf.org/doc/draft-bonica-spring-srv6-end-dtm
> Htmlized:  https://datatracker.ietf.org/doc/html/draft-bonica-spring-srv6-end-dtm
> Htmlized:      https://tools.ietf.org/html/draft-bonica-spring-srv6-end-dtm-01
> Diff:  https://www.ietf.org/rfcdiff?url2=draft-bonica-spring-srv6-end-dtm-01
> 
> Abstract:
>    This document describes a new SRv6 segment type, called END.DTM.  The
>    END.DTM segment type supports inter-working between SRv6 and SR-MPLS.
>    Like any segment type, END.DTM contains a function and arguments.
>    The function causes the processing SRv6 node to remove an SRv6 header
>    and impose an SR-MPLS label stack.  The arguments determine MPLS-
>    label stack contents.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 7 Feb 2021 22:51:37 -0800

Hi Ron,

Very useful document, thanks!

Question wrt processing:
As described in the draft:
“A SID instance is associated with SR-MPLS label stack and outgoing interface.”

I’d think that outgoing interface would be recursively resolved based on the top SID (and could change based on topological semantics).
Could you please elaborate?

Thanks!

Cheers,
Jeff

> On Feb 7, 2021, at 08:46, Ron Bonica <rbonica=[email-masked]> wrote:
> 
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Loa Andersson <[email-masked]>
Date: Tue, 9 Feb 2021 12:51:13 +0800

Jeff,

> Could you please elaborate?

What exactly do yo mean by "recursively"?

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Takuya Miyasaka <[email-masked]>
Date: Tue, 9 Feb 2021 16:37:49 +0900

Hi Ron,

I think this new SRv6 endpoint behavior is very useful to connect an 
SRv6 island and an SR-MPLS island. I have two comments.

In this draft, you introduced the End.DTM as a new "segment type", but 
according to draft-ietf-spring-srv6-network-programming draft I think 
this should be "endpoint behavior".

Section.1 says "The arguments determine MPLS-label stack contents and 
Transport Class of the MPLS Tunnel." I was interested in this feature, 
but there is no detailed description in Section.4. Could you elaborate 
on this feature in the future version? I also want to clarify the 
meaning of "Transport Class of the MPLS Tunnel".

Thanks,
Takuya

---

From: Ron Bonica <[email-masked]>
Date: Tue, 9 Feb 2021 20:35:33 +0000

Loa,

I think that Jeff means to say that " A SID instance is associated with SR-MPLS label stack. A label stack entry can be associated with a next hop. A recursive lookup may be required to derive the next hop from the topmost label stack entry."

                                                                Ron

-----Original Message-----
From: Loa Andersson <[email-masked]> 
Sent: Monday, February 8, 2021 11:51 PM
To: Jeff Tantsura <[email-masked]>; Ron Bonica <[email-masked]>
Cc: [email-masked]
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt

Jeff,

/Loa
>>> <[email-masked]>; Ron Bonica <[email-masked]>; Shaofu 
>>> Peng <[email-masked]>; Shraddha Hegde 
>>> <[email-masked]>; EXT- [email-masked] 
>>> <[email-masked]>
>>> URL:   https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-bonica-spring-srv6-end-dtm-01.txt__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F9ybUH5$
>>> Status: 
>>> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-b
>>> onica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8ap
>>> yYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8Oytsvgj$
>>> Htmlized:  https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-bonica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F2zaLIO$
>>> Htmlized:      https://urldefense.com/v3/__https://tools.ietf.org/html/draft-bonica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8DZVjUN4$
>>> Diff:  
>>> https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-
>>> bonica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4t
>>> F8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8CJWOgzv$
>>>
>>> Abstract:
>>> Please note that it may take a couple of minutes from the time of 
>>> submission until the htmlized version and diff are available at tools.ietf.org.
>>>
>>> The IETF Secretariat
>>>
>> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/spr
>> ing__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3q
>> bYIFrhF8PggLsaR$
>
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/spri
> ng__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbY
> IFrhF8PggLsaR$
>

--

---

From: Ron Bonica <[email-masked]>
Date: Tue, 9 Feb 2021 21:00:11 +0000

Takuya,

Thanks for the review. I agree with both of your comments and will update the draft to reflect them.

                                                       Ron

-----Original Message-----
From: Takuya Miyasaka <[email-masked]> 
Sent: Tuesday, February 9, 2021 2:38 AM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt

Hi Ron,

In this draft, you introduced the End.DTM as a new "segment type", but according to draft-ietf-spring-srv6-network-programming draft I think this should be "endpoint behavior".

Section.1 says "The arguments determine MPLS-label stack contents and Transport Class of the MPLS Tunnel." I was interested in this feature, but there is no detailed description in Section.4. Could you elaborate on this feature in the future version? I also want to clarify the meaning of "Transport Class of the MPLS Tunnel".

Thanks,
Takuya

On 2021/02/08 1:46, Ron Bonica wrote:
>> Peng <[email-masked]>; Shraddha Hegde <[email-masked]>; 
>> EXT- [email-masked] <[email-masked]>
>> URL:   https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-bonica-spring-srv6-end-dtm-01.txt__;!!NEt6yMaO-gk!WXJS7gHtTlKRKddVqvvm7OtkjTdhLAJpHlv4kHi3tuo8igEK-KHid3Ers3apfxpz$
>> Status: 
>> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-bo
>> nica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!WXJS7gHtTlKRKddVqvvm7OtkjTdh
>> LAJpHlv4kHi3tuo8igEK-KHid3Ers6XDGQs5$
>> Htmlized:  https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-bonica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!WXJS7gHtTlKRKddVqvvm7OtkjTdhLAJpHlv4kHi3tuo8igEK-KHid3Ers7V73ouQ$
>> Htmlized:      https://urldefense.com/v3/__https://tools.ietf.org/html/draft-bonica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!WXJS7gHtTlKRKddVqvvm7OtkjTdhLAJpHlv4kHi3tuo8igEK-KHid3Ers9Bc_0If$
>> Diff:  
>> https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-b
>> onica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!WXJS7gHtTlKRKddVqvvm7Otk
>> jTdhLAJpHlv4kHi3tuo8igEK-KHid3Ers3wHzB3_$
>>
>> Abstract:
> ng__;!!NEt6yMaO-gk!WXJS7gHtTlKRKddVqvvm7OtkjTdhLAJpHlv4kHi3tuo8igEK-KH
> id3Ers37m7DaB$

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 9 Feb 2021 17:00:22 -0800

Thanks Ron, couldn’t have explained it better.

Prefix SID (and the prefix associated with it) could be reachable over any interface participating in the topology,  depending on that topology structure, with topology changes, outgoing interface might change as well. Hence the outgoing interface is a runtime property of the top SID.

Loa - does this clarify?

Cheers,
Jeff

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 12 Feb 2021 03:54:54 -0500

Hi Ron

This is an interesting  SR-MPLS to SRv6 interworking concept.

For an end to end LSP where you end up doing a translation on a border node
doing the interworking pop of MPLS label stack and impose of SRv6 IPv6
header in one direction and POP of SRv6 IPv6 header and impose of MPLS
label stack in the other direction, how does the LSP get stitched from
ingress PE to egress PE FEC destination if the intermediate node in the
path is a P node doing the translation interworking.  I think if the
translation interworking node was an egress PE that is doing the ASBR
function handoff seems plausible, but if it’s a P node as it appears in
your example how would the LSP get stitched end to end.

Could this same concept be used for MPLS LDP fo SRv6 interworking as well.

Kind Regards

Gyan

On Tue, Feb 9, 2021 at 8:00 PM Jeff Tantsura <[email-masked]>
wrote:

> Prefix SID (and the prefix associated with it) could be reachable over any
> interface participating in the topology,  depending on that topology
> structure, with topology changes, outgoing interface might change as well.
> Hence the outgoing interface is a runtime property of the top SID.
>
> Loa - does this clarify?
>
> Cheers,
> Jeff
> I think that Jeff means to say that " A SID instance is associated with
> SR-MPLS label stack. A label stack entry can be associated with a next hop.
> A recursive lookup may be required to derive the next hop from the topmost
> label stack entry."
>
> Ron
>
>
>
> I’d think that outgoing interface would be recursively resolved based on
> the top SID (and could change based on topological semantics).
> URL:
> https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-bonica-spring-srv6-end-dtm-01.txt__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F9ybUH5$
> Status:
> Htmlized:
> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-bonica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F2zaLIO$
> Htmlized:
> https://urldefense.com/v3/__https://tools.ietf.org/html/draft-bonica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8DZVjUN4$
> Diff:
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Ron Bonica <[email-masked]>
Date: Fri, 12 Feb 2021 17:03:57 +0000

Gyan,

Control plane considerations are beyond the scope of this draft. That said, when I wrote the draft, I was thinking that the border nodes were ASBRs.

                                                                                      Ron

Juniper Business Use Only
From: Gyan Mishra <[email-masked]>
Sent: Friday, February 12, 2021 3:55 AM
To: Jeff Tantsura <[email-masked]>
Cc: Loa Andersson <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt

Hi Ron

For an end to end LSP where you end up doing a translation on a border node doing the interworking pop of MPLS label stack and impose of SRv6 IPv6 header in one direction and POP of SRv6 IPv6 header and impose of MPLS label stack in the other direction, how does the LSP get stitched from ingress PE to egress PE FEC destination if the intermediate node in the path is a P node doing the translation interworking.  I think if the translation interworking node was an egress PE that is doing the ASBR function handoff seems plausible, but if it’s a P node as it appears in your example how would the LSP get stitched end to end.

Kind Regards

Gyan

On Tue, Feb 9, 2021 at 8:00 PM Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
Thanks Ron, couldn’t have explained it better.

Loa - does this clarify?

Cheers,
Jeff
On Feb 9, 2021, 12:35 PM -0800, Ron Bonica <[email-masked]<mailto:[email-masked]>>, wrote:
Loa,

Ron

-----Original Message-----
From: Loa Andersson <[email-masked]<mailto:[email-masked]>>
Sent: Monday, February 8, 2021 11:51 PM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt

Jeff,

Question wrt processing:

/Loa

Thanks!

Cheers,
Jeff

On Feb 7, 2021, at 08:46, Ron Bonica <rbonica=[email-masked]<mailto:[email-masked]>> wrote:

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, February 7, 2021 11:41 AM
To: Greg Mirsky <[email-masked]<mailto:[email-masked]>>; Peng Shaofu
<[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>; Shaofu
Peng <[email-masked]<mailto:[email-masked]>>; Shraddha Hegde
<[email-masked]<mailto:[email-masked]>>; EXT- [email-masked]<mailto:[email-masked]>
<[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for
draft-bonica-spring-srv6-end-dtm-01.txt

Name: draft-bonica-spring-srv6-end-dtm
Revision: 01
Title: The SRv6 END.DTM Segment Type
Document date: 2021-02-07
Group: Individual Submission
Pages: 7
URL: https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-bonica-spring-srv6-end-dtm-01.txt__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F9ybUH5$<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-bonica-spring-srv6-end-dtm-01.txt__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F9ybUH5$>
Status:
https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-b<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-b>
onica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8ap
yYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8Oytsvgj$
Htmlized: https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-bonica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F2zaLIO$<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-bonica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F2zaLIO$>
Htmlized: https://urldefense.com/v3/__https://tools.ietf.org/html/draft-bonica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8DZVjUN4$<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-bonica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8DZVjUN4$>
Diff:
https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-<https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft->
bonica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4t
F8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8CJWOgzv$

Abstract:

Please note that it may take a couple of minutes from the time of
submission until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!!NEt6yMaO-gk!TZVumo7a10f3Mu7tLnW06iZ9c6yuW_EVwbfeh-jooFDtvB9TevKWnUQVFtcVfDrk$>.

The IETF Secretariat
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/spr<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spr>
ing__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3q
bYIFrhF8PggLsaR$

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/spri<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spri>
ng__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbY
IFrhF8PggLsaR$

--

Loa Andersson email: [email-masked]<mailto:[email-masked]>
Senior MPLS Expert [email-masked]<mailto:[email-masked]>
Bronze Dragon Consulting phone: +46 739 81 21 64
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!!NEt6yMaO-gk!TZVumo7a10f3Mu7tLnW06iZ9c6yuW_EVwbfeh-jooFDtvB9TevKWnUQVFvteCmsw$>
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://urldefense.com/v3/__http:/www.verizon.com/__;!!NEt6yMaO-gk!TZVumo7a10f3Mu7tLnW06iZ9c6yuW_EVwbfeh-jooFDtvB9TevKWnUQVFrlDW1y5$>

Gyan Mishra

Network Solutions Architect

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 15 Feb 2021 00:18:03 -0500

Thanks Ron!

I really like the innovative idea.

Will this work with LDP v4 v6 to SRv6 interworking as well is my guess?

Kind Regards

Gyan

On Fri, Feb 12, 2021 at 12:04 PM Ron Bonica <[email-masked]> wrote:

> Gyan,
>
>
>
> Control plane considerations are beyond the scope of this draft. That
> said, when I wrote the draft, I was thinking that the border nodes were
> ASBRs.
>
>
>
>
>              Ron
>
>
>
>
>
>
>
> *From:* Gyan Mishra <[email-masked]>
> *Sent:* Friday, February 12, 2021 3:55 AM
> *To:* Jeff Tantsura <[email-masked]>
> *Cc:* Loa Andersson <[email-masked]>; Ron Bonica <[email-masked]>;
> [email-masked]
> *Subject:* Re: [spring] FW: New Version Notification for
> *[External Email. Be cautious of content]*
>
>
>
>
>
> Hi Ron
>
>
>
> For an end to end LSP where you end up doing a translation on a border
> node doing the interworking pop of MPLS label stack and impose of SRv6 IPv6
> <https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-bonica-spring-srv6-end-dtm-01.txt__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F9ybUH5$>
> Status:
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-b>
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-bonica-spring-srv6-end-dtm__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8F2zaLIO$>
> Htmlized:
> <https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-bonica-spring-srv6-end-dtm-01__;!!NEt6yMaO-gk!Xh8RUucGY-Dw_xFwM_vU4tF8apyYbe9Xg2bqsA3kb6qY2F-3qbYIFrhF8DZVjUN4$>
> Diff:
> <https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft->
> submission until the htmlized version and diff are available at
> tools.ietf.org
> <https://urldefense.com/v3/__http:/tools.ietf.org__;!!NEt6yMaO-gk!TZVumo7a10f3Mu7tLnW06iZ9c6yuW_EVwbfeh-jooFDtvB9TevKWnUQVFtcVfDrk$>
> .
>
> The IETF Secretariat
>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spr>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spri>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/spring__;!!NEt6yMaO-gk!TZVumo7a10f3Mu7tLnW06iZ9c6yuW_EVwbfeh-jooFDtvB9TevKWnUQVFvteCmsw$>
>
> --
>
>
> <https://urldefense.com/v3/__http:/www.verizon.com/__;!!NEt6yMaO-gk!TZVumo7a10f3Mu7tLnW06iZ9c6yuW_EVwbfeh-jooFDtvB9TevKWnUQVFrlDW1y5$>
>
> *Gyan Mishra*
>
> *Network Solutions Architect *
>
>
>
> *M 301 502-1347 13101 Columbia Pike
> <https://www.google.com/maps/search/13101+Columbia+Pike?entry=gmail&source=g>
> *Silver Spring, MD
>
>
>
-- 

*Gyan Mishra*

---

From: Ron Bonica <[email-masked]>
Date: Mon, 15 Feb 2021 15:56:11 +0000

Hi Gyan,

In theory, it should map any END.DTM to  any MPLS label stack, regardless of the control plane.

                                                                      Ron

Juniper Business Use Only
From: Gyan Mishra <[email-masked]>
Sent: Monday, February 15, 2021 12:18 AM
To: Ron Bonica <[email-masked]>
Cc: Jeff Tantsura <[email-masked]>; Loa Andersson <[email-masked]>; [email-masked]
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt

Thanks Ron!

Kind Regards

Gyan

On Fri, Feb 12, 2021 at 12:04 PM Ron Bonica <[email-masked]<mailto:[email-masked]>> wrote:
Gyan,

                                                                                      Ron

Juniper Business Use Only
From: Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Sent: Friday, February 12, 2021 3:55 AM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Cc: Loa Andersson <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt

Hi Ron

Kind Regards

Gyan

Loa - does this clarify?

Cheers,
Jeff

Ron

-----Original Message-----
From: Loa Andersson <[email-masked]<mailto:[email-masked]>>
Sent: Monday, February 8, 2021 11:51 PM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] FW: New Version Notification for draft-bonica-spring-srv6-end-dtm-01.txt

Jeff,

Question wrt processing:

/Loa

Thanks!

Cheers,
Jeff

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, February 7, 2021 11:41 AM
To: Greg Mirsky <[email-masked]<mailto:[email-masked]>>; Peng Shaofu

Abstract:

The IETF Secretariat

--

[Image removed by sender.]<https://urldefense.com/v3/__http:/www.verizon.com/__;!!NEt6yMaO-gk!TZVumo7a10f3Mu7tLnW06iZ9c6yuW_EVwbfeh-jooFDtvB9TevKWnUQVFrlDW1y5$>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike<https://urldefense.com/v3/__https:/www.google.com/maps/search/13101*Columbia*Pike?entry=gmail&source=g__;Kys!!NEt6yMaO-gk!SxXh23PxhqhKPJavn0YFRaVlbQaMsJt52t189MNQrydcMfjljeN9XpBLe0cAVGGF$>
Silver Spring, MD

--

[Image removed by sender.]<https://urldefense.com/v3/__http:/www.verizon.com/__;!!NEt6yMaO-gk!SxXh23PxhqhKPJavn0YFRaVlbQaMsJt52t189MNQrydcMfjljeN9XpBLewVfXQYW$>

Gyan Mishra

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 15 Feb 2021 11:22:24 -0500

Make sense!

Thanks

Gyan

On Mon, Feb 15, 2021 at 10:56 AM Ron Bonica <[email-masked]> wrote:

> *Sent:* Monday, February 15, 2021 12:18 AM
> *To:* Ron Bonica <[email-masked]>
>
> *Cc:* Jeff Tantsura <[email-masked]>; Loa Andersson <[email-masked]>;
> [email-masked]
> <https://urldefense.com/v3/__https:/www.google.com/maps/search/13101*Columbia*Pike?entry=gmail&source=g__;Kys!!NEt6yMaO-gk!SxXh23PxhqhKPJavn0YFRaVlbQaMsJt52t189MNQrydcMfjljeN9XpBLe0cAVGGF$>
> *Silver Spring, MD
>
>
>
> --
>
> <https://urldefense.com/v3/__http:/www.verizon.com/__;!!NEt6yMaO-gk!SxXh23PxhqhKPJavn0YFRaVlbQaMsJt52t189MNQrydcMfjljeN9XpBLewVfXQYW$>
>
> *Gyan Mishra*
>
-- 

*Gyan Mishra*