Subject: Re: [spring] WGLC for draft-ietf-spring-segment-routing-policy

From: "Stone, Andrew (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 29 Apr 2021 05:41:41 +0000

Hello Chairs, WG and Authors

I think there may need to be a wording adjustment required to the BGP related text in section 2.5, for more clarity regarding the use of BGP distinguisher in place of discriminator:

   When BGP SR Policy is the Protocol-Origin, it is the distinguisher

   (refer to Section 2.1 of [I-D.ietf-idr-segment-routing-te-policy<https://tools.ietf.org/html/draft-ietf-spring-segment-routing-policy-10#ref-I-D.ietf-idr-segment-routing-te-policy>]).

The sentence seems to be focused on the context of a headend node importing SR policy from BGP into an SR Policy module, and could be interpreted differently (and incorrectly) when applied in the context of a controller defined SR Policy which is then injected into BGP. I have spoken to Ketan regarding this, so may be updated shortly. (additional clarification in idr document may also come).

Aside from that, I support WGLC adoption. The document describes the behaviour and associated contexts within the SR Policy model well, and it’s an important draft to have finalized.

Thanks
Andrew

From: spring <[email-masked]> on behalf of James Guichard <[email-masked]>
Date: Thursday, April 15, 2021 at 2:57 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [spring] WGLC for draft-ietf-spring-segment-routing-policy

Dear WG:

This email starts a 2 week Working Group Last Call for draft-ietf-spring-segment-routing-policy [1].

Please read this document if you haven’t read the most recent version and send your comments to the SPRING WG list no later than April 29th 2021.

If you are raising a point which you expect will be specifically debated on the mailing list, consider using a specific email/thread for this point.

Lastly, if you are an author or contributors for this document please response to the IPR call in the previous email thread.

Thanks!

Jim, Joel & Bruno

[1] https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-policy/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 29 Apr 2021 05:56:52 +0000

Hi Andrew,

Thanks for your review and comments.

We can update that text to clarify as below:

When BGP SR Policy is the Protocol-Origin, the BGP process receiving the route provides the distinguisher (refer to Section 2.1 of [I-D.ietf-idr-segment-routing-te-policy]) as the discriminator.

I’ll also make the clarification on the role of the distinguisher in BGP SRTE in the draft-ietf-idr-segment-routing-te-policy of which I am also a co-author.

Thanks,
Ketan

From: spring <[email-masked]> On Behalf Of Stone, Andrew (Nokia - CA/Ottawa)
Sent: 29 April 2021 11:12
To: James Guichard <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [spring] WGLC for draft-ietf-spring-segment-routing-policy

Thanks
Andrew

Dear WG:

Thanks!

Jim, Joel & Bruno

---

From: "Stone, Andrew (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 29 Apr 2021 16:53:44 +0000

Looks good to me, thanks Ketan!

Andrew

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thursday, April 29, 2021 at 1:57 AM
To: "Stone, Andrew (Nokia - CA/Ottawa)" <[email-masked]>, James Guichard <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [spring] WGLC for draft-ietf-spring-segment-routing-policy

Hi Andrew,

Thanks,
Ketan

Thanks
Andrew

Dear WG:

Thanks!

Jim, Joel & Bruno