Subject: [spring] A new draft on Segment Routing for End-to-End IETF network slicing

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 14 May 2021 08:10:01 +0000

Hi WG,

Recently we published a new draft on Segment Routing for End-to-End IETF Network Slicing:

https://datatracker.ietf.org/doc/html/draft-li-spring-sr-e2e-ietf-network-slicing

It introduces the new SRv6 behaviors and SR-MPLS BSIDs to enable the mapping and concatenation of multi-domain IETF network slices. This document is aligned with the framework for end-to-end IETF network slicing as described in draft-li-teas-e2e-ietf-network-slicing.

Your review and comments are welcome.

Best regards,
Jie

---

From: Chongfeng Xie <[email-masked]>
Date: Fri, 14 May 2021 17:17:59 +0800

Hi，Jie，
I think this work is useful and support its progress in spring or other WGs. However, I have some concerns about the term of "IETF slicing”, from the perspective of operator, the terms of “IETF slicing” and “3GPP slicing” may be confusing, there should be a universal set of terms of slicing across different SDOs, even they may cover different sections or layers of the network system.  What’s your opinion?

Best regards
Chongfeng

> 2021年5月14日 下午4:10，Dongjie (Jimmy) <[email-masked]> 写道：
> 
> Hi WG,
>  
> https://datatracker.ietf.org/doc/html/draft-li-spring-sr-e2e-ietf-network-slicing <https://datatracker.ietf.org/doc/html/draft-li-spring-sr-e2e-ietf-network-slicing>
>  
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 14 May 2021 14:44:49 +0000

Hi Chongfeng,

Thanks for your valuable comments. The term “IETF network slice” was chosen by the network slicing design team in TEAS WG, after many discussion in both the design team and the WG.  This document tries to align with the terminology there.

I also agree that the terms in different SDOs needs to be aligned, or the relationship and mapping between different terms could be defined.

Best regards,
Jie

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Friday, May 14, 2021 5:18 PM
To: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] A new draft on Segment Routing for End-to-End IETF network slicing

Hi，Jie，

Best regards
Chongfeng

2021年5月14日 下午4:10，Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>> 写道：

Hi WG,

Best regards,
Jie
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 15 May 2021 03:09:24 -0400

Hi Jimmy

I read the draft and support  the principles defined in instantiation of
E2E network slice and method of mapping a VPN+ overlay to VTN underlay
underpinning & resources provisioning via resource sid VTN ID across
multiple domains E2E using a list of VTN BSIDs for per domain hop path
steering.

This draft will be very useful for 5G E2E multi domain network slicing VTN
provisioning and E2E concatenation of SR-TE BSID per domain hop BSID list
E2E path instantiation.

Kind Regards

Gyan

On Fri, May 14, 2021 at 10:45 AM Dongjie (Jimmy) <[email-masked]>
wrote:

> Hi Chongfeng,
>
>
>
> Thanks for your valuable comments. The term “IETF network slice” was
> chosen by the network slicing design team in TEAS WG, after many discussion
> in both the design team and the WG.  This document tries to align with the
> terminology there.
>
>
>
> I also agree that the terms in different SDOs needs to be aligned, or the
> relationship and mapping between different terms could be defined.
>
>
>
> Best regards,
>
> Jie
>
>
>
> *From:* [email-masked] [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Friday, May 14, 2021 5:18 PM
> *To:* Dongjie (Jimmy) <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [spring] A new draft on Segment Routing for End-to-End
> IETF network slicing
>
>
>
> Hi，Jie，
>
> I think this work is useful and support its progress in spring or other
> WGs. However, I have some concerns about the term of "IETF slicing”, from
> the perspective of operator, the terms of “IETF slicing” and “3GPP slicing”
> may be confusing, there should be a universal set of terms of slicing
> across different SDOs, even they may cover different sections or layers of
> the network system.  What’s your opinion?
>
>
>
> Best regards
>
> Chongfeng
>
>
>
> It introduces the new SRv6 behaviors and SR-MPLS BSIDs to enable the
> mapping and concatenation of multi-domain IETF network slices. This
> document is aligned with the framework for end-to-end IETF network slicing
> as described in draft-li-teas-e2e-ietf-network-slicing.
>
>
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 17 May 2021 02:45:03 +0000

Hi Gyan,

Thanks for your comments. Yes this document extends the single domain VTN mechanisms to multi-domain network scenarios, which could be used for the end-to-end IETF network slicing and further for 5G end-to-end network slicing.

This document proposes several optional types of VTN Binding SIDs (functions), each may be applicable in a particular case. Feedbacks on these BSID types are appreciated.

Best regards,
Jie

From: Gyan Mishra [mailto:[email-masked]]
Sent: Saturday, May 15, 2021 3:09 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [spring] A new draft on Segment Routing for End-to-End IETF network slicing

Hi Jimmy

I read the draft and support  the principles defined in instantiation of E2E network slice and method of mapping a VPN+ overlay to VTN underlay underpinning & resources provisioning via resource sid VTN ID across multiple domains E2E using a list of VTN BSIDs for per domain hop path steering.

This draft will be very useful for 5G E2E multi domain network slicing VTN provisioning and E2E concatenation of SR-TE BSID per domain hop BSID list E2E path instantiation.

Kind Regards

Gyan

On Fri, May 14, 2021 at 10:45 AM Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Chongfeng,

Best regards,
Jie

Hi，Jie，

Best regards
Chongfeng

Hi WG,

Best regards,
Jie

[图像已被发件人删除。]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347