Subject: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

From: Qiuyuanxiang <[email-masked]>
Date: Fri, 4 Jun 2021 03:32:46 +0000

Hi WG,

Recently we published a new draft on data fields encapsulation model of IOAM TLV in SRv6 network:

URL:            https://www.ietf.org/archive/id/draft-qiu-spring-srv6-ioam-encap-model-00.txt
Status:         https://datatracker.ietf.org/doc/draft-qiu-spring-srv6-ioam-encap-model/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-qiu-spring-srv6-ioam-encap-model

It introduces the data fields encapsulation model of IOAM TLV for the Segment Routing headend with H.Encaps encapsulation behavior in SRv6 network.

Your review and comments are welcome.

Best regards,
Yuanxiang

-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息，仅限于发送给上面地址中列出
的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、
或散发）本邮件中的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本
邮件！
This e-mail and its attachments contain confidential information from New H3C, which is
intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender
by phone or email immediately and delete it!

---

From: "Wangyali(Yali,Data Communication Standards and Patents Dept)" <[email-masked]>
Date: Fri, 4 Jun 2021 10:36:30 +0000

Hi authors,

Glad to see you're also interested in this topic. 

Almost 3 years ago, there was a draft-song-ippm-ioam-tunnel-mode-00 we proposed to discuss the procedure of iOAM processing in tunnels with the uniform model and the pipe model. 

Welcome to join the discussion. Please feel free to let us know your comments and questions.

Best,
Yali

-----Original Message-----
From: Qiuyuanxiang [mailto:[email-masked]] 
Sent: Friday, June 4, 2021 11:33 AM
To: [email-masked]
Subject: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi WG,

Best regards,
Yuanxiang

-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息，仅限于发送给上面地址中列出
的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、
或散发）本邮件中的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本
邮件！
This e-mail and its attachments contain confidential information from New H3C, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

---

From: Qiuyuanxiang <[email-masked]>
Date: Mon, 7 Jun 2021 08:17:00 +0000

Hi yali，
Thank you very much for informing me of the existing draft-song-ippm-ioam-tunnel-mode-00.

For draft-song-ippm-ioam-tunnel-mode-00, I have a little question, which is also the problem that bothers me when I write draft-qiu-spring-srv6-ioam-encap-model-00.

In uniform model, draft-song-ippm-ioam-tunnel-mode-00 uses the method of copying the original header directly. But for some reason, it may not be possible to know in advance how many routers are in the tunnel, Whether this method works for Pre-allocated Trace Option-Type may require further discussion. We may need to specify usage scenarios for Uniform model.

In addition, would it be better to selectively partially synchronize the data fields of the IOAM TLV instead of full copies? 
For data field that needs to be modified hop-by-hop, we still need to modify the data after copying it, which will increases data plane processing. For example, the time delay needs to be calculated on the router, and the packet carries a timestamp, which needs to be modified by hop.

Best Regards,
yuanxiang

-----邮件原件-----
发件人: Wangyali(Yali,Data Communication Standards and Patents Dept) [mailto:[email-masked]] 
发送时间: 2021年6月4日 18:37
收件人: qiuyuanxiang (RD) <[email-masked]>; [email-masked]
抄送: Haoyu Song <[email-masked]>; Tianran Zhou <[email-masked]>
主题: RE: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi authors,

Best,
Yali

-----Original Message-----
From: Qiuyuanxiang [mailto:[email-masked]] 
Sent: Friday, June 4, 2021 11:33 AM
To: [email-masked]
Subject: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi WG,

Best regards,
Yuanxiang

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 8 Jun 2021 01:12:21 +0000

Hi Yuanxiang,

Please see in-line.

Cheers,
Tianran

-----Original Message-----
From: Qiuyuanxiang [mailto:[email-masked]] 
Sent: Monday, June 7, 2021 4:17 PM
To: Wangyali(Yali,Data Communication Standards and Patents Dept) <[email-masked]>; [email-masked]
Cc: Haoyu Song <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: 答复: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi yali，

ZTR> It looks you raised an valid issue. What's your suggestion on this? Do you want to propose a solution to solve this, or do you want to describe this as operational considerations or so?

ZTR> So, what’s your suggestion in detail?
Thanks.

Best Regards,
yuanxiang

-----邮件原件-----
发件人: Wangyali(Yali,Data Communication Standards and Patents Dept) [mailto:[email-masked]] 
发送时间: 2021年6月4日 18:37
收件人: qiuyuanxiang (RD) <[email-masked]>; [email-masked]
抄送: Haoyu Song <[email-masked]>; Tianran Zhou <[email-masked]>
主题: RE: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi authors,

Best,
Yali

-----Original Message-----
From: Qiuyuanxiang [mailto:[email-masked]] 
Sent: Friday, June 4, 2021 11:33 AM
To: [email-masked]
Subject: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi WG,

Best regards,
Yuanxiang

---

From: Qiuyuanxiang <[email-masked]>
Date: Tue, 8 Jun 2021 07:24:30 +0000

Hi Tianran,

My idea is that need to explicitly add scenarios for the Uniform model. If the Trace Option-type in the original packet is Pre-allocated or Edge-to-Edge, Uniform model does not work, and even does not encapsulate the outer iOAM header.
The reason why Edge-to-Edge Trace Option-type doesn't work is that, if the outer iOAM header directly copies the inner one, the tunnel egress will mistakenly assume it is the iOAM end node when it decapsulates the outer header, and reports data to the analyzer.

The second suggested changing "copy" to "selectively partially synchronize ", and lists data fields that must be synchronized, such as FlowMonID, IOAM-Trace-Type, and so on.

Best Regards,
Yuanxiang

-----邮件原件-----
发件人: Tianran Zhou [mailto:[email-masked]] 
发送时间: 2021年6月8日 9:12
收件人: qiuyuanxiang (RD) <[email-masked]>; Wangyali(Yali,Data Communication Standards and Patents Dept) <[email-masked]>; [email-masked]
抄送: Haoyu Song <[email-masked]>
主题: RE: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi Yuanxiang,

Please see in-line.

Cheers,
Tianran

-----Original Message-----
From: Qiuyuanxiang [mailto:[email-masked]] 
Sent: Monday, June 7, 2021 4:17 PM
To: Wangyali(Yali,Data Communication Standards and Patents Dept) <[email-masked]>; [email-masked]
Cc: Haoyu Song <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: 答复: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi yali，

Best Regards,
yuanxiang

-----邮件原件-----
发件人: Wangyali(Yali,Data Communication Standards and Patents Dept) [mailto:[email-masked]] 
发送时间: 2021年6月4日 18:37
收件人: qiuyuanxiang (RD) <[email-masked]>; [email-masked]
抄送: Haoyu Song <[email-masked]>; Tianran Zhou <[email-masked]>
主题: RE: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi authors,

Best,
Yali

-----Original Message-----
From: Qiuyuanxiang [mailto:[email-masked]] 
Sent: Friday, June 4, 2021 11:33 AM
To: [email-masked]
Subject: [spring] [Spring] A new draft on data fields encapsulation model of IOAM TLV in SRv6 network

Hi WG,

Best regards,
Yuanxiang