Subject: [spring] SR and DetNet, draft on sr-redundancy-protection

From: Balázs Varga A <[email-masked]>
Date: Fri, 11 Jun 2021 13:11:47 +0000

Hi Authors,

thanks for the update of your draft, to clarify the proposed mechanism of
redundancy protection.

I have concerns regarding this draft as (1) the SRv6 approach does not follow the
DetNet architecture, and (2) repeats functionalities that are provided by the DetNet
service sub-layer but with serious limitations.

(1) DetNet has defined two sub-layers: the service sub-layer and the forwarding
sub-layer. The service sub-layer is responsible for service protection and the
forwarding sub-layer provides forwarding paths and resource allocation on top of
them for the DetNet flows. DetNet specifications allow to use any technology in
the forwarding sub-layer, including Segment Routing.

The SRv6 approach described in "draft-geng-spring-sr-redundancy-protection" breaks
the clear concept of the sub-layers by mixing them up. It contradicts to several
points at least to RFC8655 (DetNet Architecture), RFC8938 (Data Plane Framework)
and RFC8964 (DetNet MPLS Data Plane).

(2) The motivation for "draft-geng-spring-sr-redundancy-protection" is not clear especially
as the SRv6 approach seems to be repeating DetNet service sub-layer functionalities; however,
with a limited set of functionalities without any clear benefits.

Cheers
Bala'zs

---

From: "Yangfan (IP Standard)" <[email-masked]>
Date: Sat, 12 Jun 2021 06:06:51 +0000

Hi Bala’zs,
Thank you for your comments. Please see my reply inline starts with Fan1>>

发件人: Balázs Varga A [mailto:[email-masked]]
发送时间: 2021年6月11日 21:12
收件人: [email-masked]
抄送: [email-masked]; spring <[email-masked]>
主题: SR and DetNet, draft on sr-redundancy-protection

Hi Authors,

Fan1>> Segment routing extends IPv6 by introducing SRH extension header and SID programming. From the perspective of SID list in SRH, it provides the explicit route to IPv6 data plane in forwarding sub-layer. From the perspective of SID programming and Endpoint behaviors, it provides the packets replication and elimination in service sub-layer. So Redundancy segment could include the routing characteristic and service indication at the same time. Similar happens to Merging segment. I think this is why you called it breaking the concepts of two sub-layers and mixing them up.
Triggered by the discussions in SPRING, I think we can define redundancy segment and merging segment as a functional segment without routing and topological semantics, and use different segment for the routing purpose. Thus, redundancy segment and merging segment are segments with pure service semantics and don’t violate the sub-layers definition in DetNet architecture.
Besides, in RFC8655 4.1.2 DetNet data-plane overview, it says,
This separation of DetNet sub-layers, while helpful, should not be considered a formal requirement. For example, some technologies may violate these strict sub-layers and still be able to deliver a DetNet service
I think SRv6 could be acceptable based on this.

In addition, I guess where to encapsulate meta data could be one concern. According to DetNet, they should be identified and encapsulated at SR edge node. We plan to include both possibilities in next update. To carry them at SR edge node would be recommended as the first choice, and thus does not violate DetNet architecture. Right now I still want to keep the possibility for redundancy segment to add meta data for some corner case.

So far, I didn’t realize there are other points contradict to DetNet RFCs. We are very happy to discuss them.

(2) The motivation for "draft-geng-spring-sr-redundancy-protection" is not clear especially
as the SRv6 approach seems to be repeating DetNet service sub-layer functionalities; however,
with a limited set of functionalities without any clear benefits.
Fan1>> as what I said in previous email to Joel, redundancy protection comes from service protection specified in DetNet, but more focus on how to do it when Segment Routing is introduced to MPLS and IPv6. Currently, DetNet defines IP and MPLS data planes for DetNet in RFC8939 and RFC8964. There is segment routing consideration in RFC8964, but not in RFC8939. In our draft, we try to focus on definition in SRv6, and for MPLS-SR just obeys the specifications in RFC8964. It is clear that we are not repeating DetNet service sub-layer functionality, but to fill the gap between RFC8939 and SRv6. If WG thinks the SR-MPLS sections are redundant, we can take reference from RFC8964 for simplicity in next update.
I don’t think there is no clear benefit what segment routing brings to IP(v6). By using the redundancy protection mechanism, DetNet services running over SRv6 don’t rely on IP+UDP/TCP tuple to provide PREOF. The authors believe this draft is meaningful.
Thank you for bring this topic into DetNet and SPRING. I take it as whether SRv6 is worth to be specified separately besides the existing DetNet data plane RFCs. It is a valid and important question for DetNet, we may need some guide from the WG.
My 2 cents.

Best regards,
Fan

Cheers
Bala'zs

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 18 Jun 2021 15:15:39 +0000

Hi Fan,

Thank you for the clarifications. Now I see the intended behavior better.

It was never a question that SR is a valuable tool to provide explicit routes for DetNet. Of course,
that part is fully in-line with DetNet RFCs, which place those functionalities at the DetNet
forwarding sub-layer, which is the natural location for SR.

The concerns are about the functionalities that are provided by the DetNet service sub-layer. It
looks strange to me to repeat DetNet service sub-layer functionalities by a tool that is naturally
for the DetNet forwarding sub-layer, in particular by SR in this case.

Note at the first place, that DetNet relay nodes are the ones that are capable to perform DetNet
service sub-layer functions. DetNet relay nodes need to perform DetNet flow identification at the
first place, which is based on 6-tuple in the case of IP data plane. Furthermore, DetNet already
includes an IP data plane that provides sequence number for PREOF as specified by RFC 9025. A
contribution has been submitted to describe how to leverage that for PREOF:
https://datatracker.ietf.org/doc/draft-varga-detnet-ip-preof/.

This all can be supported by SR with explicit routes in the natural way SR has been designed, just
like any other type of traffic on top of SR, not only DetNet. Nothing DetNet specific needed from
SR. That is, this is also fully in-line with SR today, not only DetNet.

Thanks
Bala'zs

From: Yangfan (IP Standard) <[email-masked]>
Sent: Saturday, June 12, 2021 8:07 AM
To: Balázs Varga A <[email-masked]>; [email-masked]
Cc: [email-masked]; spring <[email-masked]>
Subject: 答复: SR and DetNet, draft on sr-redundancy-protection

Hi Bala’zs,

发件人: Balázs Varga A [mailto:[email-masked]]
发送时间: 2021年6月11日 21:12
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; spring <[email-masked]<mailto:[email-masked]>>
主题: SR and DetNet, draft on sr-redundancy-protection

Hi Authors,

Best regards,
Fan

Cheers
Bala'zs

---

From: "Yangfan (IP Standard)" <[email-masked]>
Date: Wed, 23 Jun 2021 13:21:15 +0000

Hi Bala‘zs,

Not only does SR facilitate explicit routes, several WG drafts also give examples on the service function providing to other areas.
https://datatracker.ietf.org/doc/html/draft-ietf-spring-sr-service-programming
https://datatracker.ietf.org/doc/html/draft-ietf-spring-sr-replication-segment
https://datatracker.ietf.org/doc/html/draft-ietf-spring-resource-aware-segments
so I understand by leveraging redundancy segment and merging segment to provide PRF and PEF to DetNet is natural and acceptable.

I see there is a DetNet solution for PRF and PEF in IP data plane, and thanks very much for submitting another contribution to elaborate the details.
Similar like draft IPv6-HbH-Options-for-DetNet, the intent of the draft is also to bring extra capabilities from IPv6 EHs to DetNet current IP+UDP solution, in order to extend and progress existing work.
Thanks for the discussion.

Fan

发件人: Balázs Varga A [mailto:[email-masked]]
发送时间: 2021年6月18日 23:16
收件人: Yangfan (IP Standard) <[email-masked]>; [email-masked]
抄送: [email-masked]; spring <[email-masked]>
主题: RE: SR and DetNet, draft on sr-redundancy-protection

Hi Fan,

Thanks
Bala'zs

From: Yangfan (IP Standard) <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, June 12, 2021 8:07 AM
To: Balázs Varga A <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; spring <[email-masked]<mailto:[email-masked]>>
Subject: 答复: SR and DetNet, draft on sr-redundancy-protection

Hi Bala’zs,

Hi Authors,

Best regards,
Fan

Cheers
Bala'zs