Subject: [spring] SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

From: Rajesh M <[email-masked]>
Date: Thu, 1 Jul 2021 02:28:21 +0000

Hi All,

As per the draft

"When the BGP route received at an ingress PE is colored with an extended color community and is being steered over a valid SRv6

Policy associated with SID list <S1, S2, S3> as described in Section 8 of [I-D.ietf-spring-segment-routing-policy<https://datatracker.ietf.org/doc/html/draft-ietf-bess-srv6-services-07#ref-I-D.ietf-spring-segment-routing-policy>], then the

effective SR Policy is <S1, S2, S3-Service-SID>"

Here also "ingress PE SHOULD perform resolvability check for the S3 Service SID before considering the received prefix for the BGP best path computation"

Lets consider s3 service SID resolution over SRv6 TE Policy, destination address(or endpoint) of an SRv6 TE Policy is a 128 bit address(host address).So for each service SID we need to configure SRv6 TE Policy (SRV6 TE policy destination address as service SID) ?

Thanks

Rajesh

Juniper Business Use Only

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 1 Jul 2021 05:23:06 +0000

Hi Rajesh,

Per https://datatracker.ietf.org/doc/html/draft-ietf-spring-segment-routing-policy-13#section-8.4 the endpoint of the SR Policy is matched with the BGP nexthop.

Thanks,
Ketan

From: Rajesh M <[email-masked]>
Sent: 01 July 2021 07:58
To: [email-masked]; Clarence Filsfils (cfilsfil) <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: SRv6 BGP based Overlay Services (draft-ietf-bess-srv6-services-07)

Hi All,

As per the draft

Thanks

Rajesh