Subject: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

From: "Yangfan (IP Standard)" <[email-masked]>
Date: Tue, 13 Jul 2021 02:32:10 +0000

Hi SPRING，

A new draft was submitted to specify how an ACH6 (associated channel over IPv6) control channel is used in a Segment Routing network. On one hand, SRv6 SIDs list in SRH provides a certain SRv6 path. On the other hand, ACH6 provides the control and management capability to the SRv6 path.

Here is some background info if you are not acquainted with ACH6, 
ACH6 is initially proposed at IETF 110 (https://datatracker.ietf.org/doc/html/draft-yang-rtgwg-ipv6-associated-channel-01)
ACH6 in SR (https://datatracker.ietf.org/doc/html/draft-yang-spring-ach6-sr) and ACH6 OAM mechanism in SR (https://datatracker.ietf.org/doc/html/draft-yang-spring-ach6-oam-sr) are proposed at IETF 111

As always, comments and suggestions are welcome and appreciated. 

Stay safe.

Best regards,
Fan (on behalf of authors)

-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年7月13日 0:14
收件人: [email-masked]
主题: I-D Action: draft-yang-spring-ach6-sr-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : ACH6 in Segment Routing
        Authors         : Fan Yang
                          Tianran Zhou
	Filename        : draft-yang-spring-ach6-sr-00.txt
	Pages           : 11
	Date            : 2021-07-12

Abstract:
   Associated Channel over IPv6 (ACH6) provides a control channel to one
   specific IPv6 forwarding path for control and management purpose.
   When ACH6 is used in a Segment Routing network, it provides a control
   channel to an SRv6 path.  This document specifies an SRv6 ACH6
   mechanism and describes how ACH6 is applied in a Segment Routing
   network.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-yang-spring-ach6-sr/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-yang-spring-ach6-sr-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Haoyu Song <[email-masked]>
Date: Wed, 14 Jul 2021 16:46:39 +0000

Dear authors,

I like the idea of ACH for SRv6, and I think the use cases make sense and expect to see more if such mechanism exists. However, my opinion is that, since ACH packets are dedicated control packets, it might be easier to  encapsulate it in UDP payload while using an SRH flag to indicate the presence of ACH, which is more extensible. In fact, I think this draft can be consolidated with our draft "draft-song-spring-siam-01" for supporting IOAM ins SRv6 https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01  because I can see the potential for ACH6 to become a generic mechanism in SRv6 to support OAM and message passing pertaining to specific SR paths. 
Look forward more discussions on this!

Best,
Haoyu 

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Yangfan (IP Standard)
Sent: Monday, July 12, 2021 7:32 PM
To: spring <[email-masked]>
Subject: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

Hi SPRING，

Here is some background info if you are not acquainted with ACH6, 
ACH6 is initially proposed at IETF 110 (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yang-rtgwg-ipv6-associated-channel-01&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550209876%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Cd%2FpOMGuspvVA1IuCb0uVtxeb6TO%2Bge8qcQlQcPHUas%3D&amp;reserved=0)
ACH6 in SR (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yang-spring-ach6-sr&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550209876%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=NBQbeVePgWFttQOnYf%2BwlMv8MjykYl1P4CYcfK%2FfqzU%3D&amp;reserved=0) and ACH6 OAM mechanism in SR (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yang-spring-ach6-oam-sr&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550209876%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=pvBifpWgh6UdU5EI0%2F1HqaYZIBGGXeH4oSM6TWwqLtM%3D&amp;reserved=0) are proposed at IETF 111

Stay safe.

Best regards,

-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年7月13日 0:14
收件人: [email-masked]
主题: I-D Action: draft-yang-spring-ach6-sr-00.txt

Abstract:

The IETF datatracker status page for this draft is:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-yang-spring-ach6-sr%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550209876%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=E4idG%2ByLkK7m2Ye1xmOJr7Fml0NWSM%2FhVQeg7F7eDDw%3D&amp;reserved=0

There is also an htmlized version available at:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yang-spring-ach6-sr-00&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550209876%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=0WijXQSF1uZkLwgoXsy7IYX3l3VoKPoxLhb8vGEuMP8%3D&amp;reserved=0

Internet-Drafts are also available by anonymous FTP at:
https://nam11.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550219838%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=6chDqwNLq%2FjuO%2BaiNsx%2FWT4t8521TfPGwtTaCe%2B%2BPqo%3D&amp;reserved=0

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fi-d-announce&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550219838%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=19hCtlLenFKB6itLmYDzzKTNJ5fEbSqRQuKqnEmz%2BWU%3D&amp;reserved=0
Internet-Draft directories: https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.ietf.org%2Fshadow.html&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550219838%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=nk2cCgr083tziu5kIWh9gE8ZLNF6xreMctV0dYIYedA%3D&amp;reserved=0 or https://nam11.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Fietf%2F1shadow-sites.txt&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550219838%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=r%2ByqTv3po8fPM2LHSl5NS3lQYQmZgyngFCGALYuULd4%3D&amp;reserved=0
_______________________________________________
spring mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7Ccfdb5ba7c6954c1be83a08d945a6762e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637617403550219838%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2%2B1wnDDgVNgfJ4KcoKxB3dsSnIJrFo99vCawA2MpNK0%3D&amp;reserved=0

---

From: "Yangfan (IP Standard)" <[email-masked]>
Date: Thu, 15 Jul 2021 13:09:32 +0000

Hi Haoyu,

Thank you for your comments.
In the draft I propose two approaches of ACH6 encapsulation, one is in IPv6 DOH EH, another is in payload as you said. 

To encap ACH6 message in payload and use SRH flag to indicate the processing has its advantages. 1) ACH6 packet encapsulated in payload would never get lost 2) friendly to present implementations. But I doubt that ACH6 may need two different flags to indicate whether intermediate node should process it or not. In draft-~-siam, T flag indicates every SR endpoint to process IOAM data. It is not necessary for every SR endpoint to process ACH6 packet if this packet is only e2e used. It might be too luxurious to be considered as an option. :) 

Best regards,
Fan 

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Haoyu Song
发送时间: 2021年7月15日 0:47
收件人: Yangfan (IP Standard) <[email-masked]>; spring <[email-masked]>
主题: Re: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

Dear authors,

Best,
Haoyu 

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Yangfan (IP Standard)
Sent: Monday, July 12, 2021 7:32 PM
To: spring <[email-masked]>
Subject: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

Hi SPRING，

Stay safe.

Best regards,

-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年7月13日 0:14
收件人: [email-masked]
主题: I-D Action: draft-yang-spring-ach6-sr-00.txt

Abstract:

https://www.ietf.org/mailman/listinfo/spring

---

From: Haoyu Song <[email-masked]>
Date: Thu, 15 Jul 2021 16:37:27 +0000

If we have one extensible mechanism to cover many important use cases, I don't think two flags are too luxury.
I think HBH and E2E are indeed two distinct requirements and for the efficiency of packet processing, they should be taken care of separately. 

Haoyu

-----Original Message-----
From: Yangfan (IP Standard) <[email-masked]> 
Sent: Thursday, July 15, 2021 6:10 AM
To: Haoyu Song <[email-masked]>; spring <[email-masked]>
Subject: 答复: I-D Action: draft-yang-spring-ach6-sr-00.txt

Hi Haoyu,

Best regards,
Fan 

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Haoyu Song
发送时间: 2021年7月15日 0:47
收件人: Yangfan (IP Standard) <[email-masked]>; spring <[email-masked]>
主题: Re: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

Dear authors,

I like the idea of ACH for SRv6, and I think the use cases make sense and expect to see more if such mechanism exists. However, my opinion is that, since ACH packets are dedicated control packets, it might be easier to  encapsulate it in UDP payload while using an SRH flag to indicate the presence of ACH, which is more extensible. In fact, I think this draft can be consolidated with our draft "draft-song-spring-siam-01" for supporting IOAM ins SRv6 https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-song-spring-siam-01&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822819814%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=eDkM9JCqsN%2FgIUaLg00PRy%2F1WOAg%2FrznagwtejcYtn8%3D&amp;reserved=0  because I can see the potential for ACH6 to become a generic mechanism in SRv6 to support OAM and message passing pertaining to specific SR paths. 
Look forward more discussions on this!

Best,
Haoyu 

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Yangfan (IP Standard)
Sent: Monday, July 12, 2021 7:32 PM
To: spring <[email-masked]>
Subject: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

Hi SPRING，

Here is some background info if you are not acquainted with ACH6, 
ACH6 is initially proposed at IETF 110 (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yang-rtgwg-ipv6-associated-channel-01&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822819814%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=lw40XWM%2Btq2bsaHTIEBsfSrTZ95TGTwVrn6ahrrFjKE%3D&amp;reserved=0)
ACH6 in SR (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yang-spring-ach6-sr&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822819814%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=eYmH1dL0tlgZNeeWktSencVDQ8Y09H6mh6C3wuUxtp0%3D&amp;reserved=0) and ACH6 OAM mechanism in SR (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yang-spring-ach6-oam-sr&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=tvcmpAIfiQ3eoPzJoa0ZDtGgXHhX42z0ZHWESx610T8%3D&amp;reserved=0) are proposed at IETF 111

Stay safe.

Best regards,

-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年7月13日 0:14
收件人: [email-masked]
主题: I-D Action: draft-yang-spring-ach6-sr-00.txt

Abstract:

The IETF datatracker status page for this draft is:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-yang-spring-ach6-sr%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=pAQM4pTkFhAyfd9MfSi%2FZgTbLDV8dwMPjfeqhyme578%3D&amp;reserved=0

There is also an htmlized version available at:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-yang-spring-ach6-sr-00&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=hQ4LfPPGwqzLbbGSiwdLh65Hqpx0R3kAdOAXzJ7Cv7w%3D&amp;reserved=0

Internet-Drafts are also available by anonymous FTP at:
https://nam11.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=9Yw1vKXSMjxB0ZmKLjH6Fw7L%2FDGZUVhRabPXIOskVQg%3D&amp;reserved=0

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fi-d-announce&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Ogd4DSv10WnIEqfnClKg1EAuDytoWEGIUsu7R7Vhfq4%3D&amp;reserved=0
Internet-Draft directories: https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.ietf.org%2Fshadow.html&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Y%2B7J9ObF%2BJ4MXv8AEh1q13asc6FMwMh3j37dLhVDvU4%3D&amp;reserved=0 or https://nam11.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Fietf%2F1shadow-sites.txt&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Wzi2HtmPnmcSG0%2BWNk6UvyZZgDqoiTu1q%2BRr3jjBtDU%3D&amp;reserved=0
_______________________________________________
spring mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=IX9urrjS6spFRyG15cN6ZZ2XrksEdyb5cxyhNhFyt2U%3D&amp;reserved=0
_______________________________________________
spring mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C58fe8ca575554e33fb4108d94791cdb8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637619513822829767%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=IX9urrjS6spFRyG15cN6ZZ2XrksEdyb5cxyhNhFyt2U%3D&amp;reserved=0

---

From: "Yangfan (IP Standard)" <[email-masked]>
Date: Fri, 16 Jul 2021 09:34:17 +0000

Hi Haoyu,

I agree with you. Since ACH6 provides a control channel generally used for different ctrl/mgmt protocols by specifying Channel-Type, actually it avoids the worse situation where each protocol requires different SRH flags for indication. 
In this way, two SRH flags can have two indication functions:
1) indicate whether the payload is ACH6 ctrl packet or user data;
2) indicate whether every SID should check this ACH6 packet

I think it would be very friendly and only require limited modifications to current SRv6 implementations. 

Regards,
Fan 

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Haoyu Song
发送时间: 2021年7月16日 0:37
收件人: Yangfan (IP Standard) <[email-masked]>; spring <[email-masked]>
主题: Re: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

Haoyu

-----Original Message-----
From: Yangfan (IP Standard) <[email-masked]> 
Sent: Thursday, July 15, 2021 6:10 AM
To: Haoyu Song <[email-masked]>; spring <[email-masked]>
Subject: 答复: I-D Action: draft-yang-spring-ach6-sr-00.txt

Hi Haoyu,

Best regards,
Fan 

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Haoyu Song
发送时间: 2021年7月15日 0:47
收件人: Yangfan (IP Standard) <[email-masked]>; spring <[email-masked]>
主题: Re: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

Dear authors,

Best,
Haoyu 

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Yangfan (IP Standard)
Sent: Monday, July 12, 2021 7:32 PM
To: spring <[email-masked]>
Subject: [spring] I-D Action: draft-yang-spring-ach6-sr-00.txt

Hi SPRING，

Stay safe.

Best regards,

-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年7月13日 0:14
收件人: [email-masked]
主题: I-D Action: draft-yang-spring-ach6-sr-00.txt

Abstract: