Subject: [spring] SRv6 compression

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 27 Jul 2021 07:11:06 +0000

Given the design team accomplished the work on providing requirements and analysis to compress an SRv6 SID list, I would recommend we pick 1 solution similar to what was done in NVO3 (when we discussed GENEVE, GUE, GPE, etc) given this has to be implemented in HW..

I hope we can conclude on this asap and move forward on this topic

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 27 Jul 2021 08:54:11 +0000

I agree with Wim’s statement that the precedent in NVO3 *could* apply here too: pick one solution as Standard’s track RFC, and once it is done, the others might be documented as Informational RFCs if they have implementations.

That would help the industry to move forward.

Thanks.
Jorge

From: spring <[email-masked]> on behalf of Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Date: Tuesday, July 27, 2021 at 9:11 AM
To: [email-masked] <[email-masked]>
Subject: [spring] SRv6 compression
Given the design team accomplished the work on providing requirements and analysis to compress an SRv6 SID list, I would recommend we pick 1 solution similar to what was done in NVO3 (when we discussed GENEVE, GUE, GPE, etc) given this has to be implemented in HW..

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Tue, 27 Jul 2021 10:31:04 +0000

Agree, we should pick one solution to be standardized now, to facilitate the network deployment.

And I believe the solution is the one that has been implemented by the most vendors in the world, which is CSID.

That would help the industry for sure.

Respect,
Cheng

发件人: spring [mailto:[email-masked]] 代表 Rabadan, Jorge (Nokia - US/Mountain View)
发送时间: 2021年7月27日 16:54
收件人: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]
主题: Re: [spring] SRv6 compression

Thanks.
Jorge

From: spring <[email-masked]<mailto:[email-masked]>> on behalf of Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 27, 2021 at 9:11 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [spring] SRv6 compression
Given the design team accomplished the work on providing requirements and analysis to compress an SRv6 SID list, I would recommend we pick 1 solution similar to what was done in NVO3 (when we discussed GENEVE, GUE, GPE, etc) given this has to be implemented in HW..

---

From: "Sales, Bernard (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 27 Jul 2021 10:47:18 +0000

Hello,

Knowing the importance of compressed SID for SRv6, it is imperative for the industry to have a single standardized solution. In this context, it would be wise for the IETF to leverage on what has been previously achieved by other WGs facing a similar situation, e.g. NV03 when selecting the GENEVE solution.

Many Thanks,

-- Brd

From: spring <[email-masked]> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Tuesday, July 27, 2021 10:54 AM
To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]
Subject: Re: [spring] SRv6 compression

I agree with Wim's statement that the precedent in NVO3 *could* apply here too: pick one solution as Standard's track RFC, and once it is done, the others might be documented as Informational RFCs if they have implementations.

Thanks.
Jorge

---

From: Vasilenko Eduard <[email-masked]>
Date: Tue, 27 Jul 2021 12:17:41 +0000

Hi,
IMHO: Standardized solution for the same problem (more optimal data plane for SR in IPv6 infrastructure) should be one.
VPLS has lost a lot of market to L3VPN because VPLS had LDP and BGP flavors.
Many vendors have implemented only one, customers did not want vendor lock.
The primary goal of IETF is interoperability that would be broken if many solutions would be standardized.
Eduard
From: spring [mailto:[email-masked]] On Behalf Of Sales, Bernard (Nokia - BE/Antwerp)
Sent: Tuesday, July 27, 2021 1:47 PM
To: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>; Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]
Subject: Re: [spring] SRv6 compression

Hello,

Many Thanks,

-- Brd

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Tuesday, July 27, 2021 10:54 AM
To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] SRv6 compression

Thanks.
Jorge

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 27 Jul 2021 09:04:34 -0400

+1

Kind Regards

Gyan

On Tue, Jul 27, 2021 at 4:54 AM Rabadan, Jorge (Nokia - US/Mountain View) <
[email-masked]> wrote:

> I agree with Wim’s statement that the precedent in NVO3 **could** apply
> here too: pick one solution as Standard’s track RFC, and once it is done,
> the others might be documented as Informational RFCs if they have
> implementations.
>
>
>
> *From: *spring <[email-masked]> on behalf of Henderickx, Wim
> (Nokia - BE/Antwerp) <[email-masked]>
> *Date: *Tuesday, July 27, 2021 at 9:11 AM
> *To: [email-masked] <[email-masked]>
> *Subject: *[spring] SRv6 compression
>
> Given the design team accomplished the work on providing requirements and
> analysis to compress an SRv6 SID list, I would recommend we pick 1
> solution similar to what was done in NVO3 (when we discussed GENEVE, GUE,
> GPE, etc) given this has to be implemented in HW..
>
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 27 Jul 2021 14:12:01 +0000

Same here. We want a single standard method of SID compression to allow the WG to focus on finalizing it and get vendors hardware implementations updated.

Regards,
Mustapha.

From: spring <[email-masked]> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Tuesday, July 27, 2021 4:54 AM
To: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]
Subject: Re: [spring] SRv6 compression

Thanks.
Jorge

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 27 Jul 2021 12:09:27 -0400

For all operators around the world looking at deployment of SRv6
compression and being in a  holding pattern waiting for SRv6 compression to
be standardized by the IETF.

Given the ubiquitous importance of SRV6 compression and MSD issues with
long strict SR-TE explicit route object,  it is critical for
interoperability for all steering use cases that exist today: enterprise,
internet, private, access network - 5G wireless xHaul, mobile core,
wireline, MBB, FBB.

We as a WG need a single standardized solution for SRv6 compression for
interoperability to work and all vendors marching to the same sheet of
music.

I agree that the NVO3 - GENEVE is a solid precedence path forward to take
and for Spring WG to come to consensus and standardize on one solution and
progress the other solutions as informational if implementations already
exist.

Kind Regards

Gyan
Verizon Inc

On Tue, Jul 27, 2021 at 10:12 AM Aissaoui, Mustapha (Nokia - CA/Ottawa) <
[email-masked]> wrote:

> Same here. We want a single standard method of SID compression to allow
> the WG to focus on finalizing it and get vendors hardware implementations
> updated.
>
>
>
> Regards,
>
> Mustapha.
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *Rabadan, Jorge
> (Nokia - US/Mountain View)
> *Sent:* Tuesday, July 27, 2021 4:54 AM
> *To:* Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>;
> [email-masked]
> *Subject:* Re: [spring] SRv6 compression
>
>
>
> analysis to compress an SRv6 SID list, I would recommend we pick 1 solution
> similar to what was done in NVO3 (when we discussed GENEVE, GUE, GPE, etc)
> given this has to be implemented in HW..
>
>
>
-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: <[email-masked]>
Date: Thu, 29 Jul 2021 22:49:08 +0800 (CST)

Thanks for DT's hard work completing SRv6 header compression requirements and solutions comparion. 

I agree that it's better for industry if we all accept only 1 standard solution for SRv6. The different solutions compared by DT might originate from different main scenarios, such as C-SID mainly for standard SRv6, UIDSR mainly for both SR-MPLS and compressed SRv6. For standard SRv6 scenario, when we pick 1 solution the whole industry will be benificial with implementation, testing and interoperation, etc. 

Regards,

Aihua

原始邮件

发件人：Henderickx,Wim(Nokia-BE/Antwerp)
收件人：[email-masked];
日 期 ：2021年07月27日 15:11
主 题 ：[spring] SRv6 compression

Given the design team accomplished the work on providing requirements and analysis to compress an SRv6 SID list, I would recommend we pick 1 solution similar to what was done in NVO3 (when we discussed GENEVE, GUE, GPE, etc) given this has to be implemented in HW.

---

From: Ahmed MostafaSaleh ElSawaf <[email-masked]>
Date: Thu, 29 Jul 2021 15:18:00 +0000

Gents

As an operator, we do hope to reduce the number of solutions, so that we do not need to deploy multiple solutions. I hope the WG can standard one single solution.
Also, since the CSID has been implemented by most vendors, I will suggest to adopt CSID at the beginning.

BR
AS

From: spring <[email-masked]> On Behalf Of Gyan Mishra
Sent: Tuesday, July 27, 2021 6:09 PM
To: Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]>
Cc: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>; [email-masked]; Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
Subject: Re: [spring] SRv6 compression

For all operators around the world looking at deployment of SRv6 compression and being in a  holding pattern waiting for SRv6 compression to be standardized by the IETF.

Given the ubiquitous importance of SRV6 compression and MSD issues with long strict SR-TE explicit route object,  it is critical for interoperability for all steering use cases that exist today: enterprise, internet, private, access network - 5G wireless xHaul, mobile core, wireline, MBB, FBB.

We as a WG need a single standardized solution for SRv6 compression for interoperability to work and all vendors marching to the same sheet of music.

I agree that the NVO3 - GENEVE is a solid precedence path forward to take and for Spring WG to come to consensus and standardize on one solution and progress the other solutions as informational if implementations already exist.

Kind Regards

Gyan
Verizon Inc

On Tue, Jul 27, 2021 at 10:12 AM Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>> wrote:
Same here. We want a single standard method of SID compression to allow the WG to focus on finalizing it and get vendors hardware implementations updated.

Regards,
Mustapha.

Thanks.
Jorge

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347

The information in this email may contain confidential material and it is intended solely for the addresses. Access to this  email by anyone else is unauthorized. If you are not the intended recipient, please delete the email and destroy any copies of it, any disclosure, copying, distribution is prohibited and may be considered unlawful. Contents of this email and any attachments may be altered, Statement and opinions expressed in this email are those of the sender, and do not necessarily  reflect those of Saudi Telecommunications Company (STC).

---

From: Eduard Metz <[email-masked]>
Date: Fri, 30 Jul 2021 13:24:20 +0200

Agree.
The DT has done a great job in the analysis.

Moving forward with a single, standards track solution is
preferred/required for interoperable SRv6 implementations.

cheers,
  Eduard

---

From: "Voyer, Daniel" <[email-masked]>
Date: Fri, 30 Jul 2021 21:06:18 +0000

I agree as well – DT spent a year to come up with an analysis and now have a conclusion. In my view, we are ready to move with a single standard solution. This will unlock the vendors community to adopt an SRv6 compression standard and allow operators to move forward.

At the end of the analysis document, CSID seems to be the clear winner.

Thanks
dan

From: spring <[email-masked]> on behalf of Eduard Metz <[email-masked]>
Date: Friday, July 30, 2021 at 7:24 AM
To: Gyan Mishra <[email-masked]>
Cc: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>, "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>, "[email-masked]" <[email-masked]>, Wim Henderickx <[email-masked]>
Subject: [EXT]Re: [spring] SRv6 compression

Agree.

Moving forward with a single, standards track solution is preferred/required for interoperable SRv6 implementations.

cheers,
  Eduard

On Tue, Jul 27, 2021 at 6:09 PM Gyan Mishra <[email-masked]<mailto:[email-masked]>> wrote:

Kind Regards

Gyan
Verizon Inc

Regards,
Mustapha.

Thanks.
Jorge

Gyan Mishra

M 301 502-1347

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 31 Jul 2021 16:37:31 +0800

Agree. Picking 1 solution to satisfy our requirements will benefit both the vendors and the operators. 

Best Regards,
Zhenqiang Li

[email-masked]
 
From: Henderickx, Wim (Nokia - BE/Antwerp)
Date: 2021-07-27 15:11
To: [email-masked]
Subject: [spring] SRv6 compression
Given the design team accomplished the work on providing requirements and analysis to compress an SRv6 SID list, I would recommend we pick 1 solution similar to what was done in NVO3 (when we discussed GENEVE, GUE, GPE, etc) given this has to be implemented in HW..