Subject: [spring] draft-hu-spring-segment-routing-proxy-forwarding-14: Post convergence path

From: Shraddha Hegde <[email-masked]>
Date: Mon, 26 Jul 2021 20:16:17 +0000

WG,

Regarding Peter's comment on the mic that TI-LFA can divert from post convergence path when SRLG
is used for computation I would like to clarify that an operator is expected to do
planning for the post convergence path accounting for the SRLG failures.

draft-hu-spring-segment-routing-proxy-forwarding-14 is proposing a mechanism which will
divert the traffic based on nodes being upgraded to support the protection. The paths
could be quite divergent from post-convergence path and an operator would be expected
to do planning to ensure these paths have sufficient bandwidth to take on traffic.

Rgds
Shraddha

Juniper Business Use Only

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 26 Jul 2021 21:22:49 +0100

Isn’t the point about TI-LFA that it re-routes on the post convergence path to avoid micro-loops. 

When you overestimate the failure to provide node protection even though the failure was not a node failure, the repair path may not be congruent with the post convergence path in which case you need to understand if micro loops will form in the specific topology for the specific failure.

- Stewart

> On 26 Jul 2021, at 21:16, Shraddha Hegde <shraddha=[email-masked]> wrote:
> 
> WG,
>  
> Regarding Peter’s comment on the mic that TI-LFA can divert from post convergence path when SRLG
> _______________________________________________
> spring mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/spring <https://www.ietf.org/mailman/listinfo/spring>

---

From: Peter Psenak <[email-masked]>
Date: Mon, 26 Jul 2021 22:26:50 +0200

Hi Shraddha,

On 26/07/2021 22:16, Shraddha Hegde wrote:
> WG,
> 
> Regarding Peter’s comment on the mic that TI-LFA can divert from post 
> convergence path when SRLG is used for computation I would like to clarify > that an operator is expected to do planning for the post convergence
> path accounting for the SRLG failures.

TI-LFA does not always guarantee that backup path follows the 
post-convergence path.

It depends on what is the type of the backup computed and what is the 
actual failure. When the two do not match, we can not guarantee the 
backup path being equal to post convergence one.

An example is when you are calculating a node protecting backup, but the 
actual failure is a link failure, your backup path may not be the same 
as the post convergence one.

thanks,
Peter

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 26 Jul 2021 21:28:01 +0100

+1

S

> On 26 Jul 2021, at 21:26, Peter Psenak <ppsenak=[email-masked]> wrote:
> 
> Hi Shraddha,
> 
>> Regarding Peter’s comment on the mic that TI-LFA can divert from post convergence path when SRLG is used for computation I would like to clarify > that an operator is expected to do planning for the post convergence
> TI-LFA does not always guarantee that backup path follows the post-convergence path.
> 
> It depends on what is the type of the backup computed and what is the actual failure. When the two do not match, we can not guarantee the backup path being equal to post convergence one.
> 
> An example is when you are calculating a node protecting backup, but the actual failure is a link failure, your backup path may not be the same as the post convergence one.
> 
> thanks,
> Peter
> 
> 
> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Shraddha Hegde <[email-masked]>
Date: Mon, 26 Jul 2021 20:51:13 +0000

Peter,

The whole argument with post-convergence path is that the post-convergence path is expected to have 
Sufficient capacity.
I agree that backup paths may differ from actual post-convergence path for TI-LFA when SRLG is used for computation. My point is that an operator is expected to take care of this difference and ensure sufficient capacity is planned when there is single failure or multiple failures due to SRLG failure. 

Rgds
Shraddha

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]> 
Sent: Tuesday, July 27, 2021 1:57 AM
To: Shraddha Hegde <[email-masked]>; [email-masked]
Subject: Re: [spring] draft-hu-spring-segment-routing-proxy-forwarding-14: Post convergence path

[External Email. Be cautious of content]

Hi Shraddha,

On 26/07/2021 22:16, Shraddha Hegde wrote:
> convergence path when SRLG is used for computation I would like to 
> clarify > that an operator is expected to do planning for the post convergence path accounting for the SRLG failures.

thanks,
Peter