Subject: [spring] Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

From: Haoyu Song <[email-masked]>
Date: Tue, 6 Jul 2021 19:40:02 +0000

SPRING WG,
As the draft “draft-ietf-spring-stamp-srpm-01” has been adopted, I also ask the WG to consider the following related draft:

https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

We have presented this draft in the last meeting but we didn’t have much time to discuss it yet.
In essence, it proposes to carry IOAM in SR+UDP as well while using a flag bit in SRH to indicate the presence of the IOAM payload.
It achieves IOAM’s functionality but avoids the encapsulation issues. It doesn’t need to maintain sessions and it can monitor all the segment noes on an SR path.
I would also like to ask for feedbacks from the WG and request the adoption.  Thanks for consideration.

Best regards,
Haoyu

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 7 Jul 2021 01:48:17 +0000

Hi Haoyu,

Thanks for sharing your proposal.
I definitely have interest about this work.
We have a similar proposal which extends the STAMP.
https://datatracker.ietf.org/doc/draft-wang-ippm-stamp-hbh-extensions/
It would be great if we can put the use cases, requirements, potential solutions in a plate, and have comprehensive discussions on this..

Best,
Tianran
From: spring [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Wednesday, July 7, 2021 3:40 AM
To: [email-masked]; [email-masked]
Subject: [spring] Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

SPRING WG,

Best regards,
Haoyu

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 7 Jul 2021 01:50:49 +0000

On the generic use case, I see RFC 8403 in this working group, which is based on MPLS data plane.

Best,
Tianran

SPRING WG,

Best regards,
Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Wed, 7 Jul 2021 17:20:52 +0000

Hi Tianran,

Thanks for sharing.
A fundamental difference is either carrying the monitoring header in EH or in UDP payload. I think the latter is more extensible and it doesn’t have the compatibility issue therefore the deployment is easier.
The HBH or per-segment monitoring in SRv6 is important but missing today. I beleive we need a generic mechanism to support them, so we can collect more requirements and use cases to extend the draft.

Best,
Haoyu

From: Tianran Zhou <[email-masked]>
Sent: Tuesday, July 6, 2021 6:48 PM
To: Haoyu Song <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

Hi Haoyu,

https://datatracker.ietf.org/doc/draft-wang-ippm-stamp-hbh-extensions/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-wang-ippm-stamp-hbh-extensions%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7Ce71e491aad3a4378aa5708d940e94c78%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637612193042616329%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=0mKRgMw7Kn%2B3mGJabO2zPPcvxaDnR2SJTJKSrLSjs%2B4%3D&reserved=0>

Best,
Tianran
From: spring [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Wednesday, July 7, 2021 3:40 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [spring] Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

SPRING WG,

https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-song-spring-siam-01&data=04%7C01%7Chaoyu.song%40futurewei.com%7Ce71e491aad3a4378aa5708d940e94c78%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637612193042616329%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Ln8TLJpLN%2BV2uJc0yBncqoGNjt1%2BJ7GJdIBXn0DKxUM%3D&reserved=0> “SRv6 In-situ Active Measurement”

Best regards,
Haoyu

---

From: Tianran Zhou <[email-masked]>
Date: Thu, 8 Jul 2021 03:33:18 +0000

Hi Haoyu,

The STAMP extension is not in EH. Similar to your proposal, it’s after UDP and in STAMP.
The proposal did not specify how to trigger the intermediate node to process. So it could be hop by hop or per segment.
I think the major difference is on the metrics which relate to the use cases.
I am not sure how most of the IOAM data could be used for active probe.
For example, the node and interface id.
The SIAM is for designated path which is planned by the controller. The controller is topology aware. There is no need to collect node and interface again.
Another example, the queue depth.
It’s highly dynamic, I do not understand why an active probe need to collect this data. Then how to use it?

Best,
Tianran

From: spring [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Thursday, July 8, 2021 1:21 AM
To: Tianran Zhou <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [spring] Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

Hi Tianran,

Thanks for sharing.

Best,
Haoyu

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 6, 2021 6:48 PM
To: Haoyu Song <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

Hi Haoyu,

Best,
Tianran

SPRING WG,

Best regards,
Haoyu

---

From: Haoyu Song <[email-masked]>
Date: Thu, 8 Jul 2021 16:33:39 +0000

Hi Tianran,

Note that IOAM Trace/E2E are extensible to support various data types. Some may not be useful in this scenario and they can be excluded from the data collection.
I also mentioned that UDP is more extensible so measurements on other metrics can also be supported, if not already covered by IOAM.

Best,
Haoyu

From: Tianran Zhou <[email-masked]>
Sent: Wednesday, July 7, 2021 8:33 PM
To: Haoyu Song <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

Hi Haoyu,

Best,
Tianran

From: spring [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Thursday, July 8, 2021 1:21 AM
To: Tianran Zhou <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01 “SRv6 In-situ Active Measurement”

Hi Tianran,

Thanks for sharing.

Best,
Haoyu

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 6, 2021 6:48 PM
To: Haoyu Song <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-song-spring-siam-01&data=04%7C01%7Chaoyu.song%40futurewei.com%7C1349f840ba2e41c6dd2008d941c126da%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637613120119981235%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=wryO75nWGQWwte8JIojmmlaPHUNdELbtRsIGLpC37LQ%3D&reserved=0> “SRv6 In-situ Active Measurement”

Hi Haoyu,

https://datatracker.ietf.org/doc/draft-wang-ippm-stamp-hbh-extensions/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-wang-ippm-stamp-hbh-extensions%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7C1349f840ba2e41c6dd2008d941c126da%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637613120119981235%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=DZs2CIec3nSx%2FqHALQR61mrtXW%2BMFlqI9ksiO6fKfHw%3D&reserved=0>

Best,
Tianran
From: spring [mailto:[email-masked]] On Behalf Of Haoyu Song
Sent: Wednesday, July 7, 2021 3:40 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [spring] Request for adoption https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-song-spring-siam-01&data=04%7C01%7Chaoyu.song%40futurewei.com%7C1349f840ba2e41c6dd2008d941c126da%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637613120119991190%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Aaqeq5h5jkYFq8QhCZDgQGGjZjxlX23JDh9YBlYNs%2Fo%3D&reserved=0> “SRv6 In-situ Active Measurement”

SPRING WG,

https://datatracker.ietf.org/doc/html/draft-song-spring-siam-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-song-spring-siam-01&data=04%7C01%7Chaoyu.song%40futurewei.com%7C1349f840ba2e41c6dd2008d941c126da%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637613120119991190%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Aaqeq5h5jkYFq8QhCZDgQGGjZjxlX23JDh9YBlYNs%2Fo%3D&reserved=0> “SRv6 In-situ Active Measurement”

Best regards,
Haoyu