Subject: [spring] Progressing Standardizing SR over IPv6 compression

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 4 Aug 2021 14:52:26 -0400

The SPRING Working Group Chairs thank the design team for their efforts 
on the requirements and analysis drafts.  The question of how the 
working group wants to progress that part of the work will be the topic 
for a separate email a bit later.

Right now, we are hearing the discussion about how many solutions, and 
the perspectives being expressed.  While the topic was well-raised, the 
discussion to date has not been structured in a way that makes clear to 
everyone what the purpose is.  In particular, the chairs have decided to 
re-ask the question.  We ask that even those who have responded in the 
discussion respond to this thread.  Preferably with both what their 
opinion is and an explanation of why.

The question we are asking you to comment on is:

Should the working group standardize one data plane behavior for 
compressing SRv6 information?

Please speak up.  We are looking to collect responses until close of 
business PDT on 20-August-2021.

Thank you,
Joel, Jim, and Bruno

---

From: Tony Li <[email-masked]>
Date: Wed, 4 Aug 2021 12:26:05 -0700

> Should the working group standardize one data plane behavior for compressing SRv6 information?

Yes.

One. And only one.

Why? 

Let’s suppose that we choose N (or fail to choose).  Different networks will make different choices. Then vendors will be forced to support all N of them. Chip manufacturers will have to support all N of them. Effectively forever. Sure, some may fail, but by that point it becomes impossible to remove the support without re-verifying the chip. So no one will.

Choosing more than one is hideously inefficient for the entire industry.  Our job, as an SDO, is to make a single standard.

The IETF is neither a coffee klatsch nor a publishing house.  Our duty is to make the tough decisions for the world.

Tony

---

From: "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 4 Aug 2021 19:56:41 +0000

Yes. 

And repeating what I said in the earlier email message, we want a single standard method of SID compression to allow the WG to focus on finalizing it and get vendors hardware implementations updated.

Mustapha.

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Wednesday, August 4, 2021 2:52 PM
To: [email-masked]
Subject: [spring] Progressing Standardizing SR over IPv6 compression

The SPRING Working Group Chairs thank the design team for their efforts on the requirements and analysis drafts.  The question of how the working group wants to progress that part of the work will be the topic for a separate email a bit later.

Right now, we are hearing the discussion about how many solutions, and the perspectives being expressed.  While the topic was well-raised, the discussion to date has not been structured in a way that makes clear to everyone what the purpose is.  In particular, the chairs have decided to re-ask the question.  We ask that even those who have responded in the discussion respond to this thread.  Preferably with both what their opinion is and an explanation of why.

Please speak up.  We are looking to collect responses until close of business PDT on 20-August-2021.

Thank you,
Joel, Jim, and Bruno

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 4 Aug 2021 22:41:50 +0200

Yes.

This is data plane and any "flexibility" of more then one solution in data
plane would only bring pain to everyone.

Thx,
R.

---

From: Keyur Patel <[email-masked]>
Date: Wed, 4 Aug 2021 21:07:06 +0000

Yes.

Best Regards,
Keyur

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Wed, 4 Aug 2021 21:28:33 +0000

“Should the working group standardize one data plane behavior for
compressing SRv6 information?”

Yes, only one data plane behavior as standards track document.
As discussed, there are precedents in other WGs for similar processes and standardizing on a single data plane solution helped move forward.

Thanks.
Jorge

From: spring <[email-masked]> on behalf of Joel M. Halpern <[email-masked]>
Date: Wednesday, August 4, 2021 at 11:52 AM
To: [email-masked] <[email-masked]>
Subject: [spring] Progressing Standardizing SR over IPv6 compression
The SPRING Working Group Chairs thank the design team for their efforts
on the requirements and analysis drafts.  The question of how the
working group wants to progress that part of the work will be the topic
for a separate email a bit later.

Thank you,
Joel, Jim, and Bruno

---

From: Lihao <[email-masked]>
Date: Wed, 4 Aug 2021 23:02:04 +0000

>Should the working group standardize one data plane behavior for compressing SRv6 information?

Yes. more than one solution is awful for vendor/operator/provider...

-----邮件原件-----
发件人: spring [mailto:[email-masked]] 代表 Joel M. Halpern
发送时间: 2021年8月5日 2:52
收件人: [email-masked]
主题: [spring] Progressing Standardizing SR over IPv6 compression

Thank you,
Joel, Jim, and Bruno

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring
-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息，仅限于发送给上面地址中列出
的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、
或散发）本邮件中的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本
邮件！
This e-mail and its attachments contain confidential information from New H3C, which is
intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender
by phone or email immediately and delete it!

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 5 Aug 2021 04:09:01 +0000

I will repeat what I said before, given this has to be implemented in HW it is better for everyone to have a single solution.
Also for interoperability purposes 1 solution will help us all.

Date: Wednesday, 4 August 2021 at 20:52

Thank you,
Joel, Jim, and Bruno

---

From: Gyan Mishra <[email-masked]>
Date: Thu, 5 Aug 2021 02:46:59 -0400

Yes

>From an operators perspective interoperability is critical and utmost
importance, so we cannot risk having vendors pick their own solution they
like and develop that solution.

One of the primary goals and objectives of the IETF and all the
stakeholders in the industry rely on the IETF to maintain uphold the high
bar when it comes to standardization.

The major risk in having multiple solutions for a data plane is the risk of
interoperability as vendors may pick and choose their favorite and what
they want to develop which can really hurts the entire router industry.

Kind Regards

Gyan

On Thu, Aug 5, 2021 at 12:09 AM Henderickx, Wim (Nokia - BE/Antwerp) <
[email-masked]> wrote:

> I will repeat what I said before, given this has to be implemented in HW
> it is better for everyone to have a single solution.
>
> *From: *spring <[email-masked]> on behalf of Joel M. Halpern <
> [email-masked]>
> *Date: *Wednesday, 4 August 2021 at 20:52
> *To: [email-masked] <[email-masked]>
> *Subject: *[spring] Progressing Standardizing SR over IPv6 compression
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: Takuya Miyasaka <[email-masked]>
Date: Thu, 5 Aug 2021 16:51:47 +0900

Hi,

Firstly, I would like to thank the design team for their outstanding work.

 From the operator's point of view, we are always looking for quick 
implementation and interoperability across multiple vendors. For this 
reason, we prefer one data plane under the SRv6 umbrella.

Regards,
Takuya

On 2021/08/05 3:52, Joel M. Halpern wrote:
> The SPRING Working Group Chairs thank the design team for their 
> efforts on the requirements and analysis drafts.  The question of how 
> the working group wants to progress that part of the work will be the 
> topic for a separate email a bit later.
>
> the perspectives being expressed.  While the topic was well-raised, 
> the discussion to date has not been structured in a way that makes 
> clear to everyone what the purpose is.  In particular, the chairs have 
> decided to re-ask the question.  We ask that even those who have 
> responded in the discussion respond to this thread.  Preferably with 
> both what their opinion is and an explanation of why.
>

---

From: Eduard Metz <[email-masked]>
Date: Thu, 5 Aug 2021 10:22:25 +0200

Yes.

cheers,
   Eduard

---

From: "Bernier, Daniel" <[email-masked]>
Date: Thu, 5 Aug 2021 16:24:09 +0000

Hi, 

Similar to my comment on the chat during SPRING last Monday. The mailing list has been flooded of opinions, exchanges, technical arguments on all variations, to the extent that it triggered the WG to initiate that DT effort to help get better clarity.
I really do think that it would be counterproductive to go back to the list, restart another lengthy technical discussion thread and discard the outcome of what the DT has produced.
 
This discussion has slowed progress on various aspects of the industry (from ASIC SDKs, to large incumbents and new vendors support)  and in turn slowed down our ability to deploy. Nonetheless, the community is moving forward with efforts like SONIC 
on normalizing CSID and SRH within the SAI for broad homogeneous adoption. 

So, to the question "Should the working group standardize one data plane behavior for compressing SRv6 information?"

I would say a Yes and please follow the outcome of the DT work

Cheers, 

Dan B

On 2021-08-04, 2:52 PM, "spring on behalf of Joel M. Halpern" <[email-masked] on behalf of [email-masked]> wrote:

    Thank you,
    Joel, Jim, and Bruno

    _______________________________________________
    spring mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spring
    ------------------------------------------------------------------------------
    External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: Stefano Salsano <[email-masked]>
Date: Fri, 6 Aug 2021 01:20:46 +0200

Il 2021-08-04 20:52, Joel M. Halpern ha scritto:
[...]
> compressing SRv6 information?

yes, only one solution for SRv6 header compression

the design team has worked one year to compare different solutions, we 
need to take into account the results of the DT work to select the 
solution to be standardized

ciao
Stefano

-- 
*******************************************************************
Stefano Salsano
Professore Associato
Dipartimento Ingegneria Elettronica
Universita' di Roma Tor Vergata
Viale Politecnico, 1 - 00133 Roma - ITALY

http://netgroup.uniroma2.it/Stefano_Salsano/

E-mail  : [email-masked]
Cell.   : +39 320 4307310
Office  : (Tel.) +39 06 72597770 (Fax.) +39 06 72597435
*******************************************************************

---

From: Martin Horneffer <[email-masked]>
Date: Fri, 6 Aug 2021 10:07:08 +0200

My opinion clearly is: The WG should standardize ONE solution for SRv6 
header compression, and it should follow to results of the DT.

Reason: As an operator I could theoretically ignore the effort vendors 
have for implementing solution that I do not care for.
In reality however that usually does takes critical ressources away from 
implementing the technology that I need.
The effect is much later interoperability.

Best regards,
Martin

---

From: Boris Hassanov <[email-masked]>
Date: Fri, 6 Aug 2021 17:11:21 +0000 (UTC)

Hi Joel and all,
Please see my answer and comments below.
>Should the working group standardize one data plane behavior for compressing SRv6 information?
Yes, we should pick up one data plane SRv6 compression mechanism. Even if It will be not an easy choice.
I have been on vendors side for a while  but now saying from operator perspective: we need one standardized solution because we do not want to stuck with just one vendor and do not want to solve an interop nightmare between 2 or 3  different mechanisms from different vendors by ourselves in the nearest future.

With all respect for the all vendors who invested much in particular technology.
SY,Boris

    On Wednesday, August 4, 2021, 09:52:48 PM GMT+3, Joel M. Halpern <[email-masked]> wrote:  

Thank you,
Joel, Jim, and Bruno

---

From: "Luis M. Contreras" <[email-masked]>
Date: Fri, 6 Aug 2021 20:07:09 +0200

+1

Best regards

Luis

El vie., 6 ago. 2021 19:12, Boris Hassanov <bhassanov=
[email-masked]> escribió:

> I have been on vendors side for a while  but now saying from operator
> perspective: we need one standardized solution because we do not want to
> stuck with just one vendor and do not want to solve an interop nightmare
> between 2 or 3  different mechanisms from different vendors by ourselves in
> the nearest future.
>
> SY,
> Boris

---

From: Vasilenko Eduard <[email-masked]>
Date: Fri, 6 Aug 2021 19:29:35 +0000

+1

From: spring [mailto:[email-masked]] On Behalf Of Luis M. Contreras
Sent: Friday, August 6, 2021 9:07 PM
To: Boris Hassanov <bhassanov=[email-masked]>
Cc: SPRING WG List <[email-masked]>; Joel M. Halpern <[email-masked]>
Subject: Re: [spring] Progressing Standardizing SR over IPv6 compression

+1

Best regards

Luis

El vie., 6 ago. 2021 19:12, Boris Hassanov <bhassanov=[email-masked]<mailto:[email-masked]>> escribió:
Hi Joel and all,

SY,
Boris

On Wednesday, August 4, 2021, 09:52:48 PM GMT+3, Joel M. Halpern <[email-masked]<mailto:[email-masked]>> wrote:

Thank you,
Joel, Jim, and Bruno

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 10 Aug 2021 09:10:49 +0800

Yes, the working group SHOULD standardize one data plane behavior for compressing SRv6 information.

[email-masked]
 
From: Joel M. Halpern
Date: 2021-08-05 02:52
To: [email-masked]

 

Thank you,
Joel, Jim, and Bruno

---

From: "Aijun Wang" <[email-masked]>
Date: Wed, 11 Aug 2021 10:49:34 +0800

The answer to the question is: 

Yes. 
Having more data plane behaviors requires the operator to solve the
interoperability issues, or all vendors supports all solutions. 
Such results should be avoided by the efforts of standard community.

Best Regards

Aijun Wang
China Telecom

-----Original Message-----
From: [email-masked] <[email-masked]> On Behalf Of Joel M.
Halpern
Sent: Thursday, August 5, 2021 2:52 AM
To: [email-masked]
Subject: [spring] Progressing Standardizing SR over IPv6 compression

The SPRING Working Group Chairs thank the design team for their efforts on
the requirements and analysis drafts.  The question of how the working group
wants to progress that part of the work will be the topic for a separate
email a bit later.

Right now, we are hearing the discussion about how many solutions, and the
perspectives being expressed.  While the topic was well-raised, the
discussion to date has not been structured in a way that makes clear to
everyone what the purpose is.  In particular, the chairs have decided to
re-ask the question.  We ask that even those who have responded in the
discussion respond to this thread.  Preferably with both what their opinion
is and an explanation of why.

Should the working group standardize one data plane behavior for compressing
SRv6 information?
Please speak up.  We are looking to collect responses until close of
business PDT on 20-August-2021.

Thank you,
Joel, Jim, and Bruno

---

From: Chongfeng Xie <[email-masked]>
Date: Wed, 11 Aug 2021 11:40:32 +0800

Hi, folks,
As one member of design team,  I am pleased that two drafts has been produced by the members with more than 1 year effort.  Support has also been received from outside of the DT during the past year, thanks.  From the perspective of one operator, I believe that the standardization of one data plane for compressed SRv6 will be better for the whole industry.

Best regards
Chongfeng

> 2021年8月5日 上午2:52，Joel M. Halpern <[email-masked]> 写道：
>

---

From: "Ville Hallivuori" <[email-masked]>
Date: Fri, 13 Aug 2021 16:17:04 +0300

Hello,

> compressing SRv6 information?

Yes! Single data plane option is desirable. Any more is unnecessary complexity in forwarding silicon or wasted microcode space.

BR,
Ville Hallivuori

---

From: Shunsuke Homma <[email-masked]>
Date: Tue, 17 Aug 2021 02:02:29 +0900

Hi Joel and WG,

> compressing SRv6 information?

Yes, we should pick up and standardize a single solution for SRv6
compression. Interoperability is one of important factors for operators.
Multi-options may prevent interoperability.

Regards,

Shunsuke

---

From: James Guichard <[email-masked]>
Date: Tue, 17 Aug 2021 20:27:35 +0000

Dear WG:

If you have not already done so please do provide your comments to the mailing list as soon as possible. 

Thanks!

Jim, Joel & Bruno

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Wednesday, August 4, 2021 2:52 PM
To: [email-masked]
Subject: [spring] Progressing Standardizing SR over IPv6 compression

Thank you,
Joel, Jim, and Bruno

_______________________________________________
spring mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=04%7C01%7Cjames.n.guichard%40futurewei.com%7C250776c6aff74c568c8a08d957790ab9%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637636999654946952%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=JyUjJng7gmClXGUsLl9AV6YWYWLQUFpmTPud8%2F0LRWE%3D&amp;reserved=0

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 18 Aug 2021 14:58:12 +0530

Hi Chairs, WG,

Mostly I have been in favor of providing multiple tools for the operator's
toolbox in the control plane. But in this instance, the cost of multiple
data plane behaviors for compressing SRv6 would be very high and finally,
the interoperability would suffer. In the long run, it would be best for
the SRv6 technology, industry, and the WG, if the decision is made now by
the WG to select one technique.

Thanks!
Dhruv

On Wed, Aug 18, 2021 at 1:58 AM James Guichard <
[email-masked]> wrote:

> the requirements and analysis drafts.  The question of how the working
> group wants to progress that part of the work will be the topic for a
> separate email a bit later.
>

---

From: Ahmed MostafaSaleh ElSawaf <[email-masked]>
Date: Wed, 18 Aug 2021 09:30:46 +0000

Dears

 we want to have less solutions for sure, we do not want to introduce more complexities in our network, so please choose one solution.
Apparently, we should standardize CSID.

-----Original Message-----
From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Tuesday, August 17, 2021 10:28 PM
To: Joel M. Halpern <[email-masked]>; [email-masked]
Subject: Re: [spring] Progressing Standardizing SR over IPv6 compression

Dear WG:

Thanks!

Jim, Joel & Bruno

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Wednesday, August 4, 2021 2:52 PM
To: [email-masked]
Subject: [spring] Progressing Standardizing SR over IPv6 compression

Thank you,
Joel, Jim, and Bruno

The information in this email may contain confidential material and it is intended solely for the addresses. Access to this  email by anyone else is unauthorized. If you are not the intended recipient, please delete the email and destroy any copies of it, any disclosure, copying, distribution is prohibited and may be considered unlawful. Contents of this email and any attachments may be altered, Statement and opinions expressed in this email are those of the sender, and do not necessarily  reflect those of Saudi Telecommunications Company (STC).

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Wed, 18 Aug 2021 17:35:54 +0000

Joel

Yes, I believe the WG should standardize a single data plane solution.

This will enable to the WG and industry to move forward and enable vendors to implement a single interoperable solution. It reduces overall solution complexity and greatly benefits deployments.

Based on the experience of multiple working groups, it is hugely beneficial to have a single data plane solution on which we can focus our efforts.

Thanks

Matthew

Date: Wednesday, 4 August 2021 at 19:52

Thank you,
Joel, Jim, and Bruno

---

From: <[email-masked]>
Date: Thu, 19 Aug 2021 03:56:07 +0800 (CST)

Dear All,

I strongly support the standardization of a single data plane solution that supports Segment Routing using also compressed SIDs in an IPv6 network.

Regards,

Greg Mirsky

Sr. Standardization Expert
预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product R&D Institute/Wireline Product Operation Division

E: [email-masked] 
www.zte.com.cn

Original Mail

Sender: JamesGuichard
To: Joel M. Halpern;[email-masked];
Date: 2021/08/17 13:28
Subject: Re: [spring] Progressing Standardizing SR over IPv6 compression

Dear WG:

Thanks!
 
Jim, Joel & Bruno
 
-----Original Message-----
From: spring <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Wednesday, August 4, 2021 2:52 PM
To: [email-masked]
Subject: [spring] Progressing Standardizing SR over IPv6 compression

 

 
Thank you,
Joel, Jim, and Bruno

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 19 Aug 2021 01:16:06 +0000

Dear chairs, 

I believe the WG should standardize a single data plane solution. 

I fully agree with Dhruv that the cost of multiple data plane for SRv6 compression would be unaffordable and the interoperable deployment would suffer from it. 

Best regards,
Jie

> From: spring [mailto:[email-masked]] On Behalf Of James Guichard
> Sent: Wednesday, August 18, 2021 4:28 AM
> group wants to progress that part of the work will be the topic for a separate
> email a bit later.
> 
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fww
> w.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=04%7C01%7Cjames.
> n.guichard%40futurewei.com%7C250776c6aff74c568c8a08d957790ab9%7C
> 0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637636999654946952
> %7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiL
> CJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=JyUjJng7gmClXGUs
> Ll9AV6YWYWLQUFpmTPud8%2F0LRWE%3D&amp;reserved=0
>

---

From: "Luc-Fabrice Ndifor Ngwa [ MTN Cameroon ]" <[email-masked]>
Date: Thu, 19 Aug 2021 02:52:40 +0000

+ 1

One solution will be the best for any operator and the industry, so suggest to move forward with one solution rather than spending more time again to explore several options (this has already taken long)
Since the CSID satisfies all the requirements, it will be great if we can have CSID standardized.

​Warm regards,
Luc-Fabrice
 
Ndifor
Specialist - IP Access and Data center
[email-masked]
T +237 677 55 02 13
Head Office: 360, Rue Drouot
​P.O. Box 15 574 Douala, Cameroon
T +237 679 00 90 90
 | mtn.cm
This email is confidential. If you have received it in error, you are on notice of its status. Please notify ​the ​​sender immediately by 
​reply email and then delete this message from your system. Please do not copy it ​or use it for any purpose or disclose its content 
​to any other person as to do so could be a breach of ​confidentiality.
​
 Please be informed that no employee or agent is authorized to conclude any legally binding agreement ​on behalf of MTN Cameroon
​via email. This can be only done if the email is confirmed explicitly in writing ​by an MTN Cameroon authorized officer. In no event 
​will this email or its content be construed as a written ​approval.
From: spring <[email-masked]> On Behalf Of Luis M. Contreras
Sent: Friday, August 6, 2021 7:07 PM
To: Boris Hassanov <bhassanov=[email-masked]>
Cc: SPRING WG List <[email-masked]>; Joel M. Halpern <[email-masked]>
Subject: Re: [spring] Progressing Standardizing SR over IPv6 compression

+1

Best regards

Luis

SY,
Boris

Thank you,
Joel, Jim, and Bruno

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 19 Aug 2021 04:37:45 +0000

Hi Everyone,

    It is better for the WG to standardize one data plane behavior
for compressing SRv6 information at present time.

Best Regards,

Huaimo

Thank you,
Joel, Jim, and Bruno

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C8e55c4ab24e3495a7bcd08d9626eaf71%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637649049795911891%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=5F3C%2BbG8mGbd2aPPJD4g3JVfU0HLyqOqeK3yUbsx6F8%3D&reserved=0>

---

From: Loa Andersson <[email-masked]>
Date: Thu, 19 Aug 2021 12:04:25 +0200

Dhairs, working group,

I agree with Matthew, we should standardize one single data plane 
behavior for IPv6 compression.

/Loa
 > compressing SRv6 information

On 18/08/2021 19:35, Bocci, Matthew (Nokia - GB) wrote:
> This will enable to the WG and industry to move forward and enable 
> vendors to implement a single interoperable solution. It reduces overall 
> solution complexity and greatly benefits deployments.
> 
> Based on the experience of multiple working groups, it is hugely 
> beneficial to have a single data plane solution on which we can focus 
> our efforts.
> 
> Thanks
> 
> Matthew
> 
> *From: *spring <[email-masked]> on behalf of Joel M. Halpern 
> <[email-masked]>
> *Date: *Wednesday, 4 August 2021 at 19:52
> <https://www.ietf.org/mailman/listinfo/spring>
> 
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: "Sales, Bernard (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 19 Aug 2021 13:20:34 +0000

Hello,

As said previously, it is imperative for the industry to have a single standardized solution.

Many Thanks,

-- Brd

-----Original Message-----
From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Tuesday, August 17, 2021 10:28 PM
To: Joel M. Halpern <[email-masked]>; [email-masked]
Subject: Re: [spring] Progressing Standardizing SR over IPv6 compression

Dear WG:

Thanks!

Jim, Joel & Bruno

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Wednesday, August 4, 2021 2:52 PM
To: [email-masked]
Subject: [spring] Progressing Standardizing SR over IPv6 compression

Thank you,
Joel, Jim, and Bruno

---

From: Yingzhen Qu <[email-masked]>
Date: Thu, 19 Aug 2021 10:17:13 -0700

I support to have only one data plane compressing solution. 

Having more than one behaviors standardized means that vendors will need to support all the solutions, and before that happens there will be interoperability issues, essentially zero solution.

Thanks,
Yingzhen

> On Aug 4, 2021, at 11:52 AM, Joel M. Halpern <[email-masked]> wrote:
>

---

From: Satoru Matsushima <[email-masked]>
Date: Sat, 21 Aug 2021 01:32:25 +0900

Hi Chairs, and WG,

As an SRv6 network operator, I support that the WG adopts one single data plane behavior and standardize it as the SRv6 SID list compression spec. It is simple and IMO the best way for all of us.

Cheers,
--satoru

> On Aug 18, 2021, at 5:28, James Guichard <[email-masked]> wrote:
> Dear WG:
>

---

From: Joel Halpern <[email-masked]>
Date: Fri, 20 Aug 2021 15:17:56 -0400

Thank you to everyone who has replied to our request for WG feedback. As 
soon as the chairs have had a chance to consult, we will let you know 
what the next steps are.

Yours
Joel, Jim, and Bruno

---

From: Haoyu Song <[email-masked]>
Date: Fri, 20 Aug 2021 19:24:49 +0000

SPRING WG,

I support a single standard for SR compression from the perspective of system design (both hardware and software). I have reviewed the solution drafts and believe CSID should be standardized. Thanks!

Haoyu

-----Original Message-----
From: spring <[email-masked]> On Behalf Of James Guichard
Sent: Tuesday, August 17, 2021 1:28 PM
To: Joel M. Halpern <[email-masked]>; [email-masked]
Subject: Re: [spring] Progressing Standardizing SR over IPv6 compression

Dear WG:

Thanks!

Jim, Joel & Bruno

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Wednesday, August 4, 2021 2:52 PM
To: [email-masked]
Subject: [spring] Progressing Standardizing SR over IPv6 compression

Thank you,
Joel, Jim, and Bruno

_______________________________________________
spring mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C98b0f48e10f241cd561b08d961bd7fab%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637648288814730023%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=hnXF7kduzyJlyyBUw8sntnkAU6XWem62n1T9L2F5MgI%3D&amp;reserved=0

_______________________________________________
spring mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C98b0f48e10f241cd561b08d961bd7fab%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637648288814730023%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=hnXF7kduzyJlyyBUw8sntnkAU6XWem62n1T9L2F5MgI%3D&amp;reserved=0

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 21 Aug 2021 01:08:47 -0400

Dear Chairs

+1 on the high cost to implementations of multiple SRv6 compression
solutions and major issue for operators on interoperability.

On Wed, Aug 18, 2021 at 9:16 PM Dongjie (Jimmy) <[email-masked]> wrote:

> I fully agree with Dhruv that the cost of multiple data plane for SRv6
> compression would be unaffordable and the interoperable deployment would
> suffer from it.
>
> Best regards,
> Jie
>
> on
> the
-- 

*Gyan Mishra*

*M 301 502-1347*

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Sat, 21 Aug 2021 12:36:07 +0000

Hi chairs, I’m just catching up on SPRING after a few weeks away for summer vacation.

Yes we should standardize one SRv6 compression proposal. CSID meets the requirements and I would like to see it adopted.

Darren
________________________________
From: spring <[email-masked]> on behalf of Joel M. Halpern <[email-masked]>
Sent: Wednesday, August 4, 2021 2:53 PM
To: [email-masked]
Subject: [spring] Progressing Standardizing SR over IPv6 compression

Thank you,
Joel, Jim, and Bruno

---

From: Dirk Steinberg <[email-masked]>
Date: Wed, 25 Aug 2021 09:46:03 +0300

Dear Chairs,

please excuse my late reply, I am catching up with the list after some
weeks of travel.

I strongly believe that the WG should standardize one and only one solution
for SRv6 header compression. More than one solution would mean pain
for both vendors and operators.

Based on the DT analysis it appears to me that CSID meets the
requirements and is the best solution.

I support adoption of CSID as a SRv6 header compression standard.

Dirk

On Sat, Aug 21, 2021 at 3:36 PM Darren Dukes (ddukes) <ddukes=
[email-masked]> wrote:

> Yes we should standardize one SRv6 compression proposal. CSID meets the
> requirements and I would like to see it adopted.
>
> Darren
> ------------------------------
> *From:* spring <[email-masked]> on behalf of Joel M. Halpern <
> [email-masked]>
> *Sent:* Wednesday, August 4, 2021 2:53 PM
> *To:* [email-masked]
> *Subject:* [spring] Progressing Standardizing SR over IPv6 compression
>