Subject: Re: [spring] SRv6 compression

From: Qiuyuanxiang <[email-masked]>
Date: Mon, 2 Aug 2021 10:00:58 +0000

Agree.

As a vendor, we do hope to pick one solution to be standardized, to facilitate the network deployment.
Also, since the CSID has been implemented by many vendors, I will suggest to adopt CSID.

Best Regards,
Yuanxiang Qiu

发件人: spring [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2021年7月31日 16:38
收件人: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]
主题: Re: [spring] SRv6 compression

Agree. Picking 1 solution to satisfy our requirements will benefit both the vendors and the operators.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]<mailto:[email-masked]>

From: Henderickx, Wim (Nokia - BE/Antwerp)<mailto:[email-masked]>
Date: 2021-07-27 15:11
To: [email-masked]<mailto:[email-masked]>
Subject: [spring] SRv6 compression
Given the design team accomplished the work on providing requirements and analysis to compress an SRv6 SID list, I would recommend we pick 1 solution similar to what was done in NVO3 (when we discussed GENEVE, GUE, GPE, etc) given this has to be implemented in HW..

I hope we can conclude on this asap and move forward on this topic

-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息，仅限于发送给上面地址中列出
的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、
或散发）本邮件中的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本
邮件！
This e-mail and its attachments contain confidential information from New H3C, which is
intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender
by phone or email immediately and delete it!

---

From: Andrew Alston <[email-masked]>
Date: Tue, 3 Aug 2021 06:12:57 +0000

From my side,

With or without the IETF – I will continue to use CRH and we will continue to make product choices based on it.  CRH is not SRv6 – it is, and we have stated this before, a building block for many things.

In our case – the ability to steer traffic is what drives a lot of what we do, but at the same time – the destination option SID for 16/32 bit which is an arbitrary number we can tie to functional behavior on the server side – is useful.

I also point out that as I said time and again, we could not wait for the IETF, and we have invested significantly in CRH development into various products – and the rejection of CRH by the IETF – by a DT inside SPRING when the document is actually in 6man and is not srv6 – will simply lead to a case of us making large purchasing decisions on the vendors that choose to support what would be a proprietary protocol.  So – rather than contributing to open standards the IETF by choosing one option – an option favored in the DT report – where 5 outta 7 members were actually authors or directly related to CSID – the IETF will be contributing towards what will become a proprietary protocol – either on IANA allocated code points, experimental code points or squatted code points – either way – CRH will continue and we will base our millions a year in purchasing partially on this factor (especially considering the significant amount of development resource that has been put into this – and yes – people will say – why did you put the resources into it – well – CRH has been stable in RFC since before CSID existed – and development cannot stop because of inertia in the IETF)

CRH is functional – in production – and deployed – and caters for use cases simply not covered by CSID – because they have entirely different purposes.  CSID was built to compress SRv6 – CRH is a building block for whatever the hell you want it to be.  To choose one over the other disregards this entirely.

Hence, I say this again, I am supportive of moving multiple options forward here – one within spring, and the other in 6man where it currently resides, to cater for disparate use cases.

Thanks

Andrew

From: spring <[email-masked]> On Behalf Of Qiuyuanxiang
Sent: Monday, August 2, 2021 1:01 PM
To: [email-masked]; Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]
Subject: Re: [spring] SRv6 compression

Agree.

Best Regards,
Yuanxiang Qiu

发件人: spring [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2021年7月31日 16:38
收件人: Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: Re: [spring] SRv6 compression

Best Regards,
Zhenqiang Li

---

From: Vasilenko Eduard <[email-masked]>
Date: Tue, 3 Aug 2021 10:49:30 +0000

Hi all,
The number of people who could write the same as below but substitute “CRH” for “SRv6” is much bigger.
Because the number of SRv6 installations is much bigger.
If they would become proprietary then it would be even more harmful.
It is exactly the essence of this 2y old dilemma: Nobody sees a win-win solution.
Andrew, sorry, but you are not proposing it too. What you are proposing: the minority would win, the majority would lose.

I do not understand why this dispute still exists.
IMHO: it was decided by IETF at the time when SRH has been promoted to RFC 8754.
From that time, carriers chosen RFC believes that it is standard. It would be not fair to say to them now that IETF has changed the mind – RFC 8754 is a dead end.

Carriers that have chosen to implement personal draft (draft-bonica-6man-comp-rtg-hdr) were probably aware that it is a proprietary solution and may stay proprietary forever.

The problem could potentially hang indefinitely.
It would aggravate over time because more and more installations would diverge to incompatible solutions.
We are losing precious time. The more time – the more painful would be the decision.

Dear chairs,
If all augments are presented (I am not positive about it) then maybe voting?
For you to see who is the minority and who is the majority.
Not a good resolution for a technical dispute, but it is not purely technical, right?
Another possibility is to improve “convergence”: not to choose the final solution immediately, but cancel any current one from consideration then discuss only what is left.

PS: It is my personal opinion. I am far from the SRv6 team in Huawei.
Just this problem is so big for the community: 240 personal drafts stuck in the queue (in different WGs) waiting for NG data plane for SR over IPv6.
I could not imagine how big activity would start in the whole IETF after the data plane would be decided.
Eduard
From: spring [mailto:[email-masked]] On Behalf Of Andrew Alston
Sent: Tuesday, August 3, 2021 9:13 AM
To: Qiuyuanxiang <[email-masked]>; [email-masked]; Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]
Subject: Re: [spring] SRv6 compression

From my side,

Thanks

Andrew

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Qiuyuanxiang
Sent: Monday, August 2, 2021 1:01 PM
To: [email-masked]<mailto:[email-masked]>; Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] SRv6 compression

Agree.

Best Regards,
Yuanxiang Qiu

Best Regards,
Zhenqiang Li

---

From: Tony Li <[email-masked]>
Date: Tue, 3 Aug 2021 07:55:22 -0700

Hi all,

I have a bit of a different perspective.

Whatever solution is selected, it will be basically forever. Vendors will cut this into silicon. Quite literally set in stone. It will get deployed and there will be no turning back.
We should pick the best possible solution because we will have to live with it. Forever. That far surpasses the pain of having to replace whatever folks have deployed so far.

Thus, while I wish no one undue pain, the fact is that current deployment, popularity, and market share aren’t compelling reasons to make a selection. 
We need the technically optimal solution.

Please choose carefully. Please choose wisely. Please choose for the very long haul.

Tony

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 3 Aug 2021 17:27:12 +0200

Hi Tony,

I beg to differ on the "forever" part. Which forwarding technology well
maybe other then IPv6 is lasting forever. Take ATM, take FR, take even
MPLS.

It seems that whatever is most widely deployed and supported today is good
choice for squeezing just a bit more SRv6 header. CSID seems the be a clear
winner which market and big vendors decided to adopt.

I am questioning the "forever" part specifically based on control plane
proposal I published to accomplish many similar objectives with no SRH at
all - ultimate SRH compression :) Can't beat that.

Cheers,
Robert.

On Tue, Aug 3, 2021 at 4:55 PM Tony Li <[email-masked]> wrote:

> Whatever solution is selected, it will be basically forever. Vendors will
> cut this into silicon. Quite literally set in stone. It will get deployed
> and there will be no turning back.
> We should pick the best possible solution because we will have to live
> with it. Forever. That far surpasses the pain of having to replace whatever
> folks have deployed so far.
>
> Thus, while I wish no one undue pain, the fact is that current deployment,
> popularity, and market share aren’t compelling reasons to make a selection.
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Tony Li <[email-masked]>
Date: Tue, 3 Aug 2021 08:40:10 -0700

Hi Robert,

> I beg to differ on the "forever" part. Which forwarding technology well maybe other then IPv6 is lasting forever. Take ATM, take FR, take even MPLS. 

How about IPv4?

It’s very true that link layers can fall out of popularity. Yet the hardware lives on.  I have hardware that forwards CLNS, IPX, and Token Ring. I don’t have a use for it, but if I did, it still works.

> I am questioning the "forever" part specifically based on control plane proposal I published to accomplish many similar objectives with no SRH at all - ultimate SRH compression :) Can't beat that. 

Yes, new proposals can obsolete things.  That’s ok, that’s the normal evolution of technology.  

The point that I’m trying to make is that what we’re doing might well take off.  If it does, we will be stuck with it for a very long time indeed.

Steve Deering, the father of IPv6, said it was specifically designed to last only 20 years, becuse we would need to change the network layer that frequently as we learned things.  He said that 30 years ago.

Look at the north American two prong electrical plug. Still widely used, dangerous, and something that we’re stuck with.

Ditto for 120V 60Hz power.

Get it right, because if it does catch on, our great grandchildren will have to live with it.

Tony

---

From: Ron Bonica <[email-masked]>
Date: Tue, 3 Aug 2021 16:19:57 +0000

Tony,

Thanks for these wise words! It is time for the WG to consider the DT output and make an informed decision based on best technical reasoning, not current popularity, deployment or market share.

IMHO, the requirements and analysis documents are not a ringing endorsement for any particular solution. Close examination will reveal that each solution is better suited for some use-cases than others, and that each solution has to stretch to perform in use-cases where it is not well-suited.

Beyond that, not all requirements are equally important. Some are use-case specific. Some may not be interesting at all.

Let us choose carefully!

                                                                                                         Ron

Juniper Business Use Only

-----Original Message-----
From: spring <[email-masked]> On Behalf Of Tony Li
Sent: Tuesday, August 3, 2021 10:55 AM
To: Vasilenko Eduard <[email-masked]>
Cc: [email-masked]; [email-masked]; Andrew Alston <Andrew.Alston=[email-masked]>
Subject: Re: [spring] SRv6 compression

[External Email. Be cautious of content]

Hi all,

Tony

_______________________________________________
spring mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/spring__;!!NEt6yMaO-gk!QI8E3x0zpU-ePOlUDMUg9GDUvHSa12qyO8bjhO9tgJiDnr674jn0qqPseMqRT0BQ$

---

From: Martin Horneffer <[email-masked]>
Date: Wed, 4 Aug 2021 10:07:25 +0200

Hi Tony,

well said.

With this in mind I'd rather ask: Do we really need SID list compression 
at all?

If silicon sooner or later get's tailored for SRv6, can't it be made to 
simply parse big enough headers?

IMHO SRv6 is the one thing that really allows for full flexibility for 
whatever use-cases may come up in the future. Any compression scheme has 
drawbacks.

Best regards, Martin

---

From: Tony Li <[email-masked]>
Date: Wed, 4 Aug 2021 09:17:23 -0700

Hi Martin,

> well said.

Thanks.

> With this in mind I'd rather ask: Do we really need SID list compression at all?

A very fair question. 

> If silicon sooner or later get's tailored for SRv6, can't it be made to simply parse big enough headers?

My understanding of SRv6 is that the SID list is effectively unbounded. It’s hard to grow silicon to keep up with unbounded. :-)

The size of the SID list also affects MTU.  Every byte that you send in a SID list is one byte less of payload that fits.  This is perhaps less of a concern right now, but over time, as more folks move to larger MTUs, this will become more problematic.

The real killer is the cost in bandwidth. Please remember that every byte of SID list costs us because we have to transport it. And there’s no ‘revenue’ associated with this, it’s pure overhead.

I’m old enough to remember another link layer with a high overhead: ATM. Adaptation layers, cells, the whole nine yards. The net overhead was painful. So painful that it was uncompetitive. So uncompetitive that ISPs simply turned it off and replaced it with packet over SONET. And for lower overhead, just straight Ethernet over fiber.

Overhead counts. It comes straight off of the bottom line.  Reducing it is very helpful. Even with a compressed header, SRv6 is asking the industry to pay a pretty penny in overhead and this will go directly against SRv6 adoption, especially by those who are knowledgeable and paying the bills.  So yes compressing the SID list is beneficial for SRv6. It may well be the only real hope that SRv6 has for widespread adoption.

> IMHO SRv6 is the one thing that really allows for full flexibility for whatever use-cases may come up in the future. Any compression scheme has drawbacks.

That would be called the reserve parachute.  :)

Tony

---

From: Martin Horneffer <[email-masked]>
Date: Fri, 6 Aug 2021 10:33:30 +0200

Hi Tony,

> My understanding of SRv6 is that the SID list is effectively unbounded. It’s hard to grow silicon to keep up with unbounded. :-)

true, but also true for any factor x by which you reduce the header size!

In practice I think it's the operator's responsibility to think wisely 
about which header or segments they really need to add, and to account 
for them. And so far I do not see any use case that really would need 
more than a few segments.
Traffic Engineering can achieve almost the full optential with "2-SR" 
optimizations in all real-world topologies we could get hold of. And I 
doubt that service chaining with tens of steps will ever be really useful.

> I’m old enough to remember another link layer with a high overhead: ATM. Adaptation layers, cells, the whole nine yards. The net overhead was painful. So painful that it was uncompetitive. So uncom…

This argument might be valid, but personally I don't share it.

Neither for the current situation.
Even though I am with an operator who actually is the one who pays for 
the overhead. I do not consider a few % overhead as critical for chosing 
a technology. What counts much more is whether a new technology is 
available, solves an acxtually existing problem, and _robustly_ works 
and interoperates.

Nor for the historic assessment of ATM.
I have been there, too. Using STM-4/OC12 with LAN Emulation when 
Gigabit-Ethernet didn't yet exist. In my personal perception, the main 
reasons to let ATM die were:
  - Overall the idea to segment packets for transport didn't seem to pay 
off at all. Is simply wasn't well suited for packet transport. And there 
were no real use cases for services besides IP.
  - AAL5 was a pain and there were no reassembly-chips for speeds higher 
than STM-4.
  - Getting EPD was an issue, but essential for reliable and effective 
IP transport.
  - Stateful LAN Emulation caused a lot of operational problems.

IMHO the limited transport overhead was a negligible problem compared to 
those.

Best rergards,
Martin