Subject: Re: [spring] SRv6 compression

From: Kentaro Ebisawa <[email-masked]>
Date: Mon, 2 Aug 2021 19:28:32 +0900

I really appreciate the hard work accomplished by the DT members.

As a user and implementer, I would also agree that it's preferred to pick a single solution so we can focus the effort to improve and standardize the selected solution.

Thanks,

-- 
Kentaro Ebisawa | Mailing List: <[email-masked]> | Work: <[email-masked]>

On 2021/07/27 16:11, Henderickx, Wim (Nokia - BE/Antwerp) wrote:
>
> Given the design team accomplished the work on providing requirements and analysis to compress an SRv6 SID list, I would recommend we pick 1 solution similar to what was done in NVO3 (when we discussed GENEVE, GUE, GPE, etc) given this has to be implemented in HW..
>
> I hope we can conclude on this asap and move forward on this topic
>
>
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Martin Horneffer <[email-masked]>
Date: Tue, 3 Aug 2021 15:43:08 +0200

Many thanks to the DT for the good and thorough work(1)!

And many thanks to Wim for bringing this thread to the list.

My view as an operator is:
We already have more than enough standards and options. Often enough 
actually introducing new technology in a multi-vendor environment is a 
pain because not all vendors implement the same option at the same time, 
and rather have different understandings of the overall architecture and 
of priorities.
Thus I'd really suggest do proceeed with just a single solution.

If I got it right, one vendor and one operator intend to continue with 
CRH independently of segment routing. That is of course perfectly 
legitimate. From my perspective it's still a pity because we won't pull 
together. And the vendor will - from my perspective - waste development 
energy on technology that will never be useful for my enviroment.

Best regards,
Martin

P.S.:
(1) The requirement I suggested in April, concerning Number Resource 
Management, apparently didn't make it into the documents. But if I get 
it right, the overall reesults wouldn't have changed.

Am 27.07.21 um 09:11 schrieb Henderickx, Wim (Nokia - BE/Antwerp):
> Given the design team accomplished the work on providing requirements 
> and analysis to compress an SRv6 SID list, I would recommend we pick 1 
> solution similar to what was done in NVO3 (when we discussed GENEVE, 
> GUE, GPE, etc) given this has to be implemented in HW..
>

---

From: "Ville Hallivuori" <[email-masked]>
Date: Tue, 03 Aug 2021 16:48:59 +0300

Hello,

I would strongly prefer a single solution. While I am not particular on which of the solutions is selected, DT does make compelling argument for CSID.

I work for a vendor and would hate to have to implement multiple different header compression schemes. Especially if it comes out of limited microcode resources. While IETF has a long history of having two competing solutions (LDP/RSVP-TE, OSPF/ISIS), having competing options in forwarding plane is even less desirable than it is on the control plane.

Thanks for the DT for their excellent work.

BR,
Ville Hallivuori

On Sat, 31 Jul 2021, at 00:06, Voyer, Daniel wrote:
> I agree as well – DT spent a year to come up with an analysis and now have a conclusion. In my view, we are ready to move with a single standard solution. This will unlock the vendors community to adopt an SRv6 compression standard and allow operators to move forward.
>  
> At the end of the analysis document, CSID seems to be the clear winner.
>  
> Thanks
> dan
>  
> *From: *spring <[email-masked]> on behalf of Eduard Metz <[email-masked]>
> *Date: *Friday, July 30, 2021 at 7:24 AM
> *To: *Gyan Mishra <[email-masked]>
> *Cc: *"Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>, "Aissaoui, Mustapha (Nokia - CA/Ottawa)" <[email-masked]>, "[email-masked]" <[email-masked]>, Wim Henderickx <[email-masked]>
> *Subject: *[EXT]Re: [spring] SRv6 compression
>  
> Agree.
> The DT has done a great job in the analysis. 
>  
> Moving forward with a single, standards track solution is preferred/required for interoperable SRv6 implementations.
>  
> cheers,
>   Eduard
>  
>  
> On Tue, Jul 27, 2021 at 6:09 PM Gyan Mishra <[email-masked]> wrote:
>>  
>> For all operators around the world looking at deployment of SRv6 compression and being in a  holding pattern waiting for SRv6 compression to be standardized by the IETF.  
>>  
>> Given the ubiquitous importance of SRV6 compression and MSD issues with long strict SR-TE explicit route object,  it is critical for interoperability for all steering use cases that exist today: enterprise, internet, private, access network - 5G wireless xHaul, mobile core, wireline, MBB, FBB. 
>>  
>> We as a WG need a single standardized solution for SRv6 compression for interoperability to work and all vendors marching to the same sheet of music.  
>>  
>> I agree that the NVO3 - GENEVE is a solid precedence path forward to take and for Spring WG to come to consensus and standardize on one solution and progress the other solutions as informational if implementations already exist.
>>  
>> Kind Regards 
>>  
>> Gyan 
>> Verizon Inc
>>  
>> On Tue, Jul 27, 2021 at 10:12 AM Aissaoui, Mustapha (Nokia - CA/Ottawa) <[email-masked]> wrote:
>>> Same here. We want a single standard method of SID compression to allow the WG to focus on finalizing it and get vendors hardware implementations updated.
>>>  
>>> Regards,
>>> Mustapha.
>>>  
>>> *From:* spring <[email-masked]> *On Behalf Of *Rabadan, Jorge (Nokia - US/Mountain View)
>>> *Sent:* Tuesday, July 27, 2021 4:54 AM
>>> *To:* Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>; [email-masked]
>>> *Subject:* Re: [spring] SRv6 compression
>>>  
>>> I agree with Wim’s statement that the precedent in NVO3 **could** apply here too: pick one solution as Standard’s track RFC, and once it is done, the others might be documented as Informational RFCs if they have implementations.
>>>  
>>> That would help the industry to move forward.
>>>  
>>> Thanks.
>>> Jorge
>>>  
>>>  
>>> *From: *spring <[email-masked]> on behalf of Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]>
>>> *Date: *Tuesday, July 27, 2021 at 9:11 AM
>>> *To: [email-masked] <[email-masked]>
>>> *Subject: *[spring] SRv6 compression
 <http://www.verizon.com/>
>> 
>> *Gyan Mishra*
>> 
>> *Network Solutions Architect *
>> 
>> *Email [email-masked]*
>> 
>> *M 301 502-1347*
>> 
>>

---

From: Tetsuya Murakami <[email-masked]>
Date: Mon, 9 Aug 2021 14:36:09 -0700

I really appreciate the good achievement done by the DT members. 

I also prefer to pick up a single solution. Based on SRCOMP presentation, only CSID can meet all requirements and already there is open source code supporting CSID. Hence, I think it is ready for WG to proceed with the adoption of CSID.

Thanks,
Tetsuya

> On Jul 27, 2021, at 12:11 AM, Henderickx, Wim (Nokia - BE/Antwerp) <[email-masked]> wrote:
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/spring <https://www.ietf.org/mailman/listinfo/spring>