Subject: Re: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

From: "Bao,Guixin" <[email-masked]>
Date: Thu, 14 Oct 2021 09:13:33 +0000

Hi, Dear WG

I support the adoption of this draft.

From the user point of view, I think the CSID proposes a highly efficient way  for SRv6 compression, and it can make the network programming model (RFC8986) be easier to deploy. CSID is just adding the next and replace flavors and still maintain a single SRv6 based data plane.

Thanks.

Guixin Bao
Baidu  Network Chief Architect

发件人: spring <[email-masked]> 代表 James Guichard <[email-masked]>
日期: 2021年10月1日 星期五 22:04
收件人: SPRING WG <[email-masked]>
抄送: "[email-masked]" <[email-masked]>
主题: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

Dear WG:

The chairs would like to express their appreciation for all the responses received to our emails with reference to how the working group wishes to move forward with respect to a solution for SRv6 compression.

The apparent inclination of the working group is to use https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/ as the basis for its compression standardization work. That is part of what this email attempts to confirm.

Because of the above the chairs would like to issue a 2-week WG call for adoption ending October 15th for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/ but with some clear guidelines as follows. By expressing support for adoption of this document you are fully aware of and are acknowledging that:

  1.  The SPRING working group is adopting a document that has multiple SRv6 Endpoint behaviors.
  2.  The document is a “living” document; it may change as it goes through review and analysis by the SPRING working group.
  3.  All open discussion points raised on our mailing list MUST be addressed BEFORE said document is allowed to progress from the working group to publication. A list of these discussion points will be documented in the WG document and maintained by the document editor in conjunction with the chairs.
  4.  If this document is adopted by the working group, the chairs specify as part of the adoption call that the following text describing an open issue be added to the document in the above-described open issues section:
     *   "Given that the working group has said that it wants to standardize one data plane solution, and given that the document contains multiple SRv6 EndPoint behaviors that some WG members have stated are multiple data plane solutions, the working group will address whether this is valid and coherent with its one data plane solution objective.".

Please consider the above guidelines as you decide on whether to support or not this WG adoption. Please express clearly your reasoning for support/non-support as well as any open discussion points you would like addressed should the document be adopted into the working group.

Thanks!

Jim, Bruno & Joel

---

From: "Bao,Guixin" <[email-masked]>
Date: Thu, 14 Oct 2021 08:24:07 +0000

Hi, Dear WG

Thanks.

Guixin Bao

Dear WG:

Thanks!

Jim, Bruno & Joel