Subject: Re: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

From: Laurent Metzger <[email-masked]>
Date: Sat, 9 Oct 2021 18:24:55 +0000

Dear WG

I would like to express support for the WG adoption of the draft https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

I have been using the SRv6 encapsulation in various applied research projects at my university and I have mostly experience with the NEXT-C-SID flavor in projects related to SR-TE and service chaining.

I am happy about the fact that the draft describes multiple SRv6 EndPoint behaviors and adds the Combined NEXT-and-REPLACE-C-SID flavor in order to allow the support of different deployment use cases. It is adding a new flavor, in the same way the Penultimate Segment Pop (PSP), Ultimate Segment Pop (USP), and Ultimate Segment Decapsulation (USD) of the SRH are flavors of the End, End.X, and End.T behaviors in the RFC8986.

I consider that the draft is proposing a single SRv6 based dataplane that is consistent with RFC8986 and I therefore support the WG adoption of the draft.

Best Regards,

Laurent

From: spring <[email-masked]> on behalf of James Guichard <[email-masked]>
Date: Friday, October 1, 2021 at 4:05 PM
To: SPRING WG <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [spring] WG Adoption call for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/
Dear WG:

The chairs would like to express their appreciation for all the responses received to our emails with reference to how the working group wishes to move forward with respect to a solution for SRv6 compression.

The apparent inclination of the working group is to use https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/ as the basis for its compression standardization work. That is part of what this email attempts to confirm.

Because of the above the chairs would like to issue a 2-week WG call for adoption ending October 15th for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/ but with some clear guidelines as follows. By expressing support for adoption of this document you are fully aware of and are acknowledging that:

1.       The SPRING working group is adopting a document that has multiple SRv6 Endpoint behaviors.

2.       The document is a “living” document; it may change as it goes through review and analysis by the SPRING working group.

3.       All open discussion points raised on our mailing list MUST be addressed BEFORE said document is allowed to progress from the working group to publication. A list of these discussion points will be documented in the WG document and maintained by the document editor in conjunction with the chairs.

4.       If this document is adopted by the working group, the chairs specify as part of the adoption call that the following text describing an open issue be added to the document in the above-described open issues section:

·         "Given that the working group has said that it wants to standardize one data plane solution, and given that the document contains multiple SRv6 EndPoint behaviors that some WG members have stated are multiple data plane solutions, the working group will address whether this is valid and coherent with its one data plane solution objective.".

Please consider the above guidelines as you decide on whether to support or not this WG adoption. Please express clearly your reasoning for support/non-support as well as any open discussion points you would like addressed should the document be adopted into the working group.

Thanks!

Jim, Bruno & Joel

---

From: liujh.cc <[email-masked]>
Date: Tue, 12 Oct 2021 22:22:59 +0800

Hi,  All

I’d like to  support the adoption of the draft https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/

For CSID is a efficient solution based on the SRv6 data plane. And it provides a flexible choice of flavors when apply in different kinds of scenarios.

Best Wishes!

Jianhua Liu

http://www.fiberhome.com

Dear WG:

The chairs would like to express their appreciation for all the responses received to our emails with reference to how the working
group wishes to move forward with respect to a solution for SRv6 compression.

The apparent inclination of the working group is to use https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/
as the basis for its compression standardization work. That is part of what this email attempts to confirm.

Because of the above the chairs would like to issue a 2-week WG call for adoption ending October 15th for https://datatracker.ietf.org/doc/draft-filsfilscheng-spring-srv6-srh-compression/
but with some clear guidelines as follows. By expressing support for adoption of this document you are fully aware of and are acknowledging that:

3.       All open discussion points raised on our mailing list MUST be addressed BEFORE said document is allowed to progress from
the working group to publication. A list of these discussion points will be documented in the WG document and maintained by the document editor in conjunction with the chairs.

4.       If this document is adopted by the working group, the chairs specify as part of the adoption call that the following text
describing an open issue be added to the document in the above-described open issues section:

·         "Given that the working group has said that it wants to standardize one data plane solution, and given that the document
contains multiple SRv6 EndPoint behaviors that some WG members have stated are multiple data plane solutions, the working group will address whether this is valid and coherent with its one data plane solution objective.".

Please consider the above guidelines as you decide on whether to support or not this WG adoption. Please express clearly your reasoning
for support/non-support as well as any open discussion points you would like addressed should the document be adopted into the working group.

Thanks!

Jim, Bruno & Joel