Subject: [spring] I-D Action: draft-ietf-spring-segment-routing-policy-15.txt

From: [email-masked]
Date: Wed, 26 Jan 2022 07:10:50 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Source Packet Routing in Networking WG of the IETF.

        Title           : Segment Routing Policy Architecture
        Authors         : Clarence Filsfils
                          Ketan Talaulikar
                          Daniel Voyer
                          Alex Bogdanov
                          Paul Mattes
	Filename        : draft-ietf-spring-segment-routing-policy-15.txt
	Pages           : 39
	Date            : 2022-01-26

Abstract:
   Segment Routing (SR) allows a headend node to steer a packet flow
   along any path.  Intermediate per-path states are eliminated thanks
   to source routing.  The headend node steers a flow into an SR Policy.
   The packets steered into an SR Policy carry an ordered list of
   segments associated with that SR Policy.  This document details the
   concepts of SR Policy and steering into an SR Policy.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-spring-segment-routing-policy/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-spring-segment-routing-policy-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-segment-routing-policy-15

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Nandan Saha <[email-masked]>
Date: Wed, 26 Jan 2022 09:52:06 -0800

Hi folks,
 revision 15 has:
<quote>
  The color is an unsigned *__non-zero__* 32-bit numerical
</quote>

This seems like a backwards incompatible change since all this while 0 was
a valid color.
Has this been discussed on the list?
Also, are we going to make changes to
draft-ietf-idr-segment-routing-te-policy to define the handling for NLRIs
that have color set to 0?

Thanks,
Nandan

On Wed, Jan 26, 2022 at 7:11 AM <[email-masked]> wrote:

> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring
>

---

From: Ketan Talaulikar <[email-masked]>
Date: Thu, 27 Jan 2022 10:01:08 +0530

Hi Nandan,

The comment for clarification on zero value came during the Last-Call
review:
https://mailarchive.ietf.org/arch/msg/spring/d7XCsWsbiTyE588nHNrKhl4woYQ/

There have been previous discussions/suggestions on the list for the color
value 0. I am not able to readily find those threads.

We can revert this change to include the value 0 as a valid color if there
are concerns. Please let us know.

The draft-ietf-idr-segment-routing-te-policy points to the SPRING draft for
validation so there would not need to be any changes in there.

Thanks,
Ketan

---

From: Nandan Saha <[email-masked]>
Date: Fri, 28 Jan 2022 08:59:40 -0800

Thanks Ketan. It should be fine to keep the latest text to disallow 0.

On Wed, Jan 26, 2022 at 8:31 PM Ketan Talaulikar <[email-masked]>
wrote:

> The draft-ietf-idr-segment-routing-te-policy points to the SPRING draft
> for validation so there would not need to be any changes in there.
>
> Thanks,
> Ketan
>
>
>> This seems like a backwards incompatible change since all this while 0
>> was a valid color.