Subject: [spring] I-D Action: draft-ietf-spring-stamp-srpm-03.txt

From: [email-masked]
Date: Tue, 01 Feb 2022 16:19:10 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Source Packet Routing in Networking WG of the IETF.

        Title           : Performance Measurement Using Simple TWAMP (STAMP) for Segment Routing Networks
        Authors         : Rakesh Gandhi
                          Clarence Filsfils
                          Daniel Voyer
                          Mach(Guoyi) Chen
                          Bart Janssens
                          Richard Foote
	Filename        : draft-ietf-spring-stamp-srpm-03.txt
	Pages           : 24
	Date            : 2022-02-01

Abstract:
   Segment Routing (SR) leverages the source routing paradigm.  SR is
   applicable to both Multiprotocol Label Switching (SR-MPLS) and IPv6
   (SRv6) data planes.  This document describes procedures for
   Performance Measurement in SR networks using the mechanisms defined
   in RFC 8762 (Simple Two-Way Active Measurement Protocol (STAMP)) and
   its optional extensions defined in RFC 8972 and further augmented in
   draft-ietf-ippm-stamp-srpm.  The procedure described is applicable to
   SR-MPLS and SRv6 data planes and is used for both links and end-to-
   end SR paths including SR Policies.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-spring-stamp-srpm/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-spring-stamp-srpm-03.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-stamp-srpm-03

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Haoyu Song <[email-masked]>
Date: Wed, 2 Feb 2022 19:32:59 +0000

Hi Rakesh and the other authors,

Since this draft also propose to use UDP for active measurement in SRv6, I'd like to suggest that a flag bit in SRH is used to indicate that. The reasons are twofold: (1) routers may only look at L3 header for forwarding without examining the L4 header. So if a test packet can only be identified by UDP port, it may be missed; (2) it's possible to use the same mechanism to support other kinds of active measurements (e.g., HBH IOAM as proposed in our draft https://datatracker.ietf.org/doc/html/draft-song-spring-siam-02. 

Best,
Haoyu

-----Original Message-----
From: spring <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, February 1, 2022 4:19 PM
To: [email-masked]
Cc: [email-masked]
Subject: [spring] I-D Action: draft-ietf-spring-stamp-srpm-03.txt

Abstract:

The IETF datatracker status page for this draft is:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-spring-stamp-srpm%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C9e9ebc01c8c942755a2d08d9e5e1c397%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637793580085471585%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=uRFB7p9GlMVjo%2Ft9FOVR7Gg49Ah1Y79CbhzLWHPDFH0%3D&amp;reserved=0

There is also an HTML version available at:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-spring-stamp-srpm-03.html&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C9e9ebc01c8c942755a2d08d9e5e1c397%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637793580085471585%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=0m4WNO9jMptJw14nENpOaftEzNdQDqHUbRr5YJMaX8w%3D&amp;reserved=0

A diff from the previous version is available at:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-spring-stamp-srpm-03&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C9e9ebc01c8c942755a2d08d9e5e1c397%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637793580085471585%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=4qPBxUc7x44ZFWzb3kM7tIVrYODE8iMw8xQD1eMC4zw%3D&amp;reserved=0

_______________________________________________
spring mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspring&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C9e9ebc01c8c942755a2d08d9e5e1c397%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637793580085471585%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=laC%2B5pQbD7tnmE34VUJRR0s19LoPnEipFQbPe0PwfqE%3D&amp;reserved=0