Subject: [spring] Query : draft-filsfils-spring-net-pgm-extension-srv6-usid-12

From: Salih K A <[email-masked]>
Date: Thu, 7 Apr 2022 07:20:59 +0000

Can you please clarify whether Function Length (FL) will be 0 or 16 for the below uN use-case ?

>> Assume we have a uN advertised from Node N
   *  Value = 2001:db8:0:0N00::

   *  Behavior = uN

   *  Structure =

      -  LBL = 48

      -  LNL = 16

      -  FL = 0

      -  AL = 64

Now say we need 2 flavors for that uN; one with just USD flavor and another with just USP flavor.

Will that be 2001:db8:0:0N00:0000::/80 for USD and 2001:db8:0:0N00:0001::/80 for USP? In these 2 SID advertisements the FL will be 16?
or do we need separate uN from same node for different flavors (all with implicit :0000::) with FL 0?

Juniper Business Use Only

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Tue, 12 Apr 2022 17:10:38 +0000

Salih,

Inline with PC.

Cheers,
Pablo.

From: Salih K A <[email-masked]>
Sent: jueves, 7 de abril de 2022 9:21
To: SPRING WG <[email-masked]>
Cc: Darren Dukes (ddukes) <ddukes=[email-masked]>; Pablo Camarillo (pcamaril) <[email-masked]>
Subject: Query : draft-filsfils-spring-net-pgm-extension-srv6-usid-12

Can you please clarify whether Function Length (FL) will be 0 or 16 for the below uN use-case ?
[PC] FL=0 as explained later

   *  Behavior = uN

   *  Structure =

      -  LBL = 48

      -  LNL = 16

      -  FL = 0

      -  AL = 64

Will that be 2001:db8:0:0N00:0000::/80 for USD and 2001:db8:0:0N00:0001::/80 for USP? In these 2 SID advertisements the FL will be 16?
or do we need separate uN from same node for different flavors (all with implicit :0000::) with FL 0?
[PC] The latter, separate uN with FL=0. Although in practice you will only have a single uN per algo supported by the node, with the combination of flavors that is supported on that device.