Subject: Re: [spring] NEXT-ONLY-CSID in draft-filsfils-spring-net-pgm-extension-srv6-usid-12

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Thu, 7 Apr 2022 13:52:42 +0000

Hi Trevor,

This refers to a node that only processes the ::/64 (shift-and-lookup) of 4.1.1.

Cheers,
Pablo.

From: spring <[email-masked]> On Behalf Of Trevor Mendez
Sent: viernes, 25 de marzo de 2022 19:20
To: [email-masked]
Subject: [spring] NEXT-ONLY-CSID in draft-filsfils-spring-net-pgm-extension-srv6-usid-12

Hi all,

What is the meaning of NEXT-ONLY-CSID?  It isn't clear to me what the difference is between 42 and 43 below?

   +=======+========+======================================+===========+

   | Value |  Hex   |          Endpoint behavior           | Reference |

   +=======+========+======================================+===========+

   | 42    | 0x002A |       End with NEXT-ONLY-CSID        | [This.ID] |

   +-------+--------+--------------------------------------+-----------+

   | 43    | 0x002B |          End with NEXT-CSID          | [This.ID] |

   +-------+--------+--------------------------------------+-----------+

(Looks like a similar question was asked before here<https://mailarchive.ietf.org/arch/msg/spring/CAhP45_cgEQ2_1cWLFBdm8llJYA/>, but I didn't see an answer.)

Thanks,
Trevor

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 7 Apr 2022 13:09:20 -0400

(speaking as a WG member trying to understand this exchange.)

Having two codes, one for NEXT-ONLY-CSID and one for NEXT-CSID seems odd.
In terms of what the node does with packets addressed to SIDs with the 
given behavior, they seem to be the same.
So if I understand properly, the different is an implication about the 
existence of SIDs for this node with other behaviors?  But wouldn't 
receivers determine such behavior being available from the 
advertisements of those behaviors?  If there are no other advertised 
(compressed?) behaviors, wouldn't that tell you everything you need to 
know.  If there are such other advertiements, but 42 (NEXT-ONLY-CSID) is 
advertised what would that mean?  And conversely, if there are no other 
advertised relevant behaviors, what would it mean to advertise 43 
(NEXT-CSID)?

Yours,
Joel

On 4/7/2022 9:52 AM, Pablo Camarillo (pcamaril) wrote:
> *From:*spring <[email-masked]> *On Behalf Of *Trevor Mendez
> *Sent:* viernes, 25 de marzo de 2022 19:20
> *To:* [email-masked]
> *Subject:* [spring] NEXT-ONLY-CSID in 
> draft-filsfils-spring-net-pgm-extension-srv6-usid-12
> 
> Hi all,
> 
> (Looks like a similar question was asked before here 
> <https://mailarchive.ietf.org/arch/msg/spring/CAhP45_cgEQ2_1cWLFBdm8llJYA/>, 
> but I didn't see an answer.)
> 
> 
> Thanks,
> Trevor
> 
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Tue, 12 Apr 2022 17:10:24 +0000

Hi Joel,
Inline with PC.
Cheers,
Pablo.

-----Original Message-----
From: Joel M. Halpern <[email-masked]> 
Sent: jueves, 7 de abril de 2022 19:09
To: Pablo Camarillo (pcamaril) <[email-masked]>; Trevor Mendez <[email-masked]>; [email-masked]
Subject: Re: [spring] NEXT-ONLY-CSID in draft-filsfils-spring-net-pgm-extension-srv6-usid-12

Having two codes, one for NEXT-ONLY-CSID and one for NEXT-CSID seems odd.
[PC] Those are two different packet processing, and hence two different SRv6 Endpoint Behavior values from IANA.
In terms of what the node does with packets addressed to SIDs with the given behavior, they seem to be the same.
[PC] No they are not. NEXT-ONLY only processes the ::/64 of the 4.1.1; whereas NEXT-CSID processes both. Perhaps this can be clarified in further revisions.
So if I understand properly, the different is an implication about the existence of SIDs for this node with other behaviors?  But wouldn't receivers determine such behavior being available from the advertisements of those behaviors?
[PC] Not sure I follow these two, but I don't think its correct.
  If there are no other advertised (compressed?) behaviors, wouldn't that tell you everything you need to know.  
If there are such other advertiements, but 42 (NEXT-ONLY-CSID) is advertised what would that mean?  
[PC] That you are only capable of doing the shifting operation.
And conversely, if there are no other advertised relevant behaviors, what would it mean to advertise 43 (NEXT-CSID)?
[PC] That you are capable of processing the whole 4.1.1. We will clarify this in future revisions.

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 12 Apr 2022 13:21:40 -0400

Thanks.  I think I now understand what the "only" is trying to say.

To make sure, if a node advertises a SID with "ONLY", then that 
compressed SID can not be the last SID in a container, as the node is 
saying that it is not able to do the rest of the required work.

An interesting form of conformance, but I will leave that to the rest of 
the WG to discuss.

Yours,
Joel