Subject: [Srcomp] comments on REQ-8-26-HET-SID-LIST

From: Ron Bonica <[email-masked]>
Date: Tue, 29 Sep 2020 20:39:25 +0000

Folk,

The rationale for this requirement are dubious.

You are proposing that SR ingress nodes must support the following SR encoding:

  *   Legacy SRv6
  *   Compressed
  *   Hybrids containing Legacy encoding features and compressed encoding features

The rational are:

  *   That this supports one particular transition strategies
  *   That some nodes may not require compression

Other, more frequently deployed transition strategies are available. And what is the motivation for using classing encoding when compression is available?

                                                                       Ron

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 30 Sep 2020 05:33:14 +0000

Hi Ron

The metric states that a proposal permits the use of compressed and non-compressed segments within a segment list.

"A solution that supports compressed and non-compressed segments, and allows their combination within a segment list meets this requirement."

The benefits to deployment seem clear.  Some nodes support the compression solution while others do not yet, the service is incrementally upgradable.

Darren
________________________________
From: Srcomp <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Sent: Tuesday, September 29, 2020 4:39 PM
To: srcomp <[email-masked]>
Subject: [Srcomp] comments on REQ-8-26-HET-SID-LIST

Folk,

  *   Legacy SRv6
  *   Compressed

The rational are:

                                                                       Ron

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 30 Sep 2020 07:41:27 +0000

To me, I think the benefits are clear.

But in the real deployment, we should avoid the combination in order to simplify the deployment.

Therefore, it is a bonus instead of a basic requirement I think. It is good to provide this capability.

Best,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Darren Dukes (ddukes)
Sent: Wednesday, September 30, 2020 1:33 PM
To: Ron Bonica <rbonica=[email-masked]>; srcomp <[email-masked]>
Subject: Re: [Srcomp] comments on REQ-8-26-HET-SID-LIST

Hi Ron

Darren
________________________________
From: Srcomp <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Sent: Tuesday, September 29, 2020 4:39 PM
To: srcomp <[email-masked]<mailto:[email-masked]>>
Subject: [Srcomp] comments on REQ-8-26-HET-SID-LIST

Folk,

  *   Legacy SRv6
  *   Compressed

The rational are:

                                                                       Ron