Subject: [Srcomp] Question Regarding REQ-7-29-Explicit-SID-Length

From: Ron Bonica <[email-masked]>
Date: Tue, 8 Sep 2020 15:40:20 +0000

Pengshaofu,

In  Regarding REQ-7-29-Explicit-SID-Length, You say:

"The compression mechanism must provide explicit information of the length of the compressed SID in the IPv6 packet".

Does this mean that the packet must include a field that indicates the SID length?

                                                                                               Ron

Juniper Business Use Only

---

From: <[email-masked]>
Date: Wed, 9 Sep 2020 09:42:41 +0800 (CST)

Ron,

Yes, that's exactly my point of view. However, the field may not be a direct value of SID length, may be an indirect indication.

A main scenerio is to analysis packet depending on packet itself, without the help of any control information. The tradition supporting packet parsing cannot be discarded.

Regards,

PSF

原始邮件

发件人：RonBonica <rbonica=[email-masked]>
收件人：srcomp <[email-masked]>;
日 期 ：2020年09月08日 23:47
主 题 ：[Srcomp] Question Regarding REQ-7-29-Explicit-SID-Length

-- 
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

Pengshaofu,

 

“The compression mechanism must provide explicit information of the length of the compressed SID in the IPv6 packet”.

 

                                                                                               Ron