Subject: Re: [Srcomp] csid scale

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Sun, 2 May 2021 18:02:06 +0000

Hi Ron,

As discussed in Wednesdays call:

In the network 1--2--3--4--5
The ask is a strict source routed path from 1 to 5 using adjacency SIDs.
adj1-2 is the adjacency SID at 1 to 2 via the interface connecting node 1 and 2.
The strict source-routed path from 1-5 results in the segment list <adj1-2,adj2-3,adj3-4,adj4-5>

Each node instantiates adjacency SIDs from its LIB (65408-65535 = ff80-ffff) such that they all use ff80 for adjacencies to their right (eg. adj1-2, adj2-3, etc).

With SRv6 block of b:b:b::/48, node 1 sends an IPv6 encapsulated packet toward 2 via adj1-2 with a destination address of:
    b:b:b:ff80:ff80:ff80::

Darren

On 2021-04-28, 1:08 PM, "Ron Bonica" <rbonica=[email-masked]> wrote:

Darren,

What would the carrier SID look like in Slide 9  of the attached deck, where we three adjacency SIDs, terminating on Nodes 3, 4 and 5?

From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Wednesday, April 28, 2021 6:53 AM
To: Ron Bonica <rbonica=[email-masked]>; 'srcomp' <[email-masked]>
Subject: Re: [Srcomp] csid scale

[External Email. Be cautious of content]

Hi Ron, I’m afraid you’re missing the point of the LIB.  Could you please re-read section 5 and 5.2 of the CSID draft and consider that text when reading what follows.

What you describe below is adjacency SIDs as global CSIDs in the GIB.
However, the specification recommends 16bit adjacency CSIDs as local CSIDs allocated from a LIB.

Using adjacency and VPN SIDs from the LIB an administrator could choose to define, for example, 128 LIB entries leaving the rest for GIB, partitioning their 16bit CSID space as:
LIB: 65408-65535
GIB: 0-65469

Darren

On 2021-04-26, 1:57 PM, "Ron Bonica" <rbonica=[email-masked]<mailto:rbonica=[email-masked]>> wrote:

Darren,

Where does the extra bit come from? Please tell me where the following analysis gets it wrong:

Because the domain contains 1024 nodes, you must dedicated 10 bits to the NF

Each node advertises a /58 (i.e., 48 bit locator-block plus 10 bits NF)

Because each node has 65 links that you might want to access with END.X, you must dedicate 7 bits to the FUNCTION part of the CSID

2^^7> 65 > 2^^6

How does the GIB/LIB distinction change any of this?

                                                                               Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <ddukes=[email-masked]<mailto:ddukes=[email-masked]>>
Sent: Monday, April 26, 2021 10:37 AM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; 'srcomp' <[email-masked]<mailto:[email-masked]>>
Subject: Re: csid scale

[External Email. Be cautious of content]

Hi Ron, please see inline

On 2021-04-22, 2:02 PM, "Srcomp" <[email-masked]<mailto:[email-masked]>> wrote:

Darren,

I know that we have talked about this before, but I can’t find your response in the mountain of emails that we have exchanged.

Assume that an SR domain lives in a single IS-IS level. It contains 1024 (i.e., 2^10 ) routers. Each router instantiates one prefix SID and 65 (i.e., (2^6) +1 ) adjacency SIDs. Can that network use CSID-16 encoding.
[DD] Yes

If so, consider an SR path that contains 4 adjacency SIDs and a VPN SID. What does the encoding look like. What information is encoded where?
[DD] This segment list consisting of five segments can be encoded at an SR source node as five 16bit CSIDs from the LIB;  One CSID per adjacency segment and one CSID for the VPN SID.
[DD] With an SRv6 locator-block of 48bits, this 5 CSID segment list could be encoded in a single CSID container.

Darren

                                                                                                                                                                   Ron

Juniper Business Use Only

---

From: Ron Bonica <[email-masked]>
Date: Mon, 3 May 2021 22:24:03 +0000

Darren,

I get it. Every node in the domain can instantiate a SID with the address b:b:b:ff80::0. So, in this scenario, where each adjacency segment endpoint is directly connected to the next adjacency segment endpoint, you can get the desired forwarding behavior with  <adj1-2,adj2-3,adj3-4,adj4-5> represented as  b:b:b:ff80:ff80:ff80::.

However, if each adjacency segment endpoint were not directly connected to the next (i.e., a non-SR node is between them),  you would need <adj1-2, pre2, adj2-3,  pre3, adj3-4. Pre4, adj4-5, pre5> to get the desired forwarding behavior. This could be represented by the following sequence of carrier SIDs:

  *   b:b:b:ff80:3:ff80:4:ff80
  *   b:b:b:5::0

Do I have this right?

                                                          Ron

Juniper Business Use Only
From: Darren Dukes (ddukes) <[email-masked]>
Sent: Sunday, May 2, 2021 2:02 PM
To: Ron Bonica <[email-masked]>; 'srcomp' <[email-masked]>
Subject: Re: csid scale

Hi Ron,

Darren

On 2021-04-28, 1:08 PM, "Ron Bonica" <rbonica=[email-masked]<mailto:rbonica=[email-masked]>> wrote:

Darren,

From: Srcomp <[email-masked]<mailto:[email-masked]>> On Behalf Of Darren Dukes (ddukes)
Sent: Wednesday, April 28, 2021 6:53 AM
To: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>; 'srcomp' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Srcomp] csid scale

Hi Ron, I'm afraid you're missing the point of the LIB.  Could you please re-read section 5 and 5.2 of the CSID draft and consider that text when reading what follows.

Darren

Darren,

2^^7> 65 > 2^^6

                                                                               Ron

Darren,

I know that we have talked about this before, but I can't find your response in the mountain of emails that we have exchanged.

Darren

                                                                                                                                                                   Ron

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Tue, 4 May 2021 00:27:44 +0000

Hi Ron, see inline.

On 2021-05-03, 6:24 PM, “Ron Bonica” <[email-masked]> wrote:

Darren,

[DD] In the example you now describe, the 16-bit CSID encoding would require a prefix segment follows the adjacency segment to reach the next non-adjacent segment endpoint since adjacency segments are assigned from the LIB.

-          b:b:b:ff80:3:ff80:4:ff80

-          b:b:b:5::0

Do I have this right?

                                                          Ron

Hi Ron,

Darren

Darren,

Darren

Darren,

2^^7> 65 > 2^^6

                                                                               Ron

Darren,

Darren

                                                                                                                                                                   Ron