Subject: [Srcomp] Section 3.4.1 C-SID and VSID RE: Draft meeting minutes: 5/6/2021

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 7 May 2021 09:44:23 +0000

-          3.4.1
o   Add 2-3 sentences on how we got to "yes" (Darren: CSID, Cheng:VSID, PSF: UIDSR, Ron:CRH

CSID: A SID with Replace-CSID/COC flavor can be encoded as 32-bit compressed SID in SRH, and a SID with next-CSID flavor can be encoded as a 16-bit compressed SID in SRH. The replace-CSID flavor SIDs and next-CISD flavor SIDs can be encoded in different C-SID carriers so that they can be encoded in a single SRH encapsulation.

VSID: Only one type of vSID with specified length can be encoded in an SRH encapsulation. Encoding different length of vSIDs in an SRH encapsulation will cause SID location error since SL is interpreted as a single length in an SRH encapsulation.

Thanks,
Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Thursday, May 6, 2021 11:07 PM
To: 'srcomp' <[email-masked]>
Subject: [Srcomp] Draft meeting minutes: 5/6/2021

Attendees:

Weiqiang, Darren, Ron, Wim, Cheng

RESOLVED
--------------

-          The group will meet twice weekly, at 1300 UTC on Wednesdays and Fridays
-          The Wednesday meeting will be dedicated to consensus calls for each section of the analysis document
-          The Friday meeting will be dedicated to preparing sections that have been  analyzed on the mailing list for a consensus call
-          All participants will contribute to analysis on the mailing list
-          The following sections have passed consensus call
o   3.2.3
o   3.2.4
o   4.1
o   5.1
o   5.2

ACTION ITEMS
============
-          Section 3.2.2
o   Cheng Li to send email regarding the note and VSID
o   PSF to send email regarding the node and UIDSR
o   Weiqiang to send email regarding the conclusion statement
-          3.3.1
o   All: Formulate text on note
-          3.4.1
o   Add 2-3 sentences on how we got to "yes" (Darren: CSID, Cheng:VSID, PSF: UIDSR, Ron:CRH

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 7 May 2021 11:45:52 +0000

Hi Cheng, I think this text is more accurate for CSID and VSID, we can discuss more today.

CSID: A SID with Replace-CSID/COC flavor can be encoded as 32-bit compressed SID in SRH, and a SID with next-CSID flavor can be encoded as a 16-bit compressed SID in SRH. CSIDs of different lengths can be intermixed within a segment list to support larger or smaller CSIDs as required at the segment endpoint.

VSID: VSID is defined with 16 and 32bit lengths.  One VSID length can be used within one segment list, but VSID supports combining VSIDs at a segment endpoint to support larger VSIDs as required at the segment endpoint.

Darren

________________________________
From: Srcomp <[email-masked]> on behalf of Chengli (Cheng Li) <[email-masked]>
Sent: Friday, May 7, 2021 5:44 AM
To: Ron Bonica; 'srcomp'
Cc: Lizhenbin
Subject: [Srcomp] Section 3.4.1 C-SID and VSID RE: Draft meeting minutes: 5/6/2021

-          3.4.1
o   Add 2-3 sentences on how we got to “yes” (Darren: CSID, Cheng:VSID, PSF: UIDSR, Ron:CRH

Thanks,
Cheng

Attendees:

RESOLVED
--------------

ACTION ITEMS
============
-          Section 3.2.2
o   Add 2-3 sentences on how we got to “yes” (Darren: CSID, Cheng:VSID, PSF: UIDSR, Ron:CRH