Subject: [Srcomp] CRH Analysis On Lossless compression

From: Ron Bonica <[email-masked]>
Date: Mon, 24 May 2021 20:21:16 +0000

F.SID:                    CRH
F.SCOPE:              CRH
F.PFX:                   CRH
F.ADJ:                   CRH (See version 25)
F.BIND:                 CRH (See version 26, may be posted by Wednesday)
F.Peer:                 (Is this redundant with F.BGP?)
F.SVC:                   CRH
F.ALG:                   draft-ietf-lsr-ip-flex-algo
F.TI-LFA:              draft-ietf-rtgwg-segment-routing-ti-lfa
F.SEC:                    CRH
F.IGP:                    draft-bonica-lsr-crh-isis-extensions
F.BGP:                  draft-ssangli-idr-bgp-vpn-srv6-plus when TPF is used or
                                draft-ietf-bess-srv6-services when VPN instruction is encoded
in a classic SRv6 SID
F.POL:                   draft-ietf-spring-segment-routing-policy (1)
F.BLSL                   Specification Required
F.SFC:                    CRH
F.PING:                CRH

  1.  draft-ietf-spring-segment-routing-policy is, for the most part, agnostic between SR-MPLS and SRv6. However, it does mention SRv6 SIDs and not C-SIDs or uSIDs. So, it will need to be update for whatever compression mechanism the WG chooses.

Juniper Business Use Only

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 26 May 2021 12:38:01 +0000

The note on SR Policy and non-crh proposals is not correct. Other proposals use SRv6 SIDs.

On 2021-05-24, 4:21 PM, "Srcomp" <[email-masked]> wrote:

F.SID:                    CRH
F.SCOPE:              CRH
F.PFX:                   CRH

(1)    draft-ietf-spring-segment-routing-policy is, for the most part, agnostic between SR-MPLS and SRv6. However, it does mention SRv6 SIDs and not C-SIDs or uSIDs. So, it will need to be update for whatever compression mechanism the WG chooses.