Subject: [Srcomp] Section 3.3.2 Non-routing information

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 21 May 2021 11:15:48 +0000

CSID preserves non-routing information, i.e. it does not cause loss of non-routing information.

I wonder if proposals that require a binding SID for heterogeneous segment lists preserve this information for the portion of the path requiring the new encapsulation?

3.3.2.  Preservation of non-routing information
   The compression mechanism MUST NOT cause the loss of non-routing
   information when delivering a packet from the SR ingress node to the
   egress/penultimate SR node
   +-----------------------------------+----------+-----+------+-------+
   |                                   | CSID     | CRH | VSID | UIDSR |
   +-----------------------------------+----------+-----+------+-------+
   | Preserves Non-Routing Information | Complies |     |      |       |
   +-----------------------------------+----------+-----+------+-------+

Darren

---

From: Ron Bonica <[email-masked]>
Date: Fri, 21 May 2021 20:06:49 +0000

Darren,

The CRH complies and does not require a binding SID. I think that the same is true of VSID and UIDSR.

Did we agree to call consensus on this one next week. If not, we should.

                                                                                                     Ron

Juniper Business Use Only
From: Srcomp <[email-masked]> On Behalf Of Darren Dukes (ddukes)
Sent: Friday, May 21, 2021 7:16 AM
To: [email-masked]
Subject: [Srcomp] Section 3.3.2 Non-routing information

[External Email. Be cautious of content]

Darren

---

From: <[email-masked]>
Date: Sat, 22 May 2021 10:30:00 +0800 (CST)

Hi Team,

For this action, UIDSR also preserves non-routing information.

Regards,

PSF

原始邮件

发件人：DarrenDukes(ddukes)
收件人：[email-masked];
日 期 ：2021年05月21日 19:16
主 题 ：[Srcomp] Section 3.3.2 Non-routing information

--  
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

 

 

 

Darren

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Mon, 24 May 2021 06:49:43 +0000

I guess I have replied all the analysis of C-SID and V-SID in one of my previous email.
But it is OK to repeat once more.

   | Preserves Non-Routing Information | Complies |     |Complies|       |

Cheng

From: Srcomp [mailto:[email-masked]] On Behalf Of Darren Dukes (ddukes)
Sent: Friday, May 21, 2021 7:16 PM
To: [email-masked]
Subject: [Srcomp] Section 3.3.2 Non-routing information

Darren