Subject: [Srcomp] Section 3.4.1 Compression Levels

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 12 May 2021 11:20:59 +0000

Text was proposed in the ppt presentation on Friday, I updated the CSID text and we still need ShaoFu’s help on the UIDSR text.

Proposed text:
CRH: The CRH can encode transit segments in 16-bit or 32-bit SIDs. It can encode VPN SIDs in the CRH (16-or 32-bits), the TPF (32-bits).

CSID: A REPLACE-C-SID flavor SID can be encoded in 32-bits in SRH, REPLACE-C-SID flavor SID can be encoded in 16-bits in the SRH. CSIDs of differing lengths can be intermixed within a segment list.

VSID: VSID is defined with 16-bit and 32-bit lengths.  One VSID length can be used within one segment list, but VSID supports combining VSIDs at a segment endpoint to support larger VSIDs as required at the segment endpoint.

UIDSR: UIDSR defines 16-bit and 32-bit compressed SID lengths.  A segment list consists of one size, with a flag in the SRH identifying the current encoding.  SID of different lengths ... ( Need ShaoFu’s help here)

---

From: <[email-masked]>
Date: Thu, 13 May 2021 11:16:14 +0800 (CST)

Hi Team,

The following is reply of UIDSR:

UIDSR: UIDSR defines 16-bit and 32-bit compressed SID lengths.  A segment list consists of one size, with a flag in the SRH identifying the current encoding, and UET-flavor of current SID indicates the length of next SID in SRH.  SID of different lengths can be intermixed within a segment list.

Regards,

PSF

原始邮件

发件人：DarrenDukes(ddukes)
收件人：[email-masked];
日 期 ：2021年05月12日 19:21
主 题 ：[Srcomp] Section 3.4.1 Compression Levels

--  
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

 

Proposed text: