Subject: [Srcomp] Notes on Section 3.3.1

From: Ron Bonica <[email-masked]>
Date: Thu, 6 May 2021 19:52:44 +0000

Note: Any path that can be represented by uncompressed SRv6 can also be represented by any of the proposed compression mechanisms. However, for some SR paths, a compression mechanism may require additional segments or additional state in transit routers. See Appendix B for details.

Conclusion:  All proposals satisfy this requirement, because any path that can be represented by uncompressed SRv6 can also be represented by any of the proposed compression mechanisms.

Appendix B:

This appendix provides examples of SR paths that  can be represented by uncompressed SRv6 or any of the proposed compression mechanisms. However, extra state or segments are required when representing the path in compressed format.

B.1 Transit Nodes Following Adjacency Segments

Consider the following network topology:

                          Network A
                        /          |            \
     S  ----  P                 | --------  D1
                        \             -------- DN
                           \          |         /
                            Network B

  *   The SR domain contains Node S, Node P, and a set of destination nodes (D1 through DN)
  *   S is connected to P
  *   P is connected to Network A and to Network B. Neither of these networks are SR-capable.
  *   The destination nodes  connect to both Network A and Network B

S needs to reach each destination node through two SR paths. One SR path traverses:

  *   A prefix segment that is instantiated on node S and takes the packet to Node P
  *   An adjacency segment that is instantiated on Node P and takes the packet through Network A to a destination node

The other SR path traverses:

  *   A prefix segment that is instantiated on node S and takes the packet to Node P
  *   An adjacency segment that is instantiated on Node P and takes the packet through Network B to a destination node

Uncompressed SRv6 can achieve this goal by:

  *   Using two segments, one ending at P and the other at the destination
  *   Instantiating 2 adjacency SIDs on Node P (one per outbound interface).

CRH compressed SRv6 can achieve this goal by:

  *   Using two segments, one ending at P and the other at the destination
  *   Instantiating 2*N adjacency SIDs on Node P (one per outbound interface per destination).

Alternatively, CRH compressed SRv6  by:

  *   Using three segments, two ending at P and the other at the destination
  *   Instantiating 2 adjacency SIDs on Node P (one per outbound interface per destination).

In this case, the first segment on P would change the IPv6 destination address but not forward the packet. The second segment would forward the packet, but not change the destination address.

B.2 Transit Nodes Preceding Local Adjacency Segments

Consider the following network topology:

 S---P1-T1-P2-T2---P3---T3---D

  *   The SR domain contains Node S, P1, P2, P3, and D.
  *   T1, T2, and T3 are not SR aware.

S needs to reach D through local (LIB) adjacency segments instantiated on P1,P2 and P3.

Uncompressed SRv6 can achieve this goal using three adjacency segments, instantiated on P1, P2 and P3.

CSID compressed SRv6 can achieve this goal five adjacency segments. These are:

  *   A prefix segment on P1
  *   A prefix segment followed by an adjacency segment on P2
  *   A prefix segment followed by an adjacency segment on P3

The prefix segments are required because local adjacency segments are not routable on T1, T2 or T3.

B.3 SR Path 3

Do we need to discuss CRH handling of VPN SIDs?

B.4 SR Path 4

Do we need to discuss CSID handling of VPN labels?

Juniper Business Use Only

---

From: <[email-masked]>
Date: Fri, 7 May 2021 16:45:52 +0800 (CST)

Hi Team,

The following is UIDSR's reply for this action:

            Without "Global Container SID + local index", USID compressed SRv6 can achieve this goal by:

            Using two segments, one ending at P (i.e., END.X SID) and the other at the destination (i.e., END SID)

            Instantiating 2 END.X SIDs on Node P (one per outbound interface).

            Or, with "Global Container SID + local index", USID compressed SRv6 can achieve this goal by:

            Using three segments, two ending at P (i.e., END.T.X + interface-id) and the other at the destination (i.e., END SID)

            Instantiating 1 END.T.X SID for adjacency type and 2 local interface-id on Node P (one per outbound interface).

            Without "Global Container SID + local index", USID compressed SRv6 can achieve this goal using three END.X SIDs and one END SID. These are:

            An END.X SID on P1 for link-P1-T1

            An END.X SID on P2 for link-P2-T2

            An END.X SID on P3 for link-P3-T3

            An END SID on D

            Or,  with "Global Container SID + local index", USID compressed SRv6 can achieve this goal using six SIDs (END.T.X + interface-id) and one END SID. These are:

            An END.T.X SID + interface-id on P1 for link-P1-T1

            An END.T.X SID + interface-id on P2 for link-P2-T2

            An END.T.X SID + interface-id on P3 for link-P3-T3

            An END SID on D

        B.3 SR Path 3

             No idea.

        B.4 SR Path 4

                 No idea.

Regards,

PSF

原始邮件

发件人：RonBonica
收件人：'srcomp';
日 期 ：2021年05月07日 03:53
主 题 ：[Srcomp] Notes on Section 3.3.1

--  
Srcomp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/srcomp

 

 

Appendix B:

 

 

 

                          Network A

                        /          |            \

     S  ----  P                 | --------  D1

                        \             -------- DN

                           \          |         /

                            Network B 

The SR domain contains Node S, Node P, and a set of destination nodes (D1 through DN)

S is connected to P

P is connected to Network A and to Network B. Neither of these networks are SR-capable.

The destination nodes  connect to both Network A and Network B

 

A prefix segment that is instantiated on node S and takes the packet to Node P

An adjacency segment that is instantiated on Node P and takes the packet through Network A to a destination node

 

A prefix segment that is instantiated on node S and takes the packet to Node P

An adjacency segment that is instantiated on Node P and takes the packet through Network B to a destination node

Using two segments, one ending at P and the other at the destination

Instantiating 2 adjacency SIDs on Node P (one per outbound interface).

Using two segments, one ending at P and the other at the destination

Instantiating 2*N adjacency SIDs on Node P (one per outbound interface per destination).

Using three segments, two ending at P and the other at the destination

Instantiating 2 adjacency SIDs on Node P (one per outbound interface per destination).

 

 

 

 S---P1—T1—P2—T2---P3---T3---D

The SR domain contains Node S, P1, P2, P3, and D.

T1, T2, and T3 are not SR aware.

 

 

A prefix segment on P1

A prefix segment followed by an adjacency segment on P2

A prefix segment followed by an adjacency segment on P3

 

B.3 SR Path 3

 

B.4 SR Path 4