Subject: Re: Reserved addresses in the SSM range

From: David Meyer <[email-masked]>
Date: Mon, 7 Aug 2000 07:56:06 -0700 (PDT)

No, why would you need it? Addresses in 232/8 are local to
	the a source.

	Dave

According to zaid:
> 
> Is there a plan to use the GLOB mechanism
> for SSM address allocation ?
> 
> Zaid
> -----Original Message-----
> From: Doron Rajwan <[email-masked]>
> To: [email-masked] <[email-masked]>
> Date: Friday, August 04, 2000 11:03 PM
> Subject: Reserved addresses in the SSM range
> 
> 
> 
> Regarding Hugh question about reserving addresses in the SSM address
> space,
> I would suggest to reserve at least 255 addresses, or even more.
> 
> First, we have nothing to loose.
> 
> Second, we all know that UDP and TCP reserved ports is proven to be
> helpful.
> 
> Third, especially if my suggestion about "Multicast on-demand" will be
> accepted, a multicast server will have the ability to know if it has
> at
> least one connected client to any given multicast address. In this
> case, we
> can think of the following services, each given in a different,
> predefined,
> multicast address:
> 
> 1. Time service. The server's local time and time zone every second.
>    Support packet-loss rate detection.
>    Support "ping" for multicast.
>    I suggest address 232.0.0.1 for this one.
> 
> 2. CA service. Send certification about the server every 5 seconds.
> 
> 3. Quote of the day service. Actually, quote of the minute.
> 
> 4. Directory service. Send some information regarding the current
> server.
>    Probably the most important service.
> 
> 5. ...
> 
> 
> Doron.
> 
> 
> 
> 
>

---

From: zaid <[email-masked]>
Date: Mon, 07 Aug 2000 11:12:41 -0400

Zaid
-----Original Message-----
From: Doron Rajwan <[email-masked]>
To: [email-masked] <[email-masked]>
Date: Friday, August 04, 2000 11:03 PM
Subject: Reserved addresses in the SSM range

5. ...

Doron.

---

From: [email-masked] (Jeremy Hall)
Date: Mon, 7 Aug 2000 14:01:32 -0400 (EDT)

Hi,

I am finding it difficult to know why one would wish to reserve addresses.

_J

---

From: Thomas Marshall Eubanks <[email-masked]>
Date: Mon, 07 Aug 2000 15:15:05 -0400

> I am finding it difficult to know why one would wish to reserve addresses.

Dear Jeremy;

   Which kind of reservation ?

   At the IETF, the proposal was that a small number of addresses in 232/8 be reserved
for special purposes, "just in case,'" although no-one really seemed to know what those might be.
I regard this as not likely to be useful, although not too objectionable either.

   If you're talking about GLOP type addresses, I think that there is something to be said for this, in the
sense of avoiding MAC address collisions in ethernet type networks. Clearly, if everyone uses
232.0.0.1 as their favorite SSM address, this is asking for trouble. Rather that
use a random address, using your GLOP address (mapped to 232/8) would make sense IMHO. It would be
cleaner, and it might help in identifying the source of errant multicasts. This
could be done informally without involving IANA by just making it recommended.

                                 Regards
                                 Marshall Eubanks

T.M. Eubanks
Multicast Technologies, Inc
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624
Fax     : 703-293-9609
e-mail : [email-masked]     [email-masked]

http://www.on-the-i.com http://www.buzzwaves.com

---

From: Hugh LaMaster <[email-masked]>
Date: Mon, 7 Aug 2000 16:11:32 -0700 (PDT)

> I am finding it difficult to know why one would wish to reserve addresses.

I agree completely.  I see no reason to reserve *any* SSM groups.

> > First, we have nothing to loose.

Not true.  We have excess documentation.  Look at all the current
IANA multicast address assignments that were made, sit there taking 
up space in the documents, people have to read at various times, 
and 99% of which are never used.

> > Second, we all know that UDP and TCP reserved ports is proven to be

And harmful.  Look at all the unnecessary port assignments in the
IANA documents.  380K worth of port assignments, almost all of 
which could easily have been assigned dynamically.

> > can think of the following services, each given in a different,

IMHO, static address and port assignments should only be used
for unavoidable bootstrap mechanisms or where a well-known port
is used to support a universal service (e.g. NTP).  All other 
addresses and ports should be dynamically assigned.  If this 
policy were followed, about 99% of these assignments could 
go away.

> >    I suggest address 232.0.0.1 for this one.

OK, I changed my mind.  This is one that should be "reserved"
so that no one will ever use it.

--
 Hugh LaMaster, M/S 233-21,    Email: [email-masked]
 NASA Ames Research Center     Or:    [email-masked]
 Moffett Field, CA 94035-1000  Or:    [email-masked]
 Phone: 650/604-1056           Disc:  Unofficial, personal *opinion*.