Subject: Re: Use of SAP in a PIM SSM Network

From: zaid <[email-masked]>
Date: Thu, 16 Nov 2000 17:43:30 -0500

Just wondering ........

Instead of having a SAP like mechanism , does it make sense to
have a [Si,Gw] for every [Si,Gx] (x=1....n). Where Gw is a well known
group
with a well known port number ??

-----Original Message-----
From: Toerless Eckert <[email-masked]>
To: Jon Crowcroft <[email-masked]>
Cc: Toerless Eckert <[email-masked]>; Leonard Giuliano
<[email-masked]>; Hugh LaMaster <[email-masked]>;
[email-masked] <[email-masked]>;
[email-masked] <[email-masked]>
Date: Thursday, November 16, 2000 1:43 PM
Subject: Re: Use of SAP in a PIM SSM Network

> not clear - the GLOP and ipv6 ways of allocating multicast introduce
> _some_ hierarchiy - in fact its relatively easy to impose all sorts
if
> you have _enough_ address space.....

Isn't the right phrase for IPv4 "If you had _enough_ address space..."
?

> if yo uhave applications which genuijley have significant number of
> sources  with dynamics, then the server solution does not scale -
you
> have just pushed the management problem to that of
> 1/ locating one of a set of servers (how)
> 2/ making servers fault tolerant (anyone for anycast? :-)
> 3/ managing the application state in an unnatural way
> 4/ putting performance (delay and procerssign) limits on the scale
of
> the application

Well, /1 i think is not siginificantly more expensive if done outside
the
network layer than inside. The way we have it now is to have one
common
"server" (RP) infrastructure for all applications together, and isn't
it exactly this one size fits all" that limits flexibility introduces
unnecessary complexity and can not be individually be optimized for
particular suites of applications ?

/2 Sure, i love anycast ;-)

/3 I do not get it.
"Biking is an unnatural way of transportation (TM) automotive society"
?

/4 Only if we can assume that we can not build scaling server
infrastructures
for large scale applications. I think we can. There must be something
all
those content server boxes will be good for. How about this ? Wasn't
there
sufficient research in distributed systems in the last 20 years to
come up
with appropriate solutions for larger scale applications, as long as
you
stick to some scenarios in the first place (instead of trying to solve
it generically for all of them together in the network layer) ?

> ok so you could have a hierarchy of redundant servers....,and what
> standard internet protocoos are you going to use to manage those?

Why does it have to be standardised in the IETF ? Why not some other
place ?
Why are things like CORBA not standardised in the IETF ? Don't those
distributed applications relying on it run over the Internet also ?

> no, i think we need to retain the deering multicast model and just
> keep up the pressure on Large Router Vendors (this means you:-)
> to be smart about scaling the routers up to meet the users
> requirements rather than scaling the users expectations down to what
> you want to do:-)

We won't take the holy grail away, Lancelot ;-)
I guess this router vendor would just love to see some return of
investment
on multicast, and as far as i am concerned this in the first place
means
to get ip packet replication in routers used and payed for. The
control plane
operations will just follow the users application demands, and SSM is
just
another alternative. If there were more interesting Internet-wide
applications
that can not work well with SSM, then certainly the focus would be
different.

Cheers
Toerless

---

From: "Scott Millington (BCT)" <[email-masked]>
Date: Sun, 19 Nov 2000 20:31:57 +0100

Hi Hugh & all,

I don't know in which world you are living, but I would love to be there.

Ericsson has very little problem with multicast in Campus environmnets & LAN's...It is the WAN that "generates" all the problems (link speed, load on existing links, business critical traffic "at risk", and redundancy).  Add to this that My division is responsible, but doesn't have control over different "islands" it also becomes a political mess.

I have been kicking away for 2 years to try and motivate folks / organisations to open their eyes to the necessity of multicast.  Until September there was very little interest.  NOW everyone & their brother wants everything to work 6 months ago.  Perhaps it is the globality of organisations that the Ericsson Global IT Services Provides for...Am I the only one with this dilemma??

SSM would be wonderful if we can get it up & running with support for different applications.  

I have an organisational question but it can easily be SSM / PIM-SM related.  Is there anyone out there that has an application (Platform & Application independant) for the dynamic assignment of multicast addresses GGG.GGG.GGG.GGG:port where folks can book a randomized multicast group in the same way as one would book a conference room??  A bonus feature would be that this application could handle & mediate conflicts (someone "keeping" an assignment, or making their own assignments).

My problem is that conflicts are a recognised "threat", but my department is only responsible for providing "Multicast" in the net...without any concern for the applications / uses.

Sincerely,
Scott Millington
Data Communications Architect
+++++++++++++++++++++++++
Ericsson Global IT Services AB
Corporate Network - Basic EriNet
KI/BCT/I/ONF
Kistagången 4-4tr.
125 82 Stockholm
Telephone: +46-8-75 71667
Cellphone: +46-70-643 7897
Facsimile: +46-8-40 45550
EMAIL: [email-masked]
URL:    work - http://www.ericsson.se
           home - http://haapis.zap.to
+++++++++++++++++++++++++
Disclaimer: When I say something 
it is just me saying something 
and it is probably wrong anyway.
Certainly nothing I post should 
be construed as a statement of 
Ericsson company policy.

-----Original Message-----
From: Hugh LaMaster [mailto:[email-masked]]
Sent: 2000-11-16 18:11
To: [email-masked]
Subject: Re: Use of SAP in a PIM SSM Network

Multicast is widely available on WANs.  By far the largest problem
is getting it into the enterprise LAN and out to the consumer.  
If SSM is the catalyst that gets content providers and consumers 
demanding multicast, that's great, but, you're still going to have 
to deal with all the legacy enterprise, dialup, tier-2/3 deployment 
issues that you had before.  [Hmm.  I'm plagiarizing...;-)  ]
The hope is, that, with new content providers embracing SSM,
the demand will be there, and hence, the motivation to work on
the deployment issues.

---

From: "Scott Millington (BCT)" <[email-masked]>
Date: Thu, 23 Nov 2000 09:41:36 +0100

The problem is that someone could "hard code" a group address, and then begin sending at a different time.  If they do this and interrupt / disturb something important (i.e. a global press conference) then Someone (namely me) will be getting a mess of angry phone calls.  Not enough that it is a "hacker" problem, but even 

Some applications (Marratech off the top o me head) allow many to many where the group:port address combination is the only deciding factor...while this isn't the SSM model there are the same inherent risks, or am I paranoid?

Scott
Just because you are paranoid doesn't mean they aren't out to get you.

-----Original Message-----
From: Marshall Eubanks [mailto:[email-masked]]
Sent: 2000-11-23 01:42
To: Mike Luby
Cc: Kevin C. Almeroth; [email-masked];
[email-masked]
Subject: Re: Use of SAP in a PIM SSM Network

Mike Luby wrote:
> 
> Actually, I don't fully understand the last question about choosing SSM
> multicast addresses uniquely.  Since with SSM the address (channel) that the
> client sends an IGMPv3 join to is a (S,G) pair, where S is the origin server
> IP address and G is easily chosen to be unique among all G's that S is
> sourcing, it would seem that the problem of finding a globally unique
> address is not a problem.  However, there is still the issue of how the
> (S,G) address is mapped to a shorter address by some hardware environments
> like Ethernet, and maybe the question is how to make sure that this is
> unique with high probability?  It would be good to clarify this question so
> that there aren't misunderstandings and so that the weakness of the current
> solutions can be potentially fixed in the future.
> -Mike
> 

Dear Mike;

   I think that the biggest issue here is MAC address collision at layer
2. 
I think that it is a good idea to avoid this if possible. What we plan 
to do with our SSM broadcasts (starting next month) is to map our GLOP space
from  233/8  into the 232/8 SSM address range, and use that. If everyone does
this, then it is pretty straight-forward to avoid MAC collisions. Of course,
then, if you have more than 256 multicast groups, you have to worry about
collisions, but at least you can manage that yourself (or acquire access
to another ASN).

   The basic thing here is that broadcasters are going to want static
Class D addresses. (We, for example, have been up (doing ISM) since
early 
October with about 30 seconds of down time, and certainly want constant
addresses.) 
SSM will not change that. Whether these addresses are assigned by GLOP
type mechanisms or by other means such as MALLOC/ MADCAP doesn't really
matter that much, as long
as collisions can be avoided. It would be nice, however, if a Global SSM
allocation mechanism could be set up in the near future, before too many
people's choices get set in stone.

                                  Marshall

> From: Kevin C. Almeroth [mailto:[email-masked]]
> Sent: Wednesday, November 22, 2000 7:41 AM
> To: [email-masked]; [email-masked]
> Subject: RE: Use of SAP in a PIM SSM Network
> 
> >>Ericsson has very little problem with multicast in Campus environmnets &
> LAN's...It is the WAN that "generates" all the problems (link speed, load on
> existing links, business critical traffic "at risk", and redundancy).  Add
> to this that My division is responsible, but doesn't have control over
> different "islands" it also becomes a political mess.
> 
> I hate to bring up an oft repeated argument:  "How do you deal with
> this for unicast?"
> 
> When peering between domains, every single issue you mention is
> both an issue for unicast and multicast.
> 
> >>I have been kicking away for 2 years to try and motivate folks /
> organisations to open their eyes to the necessity of multicast.  Until
> September there was very little interest.  NOW everyone & their brother
> wants everything to work 6 months ago.  Perhaps it is the globality of
> organisations that the Ericsson Global IT Services Provides for...Am I the
> only one with this dilemma??
> 
> Nope...  and everyone is struggling.  The solution seems to be to
> get these folks thinking the right way about multicast.
> 
> Do you have content and applications lined up?
> 
> >>I have an organisational question but it can easily be SSM / PIM-SM
> related.  Is there anyone out there that has an application (Platform &
> Application independant) for the dynamic assignment of multicast addresses
> GGG.GGG.GGG.GGG:port where folks can book a randomized multicast group in
> the same way as one would book a conference room??  A bonus feature would be
> that this application could handle & mediate conflicts (someone "keeping" an
> assignment, or making their own assignments).
> 
> Again, this is perception.  Tell your folks if they feel like they
> are likely to see a conflict, they should go buy a lottery ticket.
> Same odds.
> 
> -Kevin

-- 

   Multicast Technologies, Inc.
   10301 Democracy Lane, Suite 201
   Fairfax, Virginia 22030
   Phone : 703-293-9624          Fax     : 703-293-9609     
   e-mail : [email-masked]     http://www.on-the-i.com

---

From: "Scott Millington (BCT)" <[email-masked]>
Date: Thu, 23 Nov 2000 11:12:15 +0100

*theme music*ERICSSON DEFENDER!!!*/theme music*

I won't make any "warranty statements" but the IP base station address planning I did for Ericsson had a focus on just Multicast <I wonder why that is ;)> and reinforced the ipmortance of this service in the new world (IPv4 & IPv6).  OTOH I was involved in the very preliminary work, so how it has developed since my involvement ceased is quite simply beyond me.

There is (was) a 3G developers link on ericsson.com...and a search for 3g on the usenet should prove fruitful, but if you want me to do a little legwork (I'm on paternity leave) send me a private message.

Scott

-----Original Message-----
From: Jon Crowcroft [mailto:[email-masked]]
Sent: 2000-11-23 11:01
To: Scott Millington (BCT)
Cc: [email-masked]'
Subject: Re: Use of SAP in a PIM SSM Network

speakin of ericsson:
i note that the 3G mobile access net
stuff is not "multicast ready"

given 3Gpp is basically packet and shared media, this seems sort of
marginally criminal :-)

given that there's LOADS of peope thinking that push technologies channel
tech, event/alerting/notifying, based on context and proximity etc etc
etc, it in fact seems bordering on the insane ommission

in fact, its stretches my patience and credulity to breaking point,
to quote the real inspector hound...

In message <33C9100DDE98D211A16D0008C7A4E3FE0818F30A@esealnt103>, "Scott Millin
gton (BCT)" typed:

 >>Doc, you is preachin to the choir ;)
 >>
 >>True...Unicast is the same (if not worse) but Multicast is new, =
 >>"non-traditional", and presently not viewed as production traffic.
 >>
 >>I mentioned before that I was getting folks motivated...well, when you =
 >>show a graph of travel costs (air stools, not counting time / hotel =
 >>etc) contra multicast costs - ripped off quite literally from an old =
 >>Motorola presentation - the effect on admin folks can be, um, pretty =
 >>impressive.=20
 >>
 >>"Do you have content and applications lined up?"
 >>LOL . . . Which came first ;)
 >>I actually do have content...a whole organisation where the President =
 >>is interested in video conferencing "All Staff Meetings" globally.  =
 >>Applications is actually the great motivator, since they appear to be =
 >>leaning towards Microsoft Media Server...MMS has the wonderful ability =
 >>to attempt different connectvity methods multicast-udp-tcp-http until =
 >>it gets contact.  This means that simply not enabling multicast is no =
 >>longer an option. *insert gleeful "I bloody told you so" facial =
 >>expression here*.
 >>
 >>As for the lottery comparison...Who says logic has anthing to do with =
 >>corporate decisionmaking??
 >>
 >>Cheers,
 >>Scott Millington
 >>Kistag=E5ngen 4-4tr.
 >>"Friendship is the hardest thing in the world to=20
 >>explain. It's not something you learn in school.=20
 >>But if you haven't learned the meaning of=20
 >>friendship, you reallyhaven't learned=20
 >>anything."  - Muhammad Ali =20
 >>
 >>
 >>
 >>From: [email-masked] [mailto:[email-masked]]
 >>Sent: 2000-11-22 16:41
 >>>>Ericsson has very little problem with multicast in Campus =
 >>environmnets & LAN's...It is the WAN that "generates" all the problems =
 >>(link speed, load on existing links, business critical traffic "at =
 >>risk", and redundancy).  Add to this that My division is responsible, =
 >>but doesn't have control over different "islands" it also becomes a =
 >>political mess.
 >>
 >>>>I have been kicking away for 2 years to try and motivate folks / =
 >>organisations to open their eyes to the necessity of multicast.  Until =
 >>September there was very little interest.  NOW everyone & their brother =
 >>wants everything to work 6 months ago.  Perhaps it is the globality of =
 >>organisations that the Ericsson Global IT Services Provides for...Am I =
 >>the only one with this dilemma??
 >>
 >>get these folks thinking the right way about multicast. =20
 >>
 >>>>SSM would be wonderful if we can get it up & running with support for =
 >>different applications. =20
 >>
 >>>>I have an organisational question but it can easily be SSM / PIM-SM =
 >>related.  Is there anyone out there that has an application (Platform & =
 >>Application independant) for the dynamic assignment of multicast =
 >>addresses GGG.GGG.GGG.GGG:port where folks can book a randomized =
 >>multicast group in the same way as one would book a conference room??  =
 >>A bonus feature would be that this application could handle & mediate =
 >>conflicts (someone "keeping" an assignment, or making their own =
 >>assignments).
 >>

 cheers

   jon

---

From: Scott Bradner <[email-masked]>
Date: Sat, 25 Nov 2000 11:33:59 -0500 (EST)

Marshall sez:
> If there is a MAC layer collision, for any reason, they will want a fast
> means of resolving it. 

I guess I'm confused - the Ethernet (for example) drivers I've seen do not
assume that the multicast packet they just got is actually for them - they
check and discard the ones that are not

so I do not see what the problem is

Scott

(in fact many Ethernet adapters do not know how to check for a specifc
multicast address - they hash teh address into some number of bins (e.g. 64) 
and if a flag for that bin is on they accept the packet )

---

From: Michael Smirnov <[email-masked]>
Date: Sat, 25 Nov 2000 23:44:26 +0100 (MET)

Hi,

SIM, ASM, GSM, HGM,... sound to me like an attempt to hoard what has been
open before, however I understand that with SSM there is  such a need.

It's also fine with me when people refer to rfc1112 as "native multicast"

cheers

Michael