Subject: SSM Address Space

From: Marshall Eubanks <[email-masked]>
Date: Wed, 13 Dec 2000 12:31:51 -0500

Hello;

   In the SSM meeting yesterday there was a little discussion about
the SSM address space. Now, I think that using something other than 
232/8 for Global scope SSM iss a VERY bad idea. Everyone should know
how hard it is to get the whole Internet to coordinate on something -
you would then for sure have domains that multicast peer using SSM on one
side and ISM on the other for the same address range - which would be bad
for interoperability and for deployment.

   Having said that, I can easily see that as SSM applications become available,
then people will want to use them for administratively or ttl scoped
address ranges.
Since it's localized, you can do what you want and not worry about interfering
with other peoples deployments.

   So, shouldn't the (framework?) draft state something like

SSM applications with global scope MUST be restricted to the 232/8
address range.
Applicatations in the 239/8 address range, or in other restricted scope
address 
ranges, MAY use SSM as desired; however, the administrator of the scoped address
space MUST ensure that SSM trees do not cross the scope domain boundaries.

                                   Regards
                                   Marshall Eubanks

   Multicast Technologies, Inc.
   10301 Democracy Lane, Suite 201
   Fairfax, Virginia 22030
   Phone : 703-293-9624          Fax     : 703-293-9609     
   e-mail : [email-masked]     http://www.on-the-i.com

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 13 Dec 2000 10:41:58 -0800 (PST)

Agreed in princile. 

Would it not be sufficient to say that an SSM address space can only be of
global scope if it is assigned by IANA for this purpose ?

Cheers
	Toerless

---

From: [email-masked] (Jeremy Hall)
Date: Wed, 13 Dec 2000 13:42:12 -0500 (EST)

sounds fine to me...I think people using SSM should use 232 regardless and
figure out how to do their own scoping.

_J

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 13 Dec 2000 13:48:17 -0500

> global scope if it is assigned by IANA for this purpose ?

That's a good idea - it makes it IPv6 compliant :)
-- 

                                   Regards
                                   Marshall Eubanks