Subject: [ssm] Any SSM implementations on PC routers ?

From: Vasaka Visoottiviseth <[email-masked]>
Date: Wed, 21 Apr 2004 19:14:06 +0900

Dear Sir,

	I would like to know whether there is any "open source" 
	for the SSM implementation ?
	I mean the routing daemon, not the IGMPv3 nor the MLDv2.

	As far as I know, Cisco and Juniper routers can support 
	SSM routing, but I haven't heard of the free software running on
	PC routers such as on the *BSD or the Linux.

Thank you very much in advance.

Sincerely Yours,
Vasaka

--------------------------------------------------------
Vasaka Visoottiviseth
Computer Science Department, Faculty of Science
Mahidol University, Thailand
http://www.sc.mahidol.ac.th/sccs/
-------------------------------------------------------

_______________________________________________
ssm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ssm

---

From: SUZUKI Shinsuke <[email-masked]>
Date: Wed, 21 Apr 2004 19:38:37 +0900

>>>>> On Wed, 21 Apr 2004 19:14:06 +0900
>>>>> [email-masked](Vasaka Visoottiviseth)  said:

> 	As far as I know, Cisco and Juniper routers can support SSM
> 	routing, but I haven't heard of the free software running on

KAME-SNAP contains SSM-ready IPv6 PIM-SM daemon "pim6sd" (also
included in freebsd-ports).

Please see
	http://www.kame.net/
for further detail.

Thanks,
----
SUZUKI, Shinsuke @ Hitachi / KAME Project

---

From: SUZUKI Shinsuke <[email-masked]>
Date: Wed, 21 Apr 2004 19:38:37 +0900

Please see
	http://www.kame.net/
for further detail.

Thanks,
----

---

From: Xavier Brouckaert <[email-masked]>
Date: Wed, 21 Apr 2004 13:12:32 +0200

Dear Vasaka,

It is on the roadmap of the XORP project.
See http://www.xorp.org/ and
http://www.xorp.org/releases/0.1/docs/design_arch/design_arch.pdf
However, AFAIK, nobody has taken care of implementing the ipv6 multicast
routing component in the linux kernel.
>From xorp/pim/README : "Note that currently Linux doesn't support IPv6
multicast routing."

Regards,
Xavier

---

From: Xavier Brouckaert <[email-masked]>
Date: Wed, 21 Apr 2004 13:12:32 +0200

Dear Vasaka,

multicast routing."

Regards,
Xavier

---

From: "Marshall Eubanks" <[email-masked]>
Date: Wed, 21 Apr 2004 07:44:44 -0400

On Wed, 21 Apr 2004 19:38:37 +0900
> > 	I mean the routing daemon, not the IGMPv3 nor the MLDv2.

Every PIM-SM implementation supports PIM-SSM. It's the same
routing protocol; all you need is to turn off (filter)
RP traffic for any SSM channels. Details are in 

http://www.ietf.org/internet-drafts/draft-ietf-pim-sm-v2-new-09.txt

section 4.9.1

Regards
Marshall Eubanks

---

From: Mark Handley <[email-masked]>
Date: Wed, 21 Apr 2004 12:54:46 +0100

>>From xorp/pim/README : "Note that currently Linux doesn't support IPv6

XORP itself provides PIM-SM using IPv4 or IPv6.  But obviously you
need to run XORP on an OS with a forwarding path that has appropriate
support.

If you need PIM-SM using IPv6, right now the best bet is probably to
use FreeBSD 4.9 (or FreeBSD 5.x, but 4.9 is probably preferable).  The
kernel changes needed for efficient PIM usage are already included in
FreeBSD.  Probably best to wait for the XORP 1.0 release due out
shortly though, or at least run the latest CVS snapshot.

The remaining issue would be if you need to use this as an SSM edge
router, because then you'll need IGMPv3/MLDv2 router support to allow
local hosts to join.  Currently we only have IGMPv2 and MLDv1 router
support in XORP.  IGMPv3/MLDv2 is on the roadmap for later this year.

Pavlin Radoslavov is the XORP multicast guru.  He'll no doubt correct
me if I got anything wrong.

Cheers,
	Mark

---

From: "Marshall Eubanks" <[email-masked]>
Date: Wed, 21 Apr 2004 07:44:44 -0400

section 4.9.1

Regards
Marshall Eubanks

---

From: Mark Handley <[email-masked]>
Date: Wed, 21 Apr 2004 12:54:46 +0100

Cheers,
	Mark

---

From: Pavlin Radoslavov <[email-masked]>
Date: Wed, 21 Apr 2004 11:02:00 -0700

> me if I got anything wrong.

Everything is correct with a small clarification.
If you need PIM-SM for IPv4, then you have to run FreeBSD-4.9 or 5.1
(or later).
If you need PIM-SM for IPv6, then older versions of FreeBSD with
KAME's IPv6 support should be fine too.

Pavlin

---

From: Pavlin Radoslavov <[email-masked]>
Date: Wed, 21 Apr 2004 11:02:00 -0700

Pavlin