Subject: [stir] Renaming E164Number

From: Sean Turner <[email-masked]>
Date: Wed, 12 Apr 2017 19:03:38 -0400

In another thread I remember seeing a suggestion to rename E164Number to DTMFNumber.  I created an issue:
  https://github.com/stirwg/certificates/issues/4
and here’s the PR showing the resulting change:
  https://github.com/stirwg/certificates/pull/5

What do people think?

spt

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Wed, 12 Apr 2017 23:13:09 +0000

Sean,

DTMF has no end to end meaning for routing, but is meaningful between the UE and the SP processing those symbols.

Therefore, I do not see this as an issue.

Regards,

Martin

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of Sean Turner
Sent: Wednesday, April 12, 2017 7:04 PM
To: [email-masked]
Subject: [stir] Renaming E164Number

In another thread I remember seeing a suggestion to rename E164Number to DTMFNumber.  I created an issue:
  https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_stirwg_certificates_issues_4&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=UhVA_2O-z5DN-Bdom_WhPcD_-4nWww1SYGSyTVjFPBA&s=DXAZMIa2681lT5v97AAp36rnY1CfZpJifa2PbpimkwQ&e= 
and here’s the PR showing the resulting change:
  https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_stirwg_certificates_pull_5&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=UhVA_2O-z5DN-Bdom_WhPcD_-4nWww1SYGSyTVjFPBA&s=72Ta2iS7yNcl-FCR5HdvXB5njEfC12k0kLz7QgCp87g&e= 

What do people think?

spt
_______________________________________________
stir mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_stir&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=UhVA_2O-z5DN-Bdom_WhPcD_-4nWww1SYGSyTVjFPBA&s=NSOnsQJ832JfPXkcoeqf68PvPzxIr21SPbpPP4dg270&e=

---

From: Russ Housley <[email-masked]>
Date: Thu, 13 Apr 2017 09:47:52 -0400

Martin:

E.164 only allows digits.  What should we call a number that include digits and * and #?

Russ

> On Apr 12, 2017, at 7:13 PM, DOLLY, MARTIN C <[email-masked]> wrote:
> 
> Sean,
> 
> https://www.ietf.org/mailman/listinfo/stir

---

From: Chris Wendt <[email-masked]>
Date: Thu, 13 Apr 2017 11:11:23 -0400

Can we just call it telephoneNumber?  I think we are mostly arguing name here, right?

> On Apr 13, 2017, at 9:47 AM, Russ Housley <[email-masked]> wrote:
> 
> Martin:
>

---

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 13 Apr 2017 15:19:19 +0000

Agreed. We are allowing these non-numeric characters in certs to support a corner case that might arise in the future. Let's not agonize over what to call the field. 

Jon Peterson
Neustar, Inc.

> On Apr 13, 2017, at 11:11 AM, Chris Wendt <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Thu, 13 Apr 2017 13:33:42 -0400

Jon’s right here because no ASN.1 field’s name is encoded on the wire.  Can I suggest “fred” :)

spt

> On Apr 13, 2017, at 11:19, Peterson, Jon <[email-masked]> wrote:
>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Thu, 13 Apr 2017 18:29:55 +0000

Freddy

Martin C. Dolly
Lead Member of Technical Staff
Core & Government/Regulatory Standards
AT&T
Cell: +1.609.903.3360<tel:+1.609.903.3360>
Email: [email-masked]<mailto:[email-masked]>

On Apr 13, 2017, at 1:34 PM, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:

spt

On Apr 13, 2017, at 11:19, Peterson, Jon <[email-masked]<mailto:[email-masked]>> wrote:

Jon Peterson
Neustar, Inc.

On Apr 13, 2017, at 11:11 AM, Chris Wendt <[email-masked]<mailto:[email-masked]>> wrote:

On Apr 13, 2017, at 9:47 AM, Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:

Martin:

Russ

On Apr 12, 2017, at 7:13 PM, DOLLY, MARTIN C <[email-masked]<mailto:[email-masked]>> wrote:

Sean,

Regards,

Martin

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of Sean Turner
Sent: Wednesday, April 12, 2017 7:04 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [stir] Renaming E164Number

What do people think?

spt
_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_stir&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=UhVA_2O-z5DN-Bdom_WhPcD_-4nWww1SYGSyTVjFPBA&s=NSOnsQJ832JfPXkcoeqf68PvPzxIr21SPbpPP4dg270&e=
_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_stir&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=6M6N4M5LZ1d6WcCBvI_vEcQlR3feA-kcNLreo3H_oig&s=D2ZbCmNqrBuXHVfSX9ncLvfsfB2x5XlMh3I_KXfd3IQ&e=

_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_stir&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=6M6N4M5LZ1d6WcCBvI_vEcQlR3feA-kcNLreo3H_oig&s=D2ZbCmNqrBuXHVfSX9ncLvfsfB2x5XlMh3I_KXfd3IQ&e=

_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_stir&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=6M6N4M5LZ1d6WcCBvI_vEcQlR3feA-kcNLreo3H_oig&s=D2ZbCmNqrBuXHVfSX9ncLvfsfB2x5XlMh3I_KXfd3IQ&e=

_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_stir&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=6M6N4M5LZ1d6WcCBvI_vEcQlR3feA-kcNLreo3H_oig&s=D2ZbCmNqrBuXHVfSX9ncLvfsfB2x5XlMh3I_KXfd3IQ&e=

_______________________________________________
stir mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_stir&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG0r2g&m=6M6N4M5LZ1d6WcCBvI_vEcQlR3feA-kcNLreo3H_oig&s=D2ZbCmNqrBuXHVfSX9ncLvfsfB2x5XlMh3I_KXfd3IQ&e=

---

From: Michael Hammer <[email-masked]>
Date: Fri, 14 Apr 2017 14:56:39 +0000

Jon,

Can the * and # be used arbitrarily anywhere in the string?

Is there some semantic to those characters that needs 
to be understood by both the sender and receiver?

Or does it not matter because the recipient only treats it as an opaque string?

________________________________
Michael Hammer
[email-masked]
+1 408 202 9291

© 2016 Yaana Technologies, LLC. All Rights Reserved. Email confidentiality notice. This message is private and confidential. If you have received this message in error, please notify us and remove it from your system.

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of Peterson, Jon
Sent: Thursday, April 13, 2017 11:19 AM
To: Chris Wendt <[email-masked]>
Cc: IETF STIR Mail List <[email-masked]>; Russ Housley <[email-masked]>; Martin C Dolly <[email-masked]>
Subject: Re: [stir] Renaming E164Number

Jon Peterson
Neustar, Inc.

>>> and here's the PR showing the resulting change:

---

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 14 Apr 2017 16:14:34 +0000

No mutual understanding of the semantics is required by the authentication
and verification services here - though in practice, calls that are routed
to destinations via a dial string with a * or # in it should end up going
to fairly specialized pieces of equipment, and I'm actually less worried
about canonicalization and so on being an issue for special dial strings
like this than I am for ordinary E.164 numbers. We're not placing any
restrictions on where in the dial string those non-numeric characters
might appear, as there doesn't seem to be anything gained by doing so
except introducing complexity.

In terms of what to call it, if we can't agree on Freddie, I do think TN
or something similarly generic is appropriate. If we already have a group
field for TelphoneNumberRange, why wouldn't the base element be
TelephoneNumber? Or if we'd be overloading some existing registered name
by using that, like TelNum or something?

Jon Peterson
Neustar, Inc.

On 4/14/17, 10:56 AM, "Michael Hammer" <[email-masked]>
wrote:

>© 2016 Yaana Technologies, LLC. All Rights Reserved. Email
>confidentiality notice. This message is private and confidential. If you
>have received this message in error, please notify us and remove it from
>your system.
>
>Cc: IETF STIR Mail List <[email-masked]>; Russ Housley
><[email-masked]>; Martin C Dolly <[email-masked]>
>Agreed. We are allowing these non-numeric characters in certs to support
>a corner case that might arise in the future. Let's not agonize over what
>to call the field.
>
>Jon Peterson
>Neustar, Inc.
>
>>>> DTMF has no end to end meaning for routing, but is meaningful between
>>>>the UE and the SP processing those symbols.
>>>> 
>>>>https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_stirwg_
>>>>certificates_issues_4&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmp
>>>>w7ItG0r2g&m=UhVA_2O-z5DN-Bdom_WhPcD_-4nWww1SYGSyTVjFPBA&s=DXAZMIa2681lT
>>>>5v97AAp36rnY1CfZpJifa2PbpimkwQ&e=
>>>>https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_stirwg_
>>>>certificates_pull_5&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7
>>>>ItG0r2g&m=UhVA_2O-z5DN-Bdom_WhPcD_-4nWww1SYGSyTVjFPBA&s=72Ta2iS7yNcl-FC
>>>>R5HdvXB5njEfC12k0kLz7QgCp87g&e=
>>>> 
>>>> What do people think?
>>>> 
>>>> spt
>>>>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailm
>>>>an_listinfo_stir&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=G9v8uCSSQhCmpw7ItG
>>>>0r2g&m=UhVA_2O-z5DN-Bdom_WhPcD_-4nWww1SYGSyTVjFPBA&s=NSOnsQJ832JfPXkcoe
>>>>qf68PvPzxIr21SPbpPP4dg270&e=

---

From: Russ Housley <[email-masked]>
Date: Fri, 14 Apr 2017 13:30:51 -0400

Suggestion…

OLD w/ the addition of SIZE to TelephoneNumberRange:

     TNAuthorizationList ::= SEQUENCE SIZE (1..MAX) OF TNEntry

     TNEntry ::= CHOICE {
       spc   [0] ServiceProviderCodeList,
       range [1] TelephoneNumberRange,
       one       E164Number }

     ServiceProviderCodeList ::= SEQUENCE SIZE (1..3) OF IA5String

     TelephoneNumberRange ::= SEQUENCE SIZE (2..MAX) {
       start E164Number,
       count INTEGER  }

     E164Number ::= IA5String (SIZE (1..15)) (FROM ("0123456789#*”))

NEW:

     TNAuthorizationList ::= SEQUENCE SIZE (1..MAX) OF TNEntry

     TNEntry ::= CHOICE {
       spc   [0] ServiceProviderCodeList,
       range [1] TelephoneNumberRange,
       one       TelephoneNumber }

     ServiceProviderCodeList ::= SEQUENCE SIZE (1..3) OF IA5String

     TelephoneNumberRange ::= SEQUENCE SIZE (2..MAX) {
       start TelephoneNumber,
       count INTEGER  }

     TelephoneNumber ::= IA5String (SIZE (1..15)) (FROM ("0123456789#*”))

If this is acceptable, then I ask the authors to make the changes and post an updated I-D.

Russ

> On Apr 14, 2017, at 12:14 PM, Peterson, Jon <[email-masked]> wrote:
> 
>

---

From: Russ Housley <[email-masked]>
Date: Fri, 14 Apr 2017 16:54:59 -0400

Ooops.  I put the (2..MAX) in the wrong spot.

Also, I think that the TNEntry for spa should not be a list since TNAuthorizationList can contain as many spa entries as desired.

My revised suggestion is:

TNEntry ::= CHOICE {
  spc   [0] ServiceProviderCode,
  range [1] TelephoneNumberRange,
  one       TelephoneNumber }

ServiceProviderCode ::= IA5String

TelephoneNumberRange ::= SEQUENCE {
  start TelephoneNumber,
  count INTEGER (2..MAX)  }

Russ

> On Apr 14, 2017, at 1:30 PM, Russ Housley <[email-masked]> wrote:
> 
> Suggestion…
>

---

From: Michael Hammer <[email-masked]>
Date: Tue, 18 Apr 2017 18:27:34 +0000

That addressed my main concern.

I have qualms about dial strings, but
will let this play out to see where it goes.

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: Friday, April 14, 2017 4:55 PM
To: IETF STIR Mail List <[email-masked]>
Subject: Re: [stir] Renaming E164Number

TNEntry ::= CHOICE {

TelephoneNumber ::= IA5String (SIZE (1..15)) (FROM ("0123456789#*"))

Russ

> Suggestion...
>     E164Number ::= IA5String (SIZE (1..15)) (FROM ("0123456789#*"))
>
> NEW:
>
>     TelephoneNumber ::= IA5String (SIZE (1..15)) (FROM
> ("0123456789#*"))
>
>> No mutual understanding of the semantics is required by the
>> authentication and verification services here - though in practice,
>> calls that are routed to destinations via a dial string with a * or #
>> in it should end up going to fairly specialized pieces of equipment,
>> and I'm actually less worried about canonicalization and so on being
>> an issue for special dial strings like this than I am for ordinary
>> E.164 numbers. We're not placing any restrictions on where in the
>> dial string those non-numeric characters might appear, as there
>> doesn't seem to be anything gained by doing so except introducing complexity.
>>
>> In terms of what to call it, if we can't agree on Freddie, I do think
>> TN or something similarly generic is appropriate. If we already have
>> a group field for TelphoneNumberRange, why wouldn't the base element
>> be TelephoneNumber? Or if we'd be overloading some existing
>> registered name by using that, like TelNum or something?
>>
>> Jon Peterson
>> Neustar, Inc.
>>
>>> Is there some semantic to those characters that needs to be
>>> understood by both the sender and receiver?
>>>
>>> confidentiality notice. This message is private and confidential. If
>>> you have received this message in error, please notify us and remove
>>> it from your system.
>>>
>>> Agreed. We are allowing these non-numeric characters in certs to
>>> support a corner case that might arise in the future. Let's not
>>> agonize over what to call the field.
>>>
>>> Jon Peterson
>>> Neustar, Inc.
>>>
>>>> On Apr 13, 2017, at 11:11 AM, Chris Wendt
>>>> <[email-masked]>
>>>> wrote:
>>>>
>>>>>> DTMF has no end to end meaning for routing, but is meaningful
>>>>>> between the UE and the SP processing those symbols.
>>>>>>
>>>>>> In another thread I remember seeing a suggestion to rename
>>>>>> E164Number to DTMFNumber.  I created an issue:
>>>>>>
>>>>>> w7ItG0r2g&m=UhVA_2O-z5DN-Bdom_WhPcD_-4nWww1SYGSyTVjFPBA&s=DXAZMIa
>>>>>> 2681lT 5v97AAp36rnY1CfZpJifa2PbpimkwQ&e= and here's the PR
>>>>>> showing the resulting change:
>>>>>>

---

From: Sean Turner <[email-masked]>
Date: Thu, 20 Apr 2017 15:04:18 -0400

All I’ve revised the PR to reflect switch the “TelephoneNumber”:
https://github.com/stirwg/certificates/pull/5

Note that I’ve got another PR to address the changes to ServiceProviderCodeList.

spt

> On Apr 18, 2017, at 14:27, Michael Hammer <[email-masked]> wrote:
>