Subject: [stir] Changes to ServiceProviderCodeList

From: Sean Turner <[email-masked]>
Date: Thu, 20 Apr 2017 15:06:29 -0400

To remove the constraints on ServiceProviderCodeList I’ve created an issue:
https://github.com/stirwg/certificates/issues/7
and a PR:
https://github.com/stirwg/certificates/pull/8

To date that’s three tweaks to the TNAuthoriztionList syntax:
1. Add constraints to count, i.e., (2..MAX)
2. Rename E164Number to TelephoneNumber
3. Tweaks to ServiceProviderCodeList

spt

---

From: Sean Turner <[email-masked]>
Date: Thu, 20 Apr 2017 18:53:04 -0400

Note that as a result of changing ServiceProviderCodeList to be just one code, we needed to also change TNEntry to tag TelephoneNumber because ServiceProviderCode and TelephoneNumber are both IA5String:

TNEntry ::= CHOICE {
    spc   [0] ServiceProviderCode,
    range [1] TelephoneNumberRange,
    one   [2]    TelephoneNumber
    }

I updated the PR.

spt

> On Apr 20, 2017, at 15:06, Sean Turner <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Tue, 25 Apr 2017 22:44:58 -0500

I’m looking at merging these PRs on Thursday.  Please let me know if you think I’ve missed anything.

spt

> On Apr 20, 2017, at 14:06, Sean Turner <[email-masked]> wrote:
>