Subject: [stir] Question about "RPH Types" RE: I-D Action: draft-ietf-stir-rph-00.txt

From: "Gunn, Janet P" <[email-masked]>
Date: Wed, 5 Jul 2017 15:41:00 +0000

I am having some difficulty understanding "RPH types"

Section 5 says
" A new IANA registry has been defined to hold potential values of the "rph" array; see Section 8.3."
<there is no Section 8.3.  This may be a typo for 6.2>

Within Section 6, IANA considerations, Section 6.2 says:

" This document requests that the IANA create a new registry for PASSporT RPH types.  Registration of new PASSporT RPH types shall be under the specification required policy. This registry is to be initially populated with a single value for "namespace" which is specified in [RFCThis]."

But I can find no reference to "RPH types" in the rest of the document.  Nor can I find any other references to "rph" array.  And I can't  find anything that indicates  what this a single value for    "namespace" is.

So I am not sure how it/they will be used.

Some additional description and clarification would be useful.

Janet

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, June 30, 2017 7:42 PM
To: [email-masked]
Cc: [email-masked]
Subject: [stir] I-D Action: draft-ietf-stir-rph-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Secure Telephone Identity Revisited of the IETF.

        Title           : PASSporT Extension for Resource-Priority Authorization
        Authors         : Ray P. Singh
                          Martin Dolly
                          Subir Das
                          An Nguyen
Filename        : draft-ietf-stir-rph-00.txt
Pages           : 9
Date            : 2017-06-30

Abstract:
   This document extends the PASSporT object to convey
   cryptographically-signed assertions of authorization for
   communications 'Resource-Priority'.  It extends PASSporT to allow
   cryptographic-signing of the SIP 'Resource-Priority" header field
   which is used for communications resource prioritization.  It also
   describes how the PASSPorT extension is used in SIP signaling to
   convey assertions of authorization of the information in the SIP
   'Resource-Priority' header field.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-stir-rph/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-stir-rph-00
https://datatracker.ietf.org/doc/html/draft-ietf-stir-rph-00

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
stir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/stir

This electronic message transmission contains information from CSRA that may be attorney-client privileged, proprietary or confidential. The information in this message is intended only for use by the individual(s) to whom it is addressed. If you believe you have received this message in error, please contact me immediately and be aware that any use, disclosure, copying or distribution of the contents of this message is strictly prohibited. NOTE: Regardless of content, this email shall not operate to bind CSRA to any order or other contract unless pursuant to explicit written agreement or government initiative expressly permitting the use of email for such purpose.

---

From: "Singh, Ray P" <[email-masked]>
Date: Fri, 7 Jul 2017 01:00:22 +0000

Janet,

Thanks for your comment.  This is a needed cleanup that we missed before the submission.  We will clarify the IANA considerations in the next draft update (v-01) as follows:

1. Update text in section 5 to say
"The definition  of the "rph" claim may have one or more such additional information field(s). Details of such "rph" claim to encompass other data elements are left for future version of this specification." 
2. Update section 6 text as follows:
6.2 PASSporT Types
This specification requests that the IANA add a new entry to the PASSporT Types registry for the type "rph" which is specified in
[RFCThis].

6.3. PASSporT RPH Types
This document requests that the IANA create a new registry for PASSporT RPH types. Registration of new PASSporT RPH types shall be
under the specification required policy.  This registry is to be initially populated with a single value for "auth" which is specified in [RFCThis].

Regards
Ray

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of Gunn, Janet P
Sent: Wednesday, July 05, 2017 11:41 AM
To: [email-masked]
Subject: [stir] Question about "RPH Types" RE: I-D Action: draft-ietf-stir-rph-00.txt

Section 5 says

Janet

-----Original Message-----
From: stir [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, June 30, 2017 7:42 PM
To: [email-masked]
Cc: [email-masked]
Subject: [stir] I-D Action: draft-ietf-stir-rph-00.txt

Abstract: