Subject: [Storagesync] thoughts on the BOF and way forward

From: Jari Arkko <[email-masked]>
Date: Wed, 4 Nov 2015 06:09:36 +0900

I attended the BOF, and have followed the topic
somewhat in previous months. I wanted to offer
some thoughts after the BOF ended.

The BOF focused on the right questions, and the
discussion was spot on. I concur with many of the
points made about what is important. From my
personal perspective, improvements in efficiency
are interesting, but they are sort of secondary to the
question of whether we should standardise something.
In any case, updates of existing solutions happen fairly
easily if the party in question realises they need and
can improve efficiency.

I also tend to think that extreme efficiency was never a key
factor in any successful Internet technology deployment. Speed of
deployment, flexibility, value for user, common market for something,
and so on are far bigger issues. Functionality, e.g., ability to
compose and move structured datasets and not just files, or
ability to do multi-party synchronisation are definitely more
interesting than pure efficiency, and perhaps that is something
that can be considered. But even those are still somewhat
secondary.

What is really important in this case is the ability or desire to
interoperate. That is the key question, i.e., do we want that,
for some sufficiently interesting value of “we”.

Quite rightly, the BOF asked whether there are folks who
are interested in taking this on and deploying. At least
some existing large storage vendors said that they
have no interest. Understandably, the feeling in the
room was pessimistic after that.

But we have to be careful here. First off, this space
is big, and the consumer-visible large-scale storage
services are not the only important ones. Private
clouds, enterprise markets, Internet of Things,
secure storage services, etc. are also potentially
interesting. Secondly, it has never been the case
that everybody agrees we should develop new
technology and that we all commit to using it
once it is ready. Even if we had just one market,
you may not be able to get the biggest players
to commit or even take a positive view. Thirdly,
there are often folks who are not in a position
to say anything publicly, and trying to gauge a
bit behind the scenes what the silent folks think
might be useful.

I don’t think there’s a requirement in this case
(or in general) that you need buy-in from a large
number of folks to use something. What you do
need is _some_ folks who are interested and in
a position to drive something that they would
benefit from. Whether that something succeeds
for them, and whether it eventually grows to
something that a bigger set of people are interested
in are questions for the future. I think setting the
bar too high would be a mistake.

I would also observe that vendors are not the
only ones specifying what solutions should be.
We often have a situation where users/customers
want standards that they want to place in their
RFPs so that they can create a more competitive
environment for the services that they need.
I certainly feel that this situation exists in this
case from an enterprise user perspective, for
instance.

In short, I think what this effort needs is _some_
set of folks who are driving this from a business
need. I see the researchers being interested; I
see folks like Jakub from CERN interested; I see
individual users like Ted interested. We
definitely need some more for the work to be
sensible, but I don’t think we necessarily need
the most visible brand names from the consumer
market to go ahead.

Jari

---

From: Yong Cui <[email-masked]>
Date: Wed, 4 Nov 2015 07:36:14 +0800

Please see in lines.

> and so on are far bigger issues.

I totally agree with you that the speed of deployment, flexibility, value 
for user and interoperability are much more important than the performance 
efficiency.

> interesting.

That's the key here!
We use more and more Google Doc rather than local Office software, where Google Doc leverages Google Drive. There're also a lot of cloud-based softwares on photo processing, document processing or even enterprise softwares recently. So I think maybe in the future, the softwares you use everyday could be installed in the cloud rather than on your client PCs or smart phones. In that case, ISS service could be an important platform. 

> the most visible brand names from the consumer

In addition to the scenario of enterprise/private ISS service, I see most of the people personally like to see the interoperability between the ISS services, while the third party app developers also hope to have the standard. these are the customers of ISS service. If the costumers are big/important enough, then vendors would like to think about this issue or even implement the standard. Standard protocols here could lower the entrance bar of third party apps over the ISS services.

Cheers,

Yong

---

From: Gihan Dias <[email-masked]>
Date: Thu, 5 Nov 2015 15:40:45 +0900

On 15/11/04 6:09 AM, Jari Arkko wrote:
> I attended the BOF, and have followed the topic somewhat in previous months. I wanted to offer some thoughts after the BOF ended.
Jari,

Thanks.

I agree with you.

This is a new space, and though we think there is something we need to 
do, we don't yet know quite what.

I think we should not focus on individual files, but entire file 
systems, and structured datasets. We should also consider not just 
two-party sync, but synchronising between multiple devices and clouds. 
However, to begin we may focus on a smaller problem. I suggest we first 
focus on agreeing on the system model, to ensure we are all talking 
about the same thing.

As for technology and protocols, there are many papers - and some 
implementations - out there, so we don't have to do a lot of new 
research just select a good technology and implement it.

Regards,

Gihan