Subject: Re: [Storagesync] Storagesync Digest, Vol 5, Issue 1

From: "Fei Song" <[email-masked]>
Date: Mon, 7 Dec 2015 10:38:08 +0800

Hi Markus,

So, in remoteStorage, what should be stored at the both client and server side?
Etags or metadata or metadata history or other things?
based on the draft, it seems that only Etag is enough, but the context in this mailing list confused me...

Fei Song

From: Markus Unterwaditzer
Date: 2015-12-07 05:54
To: Ted Lemon
CC: storagesync
Subject: Re: [Storagesync] Storagesync Digest, Vol 5, Issue 1
Etags are *much* simpler to implement on the server side than the WebDAV sync
protocol because they do not require the server to keep sync tokens and
metadata history. Note that the server has to keep metadata of *deleted* files
to correctly implement WebDAV's sync protocol. Etags are less efficient in
terms of network usage of course, but that's the tradeoff to be made.

I don't know what you mean with the last sentence.

On Sun, Dec 06, 2015 at 06:26:54PM +0000, Ted Lemon wrote:
> Sunday, Dec 6, 2015 12:39 PM Markus Unterwaditzer wrote:
> > What do you mean by "it"? ETags are simpler to implement than the above RFC,
> > and ETags are also required in WebDAV.
> 
> Etags are not really much simpler than a metadata versioning sync protocol, and they are a lot less efficient.   Having to fetch the whole directory for every directory that contains a change is expensive, both for the server and the client, unless changes are infrequent.   And because the server is the sole source of truth, it's a lot more fragile.
> 
> 
> --
> Sent from Whiteout Mail - https://whiteout.io
> 
> My PGP key: https://keys.whiteout.io/[email-masked]

> _______________________________________________
> Storagesync mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/storagesync

_______________________________________________
Storagesync mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/storagesync

---

From: Markus Unterwaditzer <[email-masked]>
Date: Mon, 7 Dec 2015 13:34:00 +0100

Hello Fei, see my response to Lihui Sun.

---

From: "Fei Song" <[email-masked]>
Date: Tue, 8 Dec 2015 08:24:29 +0800

Hi Markus,

Thanks. now I can roughly understand what is inside the remoteStorage or other similar schemes.
It would be great if we can see more details when you have time :) 

--------------
Fei Song