Subject: Re: [Storagesync] New version of draft-dejong-remotestorage Internet-Draft available

From: "Fei Song" <[email-masked]>
Date: Tue, 1 Dec 2015 17:44:29 +0800

Hi Gihan,

There is no "WebDAV" in this draft.
but the solution looks pretty interesting.

--------------
Fei Song
>On 2015-12-01 ??.?. 2:54, Michiel de Jong wrote:
>> FYI: 
>> https://www.ietf.org/internet-drafts/draft-dejong-remotestorage-06.txt
>>
>> Reactions welcome! :)
>Michiel,
>
>Sorry for the newbie question, but I found it difficult to figure out 
>why this cannot be handled by WebDAV.
>Could you point me at a document explaining the differences?
>
>Thanks,
>
>Gihan
>
>_______________________________________________
>Storagesync mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/storagesync

---

From: "Fei Song" <[email-masked]>
Date: Wed, 2 Dec 2015 08:14:31 +0800

+1

--------------
Fei Song

---

From: "Fei Song" <[email-masked]>
Date: Wed, 2 Dec 2015 10:09:49 +0800

Hi Michiel,

I had read the draft quickly. The draft is very thoughtful. The basic functional elements are selected reasonably. Many details are also presented clearly.

Here are some comments:

1.	The usage of “bearer tokens” (Sec. 9) is not quite clear for me. More details will be helpful.
2.	It seems that there is no server-to-client commands. I think it is useful, especially for collaborative work.
3.	For the data synchronizing (pointed by Hugo Gonzalez Labrador in previous email), I think since the draft has a scheme to avoid unnecessary folder changes trigger by individual document (Sec. 13 Distributed versioning). It would be possible to add new mechanism to do the synchronization. Or the author did not want to do that?
4.	Is it built on REST instead of XML-based communication?
5.	Several typos: In the Introduction part, “The actions the interface exposes are”.

--------------
Fei Song
>See https://remotestorage.io/ for more info about the remoteStorage
>project, and https://github.com/remotestorage/spec/issues for discussions
>around the contents of this internet-draft.
>
>Cheers,
>Michiel.
>