Subject: Re: [Storagesync] recent issues discussed (plain text)

From: "[email-masked]" <[email-masked]>
Date: Tue, 5 Jan 2016 16:58:18 +0800

Hi,Fei>If I did not get wrong, this issue is complicated and should be seperated into multiple steps. >like protocol improvement, deployment optimization, etc.I deeply agree with you. That is a great problem, but, IMO, is worth doing.  If needed, I will outline what should we do about that.Best wishes!Xiao wei Qin

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 7 Jan 2016 13:35:20 +0800

Hi,Fei
IMO, the main work includes:
1. Identification of pre-uploaded content and Redirection of the uploading request: 
     As we known, in downloading, URL/URI  -->  "DNAME” of the DNS  -->  uCDN
Uploading: How to identify the pre-uploaded content and redirect the request to UATN?
2. Move the random & mass content generated by end users efficiently
Downloading: content generated by companies, large and manageability
Uploading:  When and where end users upload content is random, mass and relatively small
3. Best edge server and optimal uploading route 
Downloading: moving content to the hot edge server in advance.
Uploading: UATN should assign the best edge server and select a optimal uploading route to serve a uploading. 

Regards

Xiaowei Qin
 
--------------
Fei Song
>Hi,Fei>If I did not get wrong, this issue is complicated and should be seperated into multiple steps. >like protocol improvement, deployment optimization, etc.I deeply agree with you. That is a grea…
 
That would be great! Please do that. then we can discuss in depth via mailing list.
Thanks for that!