Subject: [storm] On Virtual Address, Steering Address, Base Offset, Tagged Base Offset and more

From: Michael Ko <[email-masked]>
Date: Fri, 15 Jul 2011 12:05:38 -0700

I will combine my responses to Mallikarjun and Tom in one e-mail.

I am fine with using the term "Base Offset" instead of "Virtual Address".  It will be defined in the Definition section as "This represents a value to be added to the Buffer Offset in order to obtain the Tagged Offset."  So in sec. 2.4.1, the text "The base Tagged Offset is not explicitly specified, but the target must always assume it as zero" will be deleted.

In sec. 7.3.5 on SCSI Data-in, the original text "It MUST use the Buffer Offset from the SCSI Data-in PDU as the Data Sink Tagged Offset of the RDMA Write Message" will be replaced with:

"It MUST add the Buffer Offset from the SCSI Data-in PDU to the Base Offset as the Data Sink Tagged Offset of the RDMA Write Message."

Similarly, in sec. 7.3.6 on Ready To Transfer, the original text "MUST use the Buffer Offset from the R2T PDU as the Data
Source Tagged Offset of the RDMA Read Request Message" will be replaced with:

"MUST add the Buffer Offset from the R2T PDU to the Base Offset as the Data Source Tagged Offset of the RDMA Read Request Message."

Mike

---

From: Tom Talpey <[email-masked]>
Date: Fri, 15 Jul 2011 19:14:32 +0000

Sounds good. I assume you'll scan the document for other instances of the term "address" etc. I also spot a few uses of the term "points to" in 6.9 and 7.3.1. The one in 7.3.1 is associated with some questionable text indicating that the arithmetic is not needed (Base Offset == Tagged Offset). I assume you will investigate those as part of tightening up the TO calculation rules..

Tom.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Ko
Sent: Friday, July 15, 2011 3:06 PM
To: [email-masked]
Subject: [storm] On Virtual Address, Steering Address, Base Offset, Tagged Base Offset and more

Mike

---

From: Michael Ko <[email-masked]>
Date: Fri, 15 Jul 2011 13:00:19 -0700

Yes.  I will scan all occurrences of "virtual address" and "tagged offset" in the current draft to update them to the latest terminology and usage.

Mike
  ----- Original Message ----- 
  From: Tom Talpey 
  To: Michael Ko ; [email-masked] 
  Sent: Friday, July 15, 2011 12:14 PM
  Subject: RE: [storm] On Virtual Address, Steering Address, Base Offset, Tagged Base Offset and more

  Tom.

  Mike