Subject: [storm] draft-ietf-storm-mpa-peer-connect - review comment

From: Steve Wise <[email-masked]>
Date: Tue, 23 Aug 2011 08:49:06 -0500

Hey,

I believe the ORD/IRD fields in the MPAv2 messages need to be in Network 
Byte Order.  This is not mandated in the draft.

I also think there is an oversight in RFC 5044 with regard to the 
PD_Length field in the MPAv1 messages.  It should also be in Network 
Byte Order, but I don't see this requirement anywhere in the RFC.

Or maybe NBO is a always assumed in IETF wire-protocol messages?

Steve.

---

From: <[email-masked]>
Date: Sat, 27 Aug 2011 18:37:28 -0400

Network byte order is the usual default, but it doesn't hurt to say so.

Thanks,
--David

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Steve Wise
> Sent: Tuesday, August 23, 2011 9:49 AM
> To: arkady kanevsky
> Cc: Nikolova, Tatyana E; Latif, Faisal; Kumar A S; [email-masked]
> Subject: [storm] draft-ietf-storm-mpa-peer-connect - review comment
> 
> Hey,
> 
> _______________________________________________
> storm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/storm