Subject: [storm] iSCSI: New IPsec security requirements

From: <[email-masked]>
Date: Thu, 13 Oct 2011 16:55:08 -0400

I've checked with the ipsecme WG and the responsible Security AD.

The upshot is that there's still a lot of 2400-series RFC IPsec out there, and hence the appropriate IPsec requirements for iSCSI are:

	- MUST implement IPsec, 2400-series RFCs (IPsec v2, IKEv1).
	- SHOULD implement IPsec, 4300-series RFCs (IPsec v3, IKEv2).

The MUST is for interoperability and to acknowledge what's out there; the SHOULD is to encourage implementers to move forward. 

Now I need to go write the actual text to go into the draft, and the main iSCSI draft will have to update RFC 3723 as part of this.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: Mallikarjun Chadalapaka <[email-masked]>
Date: Thu, 13 Oct 2011 15:24:08 -0700

Thanks for the follow-up David!   That sounds reasonable to me.  I will wait
for the new text to get it into the draft getting now ready for submission
(I have published a draft copy to the mailing list earlier this week).

Mallikarjun

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Thursday, October 13, 2011 1:55 PM
To: [email-masked]
Subject: [storm] iSCSI: New IPsec security requirements

The upshot is that there's still a lot of 2400-series RFC IPsec out there,
and hence the appropriate IPsec requirements for iSCSI are:

The MUST is for interoperability and to acknowledge what's out there; the
SHOULD is to encourage implementers to move forward. 

Now I need to go write the actual text to go into the draft, and the main
iSCSI draft will have to update RFC 3723 as part of this.

Thanks,
--David

_______________________________________________
storm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/storm