Subject: [storm] iSCSI MIB: Functional enhancements proposal

From: "Black, David" <[email-masked]>
Date: Fri, 14 Sep 2012 21:06:13 -0400

The iSCSI MIB has been waiting for a WG decision about what to incorporate from
the list of functional enhancements suggested by the MIB Doctor review.

With <WG chair hat off>, based on consulting with the MIB draft editors, I offer
the following initial proposal for the WG's consideration ... in the hope of
getting to a decision.

--- Make the following functional enhancements:

[1] Add NOP counters at iSCSI session scope for heartbeat tracking
[2] Add a port number to the iscsiTgtLoginFailure and iscsiIntrLoginFailure notifications,
	and to the last failure info in iscsiInitiatorAttributesEntry.
[3] Add a description string to the iSCSI portal:

iscsiPortalDescr OBJECT-TYPE
    SYNTAX        SnmpAdminString
    MAX-ACCESS    read-only
    STATUS        current
    DESCRIPTION
        "A UTF-8 string, determined by the implementation to
        describe the iSCSI portal.  When only a single instance
        is present, this object may be set to the zero-length
        string; with multiple iSCSI portals, it may be used in
        an implementation-dependent manner to describe the 
        respective portal, and could include information such as
        HBA model, description and version or software driver and
        version."

[4] Support "Target Unmapped" session failure reporting in the iscsiInstSessionFailure notification:

Editors: FailureType is an OID pointing to a stat in iscsiInstSsnErrorStatsTable, so we would need to add this:

    iscsiInstSsnTgtUnmappedErrors       Counter32

[5] Add a port number to iscsiPortalAttributesEntry

[6] Add a timeout counter to iscsiInitiatorLogoutStatsEntry to distinguish implicit
	logouts caused by timeouts from implicit logouts caused by other reasons.

--- Do not make any other functional enhancements, including the following

[A] Summary notifications for large numbers of targets or initiators.  (At most
	a single summary with a count would be appropriate for each notification type).
[B] RowPointer or other connection to transport state as part of
	iscsiInstanceSsnErrorStatsEntry (can be found indirectly in current structure).
[C] Support for reporting more than two digest algorithms (only one is standardized).
[D] Additional list of authentication methods for negotiation (already available based
	on reporting of authorized entities).
[E] Additional support for mutual authentication (check the MIBs at both ends instead).
[F] Support for digest provisioning at the iSCSI node level (use iSCSI portal instead).
[G] Additional session reporting, including digest, error recovery level, session type
	and additional counters for missing PDUs, data in PDUs, data out PDUs, async PDUs.
[H] Report initial remote IP address and port for connections in addition to actual
	IP address and port - this would be for situations in which a redirection has
	occurred.
[I] Report list of discovered targets (out of scope for this MIB).

--------------------

Of the above list, I'd be particularly interested in comments on [A], [G] and [H] -
if these were added to the MIB, would they be likely to be implemented and used?

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: "Black, David" <[email-masked]>
Date: Fri, 21 Sep 2012 15:55:00 -0400

In order to move forward, I suggest that the authors make the functional
changes [1] - [6], not make changes [A] - [F] and [I}, and use their
best judgment on what (if anything) to do about [G] and [H]

> 	IP address and port - this would be for situations in which a redirection has

Please submit a revised version of the MIB draft soon.

Thanks,
--David (storm WG co-chair).

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Black, David
> Sent: Friday, September 14, 2012 9:06 PM
> To: [email-masked]
> Subject: [storm] iSCSI MIB: Functional enhancements proposal
> 
> Editors: FailureType is an OID pointing to a stat in
> iscsiInstSsnErrorStatsTable, so we would need to add this:
> 
> _______________________________________________
> storm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/storm

---

From: Mark Bakke <[email-masked]>
Date: Tue, 25 Sep 2012 14:47:08 -0500

David, this makes sense to me.  I haven't heard any other comments asking for more than this.

We will publish a new draft soon.

Mark

-----Original Message-----
From: Black, David [mailto:[email-masked]] 
Sent: Friday, September 21, 2012 2:55 PM
To: Black, David; [email-masked]
Subject: Re: [storm] iSCSI MIB: Functional enhancements proposal
Importance: High

In order to move forward, I suggest that the authors make the functional changes [1] - [6], not make changes [A] - [F] and [I}, and use their best judgment on what (if anything) to do about [G] and [H]

Thanks,

> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Black, David
> The iSCSI MIB has been waiting for a WG decision about what to 
> incorporate from the list of functional enhancements suggested by the MIB Doctor review.
> 
> With <WG chair hat off>, based on consulting with the MIB draft 
> editors, I offer the following initial proposal for the WG's 
> consideration ... in the hope of getting to a decision.
> 
> [1] Add NOP counters at iSCSI session scope for heartbeat tracking [2] 
> Add a port number to the iscsiTgtLoginFailure and iscsiIntrLoginFailure notifications,
> Of the above list, I'd be particularly interested in comments on [A], 
> [G] and [H] - if these were added to the MIB, would they be likely to 
> be implemented and used?
> 
> Thanks,
> --David
> David L. Black, Distinguished Engineer EMC Corporation, 176 South St., 
> Hopkinton, MA  01748