Subject: [storm] RFC 7306 on Remote Direct Memory Access (RDMA) Protocol Extensions

From: [email-masked]
Date: Thu, 26 Jun 2014 17:27:06 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 7306

        Title:      Remote Direct Memory Access (RDMA) 
                    Protocol Extensions 
        Author:     H. Shah, F. Marti,
                    W. Noureddine, A. Eiriksson,
                    R. Sharp
        Status:     Standards Track
        Stream:     IETF
        Date:       June 2014
        Mailbox:    [email-masked], 
                    [email-masked], 
                    [email-masked], 
                    [email-masked], 
                    [email-masked]
        Pages:      34
        Characters: 73986
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-storm-rdmap-ext-10.txt

        URL:        http://www.rfc-editor.org/rfc/rfc7306.txt

This document specifies extensions to the IETF Remote Direct Memory Access
Protocol (RDMAP) as specified in RFC 5040.  RDMAP provides read and write
services directly to applications and enables data to be transferred 
directly into Upper-Layer Protocol (ULP) Buffers without intermediate data 
copies.  The extensions specified in this document provide the following 
capabilities and/or improvements: Atomic Operations and Immediate Data.

This document is a product of the STORage Maintenance Working Group of the IETF.

This is now a Proposed Standard.

STANDARDS TRACK: This document specifies an Internet standards track
protocol for the Internet community,and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Internet
Official Protocol Standards (STD 1) for the standardization state and
status of this protocol.  Distribution of this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  http://www.ietf.org/mailman/listinfo/ietf-announce
  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see http://www.rfc-editor.org/search
For downloading RFCs, see http://www.rfc-editor.org/rfc.html

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: "Black, David" <[email-masked]>
Date: Thu, 26 Jun 2014 20:45:12 -0400

Congratulations to the authors on publication of this RFC and many thanks
to everyone who helped!

I also want to extend kudos to this set of authors for proving that it
is in fact possible to complete the "Authors 48 Hours" step of the IETF
RFC Publication process within 48 hours (!).  I've been involved in many
RFCs for which AUTH48 took much longer - nicely done, take a (virtual) bow!

The plan is for the storm WG to remain in existence for a while, as
there are a number of possibilities for additional storage-related
maintenance work that include:

- an earlier (now expired) draft on further RDMAP extensions,
- extensions to iSNS to better support iSER implementations that start
	up in RDMA (zero-copy) mode, and
- replacement of the stringprep profile for iSCSI with something better
	once the work over in the précis WG makes a bit more progress.

Thanks,
--David

-----Original Message-----
From: storm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, June 26, 2014 8:27 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [storm] RFC 7306 on Remote Direct Memory Access (RDMA) Protocol Extensions

        RFC 7306

The RFC Editor Team

_______________________________________________
storm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/storm