Subject: [storm] FW: I-D Action: draft-talpey-rdma-commit-00.txt

From: Tom Talpey <[email-masked]>
Date: Mon, 22 Feb 2016 19:20:51 +0000

This individual Draft may be of interest to folks on the STORM list.

FYI:

-----Original Message-----

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

         Title           : RDMA Durable Write Commit
         Authors         : Tom Talpey
                           Jim Pinkerton
                           <>
	Filename        : draft-talpey-rdma-commit-00.txt
	Pages           : 24
	Date            : 2016-02-19

Abstract:
    This document specifies extensions to RDMA protocols to provide
    capabilities in support of enhanced remotely-directed data
    consistency.  The extensions include a new operation supporting
    remote commitment to durability of remotely-managed buffers, which
    can provide enhanced guarantees and improve performance for low-
    latency storage applications.  In addition to, and in support of
    these, extensions to local behaviors are described, which may be used
    to guide implementation, and to ease adoption.  This document would
    extend the IETF Remote Direct Memory Access Protocol (RDMAP),
    RFC5040, and RDMA Protocol Extensions, RFC7306.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-talpey-rdma-commit/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-talpey-rdma-commit-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Yaron Klein <[email-masked]>
Date: Mon, 22 Feb 2016 12:24:19 -0800

Thanks Tom,

I assume this is a continuation of your presentation from last SDC:

http://www.snia.org/sites/default/files/SDC15_presentations/persistant_mem/Talpey-Remote_Access_Storage.pdf

What is the current status of it in IETF? Does it have a WG assigned to it?

Yaron

-----Original Message-----
From: storm [mailto:[email-masked]] On Behalf Of Tom Talpey
Sent: Monday, February 22, 2016 9:21 PM
To: [email-masked]
Subject: [storm] FW: I-D Action: draft-talpey-rdma-commit-00.txt

FYI:

-----Original Message-----

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Abstract:

_______________________________________________
storm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/storm

CONFIDENTIAL COMMUNICATION:  This communication including any attached file(s) is CONFIDENTIAL, intended only for the named recipient (s) above and contains trade secrets or other information that is exempt from disclosure under applicable law.  Any use, dissemination, distribution or copying of this communication and any file attachments by anyone other than the named recipient (s) is strictly prohibited. If you have received this communication in error, please immediately notify us by reply electronic mail and permanently delete the original transmission and any attachments from your computer system and any copies of this message and file attachments. Thank you.

---

From: "Black, David" <[email-masked]>
Date: Tue, 23 Feb 2016 17:13:55 +0000

Yaron,

> What is the current status of it in IETF? Does it have a WG assigned to it?

No (or at least not yet) - this is a just-submitted -00 individual draft.
The draft name will change to draft-<wgname>-... if/when assigned to a WG.

Discussion should be here ([email-masked]) list for now.

Thanks, --David

> From: storm [mailto:[email-masked]] On Behalf Of Yaron Klein
> Sent: Monday, February 22, 2016 3:24 PM
> To: Tom Talpey; [email-masked]
> Subject: Re: [storm] I-D Action: draft-talpey-rdma-commit-00.txt
> 
> Thanks Tom,
> 
> CONFIDENTIAL COMMUNICATION:  This communication including any attached
> file(s) is CONFIDENTIAL, intended only for the named recipient (s) above and
> contains trade secrets or other information that is exempt from disclosure under
> applicable law.  Any use, dissemination, distribution or copying of this
> communication and any file attachments by anyone other than the named
> recipient (s) is strictly prohibited. If you have received this communication in
> error, please immediately notify us by reply electronic mail and permanently
> delete the original transmission and any attachments from your computer system
> and any copies of this message and file attachments. Thank you.
>

---

From: Tom Talpey <[email-masked]>
Date: Tue, 23 Feb 2016 14:50:27 -0800

>> I assume this is a continuation of your presentation from last SDC:

Yes it is, and also a continued discussion at the SNIA NVM Summit in
January: http://www.snia.org/nvmsummit/abstracts#13

These presentations, and the SNIA NVM TWG discussions, have been
focused on higher level behaviors and requirements, and they have
deferred making specific protocol proposals. Of course, protocols are
also needed, and this draft is intended to begin that conversation,
in this case of iWARP, in the IETF.

However, many of the protocol principles apply to any RDMA protocol.
You can see in the draft that the question is not limited to protocols,
in fact. It's my hope that discussion in IETF can help guide all such
efforts.

Thanks in advance for any comments on this work in progress.

Tom.