Subject: [Stox] WG Review: SIP-TO-XMPP (stox)

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 3 Jun 2013 10:58:57 +0000

Hi,

I have two comments concerning this charter. 

1. The way the Objectives section is written does not make clear whether the current scope of stox is dully defined as making out of the draft-saintandre-sip-xmpp-* Proposed Standard RFCs, or whether other proposals for the same mapping functionality (if submitted) will be considered. 

2. It is very unusual that there are no proposed milestones for a document submitted for public review. I am pretty sure that the IESG will not approved the charter without seeing the milestones scheduled, so I suggest that they are made public before the IESG discussion. 

Thanks and Regards,

Dan

Subject: WG Review: SIP-TO-XMPP (stox)

A new IETF working group has been proposed in the Real-time Applications and Infrastructure Area. The IESG has not made any determination yet. The following draft charter was submitted, and is provided for informational purposes only. Please send your comments to the IESG mailing list (iesg at ietf.org) by 2013-06-10.

SIP-TO-XMPP (stox)
------------------------------------------------
Current Status: Proposed WG

Chairs:
  Markus Isomaki <[email-masked]>
  Yana Stamcheva <[email-masked]>

Assigned Area Director:
  Gonzalo Camarillo <[email-masked]>

Mailing list
  Address: [email-masked]
  To Subscribe: https://www.ietf.org/mailman/listinfo/stox
  Archive: http://www.ietf.org/mail-archive/web/stox/

Charter:

Problem Statement

The IETF has defined two signalling technologies that can be used for multimedia session negotiation, instant messaging, presence, file transfer, capabilities discovery, notifications, and other types of real-time functionality:

o  The Session Initiation Protocol (SIP), along with various SIP
   extensions developed within the SIP for Instant Messaging and
   Presence Leveraging Extensions (SIMPLE) Working Group.

o  The Extensible Messaging and Presence Protocol (XMPP), along
   with various XMPP extensions developed by the IETF as well as by
   the XMPP Standards Foundation.

SIP has been focused primarily on media session negotiation (e.g., audio and video), whereas XMPP has been focused primarily on messaging and presence.  As a result, the technologies are mostly complementary.
However, there is also some overlap between SIP and XMPP, since there are SIP extensions for messaging, presence, groupchat, file transfer, etc., and there are XMPP extensions for multimedia session negotiation.
This overlap has practical implications, since some deployed services use SIP for both media and messaging/presence, whereas other deployed services use XMPP for both messaging/presence and media.  When such services wish to exchange information, they often need to translate their native protocol (either SIP or XMPP) to the other protocol (either XMPP or SIP).

Implementers needing to perform such protocol mappings have often worked out their own heuristics for doing so.  Unfortunately, these heuristics are not always consistent, which can lead to interoperability problems.

Objectives

To make it easier for implementers to enable interworking between SIP-based systems and XMPP-based systems, several Internet-Drafts have defined guidelines for protocol mapping between SIP and XMPP, starting with draft-saintandre-xmpp-simple-00 in early 2004.  The current documents are:

-core
draft-saintandre-sip-xmpp-presence
draft-saintandre-sip-xmpp-im
draft-saintandre-sip-xmpp-chat
draft-saintandre-sip-xmpp-groupchat
draft-saintandre-sip-xmpp-media

These documents are fairly stable and the authors have received feedback from a number of implementers over the years.  However, implementers do not always know about these documents because they are Internet-Drafts and sometimes they have become expired due to inactivity.  Thus it would be helpful to polish them off and publish them as RFCs.

It might also be helpful to at some point publish additional documents in

the same series, covering topics like capabilities discovery and file transfer.  However, any such work would require a recharter.

The group shall not be tasked with defining any new protocols, only with specifying mappings between existing protocols that have been defined for SIP and XMPP.

Deliverables

1. Address mapping and error handling
2. Presence mapping
3. Mapping for single instant messages
4. Mapping for one-to-one text chat sessions 5. Mapping for multi-user text chat sessions 6. Mapping for media signaling

All of the foregoing deliverables are standards track, since they are subject to interoperability testing.

Milestones:
TBD

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 03 Jun 2013 16:33:00 -0600

On 6/3/13 4:58 AM, Romascanu, Dan (Dan) wrote:
> 1. The way the Objectives section is written does not make clear
> whether the current scope of stox is dully defined as making out of
> the draft-saintandre-sip-xmpp-* Proposed Standard RFCs, or whether
> other proposals for the same mapping functionality (if submitted)
> will be considered.

Your phrase "dully defined" is spot on: this topic is so dull that I
very much doubt that other proposals will be forthcoming! However, you
are right that the charter should probably say that those I-D are likely
(but not certain) starting points.

How about this?

OLD
These documents are fairly stable and the authors have received feedback
from a number of implementers over the years.  However, implementers do
not always know about these documents because they are Internet-Drafts
and sometimes they have become expired due to inactivity.  Thus it would
be helpful to polish them off and publish them as RFCs.

NEW
Those documents are fairly stable and the authors have received feedback
from a number of implementers over the years.  However, implementers do
not always know that such mapping specifications exist, because they are
Internet-Drafts and sometimes they have become expired due to
inactivity.  Thus it would be helpful to publish a set of mapping
specifications as RFCs; the foregoing Internet-Drafts provide likely
starting points, but other proposals are welcome as per normal IETF
working group processes.

> 2. It is very unusual that there are no proposed milestones for a
> document submitted for public review. I am pretty sure that the IESG
> will not approved the charter without seeing the milestones
> scheduled, so I suggest that they are made public before the IESG
> discussion.

Personally I think that they can all be submitted for IESG review before
IETF 88, and perhaps even well before that.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 4 Jun 2013 08:55:07 +0000

Hi Peter, 

Thank you for your answers. 

Please see in-line. 

Regards,

Dan

> -----Original Message-----
> From: Peter Saint-Andre [mailto:[email-masked]]
> Sent: Tuesday, June 04, 2013 1:33 AM
> To: Romascanu, Dan (Dan)
> Cc: The IESG; [email-masked]
> Subject: Re: [Stox] WG Review: SIP-TO-XMPP (stox)
> 
> > other proposals for the same mapping functionality (if submitted) will
> > be considered.
> 
[[DR]] looks good

> > will not approved the charter without seeing the milestones scheduled,
> > so I suggest that they are made public before the IESG discussion.
> 
[[DR]] so October 2013 as submission date for all documents? I suggest to add these to the proposed charter (unless somebody disagrees)

---

From: <[email-masked]>
Date: Tue, 4 Jun 2013 09:44:56 +0000

Hi Dan, Peter,

I agree with Peter on that there are not that many different, yet meaningful, ways to do protocol mappings between SIP and XMPP. The current drafts have been around for a while and the all comments so far have been generally positive that they are a good way to go. So, it is unlikely that we would receive radically different and "competing" proposals. Having said that, I agree we should leave the opportunity for anyone to submit such proposals for WG's consideration. I believe Peter's new charter text proposal covers that. 

Markus  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Peter Saint-Andre
Sent: 04 June, 2013 01:33
To: Romascanu, Dan (Dan)
Cc: [email-masked]; The IESG
Subject: Re: [Stox] WG Review: SIP-TO-XMPP (stox)

> other proposals for the same mapping functionality (if submitted) will 

Your phrase "dully defined" is spot on: this topic is so dull that I very much doubt that other proposals will be forthcoming! However, you are right that the charter should probably say that those I-D are likely (but not certain) starting points.

How about this?

OLD

NEW
Those documents are fairly stable and the authors have received feedback from a number of implementers over the years.  However, implementers do not always know that such mapping specifications exist, because they are Internet-Drafts and sometimes they have become expired due to inactivity.  Thus it would be helpful to publish a set of mapping specifications as RFCs; the foregoing Internet-Drafts provide likely starting points, but other proposals are welcome as per normal IETF working group processes.

> so I suggest that they are made public before the IESG discussion.

Personally I think that they can all be submitted for IESG review before IETF 88, and perhaps even well before that.

Peter

--
Peter Saint-Andre
https://stpeter.im/

_______________________________________________
stox mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/stox

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 04 Jun 2013 11:33:39 -0600

>> starting points, but other proposals are welcome as per normal IETF

Great.

> [[DR]] so October 2013 as submission date for all documents? I suggest to add these to the proposed charter (unless somebody disagrees)

It might not be good to send all of the documents to the IESG at the
same time. What do IESG members and the chairs think about the order?
Would it make sense to hold WGLC, IETF Last Call, and IESG review about
the whole bundle at the same time? I worry slightly about pushing them
all through simultaneously, but I suppose the total page count is not
huge (smaller than RFC 3261 or RFC 6120).

Peter

-- 
Peter Saint-Andre
https://stpeter.im/