Subject: [Stox] Maturity of the documents

From: <[email-masked]>
Date: Wed, 19 Jun 2013 11:01:30 +0000

Hi,

The chairs have started a consensus call on adopting the 'draft-saintandre-sip-xmpp-' documents as WG items. Please send your feedback on it by replying to the separate mail about the topic.

Somewhat independently of the WG adoption, here is my current understanding of the maturity of these documents (as a co-chair). This is based on my own reading as well as discussion with some of the co-authors.

These documents seem to be in a good shape and will mainly just need reviews:

saintandre-sip-xmpp-core

saintandre-sip-xmpp-presence

saintandre-sip-xmpp-im

saintandre-sip-xmpp-chat

This document still has open issues. The co-authors are already working on an update, but further work will still be needed:

saintandre-sip-xmpp-groupchat

This document requires most work still. It is in my understanding the most complex piece of these mappings:

saintandre-sip-xmpp-media

This is just a very informal categorization and people are of course welcome to raise any issues or send improvement suggestions with any of these documents still even if we adopt them as WG documents.

Markus

---

From: Mary Barnes <[email-masked]>
Date: Wed, 19 Jun 2013 09:28:02 -0500

I fully support this proposal.  Although, there were concerns raised
during chartering that it seemed that the WG would just fell swoop
adopt this documents - I personally feel that enough time has elapsed
for someone to do that if they had the intention.  But, it might be
good to set a deadline on this proposal for adopting these as WG
documents and make that the same deadline for anyone with alternative
proposals towards the milestones.

Regards,
Mary.

On Wed, Jun 19, 2013 at 6:01 AM,  <[email-masked]> wrote:
> Hi,
>
>
>
> The chairs have started a consensus call on adopting the
> ‘draft-saintandre-sip-xmpp-’ documents as WG items. Please send your
> feedback on it by replying to the separate mail about the topic.
>
>
>
> Somewhat independently of the WG adoption, here is my current understanding
> of the maturity of these documents (as a co-chair). This is based on my own
> reading as well as discussion with some of the co-authors.
>
>
>
> This document still has open issues. The co-authors are already working on
> an update, but further work will still be needed:
>
>
>
> This is just a very informal categorization and people are of course welcome
> to raise any issues or send improvement suggestions with any of these
> documents still even if we adopt them as WG documents.
>
>
>
> Markus
>
>
>
>
> _______________________________________________
> stox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stox
>

---

From: Mary Barnes <[email-masked]>
Date: Wed, 19 Jun 2013 09:31:07 -0500

Sorry - I should have read all the emails as I see the deadline in this email:
http://www.ietf.org/mail-archive/web/stox/current/msg00058.html
So, maybe just be explicit that this is the deadline for any
alternative proposals.

Thanks,
Mary.

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 19 Jun 2013 11:24:29 -0600

On 6/19/13 5:01 AM, [email-masked] wrote:

> This document still has open issues. The co-authors are already working
> on an update, but further work will still be needed:
> 

Saúl, Salvatore, and I plan to submit a revised I-D for the groupchat
document by the end of this week.

> saintandre-sip-xmpp-media

Yes, we need to have more discussion about that one. There is a great
deal of flux happening in this space right now (e.g., WebRTC using raw
SDP -- or not, as being discussed right now in the RTCWEB WG).

Peter

-- 
Peter Saint-Andre
https://stpeter.im/