Subject: [Stox] Review of -core

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Tue, 30 Jul 2013 15:41:42 +0200

Hi,

As promised, here is my review of the -core document:

- Sec 4.3 defines instant specific mapping, which maps a public GRUU to a full JID and vice versa, but doesn't contain any text on temporary GRUUs. They take the following form: sip:[email-masked]:5060;gr. I don't think we can work with those, since there is nothing we can map to the resource part of the full JID, so I think we need some text to clarify this.

- Sec 5.1 maps the XMPP unexpected-request error to SIP code 491, which is very tied to the dialog semantics IMHO. I tried to find a better matching code but I couldn't though. Maybe a 500 with a reasonable Retry-After header value?

- Sec 5.1 should me map the SIP outbound (RFC5626) error codes? Those are 430, and 439 which could be translated to bad-request.

* Editorial nits:

- Sec 3: "This assumption not meant" -> "This assumption is not meant"

Cheers,

--
Saúl Ibarra Corretgé
AG Projects

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 31 Jul 2013 16:24:29 +0200

> As promised, here is my review of the -core document:

Many thanks for the review.

> - Sec 4.3 defines instant specific mapping, which maps a public GRUU
> to a full JID and vice versa, but doesn't contain any text on
> temporary GRUUs. They take the following form:
> sip:[email-masked]:5060;gr. I don't think we can work with
> those, since there is nothing we can map to the resource part of the
> full JID, so I think we need some text to clarify this.

Agreed on temporary GRUUs. IMHO we'll need to add a note about that (but
I haven't yet had time to propose text).

> - Sec 5.1 maps the XMPP unexpected-request error to SIP code 491,
> which is very tied to the dialog semantics IMHO. I tried to find a
> better matching code but I couldn't though. Maybe a 500 with a
> reasonable Retry-After header value?

It seems to me that we'd want it to be a 4xx series error, but I don't
see a good one in RFC 3261.

> - Sec 5.1 should me map the SIP outbound (RFC5626) error codes? Those
> are 430, and 439 which could be translated to bad-request.

Could you explain the scenarios where outbound-related error codes might
be used? Feel free to say "just read RFC 5626". :-)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Wed, 31 Jul 2013 16:42:31 +0200

> see a good one in RFC 3261.

Exactly my thought.

> be used? Feel free to say "just read RFC 5626". :-)

A 430 may occur if the gateway sends a SIP INVITE to the target domain and the edge proxy which handles the INVITE gets a flow error from the authoritative proxy behind him. Forget about 439, that's for REGISTERs, sorry.

--
Saúl Ibarra Corretgé
AG Projects

---

From: "Olle E. Johansson" <[email-masked]>
Date: Wed, 31 Jul 2013 16:51:14 +0200

>> see a good one in RFC 3261.
"unexpected-request error" seems more like a server error - or does it point to the actual request?

/O
> _______________________________________________
> stox mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stox

---
* Olle E Johansson - [email-masked]
* Cell phone +46 70 593 68 51, Office +46 8 96 40 20, Sweden

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 31 Jul 2013 16:53:13 +0200

On 7/31/13 4:51 PM, Olle E. Johansson wrote:
> 
> 31 jul 2013 kl. 16:42 skrev Saúl Ibarra Corretgé <[email-masked]
> <mailto:[email-masked]>>:
> 
>>>
>>>

Not necessarily a server thing. E.g., you send me <iq type='result'/>
but I never sent you <iq type='get|set'/> (where "you" and "me" are
clients).

Peter

-- 
Peter Saint-Andre
https://stpeter.im/