Subject: [Stox] stox-presence-03: a couple of comments

From: <[email-masked]>
Date: Mon, 26 Aug 2013 12:34:23 +0000

Hi,

I have a couple of comments on the presence-03 draft:

* Some asymmetry between XMPP-to-SIP (3.2) and SIP-to-XMPP (3.3) directions

- 3.2.1 explains the DNS operations an XMPP domain uses to determine that the foreign domain does not support XMPP but actually supports SIP/SIMPLE. Presumably something similar is needed in the reverse direction, but this is not explained in 3.3.1. 
- The case where the subscription is rejected is covered in 3.3.1 but not in 3.2.1.

*200 OK to NOTIFY is missing in 3.2.1

- 3.2.1 shows a SIP 200 OK response to the SUBSCRIBE request (examples 2 and 3), not to the subsequent NOTIFY (example 4). The 200 OK to NOTIFY is not mapped to XMPP so it may be fine to leave it out but it could be added for clarity.

* SUBSCRIBE with Expires:0?

- In SIP it is possible to one-time query the presence-value by sending a SUBSCRIBE with Expires value 0. This triggers just a single NOTIFY. Does that work nicely through the mapping to XMPP, or is it a special case that would need to be separately covered?

Markus

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Mon, 26 Aug 2013 14:53:49 +0200

> - In SIP it is possible to one-time query the presence-value by sending a SUBSCRIBE with Expires value 0. This triggers just a single NOTIFY. Does that work nicely through the mapping to XMPP, or i…

Not sure if we have text about that, but basically it would be the same as sending a presence stanza of type 'probe'.

--
Saúl Ibarra Corretgé
AG Projects

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 26 Aug 2013 16:27:29 -0600

On 8/26/13 6:53 AM, Saúl Ibarra Corretgé wrote:
>> - In SIP it is possible to one-time query the presence-value by
>> sending a SUBSCRIBE with Expires value 0. This triggers just a
>> single NOTIFY. Does that work nicely through the mapping to XMPP,
>> or is it a special case that would need to be separately covered?
>> 
> 
> Not sure if we have text about that, but basically it would be the
> same as sending a presence stanza of type 'probe'.

Yes, one can send a probe, but unless you're already authorized to view
the person's presence (through a long-lived subscription) you won't
actually receive the presence data. I suppose the SIMPLE-XMPP gateway
would keep track of the long-lived subscription and would translate the
SUBSCRIBE with Expires:0 to a probe on the XMPP side. That would work.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 26 Aug 2013 16:49:29 -0600

> Hi,

Hi Markus, thanks for the feedback.

> - 3.2.1 explains the DNS operations an XMPP domain uses to determine
> that the foreign domain does not support XMPP but actually supports
> SIP/SIMPLE. Presumably something similar is needed in the reverse
> direction, but this is not explained in 3.3.1. - The case where the
> subscription is rejected is covered in 3.3.1 but not in 3.2.1.

Good point. We'll add something about that.

> - 3.2.1 shows a SIP 200 OK response to the SUBSCRIBE request
> (examples 2 and 3), not to the subsequent NOTIFY (example 4). The 200
> OK to NOTIFY is not mapped to XMPP so it may be fine to leave it out
> but it could be added for clarity.

Agreed. Clarity is good. :-)

> sending a SUBSCRIBE with Expires value 0. This triggers just a single
> NOTIFY. Does that work nicely through the mapping to XMPP, or is it a
> special case that would need to be separately covered?

See my reply to Saúl. I think it would be reasonable to mention that.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/