Subject: Re: [Stox] Review on -im

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Thu, 1 Aug 2013 10:01:36 +0200

Hi Markus,

On Jul 31, 2013, at 6:24 PM, [email-masked] wrote:

> Hi Saul, Peter,
> 
> Saúl Ibarra Corretgé wrote:
>>> 
>>> Well, the sender might really really want to know if the message was
>>> delivered to the recipient. :-)
>>> 
>> 
>> Unfortunately there is no way to do that with a SIP MESSAGE. Unless we
>> invent a special payload for acknowledging reception of a given SIP
>> MESSAGE, but I think that is really out of the scope of what we are doing in
>> the IM document.
>> 
> 
> Please take a look at RFC 5438 (http://datatracker.ietf.org/doc/rfc5438/) and see if it applies to what would be required.
> 

I had completely forgotten about this one, thanks for the pointer! Indeed this could be used to map receipts for SIP MESSAGE. Now, this is in a different spec to that which defines SIP MESSAGE, whereas MSRP reporting is baked into the protocol itself. Personally, I would define th empaling for MSRP, because REPORT is part of the protocol, and leave it out from IM, at least for the moment.

Peter added this to his slides, so I guess we'll discuss it in today's meeting.

--
Saúl Ibarra Corretgé
AG Projects

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Aug 2013 10:29:13 +0200

> Peter added this to his slides, so I guess we'll discuss it in today's meeting.

I didn't add RFC 5438 to my slides, though, because I too had forgotten
about it.

One piece of data that would be helpful is to know how widely RFC 5438
is implemented, in comparison to RFC 4975. IMHO what we're trying to do
in this WG is to describe practical interworking between SIP and XMPP.
If a particular SIP or XMPP method is not widely implemented, I say that
we don't talk about it because it's purely theoretical (e.g., I removed
everything about XEP-0155). Thus some input on that point would be
helpful here.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: <[email-masked]>
Date: Thu, 1 Aug 2013 08:52:19 +0000

Hi,

Peter Saint-Andre wrote:
> 
> I didn't add RFC 5438 to my slides, though, because I too had forgotten about
> it.
> 
> One piece of data that would be helpful is to know how widely RFC 5438 is
> implemented, in comparison to RFC 4975. IMHO what we're trying to do in
> this WG is to describe practical interworking between SIP and XMPP.
> If a particular SIP or XMPP method is not widely implemented, I say that we
> don't talk about it because it's purely theoretical (e.g., I removed everything
> about XEP-0155). Thus some input on that point would be helpful here.
> 

I agree with the principle of including only methods that are supported by real client implementations, especially related to specs that are a few years old already. 

I have not personally heard about RFC 5438 implementations. So unless someone has other info, I'm fine with excluding it from the stox-im spec.

Markus

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Thu, 1 Aug 2013 10:55:25 +0200

> I have not personally heard about RFC 5438 implementations. So unless someone has other info, I'm fine with excluding it from the stox-im spec.

FWIW, I haven't seen any myself either.

--
Saúl Ibarra Corretgé
AG Projects

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Aug 2013 10:57:45 +0200

> FWIW, I haven't seen any myself either.

Thanks for the data points!

Peter

-- 
Peter Saint-Andre
https://stpeter.im/