Subject: [Stox] media: mapping a=fmtp to jingle

From: Philipp Hancke <[email-masked]>
Date: Sun, 04 Aug 2013 20:57:03 +0200

The main problem of mapping a=fmtp to jingle and vice versa is that 
jingle has assumed that fmtp is always key-value separated by colons.
See http://xmpp.org/extensions/xep-0167.html#format at the bottom of 
section 4. Several implementors apparently noticed that the text is 
wrong and created workarounds.

I suspect the reasonable advice for the gateway is to translate lines 
with key-value pairs separated by semicolons as described in XEP-0167 
and pick one of the following ways to deal with non-key-value lines:
1) map to <parameter name='' value='thestuff'/> (used by gmail afaik)
2) map to <param name='thestuff' value=''/>
3) map to <param name='attributes'>thestuff</param>
    (XEP-0293/0294 recommend something similar)

How sensitive are SDP implementations in parsing different key-value 
variants (e.g. "key=value;key2=value" vs "key=value; key2=value2"?

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Wed, 7 Aug 2013 23:59:00 +0200

Hi Philipp!

On Aug 4, 2013, at 8:57 PM, Philipp Hancke wrote:

> The main problem of mapping a=fmtp to jingle and vice versa is that jingle has assumed that fmtp is always key-value separated by colons.
> See http://xmpp.org/extensions/xep-0167.html#format at the bottom of section 4. Several implementors apparently noticed that the text is wrong and created workarounds.
> 
> I suspect the reasonable advice for the gateway is to translate lines with key-value pairs separated by semicolons as described in XEP-0167 and pick one of the following ways to deal with non-key-value lines:

I'd go with this one.

> How sensitive are SDP implementations in parsing different key-value variants (e.g. "key=value;key2=value" vs "key=value; key2=value2"?
> 

I think they usually just treat it as a freeform text.

--
Saúl Ibarra Corretgé
AG Projects