Subject: Re: [Stox] Communication between STOX-capable and non-STOX-capable entities

From: Matt Ryan <[email-masked]>
Date: Mon, 02 Jun 2014 11:05:52 -0600

Further comments in line.

On 5/29/14, 8:48 AM, Matt Ryan wrote:
> Saúl and Peter, thanks for your input on my question.
> 
> I agree that this is the approach we should take.  This direction
> is supported by RFC 7427 (previously draft-ietf-stox-core) where
> the responsibility for determining the format for communication
> and translating if required is put upon the sending server and
> it's accompanying gateway, and not upon the receiving server.
> 
> Because of this, I have further concerns with
> draft-ietf-stox-chat-06 as well as with
> draft-ietf-stox-groupchat-04.  I will enumerate these each
> separately in their own review emails.

For simplicity's sake let me just enumerate my general suggestion
instead of separate review emails for each pertinent draft.  My
apologies for being indecisive.

I suggest the drafts contain some formal language indicating the
assumptions that should be followed on each side in order to emphasize
the interoperability point.

For example:
- - Given a server sending a message to another server with a different
protocol, the sending server doesn't know whether the receiving server
supports STOX, and interoperability is a goal, so there should be
language indicating that the server SHOULD (MUST?) support sender-side
translation of messages from one protocol to the other.
- - Because a receiving server might be receiving messages from a sender
that does not support STOX, the receiving server SHOULD support
destination-side translation of messages from one protocol to the other.

I believe this is in harmony both with RFC 7247 and the clarification
I received in answer to my question, and that such language would both
support and emphasize these two important points.

> But in summary, the concerns are that the examples given in these
> drafts show the gateways on both sides of communication as being
> involved in exchanges where they should not be required, and that
> showing the involvement of both gateways gives the impression that
> both ARE required.
> 
> In other words, it does not emphasize the point that STOX-capable 
> servers must be able to communicate effectively with
> non-STOX-capable servers, which it seems we agree is important.

I believe the discussion in a separate thread addresses this concern
for me, wherein we've talked about reworking the examples in the
drafts to not show the receiving-side gateway in the diagrams.

> 
> 
> On 5/29/14, 6:46 AM, Peter Saint-Andre wrote:
>> On 5/28/14, 6:37 AM, Saúl Ibarra Corretgé wrote:
>>> Hi Matt,
>>> 
>>> On May 20, 2014, at 4:36 AM, Matt Ryan wrote:
>>> 
>>>> -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA512
>>>> 
>>>> Should a STOX-capable server be able to communicate with a 
>>>> non-STOX-capable server, so long as the communication is 
>>>> started by the STOX-capable server?  Is this among the
>>>> current goals of the WG?
>>>> 
>>>> Sorry if this has been covered - but this particular point 
>>>> remains unclear to me despite numerous readings through 
>>>> draft-ietf-stox-core and some of the other supporting
>>>> drafts.
>>>> 
>>>> 
>>>> Let me provide a simple example to explain what I mean.
>>>> 
>>>> Suppose an XMPP client initiates a chat to a user that
>>>> happens to be a SIP client user.  Per draft-ietf-stox-chat,
>>>> this request flows through the XMPP Server which determines
>>>> that the message is targeted to a SIP user, and then invokes
>>>> its own XMPP-to-SIP Gateway to translate the request to a SIP
>>>> request and send that request on to the appropriate SIP
>>>> server.
>>>> 
>>>> So far, the XMPP Server knows that the target user is a SIP 
>>>> user, but does not know anything about the SIP Server 
>>>> capabilities other than that it is (presumably) a SIP server.
>>>>  Importantly, the XMPP Server does not know whether the SIP 
>>>> Server also supports a SIP-to-XMPP gateway.
>>>> 
>>>> 
>>>> This is where my question comes.  Given the described XMPP 
>>>> Server with a corresponding XMPP-to-SIP gateway, is it meant
>>>> to be the case that this XMPP Server should be able to
>>>> communicate with any valid SIP server, so long as the
>>>> conversation is initiated by the XMPP Server?
>>>> 
>>>> 
>>>> This is an important point because it has direct impact on 
>>>> several of our current drafts.
>>>> 
>>> 
>>> The idea is that a STOX capable infrastructure is transparent
>>> to others. To the eyes of the world,  given domain, say
>>> example.com has SRV records for SIP and XMPP. The fact that
>>> there is an actual gateway handling the traffic and doing some
>>> translations is a detail of that infrastructure. So a non-STOX
>>> server should be able to communicate with a STOX server just
>>> fine.
> 
>> +1
> 
>> Peter
> 
> 
> 
> 

- -- 
Matt Ryan
Code Slinger  |  Jive Communications, Inc.
Jive.com  |  mryan at getjive dot com

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Mon, 23 Jun 2014 09:21:35 +0200

Hi Matt,

Sorry for the belated response.

> support and emphasize these two important points.

I need to go through the rest of the emails, but given that the heart of STOX is actual translation, I'm not sure if we need more working on that. It should be obvious since *that* is exactly what we are describing.

Cheers,

--
Saúl Ibarra Corretgé
AG Projects