Subject: [Stox] STOX WG status

From: <[email-masked]>
Date: Sun, 8 Jun 2014 20:27:06 +0000

Hi all,

Below you can find the chairs' view of the current status of the STOX WG documents. Comments and questions are welcome. 

---

  * draft-ietf-stox-core
     - Published as RFC 7247

  * draft-ietf-stox-presence
     - Published as RFC 7248
     - Will need an errata to address the FAIL [1] issue.

This documents are complete from STOX WG point of view.

---

  * draft-ietf-stox-im:
     - Initial WG last call already in December 2013
     - Latest update on March 11 
     - No issues, ready for AD review. Wait to move it together with -chat, though.
 
  * draft-ietf-stox-chat:
      - Initial WG last call already in December 2013
     - Latest update on March 11
     - Reviews received after the last update
     - New revision needed to address the review comments including FAIL. 

  * draft-ietf-stox-groupchat:
     - WG last call beginning of May
     - Reviews received during and after the last call
     - New version needed to address review comments including FAIL.

Target would be to get these above three documents to AD review within June/July timeframe. Peter, the main author in all of these, has been doing a good work with this set and has promised another round of updates in the next couple of weeks.

---

  * draft-ietf-stox-media:
    - Latest update on March 20
    - Still needs more work before considering WG last call

Target is to get this document to WG last call phase in August/September timeframe. The chairs have asked the co-authors about their plans and at least Peter and Saul have promised to get busy with this again still in June.

---

[1] stox-core defines separate gateways in SIP-to-XMPP and XMPP-to-SIP direction, respectively. However, only a single gateway entity is supposed to be used within one "instance" of communication: SIP-to-XMPP gateway is used when the communication is initiated from the SIP side, and vice versa. The message flow diagrams in stox-presecen, stox-chat and stox-groupchat however mistakenly always show two gateways being involved. See http://www.ietf.org/mail-archive/web/stox/current/msg00507.html for more details.

Regards,
	Markus & Yana

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 09 Jun 2014 20:52:06 -0600

>       - New revision needed to address the review comments including FAIL.

Done!

Peter