Subject: [straw] Signaling only B2BUA's

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 9 Aug 2012 15:00:46 +0000

Hi All,

During the IETF84 session Hadriel presented the different types of B2BUA (See http://www.ietf.org/proceedings/84/slides/slides-84-straw-2.ppt) 

I pointed out that a signalling-only B2BUA that does not handle media may still modify SDP and Hadriel indicated that we might need another category of B2BUA to cover that case. 

I checked the draft (http://tools.ietf.org/html/draft-kaplan-dispatch-b2bua-taxonomy-00#section-4.2) and it does not specifically say that a signalling-only B2BUA does not modify SDP but if that is what is meant then we may need to clarify that B2BUA's that don't terminate media may still modify SDP.

Regards
Andy

---

From: Hadriel Kaplan <[email-masked]>
Date: Sat, 11 Aug 2012 18:08:33 +0000

I think we might want to differentiate - the point of having separate definitions/types was if a future RFC (from STRAW or otherwise) defined something that needed to either be handled/processed or copied by some B2BUA types but not others, then it's worth disambiguating.  

For example, if there's a draft like the BUNDLE proposal in MMUSIC, then instead of saying something like "A B2BUA which modifies SDP but does not handle media blah blah, etc., etc., MUST do XYZ", we can say "A [RFC-STRAW-TAXONOMY] SDP-aware B2BUA MUST do XYZ."

-hadriel

On Aug 9, 2012, at 11:00 AM, Hutton, Andrew wrote:

> _______________________________________________
> straw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/straw

---

From: James Polk <[email-masked]>
Date: Tue, 21 Aug 2012 19:12:43 -0500

At 01:08 PM 8/11/2012, Hadriel Kaplan wrote:

>I think we might want to differentiate - the point of having 
>separate definitions/types was if a future RFC (from STRAW or 
>otherwise) defined something that needed to either be 
>handled/processed or copied by some B2BUA types but not others, then 
>it's worth disambiguating.
>
>For example, if there's a draft like the BUNDLE proposal in MMUSIC, 
>then instead of saying something like "A B2BUA which modifies SDP 
>but does not handle media blah blah, etc., etc., MUST do XYZ", we 
>can say "A [RFC-STRAW-TAXONOMY] SDP-aware B2BUA MUST do XYZ."

B2BUAs in a singling path always have the ability to muck with SDP, 
that's part of the problem with them. And don't get me started with 
the problems SBCs can cause...  ;-)

James

> > During the IETF84 session Hadriel presented the different types 
> of B2BUA (See http://www.ietf.org/proceedings/84/slides/slides-84-straw-2.ppt)
> >
> > I pointed out that a signalling-only B2BUA that does not handle 
> media may still modify SDP and Hadriel indicated that we might need 
> another category of B2BUA to cover that case.
> >
> > I checked the draft 
> (http://tools.ietf.org/html/draft-kaplan-dispatch-b2bua-taxonomy-00#section-4.2) 
> and it does not specifically say that a signalling-only B2BUA does 
> not modify SDP but if that is what is meant then we may need to 
> clarify that B2BUA's that don't terminate media may still modify SDP.
> >
> > Regards
> > Andy