Subject: [Suit] Format of the payload

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 23 Oct 2017 19:49:48 -0700

I wasn't able to understand the reasoning for standardizing payload format.

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 24 Oct 2017 08:12:03 +0000

Hi Suhas,

standardization (in general) helps in at least two areas:

a)      You have two vendors A and B. A customer buys the server side from vendor A and the client side from vendor B and the solution interworks.

b)      Industry expert define a mechanism that has gained sufficient review, is publically available and open source implementations are available. This allows an IoT developer to use a mechanism in his or her product without having to build his or her own system.

The manifest is kind of the hard part in this firmware update story (from a standardization point of view) since it also includes the security functionality.

Ciao
Hannes

From: Suit [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: 24 October 2017 04:50
To: [email-masked]
Subject: [Suit] Format of the payload

I wasn't able to understand the reasoning for standardizing payload format.
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.