Subject: [Suit] Firmware Server Discovery

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 23 Oct 2017 17:36:38 -0700

Hello All,

Finding out where to download firmware and that there is firmware available
is a key part of download the firmware and impacts the design of the
manifest.

We think selecting a simple approach to this needs to be included in scope
of the charter

Thanks
Suhas

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 24 Oct 2017 07:11:21 +0000

Hi Suhas,

The details of how to find the server for downloading a firmware image depend on the deployment and the protocols being used.
For example, we use LwM2M for the transport and for discovery.

The charter is specifically written to give flexibility. For example, someone deploying BLE devices that are connected using a smart phone app can use their infrastructure to push firmware images to devices.

Keeping the work focused will also help to ensure that we get somewhere.

Ciao
Hannes

From: Suit [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: 24 October 2017 02:37
To: [email-masked]
Subject: [Suit] Firmware Server Discovery

Hello All,

Finding out where to download firmware and that there is firmware available is a key part of download the firmware and impacts the design of the manifest.

We think selecting a simple approach to this needs to be included in scope of the charter

Thanks
Suhas
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Suhas Nandakumar <[email-masked]>
Date: Tue, 24 Oct 2017 14:25:50 -0700

Hi Hannes

    I do see a need for using other transport protocols to download the
firmware, however we want this solution to work on the Internet. As long as
we can have something to that effect, we are happy to live with other
protocols too, given various deployment options.

Thanks
Suhas

On Tue, Oct 24, 2017 at 12:11 AM, Hannes Tschofenig <
[email-masked]> wrote:

> Hi Suhas,
>
>
>
> The details of how to find the server for downloading a firmware image
> depend on the deployment and the protocols being used.
>
> The charter is specifically written to give flexibility. For example,
> someone deploying BLE devices that are connected using a smart phone app
> can use their infrastructure to push firmware images to devices.
>
>
>
> *From:* Suit [mailto:[email-masked]] *On Behalf Of *Suhas
> Nandakumar
> *Sent:* 24 October 2017 02:37
> *To:* [email-masked]
> *Subject:* [Suit] Firmware Server Discovery
>
>
>
> Hello All,
>
>
>
> Finding out where to download firmware and that there is firmware
> available is a key part of download the firmware and impacts the design of
> the manifest.
>
>
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>