Subject: [Suit] Encrypted Firmware

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 23 Oct 2017 19:48:14 -0700

While reading the manifest/architecture document there was mention to
support encrypted firmware.

We feel most devices don’t need firmware encrypted. It is also totally an
issue specific to that device and the vendor specific. The IETF work can
allow encrypted firmware but we don’t think that needs to be specified as
it is largely specific to how the IoT device vendor chose to do it.

Thanks

Suhas Nandakumar

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 24 Oct 2017 07:11:07 +0000

Hi Suhas,

While not every company may prefer to use encrypted firmware images we see them more frequently used for two reasons: first, companies are interested in protecting their intellectual property and second, probably more important for this IETF group, is that many attacks against embedded systems are much easier if you have access to the code. This is why many attacks typically start by obtaining the firmware image first.

In a nutshell, the solution has to define a solution for encrypting firmware images but those deploying them may chose not to use such mechanism.

Ciao
Hannes

From: Suit [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: 24 October 2017 04:48
To: [email-masked]
Subject: [Suit] Encrypted Firmware

While reading the manifest/architecture document there was mention to support encrypted firmware.

We feel most devices don’t need firmware encrypted. It is also totally an issue specific to that device and the vendor specific. The IETF work can allow encrypted firmware but we don’t think that needs to be specified as it is largely specific to how the IoT device vendor chose to do it.

Thanks

Suhas Nandakumar

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.