Subject: [Suit] Github? RE: Concerns about Charter and Process Followed

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 30 Nov 2017 09:55:29 +0000

Hi Suhas,

Sometimes tools are not the solution to the problem. The IESG should make these small clarifications needed to get the charter finalized.

Ciao
Hannes

From: Suit [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: 30 November 2017 01:54
To: Waltermire, David A. (Fed)
Cc: [email-masked]
Subject: Re: [Suit] Concerns about Charter and Process Followed

Thanks Dave for the response and considering the concerns.

Also i was wondering, would it makes sense to have the charter on the github, so people can comment and generate pull requests if needed

Thanks
Suhas

On Wed, Nov 29, 2017 at 3:59 PM, Waltermire, David A. (Fed) <[email-masked]<mailto:[email-masked]>> wrote:
Thank you for raising these concerns, I plan to spend time tomorrow reviewing the meetecho recording from the BoF, reviewing the recent mailing list discuaaion, the BoF notes (which I'll post), and the current charter. Once the chairs have had a chance to review and discuss these materials we will come back to the list with a plan to move forward.

We want to make sure the charter reflects the consensus of the group and addresses any concerns raised by the IESG. Please give us some time to make sure this happens in a productive way forward.

Thanks,
Dave

-------- Original Message --------
From: Suit <[email-masked]<mailto:[email-masked]>> on behalf of Suhas Nandakumar <[email-masked]<mailto:[email-masked]>>
Date: Wed, November 29, 2017 6:32 PM -0500
To: [email-masked]<mailto:[email-masked]>
Subject: [Suit] Concerns about Charter and Process Followed
Hello Chairs

  Having spent sometime to browse through different lists and attempting to sharer concerns to ensure that the charter text and consensus match, i thought will share few points for us to ponder upon.

As a follow up from BOF,

  1.  minutes are not published to the data-tracker or the SUIT mailing list. I discovered the following notes from the etherpad instead (https://etherpad.tools.ietf.org/p/notes-ietf-100-suit<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fetherpad.tools.ietf.org%2Fp%2Fnotes-ietf-100-suit&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cf7e484ae40ac48d72b1308d537816346%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636475951228461640&sdata=%2BoqSVEWQ5%2BGnd45OKxgANL04jRfgbXipHxpowGQ0cUQ%3D&reserved=0>)
          Co-Chairs summarize concerns with current Charter text
               - Use of RFC4108
·                  - Hum on if we should remove 4108 - Stronger hum???
·                  - Hum on if we should leave 4108
            - Should we constrain this to Class 1
          - Clarification on text revolving around transport mechanisms
·                 - Hum: Should we avoid the development of new transport mechanisms - Yes is louder in the room
          - Should the charter have text to talk about capabilities
·                 - Hum: Charter needs text
·                - Hum: Leave out of charter, but add to architecture
         - Should the charter restrict to one
·               - Hum: Yes
·              - Hum: No - Much Stronger
       - Do we need a charter text update or leave it to a discussion for discovery
·            - Hum: Stronger for leaving it to discussion

      - Cullen Jennings via Jabber text to add: The architecture should provide a way to discover the firmware server
·            - Hum: ???
·
        - AD says we need to put this back on the list again

As requested by the AD (last bullet point), the consensus confirming email never made to the list.

  1.  From the above notes excerpt, the changes that had consensus in meeting are not reflected in charter

  1.  None of this has has been sent to list. Not the minutes from the meeting. Not the charter.

  1.  People have not had time to review or comment on it

What should be the plan forward in addressing the concerns here ?

Thanks
Suhas Nandakumar

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 30 Nov 2017 09:39:01 -0500

Hello all,

On Thu, Nov 30, 2017 at 4:55 AM, Hannes Tschofenig
<[email-masked]> wrote:
> Hi Suhas,
>
>
>
> Sometimes tools are not the solution to the problem. The IESG should make
> these small clarifications needed to get the charter finalized.

I agree that tools are not the answer here.  The chairs will be
following up on list to the discussions over the past few days.  The
updated text will be discussed and moved to a future telechat (very
soon, likely in 2 weeks) for review.  As the sponsoring AD, I will
continue to follow the discussions and ensure points have been
considered.  The charter has changed mostly to move decisions out of
the charter and to the WG, so I think we'll be able to wrap this up
soon and get started on the work.

Thank you,
Kathleen

> Also i was wondering, would it makes sense to have the charter on the
> github, so people can comment and generate pull requests if needed
>
>
>
> Thanks
>
> Suhas
>
>
>
> On Wed, Nov 29, 2017 at 3:59 PM, Waltermire, David A. (Fed)
> <[email-masked]> wrote:
>
> Thank you for raising these concerns, I plan to spend time tomorrow
> reviewing the meetecho recording from the BoF, reviewing the recent mailing
> list discuaaion, the BoF notes (which I'll post), and the current charter.
> Once the chairs have had a chance to review and discuss these materials we
> will come back to the list with a plan to move forward.
>
> We want to make sure the charter reflects the consensus of the group and
> addresses any concerns raised by the IESG. Please give us some time to make
> sure this happens in a productive way forward.
>
> Thanks,
> Dave
>
>
>
> From: Suit <[email-masked]> on behalf of Suhas Nandakumar
> <[email-masked]>
> To: [email-masked]
>   Having spent sometime to browse through different lists and attempting to
> sharer concerns to ensure that the charter text and consensus match, i
> thought will share few points for us to ponder upon.
>
>
>
> As a follow up from BOF,
>
> minutes are not published to the data-tracker or the SUIT mailing list. I
> discovered the following notes from the etherpad instead
> (https://etherpad.tools.ietf.org/p/notes-ietf-100-suit)
>
>       - Cullen Jennings via Jabber text to add: The architecture should
> provide a way to discover the firmware server
>
> ·            - Hum: ???
>
> ·
>
> From the above notes excerpt, the changes that had consensus in meeting are
> not reflected in charter
>
> None of this has has been sent to list. Not the minutes from the meeting.
> Not the charter.
>
> People have not had time to review or comment on it
>
>
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit
>

-- 

Best regards,
Kathleen

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 30 Nov 2017 16:16:16 +0100

Hello all,

if the visibility problem of current state/version of charter and its 
review, open AI that require call for consensus on the list, and update 
proposals to the charter can be improved as is, I would agree that this 
is not a "tool question".

I would like to highlight an example I kept tracking:

On 11/23/2017 11:22 AM, Hannes Tschofenig wrote:
> If the BOF chairs feel that the RFC 4108 reference upsets readers too much then I will not fight for it.

This seemed to be one of the hot topics. There were suggestions on the 
lists including ballot positions and to quote Dave on removing RFC 4108 
content from charter:

On 11/29/2017 08:29 PM, Dave Thaler wrote:
> The consensus at the BoF was, from my recollection anyway, indeed to do so for RFC 4108.

Alas, it still feels like this is an open topic still. And I think 
Hannes saw that one coming:

On 11/23/2017 11:48 AM, Hannes Tschofenig wrote:
> Let us finish the charter and start the real work.

And I am totally with him :)

Viele Grüße,

Henk