Subject: [Suit] Suit Charter: IOTSU Workshop information in the Charter

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 22 Nov 2017 15:46:01 -0800

Hello All

I am trying to get my head around the purpose of the following text in the
charter about IOTSU workshop to the WG objectives and deliverables. If we
think capturing IOTSU workshop background aids in WG objectives, we might
have to reword the current text to capture the intent. Otherwise, i propose
removing the below text from the charter.

“In June of 2016 the Internet Architecture Board organized a workshop on
'Internet of Things (IoT) Software Update (IOTSU)', which took place at
Trinity College in Dublin, Ireland. The main goal of the workshop was to
foster a discussion on requirements, challenges, and solutions for bringing
software and firmware updates to IoT devices. This workshop also made clear
that there are challenges with misaligned incentives and complex value
chains. It is nevertheless seen as important to create”

Thanks
Suhas Nandakumar

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 23 Nov 2017 07:44:08 +0000

Hi Suhas,

You have better language skills than I do and so help to improve the wording.

The text illustrates that the IETF has been looking at the topic of firmware updates for a while already and the IAB has even organized a workshop to reach out to interested parties.
For someone who is new to the IETF this information, including the reference to that workshop report, maybe useful background information since they may be wondering why the IETF cares about this topic.

Charters in the IETF in general also provide a bit of introduction and illustrate the history of how we got here.

Ciao
Hannes

From: Suit [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: 23 November 2017 00:46
To: [email-masked]
Subject: [Suit] Suit Charter: IOTSU Workshop information in the Charter

Hello All

I am trying to get my head around the purpose of the following text in the charter about IOTSU workshop to the WG objectives and deliverables. If we think capturing IOTSU workshop background aids in WG objectives, we might have to reword the current text to capture the intent. Otherwise, i propose removing the below text from the charter.

“In June of 2016 the Internet Architecture Board organized a workshop on 'Internet of Things (IoT) Software Update (IOTSU)', which took place at Trinity College in Dublin, Ireland. The main goal of the workshop was to foster a discussion on requirements, challenges, and solutions for bringing software and firmware updates to IoT devices. This workshop also made clear that there are challenges with misaligned incentives and complex value chains. It is nevertheless seen as important to create”

Thanks
Suhas Nandakumar

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.