Subject: [Suit] ASN.1 Encoding Format for Manifest

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 2 Nov 2017 14:01:04 -0700

I would want to discuss on the topic of ASN.1 encoding format that seems to
presume that the IoT device has the parser for ASN.1 as part of the
application stack (say TLS) outside the boot-loader

I don't think we can have that assumption that the firmware update process
will always have enough space  for two copies of application software, so
that it can download a new one before replacing the old one. Many devices
have a small downloader plus enough space for one copy of the application
firmware.

Hence I don’t think the assumptions that there is already an ASN.1 parser
available is true.  I would recommend that the charter allows the WG to
reconsider ASN.1 choice as the default for the manifest encoding format and
allow encodings that are suitable to the device in question.

Cheers

Suhas

---

From: Brendan Moran <[email-masked]>
Date: Thu, 2 Nov 2017 21:23:52 +0000

On 2 Nov 2017, at 21:01, Suhas Nandakumar <[email-masked]<mailto:[email-masked]>> wrote:

I would want to discuss on the topic of ASN.1 encoding format that seems to presume that the IoT device has the parser for ASN.1 as part of the application stack (say TLS) outside the boot-loader

Please review the latest draft. ASN.1 is not used.

I don't think we can have that assumption that the firmware update process will always have enough space  for two copies of application software, so that it can download a new one before replacing the old one. Many devices have a small downloader plus enough space for one copy of the application firmware.

This is one of the expected use-cases. However, it is important to consider that downloaders likely need to be updatable.

Hence I don’t think the assumptions that there is already an ASN.1 parser available is true.  I would recommend that the charter allows the WG to reconsider ASN.1 choice as the default for the manifest encoding format and allow encodings that are suitable to the device in question.

Best Regards,
Brendan
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.