Subject: [Suit] Concerns about Charter and Process Followed

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 29 Nov 2017 15:31:50 -0800

Hello Chairs

  Having spent sometime to browse through different lists and attempting to
sharer concerns to ensure that the charter text and consensus match, i
thought will share few points for us to ponder upon.

As a follow up from BOF,

   1. minutes are not published to the data-tracker or the SUIT mailing
   list. I discovered the following notes from the etherpad instead (
   https://etherpad.tools.ietf.org/p/notes-ietf-100-suit)

          Co-Chairs summarize concerns with current Charter text
               - Use of RFC4108

   -            - Hum on if we should remove 4108 - Stronger hum???

   -            - Hum on if we should leave 4108

            - Should we constrain this to Class 1
          - Clarification on text revolving around transport mechanisms

   -           - Hum: Should we avoid the development of new transport
   mechanisms - Yes is louder in the room

          - Should the charter have text to talk about capabilities

   -           - Hum: Charter needs text

   -          - Hum: Leave out of charter, but add to architecture

         - Should the charter restrict to one

   -         - Hum: Yes

   -        - Hum: No - Much Stronger

       - Do we need a charter text update or leave it to a discussion for
discovery

   -      - Hum: Stronger for leaving it to discussion

      - Cullen Jennings via Jabber text to add: The architecture should
provide a way to discover the firmware server

   -      - Hum: ???

   -

        - AD says we need to put this back on the list again

As requested by the AD (last bullet point), the consensus confirming email
never made to the list.

   1. From the above notes excerpt, the changes that had consensus in
   meeting are not reflected in charter

   1. None of this has has been sent to list. Not the minutes from the
   meeting. Not the charter.

   1. People have not had time to review or comment on it

What should be the plan forward in addressing the concerns here ?

Thanks
Suhas Nandakumar

---

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Wed, 29 Nov 2017 23:59:06 +0000

Thank you for raising these concerns, I plan to spend time tomorrow reviewing the meetecho recording from the BoF, reviewing the recent mailing list discuaaion, the BoF notes (which I'll post), and the current charter. Once the chairs have had a chance to review and discuss these materials we will come back to the list with a plan to move forward.

We want to make sure the charter reflects the consensus of the group and addresses any concerns raised by the IESG. Please give us some time to make sure this happens in a productive way forward.

Thanks,
Dave

-------- Original Message --------
From: Suit <[email-masked]> on behalf of Suhas Nandakumar <[email-masked]>
Date: Wed, November 29, 2017 6:32 PM -0500
To: [email-masked]
Subject: [Suit] Concerns about Charter and Process Followed

Hello Chairs

  Having spent sometime to browse through different lists and attempting to sharer concerns to ensure that the charter text and consensus match, i thought will share few points for us to ponder upon.

As a follow up from BOF,

  1.  minutes are not published to the data-tracker or the SUIT mailing list. I discovered the following notes from the etherpad instead (https://etherpad.tools.ietf.org/p/notes-ietf-100-suit<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fetherpad.tools.ietf.org%2Fp%2Fnotes-ietf-100-suit&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cf7e484ae40ac48d72b1308d537816346%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636475951228461640&sdata=%2BoqSVEWQ5%2BGnd45OKxgANL04jRfgbXipHxpowGQ0cUQ%3D&reserved=0>)

  *              - Hum on if we should remove 4108 - Stronger hum???

  *              - Hum on if we should leave 4108

  *             - Hum: Should we avoid the development of new transport mechanisms - Yes is louder in the room

  *             - Hum: Charter needs text

  *            - Hum: Leave out of charter, but add to architecture

  *           - Hum: Yes

  *          - Hum: No - Much Stronger

       - Do we need a charter text update or leave it to a discussion for discovery

  *        - Hum: Stronger for leaving it to discussion

      - Cullen Jennings via Jabber text to add: The architecture should provide a way to discover the firmware server

  *        - Hum: ???

  *

As requested by the AD (last bullet point), the consensus confirming email never made to the list.

  1.  From the above notes excerpt, the changes that had consensus in meeting are not reflected in charter

  1.  None of this has has been sent to list. Not the minutes from the meeting. Not the charter.

Thanks
Suhas Nandakumar

---

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 29 Nov 2017 16:53:38 -0800

Thanks Dave for the response and considering the concerns.

Also i was wondering, would it makes sense to have the charter on the
github, so people can comment and generate pull requests if needed

Thanks
Suhas

On Wed, Nov 29, 2017 at 3:59 PM, Waltermire, David A. (Fed) <
[email-masked]> wrote:

> Thank you for raising these concerns, I plan to spend time tomorrow
> reviewing the meetecho recording from the BoF, reviewing the recent mailing
> list discuaaion, the BoF notes (which I'll post), and the current charter.
> Once the chairs have had a chance to review and discuss these materials we
> will come back to the list with a plan to move forward.
>
> We want to make sure the charter reflects the consensus of the group and
> addresses any concerns raised by the IESG. Please give us some time to make
> sure this happens in a productive way forward.
>
> Thanks,
> Dave
>
>
>   Having spent sometime to browse through different lists and attempting
> to sharer concerns to ensure that the charter text and consensus match, i
>    https://etherpad.tools.ietf.org/p/notes-ietf-100-suit
>    <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fetherpad.tools.ietf.org%2Fp%2Fnotes-ietf-100-suit&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cf7e484ae40ac48d72b1308d537816346%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636475951228461640&sdata=%2BoqSVEWQ5%2BGnd45OKxgANL04jRfgbXipHxpowGQ0cUQ%3D&reserved=0>
>    )
>

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 30 Nov 2017 11:10:20 +0100

A happy, wholehearted, +1 with 100% support.

Viele Grüße,

Henk

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.