Subject: [Suit] Proposed WG name and software vs firmware

From: Dave Thaler <[email-masked]>
Date: Mon, 4 Dec 2017 23:51:54 +0000

One of the discussions we had during the BoF was about the relationship between SUIT and TEEP,
and there was consensus that SUIT would focus on "firmware" used for boot, as opposed to
"applications" that could be installed later which was the focus of TEEP.   As such, I believe
we said that the term "firmware" was more precise for SUIT than "software" in general.

So when Dave W. and I did the latest edits that he just sent out, the text is careful to always use the
term "firmware" when it's talking about what's in scope, and "software" is only used in more generic
text (e.g., about what's NOT in scope), etc.

The last remaining use is in the BoF title "Software Update for the Internet of Things (SUIT)".
We discussed possible alternatives, and would like to suggest the name

FiRmware Update for the Internet of Things (FRUIT)

We believe this change (s/Software/FiRmware/) would be more consistent with the charter text
and the consensus of the BoF and the list.    It's also important for all to understand that, even if
the mailing list name changes, the full email archive would be kept and moved to the new list,
so email history is not a blocker.

Comments on the proposed FRUIT name?

Dave

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 5 Dec 2017 10:07:09 +0000

Sounds good for me. It makes sense to me to be more precise regarding the SUIT/TEEP separation.

From: Suit [mailto:[email-masked]] On Behalf Of Dave Thaler
Sent: 04 December 2017 23:52
To: [email-masked]
Subject: [Suit] Proposed WG name and software vs firmware

Dave
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Brendan Moran <[email-masked]>
Date: Tue, 5 Dec 2017 10:44:52 +0000

Both SUIT and FRUIT share a common problem: they are not discoverable. Searches for SUIT or searches for FRUIT will both fail to yield IETF-related results. It would be preferable to select a name which is not a dictionary word in English. If we’re going to change away from SUIT, then I would prefer a change to a discoverable name.

Best Regards,
Brendan

On 4 Dec 2017, at 23:51, Dave Thaler <[email-masked]<mailto:[email-masked]>> wrote:

One of the discussions we had during the BoF was about the relationship between SUIT and TEEP,
and there was consensus that SUIT would focus on “firmware” used for boot, as opposed to
“applications” that could be installed later which was the focus of TEEP.   As such, I believe
we said that the term “firmware” was more precise for SUIT than “software” in general.

So when Dave W. and I did the latest edits that he just sent out, the text is careful to always use the
term “firmware” when it’s talking about what’s in scope, and “software” is only used in more generic
text (e.g., about what’s NOT in scope), etc.

The last remaining use is in the BoF title “Software Update for the Internet of Things (SUIT)”.
We discussed possible alternatives, and would like to suggest the name

We believe this change (s/Software/FiRmware/) would be more consistent with the charter text
and the consensus of the BoF and the list.    It’s also important for all to understand that, even if
the mailing list name changes, the full email archive would be kept and moved to the new list,
so email history is not a blocker.

Dave
_______________________________________________
Suit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/suit

---

From: Michael Richardson <[email-masked]>
Date: Tue, 05 Dec 2017 08:05:36 -0500

I prefer SUIT to FRUIT, but you make a good point that we carefully talk
about firmware except in the title.  I can live with either.

Perhaps someone can come up with an expansion of "FRUITFUL" :-)
or some other non-english word as Brendan Moran suggests.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 5 Dec 2017 14:58:07 +0100

> FiRmware Update for the Internet of Things (FRUIT)

Aw.  I wanted

	Firmware Replacement for the Internet of ThingZ (FRITZ)

(Sorry.  Not really googleable either.)

Grüße, Carsten

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 5 Dec 2017 09:46:26 -0500

In terms of searching, if you just add IETF into the search, it will
pop out on top.

IETF SUIT
IETF FRUIT - once it is changed.

Best regards,
Kathleen

On Tue, Dec 5, 2017 at 8:58 AM, Carsten Bormann <[email-masked]> wrote:
> [email-masked]

-- 

Best regards,
Kathleen

---

From: Eliot Lear <[email-masked]>
Date: Tue, 5 Dec 2017 15:56:00 +0100

May we have fruitful discussions that lead to a suitable set of solutions.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 6 Dec 2017 01:53:55 +0100

Suspicions about the geek nature of participants make me think this is
just a trick to get a more funny WG name, but i ca not find a flaw in your argument.

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 6 Dec 2017 03:16:38 +0100

Hello,

there seem to be a lot of pros and cons, but as Kathleen highlighted 
"search results provided by a search engine" seems not to be a deciding 
factor here, I think.

Instead, I would like to raise a pair of individually selected pro&con:

Pro: The name FirmwareUIT will probably create a better demarcation line 
- wrt the initial proposal of Hannes - between two potential WG, which 
helps associating contributions with the right working group (i.e. 
firmware vs. applications).

Con: We are starting to differentiate firmware and software. This is 
done in a lot of places... and does not always makes sense in a lot of 
places also, I think.
In consequence, this approach probably requires a useful definition of 
firmware that distinguishes it from any other kind of software 
(otherwise software - or, in extension of that term, applications or 
apps - will also be in scope of the manifest at some point, I assume).

I.e., one vital question seems to be:

Is this correct?
1.) firmware is limited to the "booting of a thing"
2.) software is about the scope of every other software that is not 
about the "booting of a thing".

If so, FRUIT it is. If not, stay with SUIT, I guess.

Any comments on trying to provide a more focused decision point here?

Viele Grüße,

Henk

p.s. I realize that this is just a discussion about how to name a WG...

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 6 Dec 2017 08:15:35 +0100

On Dec 6, 2017, at 03:16, Henk Birkholz <[email-masked]> wrote:
> 
> p.s. I realize that this is just a discussion about how to name a WG…

Indeed.  The protocols we create do not have to (and probably should not) be named after the WG name, and those are what will mostly be searched for.

Grüße, Carsten

---

From: Brendan Moran <[email-masked]>
Date: Wed, 6 Dec 2017 08:43:25 +0000

I very much prefer SUIT to FRUIT. I feel that it is reasonable to take some artistic license in the terminology when constructing an acronym for a working group. However, if the WG name really must contain “firmware” instead of “software,” may I suggest:

ENUF: Embedded Network-Updatable Firmware
CODEFU: COnstrained DEvice Firmware Update
TIUF: Things with Internet-Updatable Firmware
CFU: Constrained Firmware Update
CUT: Compact Updates for the internet of Things

Cheers,m
Brendan

On 5 Dec 2017, at 14:56, Eliot Lear <[email-masked]<mailto:[email-masked]>> wrote:

Dave

---

From: Michael Richardson <[email-masked]>
Date: Wed, 06 Dec 2017 09:59:08 -0500

Brendan Moran <[email-masked]> wrote:
    >    I very much prefer SUIT to FRUIT. I feel that it is reasonable to
    > take some artistic license in the terminology when constructing an
    > acronym for a working group. However, if the WG name really must
    > contain "firmware" instead of "software," may I suggest:

    >    ENUF: Embedded Network-Updatable Firmware

That's cool.

---

From: "Paul Hoffman" <[email-masked]>
Date: Wed, 06 Dec 2017 07:27:55 -0800

On 5 Dec 2017, at 23:15, Carsten Bormann wrote:

> Indeed.  The protocols we create do not have to (and probably should 
> not) be named after the WG name, and those are what will mostly be 
> searched for.

...initially. The IETF has a long history of WG names that overlap with 
English (and sometimes French) words, and people end up searching by RFC 
number. It is unlikely that someone who is developing IoT software will 
say "I need to find the format for manifests, they came from something 
called FRUIT, I couldn't find it in Google, so I will not develop this 
software".

Basically anyone who knows that FRUIT is/was part of the IETF will 
search for "ietf fruit" and will find what they are looking for.

--Paul Hoffman

---

From: Russ Housley <[email-masked]>
Date: Wed, 6 Dec 2017 11:24:12 -0500

I am not thrilled to have the name changed again.  It started as FUD, then became SUIT.  That said, I can see the reason to go back to something that begins with "F".

How about FWLOAD?

Russ

---

From: Emmanuel Baccelli <[email-masked]>
Date: Thu, 7 Dec 2017 09:17:03 +0100

I like FRUIT. That said, SUIT remains suitable.

If a clearer distinction is needed between software vs firmware on those
devices,
we could/should allocate some space for that in one of the WG docs, e.g.
the architecture document?

Emmanuel

On Wed, Dec 6, 2017 at 5:24 PM, Russ Housley <[email-masked]> wrote:

> I am not thrilled to have the name changed again.  It started as FUD, then
> became SUIT.  That said, I can see the reason to go back to something that
> begins with "F".
>
> How about FWLOAD?
>
> Russ
>
>
>

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 13 Dec 2017 12:06:40 -0500

Hello,

Thank you to those who weighed in on a possible name change.  We'll
leave the name as SUIT to avoid a name change since this was not
conclusive and most were fine with SUIT.

Best regards,
Kathleen

On Thu, Dec 7, 2017 at 3:17 AM, Emmanuel Baccelli
<[email-masked]> wrote:
> we could/should allocate some space for that in one of the WG docs, e.g. the
> architecture document?
>
> Emmanuel
>
>
>
>
>

-- 

Best regards,
Kathleen